Go Back   Android Forums > Android Phones > Motorola Defy

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old February 4th, 2012, 03:42 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default wifi problems in defy

hey, i searched the forum a bit but didn't find anything similar:
i have a 2.1 version (i think), and lately it started acting wierd (i havent done anything i can recall to change the settings etc.):
my wifi is working properly, apparentley, but when i try to connect to certain networks it just refuses to connect. it happens in both secured and non secured networks.
example: when i go to the network manager and ask for a password, i can enter it but nothing happens(more specificaly, the "connect" button remains grey and un responsive). other phones\ laptops in the area are connected with the password without any problem.
non secured networks, i click connect, but the connection fails everytime.
this apllies also for networks that i could connect to in the past.
other networks can be connected as always.


please help!

adard is offline  
Reply With Quote
sponsored links
Old February 4th, 2012, 09:48 AM   #2 (permalink)
Junior Member
 
Join Date: Dec 2008
Location: USA
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 13 Times in 12 Posts
Default

What market are you in? Is this a t-mo branded phone with wifi-calling? Go into "About phone" and see if you are on 2.1 or 2.2. Generally speaking...

You can try clearing the wifi list in Manage network options.

You can clear the system cache.

You can go a factory reset. (But if you are using 2.2 the reset listed on the phone is not the correct procedure for 2.2). Remember this will return your phone to "as new" state wiping out all your apps and info.

Most info on how to do these things can be found here:

T-Mobile Support Community: Topic: Motorola DEFY with MOTOBLUR


IF you do have wifi-calling there are a couple of additional things to try. Let us know.
scrannel is offline  
Reply With Quote
The Following User Says Thank You to scrannel For This Useful Post:
adard (February 5th, 2012)
Old February 5th, 2012, 07:42 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have a 2.2. silly me!

I clear the wifi list all the time.

My phone dosn't have wifi calling as far as i know. anyway, its impossible to do it on a network i can't connect to in the first place* (is it? i never tried it before).

I prefer not reset my phone, if there are other options i rather try them first. i'll try it eventually i suppose...

The problem might be limited to networks secured with WPA/WPA 2 or WEP. when i tap "add wifi network" and choose this types of security, i have the same problem, which is weird since my phone never had problems with this kinds of networks before.

*pardon my ignorance
adard is offline  
Reply With Quote
Old February 6th, 2012, 11:10 AM   #4 (permalink)
Junior Member
 
Join Date: Dec 2008
Location: USA
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 13 Times in 12 Posts
Default

If your phone is not a t-mo branded USA phone you probably do not have wifi-calling. If you do have wifi-calling it can mess with wifi connections whether you are trying to use it or not. Where are you? (if you DO have a US phone there is something else we can check).

So you CAN connect to some networks?

You might try clearing the system cache. (check the t-mo link above on how to do this). It will not wipe out your apps and data.
scrannel is offline  
Reply With Quote
Old February 17th, 2012, 10:38 AM   #5 (permalink)
Junior Member
 
Join Date: Oct 2011
Location: Bournemouth, England
Posts: 46
 
Device(s): Motorola Atrix
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by adard View Post
hey, i searched the forum a bit but didn't find anything similar:
i have a 2.1 version (i think), and lately it started acting wierd (i havent done anything i can recall to change the settings etc.):
my wifi is working properly, apparentley, but when i try to connect to certain networks it just refuses to connect. it happens in both secured and non secured networks.
example: when i go to the network manager and ask for a password, i can enter it but nothing happens(more specificaly, the "connect" button remains grey and un responsive). other phones\ laptops in the area are connected with the password without any problem.
non secured networks, i click connect, but the connection fails everytime.
this apllies also for networks that i could connect to in the past.
other networks can be connected as always.


please help!

Flash an sbf. This happened to me once. I think it is a driver problem.
HalfAnAndroid is offline  
Reply With Quote
Old March 1st, 2012, 01:37 AM   #6 (permalink)
Member
 
Join Date: Feb 2012
Posts: 108
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 4 Posts
Default

Dame problem with my Defy. I've solved changing mi router ti wifi g only
Styrisvps is offline  
Reply With Quote
Old March 2nd, 2012, 10:01 AM   #7 (permalink)
Junior Member
 
Join Date: Dec 2008
Location: USA
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 13 Times in 12 Posts
Default

Quote:
Originally Posted by Styrisvps View Post
Dame problem with my Defy. I've solved changing mi router ti wifi g only
Have seen this as a solution. Mine works fine on 'N', so it may vary router to router.
scrannel is offline  
Reply With Quote
Reply

Motorola DEFY
Current Rating:
Rate this Phone:

The Motorola DEFY is the newest Motorola Android device announced for T-Mobile USA. It sports a 3.7 inch touchscreen, Android 2.1 with MOTOBLUR, and is being advertised as "Lifeproof" by Motorola. The DEFY gets its name by supposedly de... Read More

Tags
connection, defy, problem, wifi


Go Back   Android Forums > Android Phones > Motorola Defy
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:09 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.