Go Back   Android Forums > Android Phones > Motorola Droid RAZR / RAZR MAXX

test: Reply
 
LinkBack Thread Tools
Old January 23rd, 2013, 05:29 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy No Ring, but speaker works.

My wife's Droid Razr Maxx phone is new to her (purchased used).
I'm not sure if the problem has always existed on the phone. It seems different from the hardware problems I have read about. It is running the latest OTA Rom (JB 4.1.2) I tested this problem with the phone rooted and unrooted without any change.

The phone will not ring or alert on phone calls and text messages regardless of any settings.

In a phone call, however, the speaker clearly works, BUT once I turn the speaker on (blue bar shows below the word speaker), I cannot turn it off during that phone call (no blue bar under speaker, but I'm still on speaker).

Am I correct in assuming that the phone uses the same speaker for ring and speaker phone? If so, it does not seem like the speaker hardware problems I have read about. It seems like a software problem, but I don't find anyone discussing exactly this issue?

Any ideas on diagnosing this problem? Anyone experience a similar problem?

Advertisements
neo314 is offline  
Reply With Quote
sponsored links
Old January 23rd, 2013, 06:17 PM   #2 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

Welcome to Android Forums.

I always found the volume controls confusing. The app ... https://play.google.com/store/apps/details?id=com.cb.volumePlus&feature=more_from_dev eloper#?t=W251bGwsMSwyLDEwMiwiY29tLmNiLnZvbHVtZVBs dXMiXQ.. ... can show them all to you and take out the confusion. I use the Pro version ($.99).

... Thom
__________________



Thom is online now  
Reply With Quote
Old January 23rd, 2013, 06:25 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use the same program. I'll double check when my wife gets home, but I used Audio Manager on hers because that is what she had purchased, and that was not related to the problem (tried with and without the 3rd party program installed).
neo314 is offline  
Reply With Quote
Old January 23rd, 2013, 06:39 PM   #4 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

Quote:
Originally Posted by neo314 View Post
I use the same program. I'll double check when my wife gets home, but I used Audio Manager on hers because that is what she had purchased, and that was not related to the problem (tried with and without the 3rd party program installed).
Does it look like that attached image?

... Thom
Attached Images
File Type: jpg Screenshot_2013-01-23-19-36-19.jpg (69.5 KB, 14 views)
Thom is online now  
Reply With Quote
Old January 23rd, 2013, 10:58 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes it looks like your screen shot. That isn't the problem. It sure seems like a software issue, but I don't understand how I can be alone in this, or how to get a fresh start.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 12:16 PM   #6 (permalink)
Member
 
Join Date: Aug 2012
Location: Slough UK
Gender: Male
Posts: 174
 
Device(s): Motorola Razr Maxx, iPhone 4s
Carrier: Vodafone UK

Thanks: 23
Thanked 12 Times in 10 Posts
Cool

You could try a factory reset to see if it resolves the issue. If you have updated to J.B you should have done this after updating.
razrclive is offline  
Reply With Quote
Old January 24th, 2013, 12:22 PM   #7 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

My GUESS ... it is either an app that was added that it "fiddling" with it or as suggested the Factory Data Reset was not done after the JB upgrade and it should be.

If JB was installed already when you got it ... do the Factory Data Reset so you have a known starting point for all future use.

... Thom
Thom is online now  
Reply With Quote
Old January 24th, 2013, 01:27 PM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried a factory reset. Then I installed the OTA ROM (directly through recovery mode) and did another factory reset. Then I tried it unrooted and rooted. No Joy.

I also found it will not play music. I tried Pandora to be sure the source had nothing to do with the file system. The sound quality seems quite bad on phone calls even through blue tooth, but I am not sure about the consistency of that part.

The speaker does not seem to work for much of anything except a few system sounds and when I push speaker in a phone call. Is there a different circuit that could be damaged for these other sounds that would not affect the phone speaker function, OR perhaps there is more voltage when using it as a phone speaker so that it could be dirty contacts?

It is a very strange problem. I did notice that it makes no boot up sound and when you change ring tones in the settings, it does not play the alternative ring tone one picks.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 01:46 PM   #9 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

This is with JB installed ... un-root-ed ... you did a Factory Data Reset ... you installed no other apps ... and this is the way it behaves. Right?

... Thom
Thom is online now  
Reply With Quote
Old January 24th, 2013, 02:02 PM   #10 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Correct.
neo314 is offline  
Reply With Quote
sponsored links
Old January 24th, 2013, 02:04 PM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is weird because I would think the behavior of the speaker would be the same throughout. Works, sounds crappy, or does not work at all, but that does not seem to be the case.

I'm starting to think it is a hardware problem, but a strange one.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 03:58 PM   #12 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

It seems to me that user error and software are both ruled out. I think it needs to be looked at by a hardware person.

... Thom
Thom is online now  
Reply With Quote
Old January 24th, 2013, 04:33 PM   #13 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, that is where I was headed until...

I took my wife's sound files that she has used as ring tones before (all mp3 and wma files) and put them in /sdcard/media/ringtones. They would not play. I installed an mp3/wma player. They sound fine. Perfect even through the speaker.

I'm not sure where the default files should be, but I can't find the default sound files. I do find empty folders named ringtones and one file in /sdcard/Notifications. The file in Notifications is named hangout_dingtone.m4a which also plays fine.

So I think it is a software problem. I wonder if it should be able to play mp3 and wma files as sounds or ringtones out of the box as I would have figured originally, but I think that is a distraction at the moment.

My thought is that there is something corrupted which persists through the ROM changes. That the default sound files are either not installed or can't be played and the reason everything is silent is because there are no sound files or they cannot be read. It suggest possible other problems with the install since it can't play what should be good mp3 and wma files without added software and the whole speaker phone problem.

When I changed to the OTA ROM, I did wipe the cache first and after the install I tried it without wiping the cache and with wiping the cache again.

To confirm I'm right about the problem, it would be good to know:
  1. Where are the default sound files from a fresh rom install located and should they all be m4a files?
  2. Should it play mp3 and wma files without having to add a player from the Google Play Store?
  3. Any other ideas.

I think this is a software issue. I'm wondering what else, if anything, I can do to try and ensure I wipe everything off the phone and get a ROM upgrade/install that is truly clean. Is there a boot dongle for this phone? I would also like to be certain that I have the latest OTA ROM image, but I am pretty confident that I do.

Looking for suggestions, but what I think I am going to try and do now is use the tool here and begin by downgrading it to stock ICS first and see what happens.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 05:14 PM   #14 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

I assumed from your previous response that you had started with a stock (un-root-ed) system, pull the SD card, updated to JB followed by a Factory Data Reset and installed no other apps. In that state you had the problem.

Since that is apparently not the case ... I suggest that you try it.

(The purpose was to rule out user error and software.)

... Thom
Thom is online now  
Reply With Quote
Old January 24th, 2013, 05:28 PM   #15 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Thom Little View Post
I assumed from your previous response that you had started with a stock (un-root-ed) system, pull the SD card, updated to JB followed by a Factory Data Reset and installed no other apps. In that state you had the problem.

Since that is apparently not the case ... I suggest that you try it.

(The purpose was to rule out user error and software.)

... Thom
I started with a system on JB already. I believe it was a leaked ROM. I updated with the OTA Stock JB ROM unrooted to try and fix the problem.

I have not tried to downgrade until now.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 06:36 PM   #16 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Good news. Everything seems to be working now. The road there was not exactly what I intended.

I used the Droid RAZR Utility 1.82 from the link above and completed step 1 (Fastboot Restore 6.16.211 ICS 4.0.4 Official OTA Software). Afterwards you are supposed to reboot and do step 2 to root 4.0.4, but the phone would reboot to a black screen. It was working because I could see it connected to the PC, but I could not get the screen to come up.

After trying several things including step 1 twice, connected to the PC, Not connected, etc., I reinstalled the 4.1.2 OTA ROM from recovery, and everything seems to work. So I have not installed safestrap or used any of the other steps in that utility, but I seem to be working just fine now.

I'm rooting it again. No problems. My wife hates the bootup sound (Drrrroid....) but it is music to my ears.
neo314 is offline  
Reply With Quote
Old January 24th, 2013, 06:40 PM   #17 (permalink)
Premium Guide Member
 
Thom's Avatar
 
Join Date: Feb 2011
Location: Keene, NH USA
Posts: 7,081
 
Device(s): Droid Maxx 4.4.4, Droid Bionic 4.1.2, Droid X 2.3.4
Carrier: vzw

Thanks: 2,012
Thanked 2,471 Times in 1,635 Posts
Default

Suggestion ... go slow ... assume it will fail ... when it doesn't you can just smile ...

... Thom
Thom is online now  
Reply With Quote
Old January 24th, 2013, 06:58 PM   #18 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Thom Little View Post
Suggestion ... go slow ... assume it will fail ... when it doesn't you can just smile ...

... Thom
My philosophy exactly. I said that when she went to buy a phone off Craig's list. Right now I'm guessing the previous owner had GB and did not upgrade to JB properly, and pawned the phone off, but who knows.
neo314 is offline  
Reply With Quote
Reply

Motorola DROID RAZR
Current Rating:
Rate this Phone:

The Motorola RAZR was originally rumored as the "Sypder" or "Droid HD" and is now known as the DROID RAZR for Verizon Wireless. The device eatures a 4.3-inch Super AMOLED qHD display, 1.2GHZ dual-core processor, 8MP rear camera,... Read More

Tags
motorola razr problem, motorola razr ring, motorola razr sound


Go Back   Android Forums > Android Phones > Motorola Droid RAZR / RAZR MAXX
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:17 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.