Go Back   Android Forums > Android Phones > Motorola Droid X2

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old August 3rd, 2012, 02:10 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Location: Prince of Wales Island, Alaska
Posts: 4
 
Device(s): Milestone X2
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default New photos "damaged, corrupted, or is too large".

I recently moved my SD card from a Motorola X to a Motorola X2. New pictures and video taken are getting an error message stating, "Wndows Photo Viewer can't open this picture because the file appears to be damaged, corrupted, or is too large", when opening either after being downloaded or opened directly from the SD card. The images and video taken are fine when view on the devise itself; sharp and clear. I've taken the files to other computers with the same result (XP and Windows7). I've also attempted to open the pictures with other programs: Photoshop and GIMP2. All my pictures from my old phone download and display just fine on the PC.

How can I get my pictures off my phone? Why are they getting this error? HELP!

Advertisements
Speedbark is offline  
Reply With Quote
sponsored links
Old August 3rd, 2012, 08:05 PM   #2 (permalink)
Senior Member
 
Scur's Avatar
 
Join Date: May 2011
Location: Illinois
Gender: Male
Posts: 1,394
 
Device(s):
Carrier: Not Provided

Thanks: 353
Thanked 490 Times in 309 Posts
Send a message via MSN to Scur
Default

Quote:
Originally Posted by Speedbark View Post
I recently moved my SD card from a Motorola X to a Motorola X2. New pictures and video taken are getting an error message stating, "Wndows Photo Viewer can't open this picture because the file appears to be damaged, corrupted, or is too large", when opening either after being downloaded or opened directly from the SD card. The images and video taken are fine when view on the devise itself; sharp and clear. I've taken the files to other computers with the same result (XP and Windows7). I've also attempted to open the pictures with other programs: Photoshop and GIMP2. All my pictures from my old phone download and display just fine on the PC.

How can I get my pictures off my phone? Why are they getting this error? HELP!
I don't know, new to me. Have you just viewed them in your gallery and shared them with something like Google Drive or whatever is most handy for you?
Scur is offline  
Reply With Quote
Old August 4th, 2012, 01:46 AM   #3 (permalink)
Member
 
coolpoete's Avatar
 
Join Date: May 2011
Location: Alabama
Posts: 332
 
Device(s): Current - VZW Galaxy Note 2 Retired - Moto Droid X2, Moto Q9M, HTC Vogue, HTC Imagio
Carrier: Verizon Wireless

Thanks: 42
Thanked 57 Times in 49 Posts
Send a message via Yahoo to coolpoete
Default

There could be an issue with your SD card. Backing up to the cloud as Scur suggested would be a great idea, followed by reformatting the card and seeing if that works.

If you don't have cloud service I would try using a file explorer on the phone and copy the pictures from the SD card to the phone itself. You should then be able to plug your phone in, navigate to the folder on the phone and try to copy the files from there. If that works I would then back up anything else you want from the SD card to your PC and reformat your SD card on your PC. Then try copying the files back to your card and see if the phone or PC will read them now.
__________________
Current ROM - Cyanogen Mod 7.2
Flashing rule to live by: Always remember to wipe Cache and Dalvik Cache!
coolpoete is offline  
Reply With Quote
Old August 5th, 2012, 11:21 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Location: Prince of Wales Island, Alaska
Posts: 4
 
Device(s): Milestone X2
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default No Luck - Not SD Card

Thanks for the comments. Other forums (not the exact situation, but close) suggested issues with the SD card. I did not believe it to be the case as nothing else other than the photos are being affected.

I reformatted the SD card and put back the backed up photos. Bad photos off, bad photos on. And again, newly captured images have the same issue. There must be something about how it is taking and storing the pics. I've never had issues with jpg's before. I even turned off the auto location tagging. No tags at all. I even then turned the resolution down to 1 mp. No change. I cannot see any other settings I can fiddle with.

I have found a work-around. Not a good one however. I can text myself pics and save them to the SD card. These jpg's are fine when copied to the PC, but with a major loss of resolution. This is not something I can abide by even if I found an editing app that could re-save the jpg's, that would be a pain in the butt to do every time.

Any other ideas. Bad phone?
-----
Well, that gave me the idea to try a new camera app off the Market to see if the software made difference. Saddly, the same result. I am a complete loss.
Speedbark is offline  
Last edited by Speedbark; August 5th, 2012 at 12:38 PM. Reason: Additional Information
Reply With Quote
Old August 5th, 2012, 12:59 PM   #5 (permalink)
Member
 
coolpoete's Avatar
 
Join Date: May 2011
Location: Alabama
Posts: 332
 
Device(s): Current - VZW Galaxy Note 2 Retired - Moto Droid X2, Moto Q9M, HTC Vogue, HTC Imagio
Carrier: Verizon Wireless

Thanks: 42
Thanked 57 Times in 49 Posts
Send a message via Yahoo to coolpoete
Default

I'm not sure either. For the sake of experimenting try removing the card altogether, taking a few pictures, then try to access the pictures by connecting the phone to the PC and see what happens. Then you can fully rule out whether it's the phone or the card.
coolpoete is offline  
Reply With Quote
Old August 5th, 2012, 04:38 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Location: Prince of Wales Island, Alaska
Posts: 4
 
Device(s): Milestone X2
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Yes, ealier, I did switch the storage location to the onboard memory. I did as you suggested, however, and removed the SD card altogether and took a pic. Same as before. The image cannot be displayed on the PC when the phone is plugged into it. Same if copied to the PC. Fustrating.
Speedbark is offline  
Reply With Quote
Old August 5th, 2012, 04:47 PM   #7 (permalink)
Member
 
coolpoete's Avatar
 
Join Date: May 2011
Location: Alabama
Posts: 332
 
Device(s): Current - VZW Galaxy Note 2 Retired - Moto Droid X2, Moto Q9M, HTC Vogue, HTC Imagio
Carrier: Verizon Wireless

Thanks: 42
Thanked 57 Times in 49 Posts
Send a message via Yahoo to coolpoete
Default

Is this on the x or x2? Have there been any modifications made on the phone? Is it in stock?
coolpoete is offline  
Reply With Quote
Old August 5th, 2012, 10:11 PM   #8 (permalink)
Senior Member
 
Scur's Avatar
 
Join Date: May 2011
Location: Illinois
Gender: Male
Posts: 1,394
 
Device(s):
Carrier: Not Provided

Thanks: 353
Thanked 490 Times in 309 Posts
Send a message via MSN to Scur
Default

Have you made a Picasso account and uploaded/synced them to there?
Scur is offline  
Reply With Quote
Old August 6th, 2012, 08:35 PM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Location: Prince of Wales Island, Alaska
Posts: 4
 
Device(s): Milestone X2
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Milestone X2.

Yes, I tried Picasa. Same Result.

Thanks for the ideas. I contacted Motorola directly. They were not much help, apart from confirming my second to last resort (the last being turning it in on its warrenty). I hit the reset to factory button.

THIS DID WORK. However, I do NOT think it was the solution. As I was reloading apps and adjusting the settings to my preference, I came across the encryption options. I remembered that on my previous device, I did not set any encryption on the internal or SD card, but when I got the new X2 I DID set to encrypt internal and SD. Although I have not tested the theory (and do not really want to), this could be the smoking gun. Having encryption for the internal and SD card on, I suspect was not allowing an external device (PC in this case) to view data, as it is supposed to. Now, how one deals with data on the phone device and gets it off is another subject. Does one have to decrypt the entire SD card to do so??

If any of you folks come across this or this happens to you, did you turn on encryption? If so, this may be a reason you cannot get your data off your phone. Just a theory at this point, but worth exploring before you reset your phone.

I'd like to hear if someone tests this.
Speedbark is offline  
Reply With Quote
The Following User Says Thank You to Speedbark For This Useful Post:
coolpoete (August 6th, 2012)
Old August 6th, 2012, 10:07 PM   #10 (permalink)
Member
 
coolpoete's Avatar
 
Join Date: May 2011
Location: Alabama
Posts: 332
 
Device(s): Current - VZW Galaxy Note 2 Retired - Moto Droid X2, Moto Q9M, HTC Vogue, HTC Imagio
Carrier: Verizon Wireless

Thanks: 42
Thanked 57 Times in 49 Posts
Send a message via Yahoo to coolpoete
Default

Glad you got it fixed!
(I don't use encryption as I have no use for it.)
coolpoete is offline  
Reply With Quote
sponsored links
Old September 28th, 2012, 08:28 AM   #11 (permalink)
Junior Member
 
splifmyster's Avatar
 
Join Date: Aug 2011
Posts: 73
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 2 Times in 2 Posts
Default Had the same thing happen to me

Hey I had the same thing happen to me with my other phone but when I reflashed the rom and did a factor wipe it fixed it hope this helped
splifmyster is offline  
Reply With Quote
Old December 24th, 2012, 09:20 AM   #12 (permalink)
New Member
 
Join Date: Dec 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

When you encrypt your phone or SD card, and then try to transfer photos taken after encrypting, viewers on your PC won't be able to read them.
Also, once encrypted, you would have to transfer/email them to yourself at an email address and then download them to your PC to view them.
Pilot1095 is offline  
Reply With Quote
Old September 15th, 2013, 07:46 PM   #13 (permalink)
New Member
 
Join Date: Sep 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, this is most def an encryption issue. If you turn off the encryption on your android, any photos taken from that point forward will transfer and open easily. However, any photos that were previously encrypted, will transfer but will show as being corrupted.
pascuzzo is offline  
Reply With Quote
Reply

Motorola DROID X2
Current Rating:
Rate this Phone:

The Motorola Droid X2 is the successor to the original and hugely popular Motorola Droid X for Verizon Wireless. The original DROID kicked off the madness, the Droid X offered awesomeness with a larger and touch-screen only display, and now the Dro... Read More



Go Back   Android Forums > Android Phones > Motorola Droid X2

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:38 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.