Go Back   Android Forums > Android Phones > Nexus 4

Like Tree5Likes
  • 1 Post By lion7718
  • 1 Post By lion7718
  • 1 Post By lion7718
  • 1 Post By zuben el genub
  • 1 Post By John Bean

test: Reply
 
LinkBack Thread Tools
Old September 12th, 2013, 11:54 AM   #1 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Sad Can't receive texts messages from certain numbers

Im having this problem for months already, i didn't worried at first because i never use texts message, but now i really need to use SMS on my job, and i still can't receive texts from certain numbers or carriers.

I tried different roms, i also went back to stock and still can't receive any text, i called tmobile and they couldn't figured any solutions.

Don't know why it won't work, is there other people that had the same problem and got it working now?

Could it be the sim card? i have an extra one never used, i haven't tried that yet.

Advertisements
__________________
I want to thank the Good Lord for making me a Yankee - Joe DiMaggio
xploPR is offline  
Last edited by xploPR; September 12th, 2013 at 01:02 PM.
Reply With Quote
sponsored links
Old September 14th, 2013, 02:43 PM   #2 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

I still can't get texts messages, i wonder if it's a tmobile problem.

Anyone with same issues as me?
xploPR is offline  
Reply With Quote
Old September 14th, 2013, 06:38 PM   #3 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

Quote:
Originally Posted by xploPR View Post
I still can't get texts messages, i wonder if it's a tmobile problem.

Anyone with same issues as me?
I have no issues...except at a friends house where it's a dead zone.
If you've had this problem on different ROMs with different text apps my guess is it's something on your end...either the phone itself or the service.

Now that your back on stock...have you tied a different text app or are you using the stock app...also since your rooted, are you running anything special...like kernels or radios..?? Any blocking or privacy apps..??
xploPR likes this.
lion7718 is offline  
Reply With Quote
The Following User Says Thank You to lion7718 For This Useful Post:
xploPR (September 14th, 2013)
Old September 14th, 2013, 09:41 PM   #4 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Unhappy

Quote:
Originally Posted by lion7718 View Post
I have no issues...except at a friends house where it's a dead zone.
If you've had this problem on different ROMs with different text apps my guess is it's something on your end...either the phone itself or the service.

Now that your back on stock...have you tied a different text app or are you using the stock app...also since your rooted, are you running anything special...like kernels or radios..?? Any blocking or privacy apps..??
Yeah, i have tried different stock apps, and im running stock radio and kernel, i've tried from different places not just at home, and still won't get any incoming texts from certain numbers.

I don't know what else to try

edit: i don't have any privacy or blocking apps.
xploPR is offline  
Last edited by xploPR; September 14th, 2013 at 09:44 PM.
Reply With Quote
Old September 14th, 2013, 11:01 PM   #5 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

You haven't mentioned that I can see, have you tried a factory reset..??
lion7718 is offline  
Reply With Quote
Old September 15th, 2013, 01:03 AM   #6 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

I thought flashing stock rom via Wugs Nexus 4 Root Toolkit? would factory reset my phone again, or a factory reset is needed even after flashing stock and locking bootloader again?
xploPR is offline  
Reply With Quote
Old September 15th, 2013, 08:45 AM   #7 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

Not really sure, it was just a guess really. Are you on 4.2.2 or 4.3..??
Being that your completely stock now, it's hard to figure this out...
lion7718 is offline  
Reply With Quote
Old September 15th, 2013, 01:01 PM   #8 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

I tested on both stock 4.2 & 4.3 and had the same results on both, i didn't do a factory reset on any stock rom, right now im running vanir rom MBQ nightlies, with unlock bootloader and stock kernel.

Where should i go from here, back to stock and try a factory reset? Or should i try a new sim card?
xploPR is offline  
Reply With Quote
Old September 15th, 2013, 08:17 PM   #9 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

I wouldn't think the Sim would have anything to do with it...
Check your APN setting for this:

MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MCC: 310
MNC: 260
APN Protocol: IPv4/IPv6
xploPR likes this.
lion7718 is offline  
Reply With Quote
The Following User Says Thank You to lion7718 For This Useful Post:
xploPR (September 15th, 2013)
Old September 15th, 2013, 09:52 PM   #10 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

I check the apn setting and match it with the one you provided, and the only part that was not the same was APN Protocol: IPv4/IPv6

it was setup as IPV4, i already changed it to IPv4/IPv6 and saved it, rebooted the phone did a test it still won't receive, i guess my phone just don't want to receive from certain numbers. it's so weird.
xploPR is offline  
Reply With Quote
sponsored links
Old September 15th, 2013, 10:16 PM   #11 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

Quote:
Originally Posted by xploPR View Post
I check the apn setting and match it with the one you provided, and the only part that was not the same was APN Protocol: IPv4/IPv6

it was setup as IPV4, i already changed it to IPv4/IPv6 and saved it, rebooted the phone did a test it still won't receive, i guess my phone just don't want to receive from certain numbers. it's so weird.

IPV4 alone was fine, when I flashed LTE on my phone, it was posted that either or would work.
I'm kinda at a loss now...not sure where to go from here...sorry.
xploPR likes this.
lion7718 is offline  
Reply With Quote
Old September 16th, 2013, 02:20 PM   #12 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

No problem, thanks for your help.

I guess i will have to start cheking out other prepaid carriers that works with the N4, that have zero network problems, i hate paying for things i can't use.
xploPR is offline  
Reply With Quote
Old September 20th, 2013, 05:38 PM   #13 (permalink)
Senior Member
 
zuben el genub's Avatar
 
Join Date: Jan 2011
Posts: 5,078
 
Device(s): Nexus 4, Galaxy S 4G, Nexus S
Carrier: Not Provided

Thanks: 61
Thanked 955 Times in 762 Posts
Default

I just started having this problem with a Sprint customer. The damn 4 simply will not receive texts, but it will send. Started about 2 weeks ago.

It is not the SIM. I put the SIM in the old Nexus S and things are working just fine.

The phone is rooted, but running the original 4.2. I'm having trouble getting some answers about a computer so I haven't put on a custom ROM. Nor have I updated. Google always adds too much crap I don't want. Phone was running all my apps just fine. Doing phone calls just fine. I can talk to the Sprint customer on the phone all day - no problem. Just no text.

I've rebooted the phone, removed and put the SIM back in, and still no joy.

I'd love to back up the phone, but it's a computer problem. There's a post about 7 being a biatch, and I can't get an answer if virtual XP on 7 pro will work. That XP complains about no security, but 7 has it.

Any ideas what else I can do with this phone to get text service back?

Actually started about 3 weeks ago. I tried to send an MMS using Handcent. Phone chewed on the MMS for 20 minutes and the photo was only 27K! I resize pics myself before sending.

Went on vacation to Utah, Handcent refused to send any MMS. So I added Chomp. That worked fine until a week and a day later on return to Colorado. Tried unfreezing the default text, that doesn't work either.

Something has buggered somewhere on the phone. Any help would be welcome.
xploPR likes this.
__________________
Sent by UFO
zuben el genub is offline  
Last edited by zuben el genub; September 20th, 2013 at 05:41 PM.
Reply With Quote
Old September 21st, 2013, 04:14 AM   #14 (permalink)
Happy Wanderer
 
Join Date: Jul 2010
Location: Waterfoot, Lancashire
Gender: Male
Posts: 1,166
 
Device(s): Nexus 4, Nexus 7
Carrier: 3

Thanks: 110
Thanked 428 Times in 294 Posts
Default

If it used to work but now doesn't and you're using a somewhat non-standard configuration (frozen apps, etc) I would seriously consider doing a factory reset. There are just too many unknowns to offer any kind of meaningful diagnosis.

PS: I'd also consider upgrading to 4.3 at the same time; better to start again with a working (and up to date) OS than agonise over patching up a broken one. OT for this thread, but I'm unclear why you need to use a virtual XP in Win7 to do a backup. In any case a nandroid-type backup of a broken system is of limited use, and apps/data can easily be backed up using Titanium or similar.
xploPR likes this.
John Bean is offline  
Reply With Quote
Old September 21st, 2013, 08:08 AM   #15 (permalink)
Senior Member
 
zuben el genub's Avatar
 
Join Date: Jan 2011
Posts: 5,078
 
Device(s): Nexus 4, Galaxy S 4G, Nexus S
Carrier: Not Provided

Thanks: 61
Thanked 955 Times in 762 Posts
Default

I can get texts from TMO users just fine. It's just Sprint. I don't know anyone on Verizon.

W7, despite turning off security, insists that a couple of the apk files are malware, and won't copy them. There are other users having the same problem. Someone tried to transfer using Dropbox, and only 2 files were saved. The post is in the Forum section.

You don't even need to turn on debugging with 7. With XP you do. 7 sees everything on the whole device and lists the whole device as media. It doesn't work if you turn debugging on. I just got the computer, it had a new OEM install of 7. Nothing else, especially all the crapware you get when you buy a computer from a store.

I also don't happen to want the new update. I'm not exactly happy with this phone, anyway. I've used Samsung and Nokia. I liked the S. Even pure Android shoves in too much stuff I don't want.
I use a smart phone simply for Astronomy, Nature Guides, Weather, phone and text. They just need to load, fast. I don't care if I have E, 2G, 3G, or whatever. I use my wifi at home even though I do have a data plan.
zuben el genub is offline  
Last edited by zuben el genub; September 21st, 2013 at 08:18 AM.
Reply With Quote
Old September 21st, 2013, 06:17 PM   #16 (permalink)
Senior Member
 
zuben el genub's Avatar
 
Join Date: Jan 2011
Posts: 5,078
 
Device(s): Nexus 4, Galaxy S 4G, Nexus S
Carrier: Not Provided

Thanks: 61
Thanked 955 Times in 762 Posts
Default

Fixed. Too many stored messages. I keep the damn things since I can remember a conversation from a year ago, and my friends can't. So I keep messages to remind them.

Saved via Chomp - exports as a zip file.
zuben el genub is offline  
Reply With Quote
Old September 26th, 2013, 01:47 AM   #17 (permalink)
AF Contributor
Thread Author (OP)
 
xploPR's Avatar
 
Join Date: Mar 2012
Location: Richmond, VA.
Posts: 818
 
Device(s): Nexus 4 - Rooted & Unlock, Stock 4.3, (VM) HTC V EVO 4G- Rooted & Unlock -Angry Bean 4.2
Carrier: T-Mobile

Thanks: 192
Thanked 167 Times in 126 Posts
Default

Leaving an update to whoever cares lol, my issue was solved.

It was an issue on tmobile's end, not my phone itself, they got it all fix and working for me, now i could receive texts from all carriers.
xploPR is offline  
Reply With Quote
Old September 26th, 2013, 07:42 AM   #18 (permalink)
Senior Member
 
zuben el genub's Avatar
 
Join Date: Jan 2011
Posts: 5,078
 
Device(s): Nexus 4, Galaxy S 4G, Nexus S
Carrier: Not Provided

Thanks: 61
Thanked 955 Times in 762 Posts
Default

In my case, it was BOTH Sprint and TMO messing with towers. Both Samsung and Nexus phones now working.
zuben el genub is offline  
Reply With Quote
Old September 26th, 2013, 09:48 AM   #19 (permalink)
Member
 
lion7718's Avatar
 
Join Date: Nov 2011
Posts: 168
 
Device(s): LG Nexus 4
Carrier: T-Mobile USA

Thanks: 3
Thanked 30 Times in 26 Posts
Default

Quote:
Originally Posted by xploPR View Post
Leaving an update to whoever cares lol, my issue was solved.

It was an issue on tmobile's end, not my phone itself, they got it all fix and working for me, now i could receive texts from all carriers.

lion7718 is offline  
Reply With Quote
Reply

Nexus 4
Current Rating:
Rate this Phone:

The Nexus 4 brings comes after months and months of rumors. This is Google's first time partnering with LG to make a Nexus device. The Pure Google smartphone features the latest and greatest Android 4.2 software version, along with stunning spe... Read More



Go Back   Android Forums > Android Phones > Nexus 4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:05 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.