Go Back   Android Forums > Android Phones > HTC One S > One S - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree3Likes
  • 1 Post By agentc13
  • 1 Post By Altaone
  • 1 Post By Altaone

test: Reply
 
LinkBack Thread Tools
Old March 30th, 2013, 03:39 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default S-off - Fail

This is what happened when I tried S-off.





If you notice when I got the not found error I used ADB shell to look and see what the issue was, the first time I ran 'adb push soffbin3 /data/local/tmp/' I got 'failed to copy 'soffbin3' to '/data/local/tmp/': Is a directory'

So I went and looked - the directory structure was there but the file soffbin3 was not.
Ran the command again and it copied the file - then the file copied and chmod seemed to work - but running the file did not work - tried running command and going to the directory and running command == ./soffbin3

still get not found ?? tried multiple times.

Altaone is offline  
Reply With Quote
sponsored links
Old March 30th, 2013, 04:27 PM   #2 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

what rom are you on? also,how how up to date are your adb tools? you can thry with these: miniadb_v1031.zip

those are from the newest sdk.
__________________
The Delivery Guy
If someone has helped you,please click the THANKS button on that post.
Please post questions so others can benefit from the answers.
donate to my device fund
scotty85 is online now  
Reply With Quote
The Following User Says Thank You to scotty85 For This Useful Post:
Altaone (March 30th, 2013)
Old March 30th, 2013, 05:12 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

I am on CM10.1 (nandroid of CM10.1 works great) - currently the only roms I can run are CM 10 and CM10.1 cant go back to old nandroids - tried flashing ICS boot.img and still could not get my old nandroid to run. I Cant make` work, any roms that i have tried - virtous, trick droid, dark jelly and I think one other.

Trying new ADB tools now.
Altaone is offline  
Reply With Quote
Old March 30th, 2013, 05:26 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

still get 'adb shell su -c "/data/local/tmp/soffbin3"
/sbin/sh: su: not found'

went to sbin/sh and su is not there.

However when I go to ADB shell the prompt == # which means I am root right?
Altaone is offline  
Reply With Quote
Old March 30th, 2013, 05:26 PM   #5 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default Re: S-off - Fail

Hmm... maybe we should work on why you can't flash Roms. Cm 10 and 10.1 will likely run on the same kernel... Sounds like for whatever reason you are not actually changing them.

are you certain there are no errors when flashing the boot images? Maybe you've gotten them mixed up and are installing the same one over and over?

Maybe describe in as much detail as you can the process you go thru when installing them.
scotty85 is online now  
Reply With Quote
Old March 30th, 2013, 05:47 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Ok here is my process this afternoon.





I am willing to try anything at this point - however if there is a chance of a non working phone I would like to wait till monday so if I need to I can go buy another phone.
Altaone is offline  
Last edited by Altaone; March 30th, 2013 at 06:33 PM.
Reply With Quote
Old March 30th, 2013, 05:58 PM   #7 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Shouldnt I be able to go back to ICS roms if I flash the boot.img?

Also will CM10 work on stock boot.img stuff? - fastboot flash never gave an error always says writing. do you wnat to see output there?

I just read your last post on my thread about trying to find the right RUU -- how do I find out what SU I have it is not listed as an app
Altaone is offline  
Last edited by Altaone; March 30th, 2013 at 06:13 PM.
Reply With Quote
Old March 30th, 2013, 06:28 PM   #8 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default Re: S-off - Fail

Lol you have more questions than I can answer on my phone while doing the weekly grocery shopping I will answer as soon as I get a chance to read everything more closely.

You might try entering the last cmmand without the "Su" and see if that makes a difference.
scotty85 is online now  
Reply With Quote
Old March 30th, 2013, 06:34 PM   #9 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Lol sorry, I will try to mellow.

My fastboot ==

C:\Android\New ADB>fastboot flash boot boot.img
sending 'boot' (5278 KB)...
OKAY [ 0.889s]
writing 'boot'...
OKAY [ 1.326s]
finished. total time: 2.231s
Altaone is offline  
Reply With Quote
Old March 30th, 2013, 09:26 PM   #10 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

Quote:
Originally Posted by Altaone View Post
Lol sorry, I will try to mellow.

My fastboot ==

C:\Android\New ADB>fastboot flash boot boot.img
sending 'boot' (5278 KB)...
OKAY [ 0.889s]
writing 'boot'...
OKAY [ 1.326s]
finished. total time: 2.231s
thats ok. i didnt mean you should stop asking questions,i just didnt want you to think i was ignoring you. that output looks ok. you can try some different usb cables,and double check that nothing is running on the PC that may interfere with the phone. htc sync,pda net,easy tether,even i tunes can sometimes casue issues. ive seen things look fine in the cmd window,but not change the phone- its not real common,but it does happen. if something is comunicating with the phone at the same time,it can affect things.


Quote:
Originally Posted by Altaone View Post
Shouldnt I be able to go back to ICS roms if I flash the boot.img?
yes. you definately should. it appears that you are stuck on an AOSP boot image,and for some reason its not changing. really,all the stockish,sense based roms youve tried should prolly have booted on your stock kernel.

Also will CM10 work on stock boot.img stuff? -
unfortunately,no... cm10 is AOSP,it and JB are booting on the same kernel. sense and AOSP roms/kernels are very different because of the depth to wich sense is intertwined

I just read your last post on my thread about trying to find the right RUU -- how do I find out what SU I have it is not listed as an app
it should have an app in your app drawer. if it doesnt,im not quite sure what to think.

at this time,i do not believe youre having the "segmentation" error that i was.

some superuser apps will first give you a "$" when you type adb shell

then,to get the "#" you then need to type su. heres is where the prollem lies.

that last command,is broken down,actually into 3... you have adb shell,then su,then -c "/data/local/tmp/soffbin3"

your current rom takes you right to a "#" when you enter adb shell,so maybe the su is confusing it. what i meant above when i said to leave it out is to try it like this:
adb shell -c "/data/local/tmp/soffbin3"

as its looking for su and not finding it.

hmmm it just occured to me... you said you dont have a superuser app? maybe thats the prollem. if we could find you the super user app and binary that viper one is using,maybe you wouldnt get that error,and be in happy s off land

did your cm10 rom have a working superuser app? maybe go back to that,and try again.
Quote:
Originally Posted by Altaone View Post
Ok here is my process this afternoon.





I am willing to try anything at this point - however if there is a chance of a non working phone I would like to wait till monday so if I need to I can go buy another phone.
that all looks fine. you are wiping data/factory reset,cache,and dalvik cache,correct? if not that could certainly casue issues
scotty85 is online now  
Last edited by scotty85; March 30th, 2013 at 09:28 PM.
Reply With Quote
sponsored links
Old March 30th, 2013, 11:29 PM   #11 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

I knew I needed another pair of eyes!

I think not having su is the problem, how would I get that back or get the one from Viper?

As far as using different equipment, I have another computer that I have tried. I also have another USB cable but haven't tried that yet. Is HTC sync the only thing that I should uninstall? I also have HTC driver Installer and HTC BMP USB driver

Downloaded (from play store) super user app and it force closed isnt that cool. leaving that alone till I know more.

your current rom takes you right to a "#" when you enter adb shell,so maybe the su is confusing it. what i meant above when i said to leave it out is to try it like this:
adb shell -c "/data/local/tmp/soffbin3"


right so when I ran that command I got -- not found
also when I went to the directory where the file soffbin3 was and ran ./soffbin3 it also said not found - so now it makes sense the soffbin3 file is trying to do things that require su as well.

I dont know why but I was not connecting su with super user
Altaone is offline  
Last edited by Altaone; March 30th, 2013 at 11:57 PM.
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (March 31st, 2013)
Old March 31st, 2013, 11:40 AM   #12 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Wiped cache, dalvik, factory reset, system, internal sd. Then fastboot flash TWRP again, and then install from sd super su. reboot and still not found.




Altaone is offline  
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (March 31st, 2013)
Old March 31st, 2013, 12:16 PM   #13 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Then when I went to cm10.1, opened terminal emulator and requested SU. I was asked if I wanted to allow terminal SU access, but the icon in the top left corner was not a SU icon but the CM10.1 settins icon. attached photo
Altaone is offline  
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (March 31st, 2013)
Old March 31st, 2013, 12:17 PM   #14 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

this is the attachment
Attached Images
File Type: jpg CAM00044.jpg (557.0 KB, 8 views)
Altaone is offline  
Reply With Quote
Old March 31st, 2013, 01:00 PM   #15 (permalink)
Senior Member
 
razvan06's Avatar
 
Join Date: Jun 2010
Location: Bucharest
Gender: Male
Posts: 679
 
Device(s): Nexus One; Nexus S; Galaxy S II; HTC One X[T3]; HTC One S[S4]; HTC ONE; LG G2
Carrier: Cosmote

Thanks: 11
Thanked 86 Times in 79 Posts
Send a message via Yahoo to razvan06
Default

Quote:
Originally Posted by Altaone View Post
Then when I went to cm10.1, opened terminal emulator and requested SU. I was asked if I wanted to allow terminal SU access, but the icon in the top left corner was not a SU icon but the CM10.1 settins icon. attached photo

That is SU[Superuser] only on CM it's built-in the system, try to update the SU version, or install it from market, if that fails try to install ViperOne S ROM and try again, i did S-OFF from ViperOne S and had no issues.
__________________
Was this reply helpful ?
Don't forget the "Thanks" button !
razvan06 is offline  
Reply With Quote
Old March 31st, 2013, 07:17 PM   #16 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

Did you try on cm10? (Android 4.1)
scotty85 is online now  
Reply With Quote
Old April 1st, 2013, 07:10 AM   #17 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

I dont know if I will have the time tonight, I will let you know how it goes. Also if there is any kind of log etc. that might help let me know.

I have been trying to think when I started having issues, I first was using CWM and then saw a post about CWM causing trouble with one-s so I flashed TWRP. -- I think this is when the real issues began. I have no proof though, but I had not attempted a custom rom, after changing my recovery is when I started trying to flash to Viper.
Altaone is offline  
Last edited by Altaone; April 1st, 2013 at 07:27 AM.
Reply With Quote
Old April 1st, 2013, 03:15 PM   #18 (permalink)
Senior Member
 
razvan06's Avatar
 
Join Date: Jun 2010
Location: Bucharest
Gender: Male
Posts: 679
 
Device(s): Nexus One; Nexus S; Galaxy S II; HTC One X[T3]; HTC One S[S4]; HTC ONE; LG G2
Carrier: Cosmote

Thanks: 11
Thanked 86 Times in 79 Posts
Send a message via Yahoo to razvan06
Default

Quote:
Originally Posted by Altaone View Post
I dont know if I will have the time tonight, I will let you know how it goes. Also if there is any kind of log etc. that might help let me know.

I have been trying to think when I started having issues, I first was using CWM and then saw a post about CWM causing trouble with one-s so I flashed TWRP. -- I think this is when the real issues began. I have no proof though, but I had not attempted a custom rom, after changing my recovery is when I started trying to flash to Viper.

You can use CWM as the latest version if good.
Did you try and format : system/data/cache before installing new ROM [select stock kernel under install in Aroma when asked if you are flashing stock boot.img]? Also, did you manually flash the new boot.img from the Viper ROM ?
razvan06 is offline  
Reply With Quote
Old April 1st, 2013, 03:49 PM   #19 (permalink)
Daleks Über Alles
 
agentc13's Avatar
 
Join Date: Aug 2011
Location: Skaro
Posts: 7,839
 
Device(s): HTC One S, Kindle Fire
Carrier: T-Mobile USA

Thanks: 4,106
Thanked 5,382 Times in 2,789 Posts
Default

Quote:
Originally Posted by Altaone View Post
I dont know if I will have the time tonight, I will let you know how it goes. Also if there is any kind of log etc. that might help let me know.

I have been trying to think when I started having issues, I first was using CWM and then saw a post about CWM causing trouble with one-s so I flashed TWRP. -- I think this is when the real issues began. I have no proof though, but I had not attempted a custom rom, after changing my recovery is when I started trying to flash to Viper.
I have heard of some people having issues with the latest couple of version of TWRP and the Viper ROM. What version of TWRP are you using?
agentc13 is offline  
Reply With Quote
The Following User Says Thank You to agentc13 For This Useful Post:
scotty85 (April 1st, 2013)
Old April 2nd, 2013, 06:21 AM   #20 (permalink)
Member
 
bigt's Avatar
 
Join Date: May 2010
Location: Hereford
Posts: 236
 
Device(s): Nexus 5 (32 GB Black)
Carrier: ThreeUK

Thanks: 13
Thanked 38 Times in 34 Posts
Default

By default CM10 only allows root access from Apps not ADB. Go to Settings -> Developer options -> Root access, and change option to "Apps and ADB".
bigt is offline  
Reply With Quote
The Following User Says Thank You to bigt For This Useful Post:
scotty85 (April 2nd, 2013)
sponsored links
Old April 2nd, 2013, 03:48 PM   #21 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

Quote:
Originally Posted by bigt View Post
By default CM10 only allows root access from Apps not ADB. Go to Settings -> Developer options -> Root access, and change option to "Apps and ADB".
10.1 is still being developed... i run it on my rezound,and there is not a developer options setting yet. im unfamiliar with stock 4.2,so ive no idea if thats a 4.2 change,or cm10.1 not being quite up to speed. my stock phones are still on 4.1.

there is a system group of settings that has a "superuser" setting, where you can select apps,adb,both,or disable. maybe this is your issue... if you havent checked here,do so,and make sure you have adb allowed.

edit: i actually cant get an adb shell on my rezound... idk if this is a rezound issue,ora cm10.1 issue.

i think you should go back to cm10 and try s off again
scotty85 is online now  
Last edited by scotty85; April 2nd, 2013 at 03:52 PM.
Reply With Quote
Old April 4th, 2013, 08:11 AM   #22 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

I am on TWRP V. 2.4.4.0
I am running CyanogenMod V. 10.1 - 20130312 -nightly-ville.

Should I change them both?
Or one at a time?
Altaone is offline  
Reply With Quote
Old April 4th, 2013, 08:13 AM   #23 (permalink)
Daleks Über Alles
 
agentc13's Avatar
 
Join Date: Aug 2011
Location: Skaro
Posts: 7,839
 
Device(s): HTC One S, Kindle Fire
Carrier: T-Mobile USA

Thanks: 4,106
Thanked 5,382 Times in 2,789 Posts
Default

Quote:
Originally Posted by Altaone View Post
I am on TWRP V. 2.4.4.0
I am running CyanogenMod V. 10.1 - 20130312 -nightly-ville.

Should I change them both?
Or one at a time?
If you can find a TWRP 2.3.x version that would probably solve the Viper ROM issues. I have read that the newer TWRP updates don't play nicely with Viper.
agentc13 is offline  
Reply With Quote
Old April 4th, 2013, 08:20 AM   #24 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

What about new version of CWM and is that link on all things root guide?
Altaone is offline  
Reply With Quote
Old April 4th, 2013, 08:38 AM   #25 (permalink)
Daleks Über Alles
 
agentc13's Avatar
 
Join Date: Aug 2011
Location: Skaro
Posts: 7,839
 
Device(s): HTC One S, Kindle Fire
Carrier: T-Mobile USA

Thanks: 4,106
Thanked 5,382 Times in 2,789 Posts
Default

Quote:
Originally Posted by Altaone View Post
What about new version of CWM and is that link on all things root guide?
Personally I prefer TWRP and don't use CWM at all, so I can't tell you.
Altaone likes this.
agentc13 is offline  
Reply With Quote
The Following User Says Thank You to agentc13 For This Useful Post:
Altaone (April 4th, 2013)
Old April 5th, 2013, 12:37 AM   #26 (permalink)
Senior Member
 
razvan06's Avatar
 
Join Date: Jun 2010
Location: Bucharest
Gender: Male
Posts: 679
 
Device(s): Nexus One; Nexus S; Galaxy S II; HTC One X[T3]; HTC One S[S4]; HTC ONE; LG G2
Carrier: Cosmote

Thanks: 11
Thanked 86 Times in 79 Posts
Send a message via Yahoo to razvan06
Default

Quote:
Originally Posted by Altaone View Post
What about new version of CWM and is that link on all things root guide?
I did not have any issues when installing it w/ CWM [latest] so you should try it, also : flash recovery first and format system/data/cache then install Viper.
razvan06 is offline  
Reply With Quote
The Following User Says Thank You to razvan06 For This Useful Post:
scotty85 (April 5th, 2013)
Old April 5th, 2013, 07:41 AM   #27 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

If the roms are now scripted for s off flashing(for recovery to install the boot image) you might also try fastboot booting your recovery

fastboot boot recoveryimagename.img

Then simply flash the Rom normally. No seperate boot flash should be needed.
scotty85 is online now  
Reply With Quote
Old April 7th, 2013, 02:17 PM   #28 (permalink)
Member
 
bigt's Avatar
 
Join Date: May 2010
Location: Hereford
Posts: 236
 
Device(s): Nexus 5 (32 GB Black)
Carrier: ThreeUK

Thanks: 13
Thanked 38 Times in 34 Posts
Default

Quote:
Originally Posted by scotty85 View Post
10.1 is still being developed... i run it on my rezound,and there is not a developer options setting yet....

I am sure you've found out by now, but to enable developer options go to settings then about phone then tap on build number 5 times
bigt is offline  
Reply With Quote
The Following User Says Thank You to bigt For This Useful Post:
scotty85 (April 9th, 2013)
Old April 8th, 2013, 03:55 PM   #29 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

I will get to this I have not disappeared, I was hit by a dump truck friday. I will post results of advice I have been given here soon.
Altaone is offline  
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (April 9th, 2013)
Old April 9th, 2013, 05:26 PM   #30 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

ouch! sorry to hear that,hope you get to feeling better soon
scotty85 is online now  
Reply With Quote
sponsored links
Old May 8th, 2013, 07:50 AM   #31 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Where do I find the latest CWM ... BTW all the things i was behind on because of accident are now caught up except this.

I think installing the latest CWM is what makes sense to me.
Altaone is offline  
Reply With Quote
Old May 10th, 2013, 04:23 PM   #32 (permalink)
Member
 
bigt's Avatar
 
Join Date: May 2010
Location: Hereford
Posts: 236
 
Device(s): Nexus 5 (32 GB Black)
Carrier: ThreeUK

Thanks: 13
Thanked 38 Times in 34 Posts
Default

The latest CWM = http://download2.clockworkmod.com/recoveries/recovery-clockwork-touch-6.0.3.1-ville.img

For an S4 device
bigt is offline  
Reply With Quote
The Following 2 Users Say Thank You to bigt For This Useful Post:
Altaone (May 11th, 2013), scotty85 (May 10th, 2013)
Old May 11th, 2013, 12:29 PM   #33 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

New CWM installed and S-off still failing at last step,

/sbin is a directory but sh is not a directory ???? but it is listed inside of /sbin

what is SH? is it supposed to be a directory? ....

Will try installing Viper again here in a bit.
Altaone is offline  
Reply With Quote
Old May 11th, 2013, 09:11 PM   #34 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Woo hoo Viper installed. V2.1
scotty85 likes this.
Altaone is offline  
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (May 12th, 2013)
Old May 12th, 2013, 06:21 AM   #35 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

awsome! so was s off a success on viper?
scotty85 is online now  
Reply With Quote
Old May 12th, 2013, 07:25 AM   #36 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Have not tried S-off yet, but I think it is going to fail. (reasoning) I downloaded and tried to manually install LBE security from XDA, when I ran " adb install xxxxx.xxx I got an error that said something about /sbin/sh - it was something else not su. But will try again and post results. Soon as I get some coffee.

Here is what I got last night trying to install LBE security obviously it had a different filename -- but I get the same exact error whether trying to install shadow galaxy or LBE ....

C:\Android\New ADB>adb install "Shadow Galaxy.apk"
2808 KB/s (589477 bytes in 0.205s)
/sbin/sh: pm: not found

Quote:
Originally Posted by Altaone View Post
/sbin is a directory but sh is not a directory ???? but it is listed inside of /sbin

what is SH? is it supposed to be a directory? ....
I have become convinced this is the problem....posted on XDA, if you would read and add to this post if I have missed import info.
http://forum.xda-developers.com/showthread.php?t=2275441
Altaone is offline  
Last edited by Altaone; May 12th, 2013 at 09:36 AM.
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (May 12th, 2013)
Old May 12th, 2013, 03:52 PM   #37 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 93
 
Device(s): HTC One-s (*3) HTC One
Carrier: T-Mobile

Thanks: 37
Thanked 17 Times in 16 Posts
Default

Umm sorry,

Lol I told you I was a noob.....all because I was trying to run adb in recovery.

read XDA post. OTHERWISE !!!! Woo Hoo S-off.
scotty85 likes this.
Altaone is offline  
Reply With Quote
The Following User Says Thank You to Altaone For This Useful Post:
scotty85 (May 12th, 2013)
Old May 12th, 2013, 05:02 PM   #38 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,650
 
Device(s):
Carrier: Not Provided

Thanks: 7,184
Thanked 6,786 Times in 4,268 Posts
Default

awsome! happy rom flashing
scotty85 is online now  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC One S > One S - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:18 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.