Go Back   Android Forums > Android Phones > LG Optimus M > Optimus M - All Things Root
Optimus M - All Things Root Rooting, ROMS, Overclocking, etc.

New Forums: Nexus Player | Nexus 9
Like Tree4Likes
  • 1 Post By t3084
  • 1 Post By t3084
  • 1 Post By Izu
  • 1 Post By shahbadshah

test: Reply
 
LinkBack Thread Tools
Old April 7th, 2012, 05:31 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2011
Posts: 88
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Angry Package file is invalid error

Every time I download an application from Market I get an error saying " Package file is invalid." Then I can't download the app. Anyone know how to fix this?

Advertisements
ZOOLAHiSHKOBOB is offline  
Reply With Quote
sponsored links
Old April 7th, 2012, 06:50 PM   #2 (permalink)
Member
 
Join Date: Feb 2011
Location: Tustin, CA
Posts: 327
 
Device(s):
Carrier: StraightTalk

Thanks: 6
Thanked 28 Times in 24 Posts
Send a message via Skype™ to t3084 tthreeoh
Default

This sometimes happens, and it doesn't matter what rom you are using.

you can first try to Go into Settings > Applications > Manage Applications > Market/Play store > delete the cache and data.

If this does not work, redo the steps above but right after reboot into recovery. Format/clear the cache partition, and in Advance options menu, Clear the Dalvik cache. Reboot, and try the market again.

If this doesn't work... you're just gonna have to reflash the system. Don't worry, you SHOULD be able to get away with this by Going into recovery, WITHOUT WIPING, reflash the same rom, and again format/clear the Cache partition, and in the Advance menu options, delete the Dalvik Cache. reboot again.

If this doesn't work.... wipe everything.
NFLprincess likes this.
t3084 is offline  
Reply With Quote
The Following 2 Users Say Thank You to t3084 For This Useful Post:
AlvinChien (July 4th, 2012), NFLprincess (October 11th, 2012)
Old April 7th, 2012, 07:28 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2011
Posts: 88
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

not working =/
ZOOLAHiSHKOBOB is offline  
Reply With Quote
Old April 7th, 2012, 07:50 PM   #4 (permalink)
Member
 
Join Date: Feb 2011
Location: Tustin, CA
Posts: 327
 
Device(s):
Carrier: StraightTalk

Thanks: 6
Thanked 28 Times in 24 Posts
Send a message via Skype™ to t3084 tthreeoh
Default

If you followed all the steps, even to a complete reflash of everything... that means factory reset+reflash of the rom, there should be no reason it doesn't :/

Can you tell us specifically which rom(build) you are using?
t3084 is offline  
Reply With Quote
Old April 7th, 2012, 08:41 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2011
Posts: 88
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

[ROM][WIP]CM7.2.0 RC1-BobZ
ZOOLAHiSHKOBOB is offline  
Reply With Quote
Old April 7th, 2012, 09:52 PM   #6 (permalink)
Member
 
Join Date: Feb 2011
Location: Tustin, CA
Posts: 327
 
Device(s):
Carrier: StraightTalk

Thanks: 6
Thanked 28 Times in 24 Posts
Send a message via Skype™ to t3084 tthreeoh
Default

the latest build? 3-24-12?

Did you already try the full reset and re-flash?
t3084 is offline  
Reply With Quote
Old April 11th, 2012, 12:22 PM   #7 (permalink)
Member
 
mario0318's Avatar
 
Join Date: May 2011
Posts: 220
 
Device(s):
Carrier: Not Provided

Thanks: 27
Thanked 32 Times in 27 Posts
Default

Have you tried downloading an app called MarketFix?
mario0318 is offline  
Reply With Quote
The Following User Says Thank You to mario0318 For This Useful Post:
Old April 11th, 2012, 03:04 PM   #8 (permalink)
Junior Member
 
Zokula's Avatar
 
Join Date: Feb 2012
Location: Dearborn, MI
Posts: 41
 
Device(s): LG Optimus M
Carrier: Not Provided

Thanks: 10
Thanked 5 Times in 4 Posts
Default

I had this happen a few times, the only fix that worked for me was re flashing whatever ROM I was using.
Zokula is offline  
Reply With Quote
Old April 11th, 2012, 03:10 PM   #9 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by Zokula View Post
I had this happen a few times, the only fix that worked for me was re flashing whatever ROM I was using.

Go look at my post in bobz cm7 rom
__________________
Ok, you want help? I am here to help. But if you can't read, I can't really help you.
Why on earth would anyone help someone who does not read? This is a forum, the purpose of it is to read.
sammyz is offline  
Reply With Quote
Old April 11th, 2012, 03:31 PM   #10 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: Texas
Posts: 47
 
Device(s): LG Optimus M running BACKside CM7.2 RC1, OC'd @ 768 Mhz
Carrier: Not Provided

Thanks: 5
Thanked 2 Times in 2 Posts
Default

If your on bobz RC0 build, then this happened to me too. deleting the caches didn't work either. It wasn't until RC1 was released that it worked.
Renton23 is offline  
Reply With Quote
sponsored links
Old April 11th, 2012, 04:36 PM   #11 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by Renton23 View Post
If your on bobz RC0 build, then this happened to me too. deleting the caches didn't work either. It wasn't until RC1 was released that it worked.

U have to delete the file Bob said to delete as well, not just cache....
sammyz is offline  
Reply With Quote
Old April 11th, 2012, 04:38 PM   #12 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

This is what I accidentally posted in bobz cm7 thread instead of this one:
Quote:
Originally Posted by BobZhome View Post
Try moving and/or deleting the 01mvdalvik file out of init.d, located here: /system/etc/init.d/01mvdalvik, clear market cache and data, reboot recovery, wipe cache/dalvik_cache, reboot.

This is to fix market^ use "es file explorer" or "root explorer" this goes for ALL roms

Thank BobZhome, not me.....
sammyz is offline  
Reply With Quote
The Following 2 Users Say Thank You to sammyz For This Useful Post:
mbk1994 (October 22nd, 2012), NFLprincess (October 10th, 2012)
Old April 11th, 2012, 08:13 PM   #13 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: Texas
Posts: 47
 
Device(s): LG Optimus M running BACKside CM7.2 RC1, OC'd @ 768 Mhz
Carrier: Not Provided

Thanks: 5
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by sammyz View Post
U have to delete the file Bob said to delete as well, not just cache....
I hadn't seen that.... but like I said RC1 fixed it for me.
Renton23 is offline  
Reply With Quote
Old April 15th, 2012, 02:38 PM   #14 (permalink)
Junior Member
 
DBNissan's Avatar
 
Join Date: Mar 2011
Location: NorCal
Posts: 90
 
Device(s): Samsung Galaxy Nexus, LG Optimus V
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by sammyz View Post
This is what I accidentally posted in bobz cm7 thread instead of this one:


This is to fix market^ use "es file explorer" or "root explorer" this goes for ALL roms

Thank BobZhome, not me.....

I tried deleting and moving 01mvdalvik but it wouldn't let me. Any other way to remove it?
DBNissan is offline  
Reply With Quote
Old April 15th, 2012, 02:54 PM   #15 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by DBNissan View Post
I tried deleting and moving 01mvdalvik but it wouldn't let me. Any other way to remove it?

Did you reboot into recovery and erase cache and dalvik cache??
sammyz is offline  
Reply With Quote
Old April 15th, 2012, 03:31 PM   #16 (permalink)
Junior Member
 
DBNissan's Avatar
 
Join Date: Mar 2011
Location: NorCal
Posts: 90
 
Device(s): Samsung Galaxy Nexus, LG Optimus V
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by sammyz View Post
Did you reboot into recovery and erase cache and dalvik cache??
not yet. I got stuck at the first step so I didn't want to move any further until I backed-up my files/apps. I'll try that after backup completes
DBNissan is offline  
Reply With Quote
Old April 15th, 2012, 03:42 PM   #17 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by DBNissan View Post
not yet. I got stuck at the first step so I didn't want to move any further until I backed-up my files/apps. I'll try that after backup completes
after backup completes,
  1. boot into phone
  2. remove the same file again
  3. then go to settings>Applications>Manage Applications>Market or Google Play Store
  4. hit clear data.
  5. now wipe /cache and dalvik cache in recovery
  6. reboot
sammyz is offline  
Last edited by sammyz; April 15th, 2012 at 03:44 PM.
Reply With Quote
The Following 2 Users Say Thank You to sammyz For This Useful Post:
DBNissan (April 15th, 2012), jasonzech (July 16th, 2012)
Old April 15th, 2012, 03:51 PM   #18 (permalink)
Junior Member
 
DBNissan's Avatar
 
Join Date: Mar 2011
Location: NorCal
Posts: 90
 
Device(s): Samsung Galaxy Nexus, LG Optimus V
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 8 Posts
Default

Thanks sammyz! I had already deleted google play data and then wiped cache and dalvik cache in recover after backup completed. I did not go back to remove the file but downloading apps is working again! I will go back to delete the 01mvdalviknow.
DBNissan is offline  
Reply With Quote
Old April 15th, 2012, 03:55 PM   #19 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by DBNissan View Post
Thanks sammyz! I had already deleted google play data and then wiped cache and dalvik cache in recover after backup completed. I did not go back to remove the file but downloading apps is working again! I will go back to delete the 01mvdalviknow.
Yea the fix to this particular error applies to all roms, any other error is usually fixed by just force closing it or rebooting it.
sammyz is offline  
Reply With Quote
Old April 15th, 2012, 03:56 PM   #20 (permalink)
Junior Member
 
DBNissan's Avatar
 
Join Date: Mar 2011
Location: NorCal
Posts: 90
 
Device(s): Samsung Galaxy Nexus, LG Optimus V
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 8 Posts
Default

Still won't let me delete or move 01mvdalvik but I am still able to download apps. I guess I'll just wipe cache and dalvik cache if it happens again.

Thanks again sammyz
DBNissan is offline  
Reply With Quote
sponsored links
Old April 15th, 2012, 04:00 PM   #21 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by DBNissan View Post
Still won't let me delete or move 01mvdalvik but I am still able to download apps. I guess I'll just wipe cache and dalvik cache if it happens again.

Thanks again sammyz
Make sure you have root privileges....use a root explorer, go through the settings (of the app) and make sure everything that needs to be checked is checked
sammyz is offline  
Last edited by sammyz; April 15th, 2012 at 04:03 PM.
Reply With Quote
Old April 15th, 2012, 04:10 PM   #22 (permalink)
Junior Member
 
DBNissan's Avatar
 
Join Date: Mar 2011
Location: NorCal
Posts: 90
 
Device(s): Samsung Galaxy Nexus, LG Optimus V
Carrier: Not Provided

Thanks: 11
Thanked 8 Times in 8 Posts
Default

I was using file manager. Which root explorer do you recommend?
DBNissan is offline  
Reply With Quote
Old April 15th, 2012, 04:12 PM   #23 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by DBNissan View Post
I was using file manager. Which root explorer do you recommend?
The free one, ES File Manager i think it's called, just search "root explorer" and you'll see it.
sammyz is offline  
Reply With Quote
Old April 16th, 2012, 12:21 AM   #24 (permalink)
Member
 
Join Date: Feb 2011
Location: Tustin, CA
Posts: 327
 
Device(s):
Carrier: StraightTalk

Thanks: 6
Thanked 28 Times in 24 Posts
Send a message via Skype™ to t3084 tthreeoh
Default

I think ES file explorer should be included in the roms by default... thats just my opinion
sammyz likes this.
t3084 is offline  
Reply With Quote
Old June 30th, 2012, 07:43 AM   #25 (permalink)
Izu
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Cool found a trick

Hi, Im new to this forum. About file invalid error on playstore... I faced the same problem before. So I jzt experiment something new and it worked. Just go to the access point names and see if there is an option to edit data access point settings. Then see if your connection is proxy enabled. If enabled, write down the proxy address for future referance. Then erace the proxy address and save settings. Now go to play store and see if it works! Worked for me... Itz easy and give it a try if you are going to do more advanced thing like FLASHING THE ROM... Blessings... AND OMG THIS IS MY FIRST REPLY IN FORUM.... ;-)
sammyz likes this.
Izu is offline  
Last edited by Izu; June 30th, 2012 at 07:45 AM.
Reply With Quote
The Following User Says Thank You to Izu For This Useful Post:
arjunaanuradha (October 31st, 2012)
Old July 22nd, 2012, 03:52 PM   #26 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default google play

I just got a galaxy tab 7 took it out of the box and cant download anything keeps saying invalid package
chefdube is offline  
Reply With Quote
Old August 9th, 2012, 02:51 AM   #27 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default about the package file invalid

Quote:
Originally Posted by DBNissan View Post
not yet. I got stuck at the first step so I didn't want to move any further until I backed-up my files/apps. I'll try that after backup completes
i cant remove the playstore in my phone,even i already reset my phone and then i cant install applications anymore
jon11 is offline  
Reply With Quote
Old August 9th, 2012, 02:55 AM   #28 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default about the package file invalid

Quote:
Originally Posted by sammyz View Post
Make sure you have root privileges....use a root explorer, go through the settings (of the app) and make sure everything that needs to be checked is checked
i cant download and install applications from the playstore,
can i ask some help ? its important,please help >>>
jon11 is offline  
Reply With Quote
Old August 9th, 2012, 08:31 AM   #29 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

You don't get root privileges from the play store, you have to root your tablet/phone
sammyz is offline  
Reply With Quote
Old August 10th, 2012, 07:23 AM   #30 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sammyz View Post
You don't get root privileges from the play store, you have to root your tablet/phone
how to root my phone ? the GT-s5300? please give some tips,
jon11 is offline  
Reply With Quote
sponsored links
Old August 20th, 2012, 06:40 PM   #31 (permalink)
New Member
 
Join Date: Apr 2012
Location: Daly City
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks.
Finally download MarketFix in Market and it works for me. did clear date stuff in recovery mode not working for me also and can't move/delete 01mvdalvik file either.
zsw128 is offline  
Reply With Quote
Old August 20th, 2012, 07:18 PM   #32 (permalink)
New Member
 
Join Date: Apr 2012
Location: Daly City
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

sorry, i spoke too soon. MarketFix don't work. grant superuser, move 01mvdalvik to sd. (it said moved to sd, but it's not doing it.) download an app and it said install successfully the first time, but the app is no where to found in phone, try reboot, app not there either. redo and now said package invalid again.
zsw128 is offline  
Reply With Quote
Old August 23rd, 2012, 12:18 AM   #33 (permalink)
Senior Member
 
Join Date: Aug 2011
Posts: 607
 
Device(s): LG OPTIMUS MS-690
Carrier: Not Provided

Thanks: 32
Thanked 61 Times in 47 Posts
Send a message via AIM to AndroidHogs
Default

Delete 01dalvikvm with root explorer. Don't move it to sdcard. Clear data and cache from Google play. And delete cache and dalvik in recovery this worked for me.
__________________
Donate here
AndroidHogs is offline  
Reply With Quote
Old August 23rd, 2012, 09:00 AM   #34 (permalink)
Senior Member
 
BrandonOptimus's Avatar
 
Join Date: Sep 2011
Location: Jersey
Gender: Male
Posts: 548
 
Device(s): Nexus 4 PAC-Rom,SGS3 OmegaV31(JB), LG Optimus M CM7.2 Fully Ics Themed
Carrier: Simple

Thanks: 82
Thanked 57 Times in 52 Posts
Angel Location of 01dalvik

You would have to go to /etc/init.d to find the 01dalvik, once found delete it. then go to manage applications and Erase the cache/data from the Google Play/Android Market app. Then reboot into recovery and wipe dalvik cacheTHEN wipe cache. It will take a while for the phone to boot up again. So be Patient.

Also. I've noticed roms like backside don't have that file... So there shouldnt be a invalid error if you are using that rom.
BrandonOptimus is offline  
Last edited by BrandonOptimus; August 23rd, 2012 at 09:12 AM.
Reply With Quote
Old September 3rd, 2012, 04:55 PM   #35 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

The 01mvdalvik or 01dalvik also may not be in /system/etc/init.d if you're running darktremor / Link2SD / s2e for a sd-ext partition on your SD card. On s2e, there's an option to either place it on the sd-ext or internal memory. Link2SD lets you choose where to put the dalvik files for each app individually. I'm not sure about darktremor since I havn't used it. Either way, when running a sd-ext script, don't even try looking for the dalvik file. Just wipe cache and dalvik and it should be ok.
TranceWarp is offline  
Reply With Quote
Old September 10th, 2012, 06:09 PM   #36 (permalink)
New Member
 
Join Date: Apr 2012
Location: Daly City
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

O.k, finally deleted 01mvdalvik. Now new problem, getting the same "Package file is invalid." for any app that's larger than 6 mb I think. any fix to this?? thx
zsw128 is offline  
Reply With Quote
Old September 10th, 2012, 08:11 PM   #37 (permalink)
LG Whiz Kid
 
sammyz's Avatar
 
Join Date: Jun 2011
Location: Pompano Beach, Fl
Gender: Male
Posts: 8,726
 
Device(s): LG Motion 4G---- LG Optimus L9
Carrier: MetroPCS

Thanks: 2,169
Thanked 2,332 Times in 1,515 Posts
Default

Quote:
Originally Posted by zsw128 View Post
O.k, finally deleted 01mvdalvik. Now new problem, getting the same "Package file is invalid." for any app that's larger than 6 mb I think. any fix to this?? thx
clean caches of play store, clear data, reboot into recovery, wipe cache and dalvik-cache
sammyz is offline  
Reply With Quote
Old September 12th, 2012, 11:43 AM   #38 (permalink)
New Member
 
Join Date: Apr 2012
Location: Daly City
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

wipe cache partition and in advanced wipe Dalvik Cache, but still the same "package file is invalid". I try 4 mb app this time, it's not working. I am using CM 7.2.0 RC1 dated March 24, 2012.
zsw128 is offline  
Reply With Quote
Old September 12th, 2012, 11:46 AM   #39 (permalink)
New Member
 
Join Date: Apr 2012
Location: Daly City
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Yes, I clean the caches of the Play too before I boot to recover to wipe cache and wipe Dalvik. phone memory is fine, I have 303 mb free.
zsw128 is offline  
Reply With Quote
Old September 13th, 2012, 12:59 AM   #40 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just fixed the same problem 'package file is invalid'. I couldnt download an app over 9mb in size. Called samsung and they hadnt a clue how to fix it they just told me to restore device to factory settings. I stupidly done this but it didnt fix it

Called my network provider, they helped me change a couple of network settings, delete play store data and cache n restored default settings and now its working fine.
no toes2000 is offline  
Reply With Quote
sponsored links
Old October 1st, 2012, 02:42 AM   #41 (permalink)
Junior Member
 
Join Date: Sep 2012
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

deleted play store data. rebooted to recovery and deleted 2 cache files and now i got iheartradio working
tecvoid is offline  
Reply With Quote
Old October 22nd, 2012, 10:01 PM   #42 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sammyz View Post
This is what I accidentally posted in bobz cm7 thread instead of this one:
Quote:
Try moving and/or deleting the 01mvdalvik file out of init.d, located here: /system/etc/init.d/01mvdalvik, clear market cache and data, reboot recovery, wipe cache/dalvik_cache, reboot.
This is to fix market^ use "es file explorer" or "root explorer" this goes for ALL roms

Thank BobZhome, not me.....
Hi there,

I'm having the same problem too, and I tried the thing sammyz said, but there is no such file in my phone. I used Root Explorer, go into the /system/etc folder, but there was no such folder as init.d. There were just init.goldfish.sh and init.qcom.bt.sh and such.

I'm using a LG-E405 phone with Android 2.3.5, if that helps.

Anyone giving me a hand? I'm exhausted finding compatible .apk files on websites and plug my phone in and put those files in the sd card and setting them up. It just takes too much time. I want to use Google Play T______T

Edit: I aslo tried clearing the cache, data,... even rebooting my phone many times, but nothing worked. I've just bought my phone, and I still couldn't download anything from Google Play yet.
mbk1994 is offline  
Last edited by mbk1994; October 22nd, 2012 at 10:08 PM.
Reply With Quote
Old October 24th, 2012, 04:29 PM   #43 (permalink)
Senior Member
 
rhino889a's Avatar
 
Join Date: May 2012
Location: Somewhere in the Internet
Gender: Male
Posts: 1,002
 
Device(s): Lg Motion,Lg Motion,Lg Motion
Carrier: Pidgeon

Thanks: 1
Thanked 177 Times in 128 Posts
Default

i have never had this problem. but i might try uninstalling market updates then connecting. it will update and maybe fix.just an idea i just got an optimus but dont use it much yet. but have the forum inmy favorites. connect through browser. i dont know just adifferent angle maybe manually remove market , data a n .dex renstllall playstore then let it update?
__________________
Can someone post a link to Google?
This Message Was Sent To You From ..."MikeHawk"
rhino889a is offline  
Last edited by rhino889a; October 24th, 2012 at 04:40 PM.
Reply With Quote
Old October 31st, 2012, 12:32 PM   #44 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up Thanks

Quote:
Originally Posted by Izu View Post
Hi, Im new to this forum. About file invalid error on playstore... I faced the same problem before. So I jzt experiment something new and it worked. Just go to the access point names and see if there is an option to edit data access point settings. Then see if your connection is proxy enabled. If enabled, write down the proxy address for future referance. Then erace the proxy address and save settings. Now go to play store and see if it works! Worked for me... Itz easy and give it a try if you are going to do more advanced thing like FLASHING THE ROM... Blessings... AND OMG THIS IS MY FIRST REPLY IN FORUM.... ;-)
You are the MAN, it worked for me ... Thanks a lot Bro...... I had been suffering a lot because of this damn error message.... Thanks again..............
arjunaanuradha is offline  
Reply With Quote
Old November 11th, 2012, 02:14 AM   #45 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mbk1994 View Post
Hi there,

I'm having the same problem too, and I tried the thing sammyz said, but there is no such file in my phone. I used Root Explorer, go into the /system/etc folder, but there was no such folder as init.d. There were just init.goldfish.sh and init.qcom.bt.sh and such.

I'm using a LG-E405 phone with Android 2.3.5, if that helps.

Anyone giving me a hand? I'm exhausted finding compatible .apk files on websites and plug my phone in and put those files in the sd card and setting them up. It just takes too much time. I want to use Google Play T______T

Edit: I aslo tried clearing the cache, data,... even rebooting my phone many times, but nothing worked. I've just bought my phone, and I still couldn't download anything from Google Play yet.
i used the search method on my rugby pro found /system/bin/dalvikvm so is this the file i need to delete? Also im really new at all this never rooted anything but for me to root my phone it says i need to use ODIN v3.04. I do not know anything about ODIN but i assume i would rather have 4.0.4 that came on my phone. After rooting is it possible to go back to the 4.0.4? Also is it necessary to do all of this? I haven't even seen another rugby pro have this problem in the forums. Any kind of help would be greatly appreciated
rugbypro is offline  
Reply With Quote
Old May 3rd, 2013, 11:17 AM   #46 (permalink)
Member
 
jabbawest's Avatar
 
Join Date: Mar 2011
Location: Fountain of Lamneth
Gender: Male
Posts: 400
 
Device(s): Nexus 4 - PA 3.65 nightly LG Esteem - #2 v3.0 LG Optimus - M CM7 x2 DroidX - Stock & Rooted
Carrier: T-Mobile

Thanks: 108
Thanked 101 Times in 74 Posts
Send a message via Yahoo to jabbawest 2149017525
Default

Okay, I've had this issue off and on for several weeks. This past week, it's been ON and nothing, and I mean none of the prescriptions I found worked.
FINALLY I tried one more self prescribed pill.
In Titanium Backup I first thought I could freeze the app and try installing as if it were new. That didn't work because the Play Store still sees that app but as disabled.
Still in TiBu, I did a Backup>Verify>Uninstall, went to Play and VOILA!! I was able to download again without the error.
__________________
[SIGPIC][/SIGPIC]
Level 3 IT
Master of all things Windows, Linux, Unix??
jabbawest is offline  
Reply With Quote
Old May 25th, 2013, 11:27 AM   #47 (permalink)
New Member
 
Join Date: May 2013
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi i solved it today ..if u rename your wifi ssid name than just rechange its name to the old name and enjoy
ldogg315 likes this.
shahbadshah is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > LG Optimus M > Optimus M - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:01 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.