Go Back   Android Forums > Android Phones > Orange San Francisco 2 (ZTE Blade 2)

test: Reply
 
LinkBack Thread Tools
Old March 27th, 2012, 11:39 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Cant download certain Apps!

I wanted to download the New Temple Run and when I found the link I realised it was for Versions 2.1 and up but it said on the top of the page that my device wasnt compatable!?
I have Android 2.3 on the ZTE Blade 2 and I dont understand why it wont work on my phone if ive got a phone better than the required, please help!?

Advertisements
Transidian is offline  
Reply With Quote
sponsored links
Old March 27th, 2012, 04:43 PM   #2 (permalink)
Junior Member
 
Join Date: Jun 2011
Location: Blackpool, UK
Gender: Male
Posts: 55
 
Device(s): Sony Xperia Z, Moto G 16gb
Carrier: Orange

Thanks: 4
Thanked 9 Times in 8 Posts
Default

The incompatibility isn't just concerning the version of Android, but also factors such as RAM and processing speed.

Unfortunately the crescent (blade2) is a low end handset and not all apps will function correctly on it.
fuzzface is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Orange San Francisco 2 (ZTE Blade 2)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:27 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.