Go Back   Android Forums > Android Phones > Orange San Francisco (ZTE Blade)

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old April 22nd, 2011, 05:30 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default SF screen goes black when calling...

HI, I am using Modaco r12 version... and I have a problem when I try to make a call... as soon as I stick the phone to my ear... the screen goes black and I can not do anything i.e. disconnect the call... I have to wait until call is finished and someone disconnect himself... then screen comes back. Factory reset did not help. Does anyone know how to fix this? Or maybe three is better ROM to install that r12??

Advertisements
maro1977 is offline  
Reply With Quote
sponsored links
Old April 22nd, 2011, 08:19 PM   #2 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

my best guess is you have an issue with your proximity sensor. It may be the rom (i have no experience with r12). you may want to flash a different rom or go back to stock and see if the proximity sensor works then. If not i would bring it back to the store and see what they have to say
fireislander is offline  
Reply With Quote
Old April 23rd, 2011, 10:26 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fireislander View Post
my best guess is you have an issue with your proximity sensor. It may be the rom (i have no experience with r12). you may want to flash a different rom or go back to stock and see if the proximity sensor works then. If not i would bring it back to the store and see what they have to say
I have tried different ROM... still had the same problem, well it was even worst... so I started reading about proximity sensor as you suggested and I found:

Quote:
Proximity sensor - sf screen goes off when calling:
Go into the Dialer an press *983*0#
Go all the way down to Sensors.
Hit"testing light" and then hit "testing proximity".
I give it a try... plus I did calibrate (additional option next to testing)... then a message 'proximity sensor OK' appeared just for a while and it works now!... although this soft still is saying proximity sensor fail on this page. I hope this will help someone who has experienced similar issue, too.
Cheers,
maro1977 is offline  
Last edited by maro1977; April 23rd, 2011 at 10:32 AM.
Reply With Quote
Old June 9th, 2011, 02:05 AM   #4 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wife's got the san francisco phone and The screen timeout is set very low like 30 seconds etc and thats still kicking in when on a phone call.

so screen goes off until you press power button again
fantomv50 is offline  
Reply With Quote
Old June 16th, 2011, 01:51 AM   #5 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 22
 
Device(s): Orange San Francisco/ZTE Blade
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Yea, as said above. It does it to me as well, when you want to hangup, press the home key, or the power key and it should come back to life :P
Conor Calby is offline  
Reply With Quote
Old July 3rd, 2011, 12:15 PM   #6 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s): Google Nexus One, ZTE Blade
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i've had this same problem since rooting and installing CyanogenMod 7. I didn't notice it at first, maybe because I don't really make that many calls, but when I did need to it quickly became annoying. I had to pull the battery at the end of every call.

I've tried various different Cyanogen ROMs, with the most recent nightly (CM7 Build #120) running at the moment and I still experience this.

Is this something that will be fixed in Cyanogen 7.1?

Cheers,

Ian
istacey is offline  
Reply With Quote
Old July 3rd, 2011, 12:48 PM   #7 (permalink)
Member
 
Vorbis's Avatar
 
Join Date: Mar 2011
Location: UK
Posts: 198
 
Device(s): Samsung Galaxy S4 I9505, Nexus 7 2012
Carrier: giffgaff (O2 MVNO)

Thanks: 55
Thanked 32 Times in 30 Posts
Default

I've tried CyanogenMod 7 nighlies 105, 113 and currently 104 (pre-battery drain nightly). I've not had issues with my proximity sensor (yet).
Vorbis is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Orange San Francisco (ZTE Blade)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:06 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.