Go Back   Android Forums > Android Tablets & MIDs > DoDo Pendo Pad > Pendo Pad - All Things Root

Like Tree12Likes

test: Reply
 
LinkBack Thread Tools
Old August 20th, 2012, 01:38 AM   #51 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

AWESOME work Stylez,

Downloading now to test.

Advertisements
kaneelias is offline  
Reply With Quote
sponsored links
Old August 20th, 2012, 05:45 AM   #52 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Notsure

Quote:
Originally Posted by kaneelias View Post
AWESOME work Stylez,

Downloading now to test.
I have a feeling that i may have messed up the boot.img
I used "abootimg" to create it instead of "mkbootimg" and I think I was supposed to use "mkbootimg". Let me know if it worked anyway.
styelz is offline  
Reply With Quote
Old August 20th, 2012, 06:06 PM   #53 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by styelz View Post
I have a feeling that i may have messed up the boot.img
I used "abootimg" to create it instead of "mkbootimg" and I think I was supposed to use "mkbootimg". Let me know if it worked anyway.
Hey Stylez,

Seems to be stuck at the boot screen. All that is showing is your Avatar logo and has been on this screen for 20 minutes.

Could the boot image be the problem?

Was able to restart the device and Flash the original image from Pendo and have restored it to the previous state for now. Am happy to test again if you change the boot image. Cheers.
kaneelias is offline  
Last edited by kaneelias; August 20th, 2012 at 07:15 PM.
Reply With Quote
Old August 21st, 2012, 02:33 AM   #54 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

Quote:
Originally Posted by kaneelias View Post
Hey Stylez,

Seems to be stuck at the boot screen. All that is showing is your Avatar logo and has been on this screen for 20 minutes.

Could the boot image be the problem?

Was able to restart the device and Flash the original image from Pendo and have restored it to the previous state for now. Am happy to test again if you change the boot image. Cheers.
Yes, I think it may be the system image that's the problem.
I needed to use mkuserimg.sh but left it as raw. I will try again.
Also, I messed up the boot image by using abootimg instead of mkbootimg

Will post URL's in a few hours.

I am also creating a guide on how to do this here (WIP)
styelz is offline  
Reply With Quote
Old August 21st, 2012, 02:45 AM   #55 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by styelz View Post
Yes, I think it may be the system image that's the problem.
I needed to use mkuserimg.sh but left it as raw. I will try again.
Also, I messed up the boot image by using abootimg instead of mkbootimg

Will post URL's in a few hours.

I am also creating a guide on how to do this here (WIP)
Oh cool on both fronts.

Will gladly test when it is available as I have managed to resurrect my Pendo Pad on 2 separate occasions now
kaneelias is offline  
Reply With Quote
Old August 21st, 2012, 12:31 PM   #56 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Thumbs up

I've updated the image file.

Update: tested and working for PP4MT-9 ONLY!

PP4MT-9 LiveSuit Image (ROOT,GAPPS)

I've also updated my LiveSuit Guide, on how I did this. If you want to try it yourself.

styelz is offline  
Last edited by styelz; August 23rd, 2012 at 08:17 AM.
Reply With Quote
Old August 21st, 2012, 06:46 PM   #57 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Stylez, you are an absolute legend. Worked a treat. Thanks a heap for all your help.
styelz likes this.
kaneelias is offline  
Last edited by kaneelias; August 21st, 2012 at 07:02 PM.
Reply With Quote
Old August 21st, 2012, 10:38 PM   #58 (permalink)
Junior Member
 
Join Date: Aug 2012
Location: Androidia
Posts: 18
 
Device(s): PP4MT- ICS 4.0.3
Carrier: Not Provided

Thanks: 10
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by styelz View Post
Hi,

Here's a link to the PP4MT-9 LiveSuit Image (Root, GAPPS, 1Mobile Market).
I have not been able to test it, so i'm not 100% sure it will work.

I couldn't fit CWMR on nandg. I will try again later and upload just the nandg if I can.
I removed a CPL of apps too like Aldiko and ES Explorere and Task Manager so I could fit GAPPS etc on there. You can re install these from Market if you wish.

Cheers.
{PHANDROID, I Posted this here cause iam a 100% noob when coming to forums and thought this the easiest way to contact this person -Nfv3}

Hey styelz,

Just wondering if you would happen to know anything about the XTE-Racer (T3020 in Oz)? i was trying ROM Manager and got stuck on the green android screen, i got this mooncake recovery but when i went and did everthing and reboot it, it loads to the android and then these colored shard looking things just spin around :S i think its trying to boot and cant? ive looked at a couple of other places and am at a stand still.

Thought i would come to the homie for advice :P

Cheers,
Ninjafrog
Ninjafrogv3 is offline  
Reply With Quote
Old August 22nd, 2012, 03:23 AM   #59 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Styelz, thank you so much. You a champion, and have turned my cheap and nasty "free bonus", "closed system"android tablet, into a decent true android tablet. Awesome.
styelz likes this.
bushy73 is offline  
Reply With Quote
Old August 22nd, 2012, 03:54 AM   #60 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Notsure

Quote:
Originally Posted by Ninjafrogv3 View Post
{PHANDROID, I Posted this here cause iam a 100% noob when coming to forums and thought this the easiest way to contact this person -Nfv3}

Hey styelz,

Just wondering if you would happen to know anything about the XTE-Racer (T3020 in Oz)? i was trying ROM Manager and got stuck on the green android screen, i got this mooncake recovery but when i went and did everthing and reboot it, it loads to the android and then these colored shard looking things just spin around :S i think its trying to boot and cant? ive looked at a couple of other places and am at a stand still.

Thought i would come to the homie for advice :P

Cheers,
Ninjafrog
Hi mate, sorry to hear about your troubles. I'm afraid i don't know anything about this phone. Try find a relevant forum for your device and ask there maybe.

Possibly check out this thread. ZTE won't factory reset nor access FTM mode - ZTE Racer - Racer.MoDaCo.com - MoDaCo not really sure.
styelz is offline  
Reply With Quote
sponsored links
Old August 22nd, 2012, 04:01 AM   #61 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

Here's an attempt to get CWM Recovery installed for PP4MT-9.

root_recovery-pp4mt-9.zip

The tablet needs to be rooted first.
Plugged into the PC with USB Debug Mode enabled.
Extract the ZIP file and run root_recovery.bat from Windows.
This will use ADB to write the CWM recovery image to nandg.
Press enter when done and your tablet should autoatically boot into recovery mode.
styelz is offline  
Last edited by styelz; August 24th, 2012 at 07:33 AM.
Reply With Quote
Old August 23rd, 2012, 08:59 PM   #62 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks styelz. I'll give it a try.
bushy73 is offline  
Reply With Quote
Old August 23rd, 2012, 10:26 PM   #63 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi Styelz, when I run root_recovery.bat from windows I get the following error message:

" adb is not recognized as an internal or external command, operable program, or batch file ".

Does this mean I do not have ADB properly installed on my pc? I just installed the latest Android SDK tools. Please excuse my ignorance!
bushy73 is offline  
Reply With Quote
Old August 24th, 2012, 07:37 AM   #64 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

Quote:
Originally Posted by bushy73 View Post
Hi Styelz, when I run root_recovery.bat from windows I get the following error message:

" adb is not recognized as an internal or external command, operable program, or batch file ".

Does this mean I do not have ADB properly installed on my pc? I just installed the latest Android SDK tools. Please excuse my ignorance!
You need adb.exe and the two DLL files.
I've added them to the zip file now.

You can also download ADB for windows >HERE<.

Just extract the EXE and DLL files to C:\windows\system32\
styelz is offline  
Reply With Quote
Old August 25th, 2012, 08:11 PM   #65 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

No matter what I did to my build.prop, I could not get Play Store to recognise my device for apps like Chrome, Digitally Imported Radio and Shazam.

I started to think it had something to do with the kernel. So i copied a kernel "zImage" from an update i found for a "HTC Holiday" device and created a new boot.img.

Finally, it worked!

Even RomManager works and installs a ClockworkModRecovery image.

styelz is offline  
Last edited by styelz; August 25th, 2012 at 08:51 PM.
Reply With Quote
Old August 27th, 2012, 08:20 PM   #66 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by styelz View Post
No matter what I did to my build.prop, I could not get Play Store to recognise my device for apps like Chrome, Digitally Imported Radio and Shazam.

I started to think it had something to do with the kernel. So i copied a kernel "zImage" from an update i found for a "HTC Holiday" device and created a new boot.img.

Finally, it worked!

Even RomManager works and installs a ClockworkModRecovery image.

That is awesome. Does it mean there is now a new LiveSuit image for the 7 and 9.7 inch Pendo's coming *wink, wink*
kaneelias is offline  
Reply With Quote
Old August 28th, 2012, 07:23 AM   #67 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by styelz View Post
You need adb.exe and the two DLL files.
I've added them to the zip file now.

You can also download ADB for windows >HERE<.

Just extract the EXE and DLL files to C:\windows\system32\

Thanks Styelz. After following your instructions I successfully manager to run "root_recovery.bat" . However, after pressing "Enter to reboot tablet", nothing happens. When /I manually reboot, there is no CWM app showing on the tablet. Any further suggestions?
bushy73 is offline  
Reply With Quote
Old August 29th, 2012, 02:07 AM   #68 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default 2 newbie questions

Hi everyone

Firstly thanks to the contributors for the great work!

Secondly, 2 total newbie questions:
1. If I attempt to root Pendo pad and something goes wrong, will I always be able to fix it by pushing the 'reset' button? I'm guessing 'no' but it would be nice to know at what point I cross the line and risk bricking the device.
2. Is there an easy newbie guide to rooting android devices (oxymoron?) someone can recommend?
NikoB is offline  
Reply With Quote
Old September 4th, 2012, 06:29 PM   #69 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by NikoB View Post
Hi everyone

Firstly thanks to the contributors for the great work!

Secondly, 2 total newbie questions:
1. If I attempt to root Pendo pad and something goes wrong, will I always be able to fix it by pushing the 'reset' button? I'm guessing 'no' but it would be nice to know at what point I cross the line and risk bricking the device.
2. Is there an easy newbie guide to rooting android devices (oxymoron?) someone can recommend?
Are you using a 9.7 or 7 inch pendo pad? I have written up a walk through of how to root both versions and it is pretty much fail safe if you follow the instructions to the letter. There is also an option to revert back to stock rom if it does not work. If you are interested let me know what version you have and I will direct you to the walk through.
kaneelias is offline  
Reply With Quote
Old September 5th, 2012, 12:45 AM   #70 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Great news Stylez,

Can you give me a new Image for Pendo 9.7" with new kernel Image or tell me how to do it, so I can get Chrome to work on Pendo.

Thanks
Jase987 is offline  
Reply With Quote
sponsored links
Old September 7th, 2012, 12:38 AM   #71 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kaneelias View Post
Are you using a 9.7 or 7 inch pendo pad? I have written up a walk through of how to root both versions and it is pretty much fail safe if you follow the instructions to the letter. There is also an option to revert back to stock rom if it does not work. If you are interested let me know what version you have and I will direct you to the walk through.
Kaneelias,
If you could provide the link to the walk-throughs that would be great.
PP4MT-7 is my version...haven't really looked too much into "rooting" the pad after i put panda-apps on it. Pretty much just using the pad as a comic/book reader

Cheers
Whitto69 is offline  
Reply With Quote
Old September 7th, 2012, 07:16 PM   #72 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by styelz View Post
Here is a LiveSuit Image with Full Root, CWM Recovery and GAPPS (UPDATED)
It is a two part RAR archive. Download and extract the image file.

Also, download LiveSuit Pack, extract and run LiveSuit.exe (this should install the driver for you).

Use LiveSuit and load the extracted ".img" file (press the first icon).
Make sure your tablet is off, and power and usb unplugged.

Now hold the volume down button, keep it held down and plug the USB cable in and then tap the power button about 6-8 times (tap, tap, tap). Then let go of the volume button. Nothing will appear on the tablet, but your PC should be installing the USB driver and will eventally popup a box to start the process of writing the image.

Follow the prompts and choose the "format" option so it wipes all your data.
Make a backup first if you want to keep any data on the tablet.

The fist time you boot the tablet, it will take a little longer to boot than usual, around 2 minutes.
Subsequent boots take around 40 seconds.

I have changed the boot logo and also the loading animation.
Added latest Play Store, 1Mobile, plus REGPON Wifi (keeps wifi on during sleep), Documents to Go and YouTube.
There is also a CWM Recovery image with adb access.
Everything else is stock.

The STOCK LiveSuit Image file is in comment #23.

Stylez, you are my hero. Just followed your instructions and now have Playstore working. Thanks very much for your time and effort.
Whitto69 is offline  
Reply With Quote
Old September 11th, 2012, 01:41 AM   #73 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

For anyone else needing this I have created a walk through for both the 7 inch and 9.7 inch and will show you where to get all the files.

Thanks to Stylez for his hard work.

9.7 Inch Free Cloud Storage - MediaFire
7 Inch Free Cloud Storage - MediaFire
kaneelias is offline  
Last edited by kaneelias; September 11th, 2012 at 01:43 AM.
Reply With Quote
Old October 2nd, 2012, 09:51 PM   #74 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have some news that I am about to post outside this forum that I think would be of interest to some. As this is my first post, I can't post links yet.
alancramer is offline  
Reply With Quote
Old October 3rd, 2012, 02:23 AM   #75 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Styelz, you may want to add the following applications to your rom as well...I manually pushed all the gapps from this [SCRIPTS] - Allwinner A10 Tablets Google Play Script - SlateDroid.com site to my Pendo Pad, and now, i am able to download a heap of apps from the Google Play store, without changing my build.prop.

In your image, you may want to change the size of system to make it a little larger, as I have 1MB left.
alancramer is offline  
Reply With Quote
Old October 24th, 2012, 07:04 AM   #76 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi I have a pp4mt-7 aswell and even with usb debugging enabled my pc will not recognise anything other than the sd and device manager says I need a driver for android. Can I ask what operating system you guys are using to do all this neet stuff thanks in advance
Tab Mad is offline  
Reply With Quote
Old October 25th, 2012, 12:45 AM   #77 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Tab Mad. I had trouble getting my PP4MT-7 recognised on my main pc then tried on my 2nd pc running XP (instead of Win7 on my main). Once I did this the pc recognised the pad straight away and away i went. What OS you using?
Whitto69 is offline  
Reply With Quote
Old November 1st, 2012, 10:21 AM   #78 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by styelz View Post
Here's an attempt to get CWM Recovery installed for PP4MT-9.

xxxxxxxxxxx

The tablet needs to be rooted first.
Plugged into the PC with USB Debug Mode enabled.
Extract the ZIP file and run root_recovery.bat from Windows.
This will use ADB to write the CWM recovery image to nandg.
Press enter when done and your tablet should autoatically boot into recovery mode.
this worked for me
syntax556 is offline  
Reply With Quote
Old November 20th, 2012, 01:00 AM   #79 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Question

Hi all, I'm fairly new to android imaging (did one once a couple of years back with success) and have just aquired a 7" Pendopad 4.0. I'm keen to get it imaged to a "real" android system and have read this entire thread and think I've gleaned the one post that sums up all I need. It's this one

Quote:
Originally Posted by styelz
Here is a LiveSuit Image with Full Root, CWM Recovery and GAPPS (UPDATED)
It is a two part RAR archive. Download and extract the image file.

Also, download LiveSuit Pack, extract and run LiveSuit.exe (this should install the driver for you).

Use LiveSuit and load the extracted ".img" file (press the first icon).
Make sure your tablet is off, and power and usb unplugged.

Now hold the volume down button, keep it held down and plug the USB cable in and then tap the power button about 6-8 times (tap, tap, tap). Then let go of the volume button. Nothing will appear on the tablet, but your PC should be installing the USB driver and will eventally popup a box to start the process of writing the image.

Follow the prompts and choose the "format" option so it wipes all your data.
Make a backup first if you want to keep any data on the tablet.

The fist time you boot the tablet, it will take a little longer to boot than usual, around 2 minutes.
Subsequent boots take around 40 seconds.

I have changed the boot logo and also the loading animation.
Added latest Play Store, 1Mobile, plus REGPON Wifi (keeps wifi on during sleep), Documents to Go and YouTube.
There is also a CWM Recovery image with adb access.
Everything else is stock.

The STOCK LiveSuit Image file is in comment #23.
My problem now is that the split image on media fire is blocked.
Is there an alternate download link?

Thanks for all the great work and information

Stardock
Stardock is offline  
Reply With Quote
Old November 20th, 2012, 06:22 AM   #80 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Discovered I could save the copy the files to my own Mediafire account and then download them (I'm usually a dropbox boy )
Got the pad flashed without an issue and all working great.

Thanks guys, awesome job.
Stardock is offline  
Reply With Quote
sponsored links
Old December 29th, 2012, 10:39 PM   #81 (permalink)
New Member
 
Join Date: Dec 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

MediaFire seems to have taken down the second part of the pp4mt-7 (part 2) image. :S :'(
HMHAMz is offline  
Reply With Quote
Old January 6th, 2013, 05:55 AM   #82 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

You can find all the stock / moded images here - https://www.pbptech.com/support/dmsf/android-livesuit-guide
styelz is offline  
Reply With Quote
Old January 7th, 2013, 11:27 PM   #83 (permalink)
Junior Member
 
styelz's Avatar
 
Join Date: Aug 2012
Location: Arsend
Posts: 34
 
Device(s): PP4MT-7
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 11 Posts
Default

Quote:
Originally Posted by styelz View Post
You can find all the stock / moded images here - https://www.pbptech.com/support/dmsf/android-livesuit-guide
Sorry, i forgot to make the files downloadable. They are downloadable now. https://www.pbptech.com/support/dmsf/android-livesuit-guide
bubbasd and ze_muel like this.
styelz is offline  
Reply With Quote
Old January 8th, 2013, 07:51 AM   #84 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

This worked for me:
1) DL the Android SDK from Google Android SDK | Android Developers
2) Run the SDK Manager & download the USB drivers as described here: Google USB Driver | Android Developers
3) modify the C:\..\sdk\extras\google\usb_driver\android_winusb.inf as described here (thanks bubbasd): PP4MT-7 windows 7 x64 usb adb driver
4) Update the driver for the Android device in Windows Device Manager
5) Enable USB Debugging on your device & plug in the USB
6) Run UnlockRoot. Press the big button.

- Voila.


KomusoDroid is offline  
Reply With Quote
Old January 9th, 2013, 08:24 AM   #85 (permalink)
Member
 
Join Date: Jun 2012
Posts: 109
 
Device(s): Androids: Ainol Novo 7 Elf II, Samsung GT-I5500, Pendo PP4MT-7, Nexus 7 and Sony E ST21a2.
Carrier: Not Provided

Thanks: 3
Thanked 35 Times in 24 Posts
Cool Can we get twrp Stylez?

stylez i see you put in CWMR you recon we could get TWRP for PP4MT-7/9?

It would be AWsome if we could
that recovery it has a built in file manager that every tablet needs.

ps. Very Nice Job with the images thanks.
bubbasd is offline  
Last edited by bubbasd; January 30th, 2013 at 07:20 PM. Reason: Twrps source
Reply With Quote
Old January 29th, 2013, 02:59 AM   #86 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default wow im confused!!

now that you guys have worked out how to do it (which im still amazed by) do you think one of you could post a SIMPLE step by step proccess for a genuine novice like me? im going crazy tryin to figure this out!! i used unlockroot but said i needed to use their "pro" version but dont want to pay the $30. PLEASE HELP!?!?
shaunkim is offline  
Reply With Quote
Old January 29th, 2013, 03:01 AM   #87 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

If theres links you cant post on here can supply my email if someones feeling nice enough to help out a very frustrated man!! Lol
shaunkim is offline  
Reply With Quote
Old January 29th, 2013, 03:20 AM   #88 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

now that you guys have worked out how to do it (which im still amazed by) do you think one of you could post a SIMPLE step by step proccess for a genuine novice like me? im going crazy tryin to figure this out!! i used unlockroot but said i needed to use their "pro" version but dont want to pay the $30. PLEASE HELP!?!?
shaunkim is offline  
Reply With Quote
Old January 30th, 2013, 11:17 AM   #89 (permalink)
Member
 
Join Date: Jun 2012
Posts: 109
 
Device(s): Androids: Ainol Novo 7 Elf II, Samsung GT-I5500, Pendo PP4MT-7, Nexus 7 and Sony E ST21a2.
Carrier: Not Provided

Thanks: 3
Thanked 35 Times in 24 Posts
Cool Firstly

1st thing's first is to get unlockroot without grabbing UnlockRoot_downloader_by_UnlockRoot.exe
which is riddled with Adware.(and u should'nt need pro version to root, the free one should do hopefully.)
read on below
I've downloaded (though the UnlockRoot_downloader_by_UnlockRoot.exe i couldnt track the real installer's URL though) and installed the True unlockrootsetup.exe I've matched the file's hash with with a link I've found on the net

-----------------Authenticity Info-----------------------------





If you are looking for a older version before the pro version was introduced
Get Direct Download Unlockroot 2.3.1 here (this one i used to root my PP4MT-7 ages ago.)
Thats a starting point.
bubbasd is offline  
Last edited by bubbasd; January 30th, 2013 at 06:53 PM. Reason: looking for a older version?
Reply With Quote
Old March 10th, 2013, 07:57 AM   #90 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello,
Long time reader, first time poster here.

I have two of these Penda 7" Tablets I am working on at the moment, for the kids to use. Using your instructions the process was very simple to set them both up with Google Play, however now I can not turn wi-fi on, on either of them. The Wi-Fi slider seems a bit buggy, at times you cant slide it. Other times you can, but the device just says 'Turning Wi-Fi on....' with no result, then the slider makes it's own way back to off.

I had Wi-Fi working on them both beforehand, but soon realised how rubbish GetJar is and decided to take the advice of you fine people before throwing the Pendo Tablet in the Trash.

Any assistance would be appreciated guys, cheers.
Chukitova is offline  
Reply With Quote
sponsored links
Old March 10th, 2013, 09:03 AM   #91 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok,

Now i've tried to go back the other way with the Stock Livesuit image, it seemed to work ok although Wi-Fi is still not turning on on either of the PP4MT-7 Tablets.

I cant even use the Rubbish GetJar anymore.

I have two paperweights, awesome.

Please help anyone. I've been searching the Webs for hours and this thread is all that comes up. What am I missing? Im happy to supply more info, screenshots, video's, whatever it takes.

Wi-Fi seems to be 'Bricked' on both the devices now even with the stock image back on them.

Both Tablets are Brand new, bought from Target NSW if that helps
Chukitova is offline  
Reply With Quote
Old March 11th, 2013, 05:03 AM   #92 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

WARNING

Do not use this guide.

I followed it to the letter now have two Pendo PP4MT-7 that will not connect to wi-fi, will not accept .apk apps from a computer and are good for nothing.

Do yourself a favour and do not use this procedure untill someone can offer a solution for this problem. I'd hate to see more people make the mistake I did.

2 x Pendo Tablets = Junk, thanks to this thread.
Chukitova is offline  
Reply With Quote
Old March 13th, 2013, 12:17 AM   #93 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

More praise to stylez

Smooth sailing for me. PPMT4 7 inch. Hacked this baby the day I bought it.

Downloaded livesuitpack and the 'how to' from the link in post #73.
Then downloaded the livesuit image from the link in post #83

Just follow the guide and you're there. Flawless procedure.

@ Chuckito. Read the 'how to' and make sure you're following it to the 't'.
I also had usb debugging enabled. Not sure if that makes a difference.

Anyway a previous post states these things are virtually unbrickable so keep trying!

Thanks again!
ze_muel is offline  
Reply With Quote
Old March 14th, 2013, 06:04 AM   #94 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

ze_muel,

The guide was very easy to follow. I had no issue with using Livesuit at all. I have been able to get .APK apps on both devices now, so they are saved from the scrap heap. The Google-play Livesuit image did not install a file manager/file browser app so it is impossible to run an .APK after transferring one to the device. By putting the Stock image back on, I was able to use the file manager app to run .APK's

But WI-FI will not turn on on either of the devices that I imaged with the Livesuit image from this thread. With the google play image, or with the stock image.

Im glad it worked for you, but it certainly Borked the Wi-fi on the two devices I have.

Im more than willing to try any suggestions anyone may have, but I've spent hours and hours stuffing around trying to get Wi-Fi working again. So this problem is real.

Users, beware.
Chukitova is offline  
Reply With Quote
Old March 14th, 2013, 12:53 PM   #95 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's a bugger dude.

Well with the custom rom you can boot into cwm recovery.

From there you could install a file browser that has been made into a zip.

I'm reading about it now. Could make Root Browser Lite into a zip file which you could install from recovery and at least be able to install apk's from your phone.

Bear with me as I'm about to pass out from tiredness. Someone may jump in before me, if not I shall return soon.
ze_muel is offline  
Reply With Quote
Old March 14th, 2013, 07:03 PM   #96 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

And voila!

rbl.zip
ze_muel is offline  
Reply With Quote
Old March 23rd, 2013, 10:11 AM   #97 (permalink)
New Member
 
Join Date: Aug 2011
Location: Brissy Australia
Posts: 5
 
Device(s): Samsung Galaxy S, HTC Wildfire, LG Optimus, 7" WM8650 tablet
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Sorry...real newbie when it comes to "flashing" or "rooting" devices.
Have looked through the threads and still cannot find a step by step guide for a first timer to root a Pendo Pad 4.0 P4Mt9G2
Lots on the 7 inch version and apparently doesnt work on the 9.7.
Please help me turn this paperweight ibto sonething the kids can use with playstore!
Eternally grateful!
Lisa
emilylane1 is offline  
Reply With Quote
Old March 24th, 2013, 09:31 AM   #98 (permalink)
New Member
 
Join Date: Aug 2011
Location: Brissy Australia
Posts: 5
 
Device(s): Samsung Galaxy S, HTC Wildfire, LG Optimus, 7" WM8650 tablet
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Stylez,
I have followed your instructions exactly and do really well till step 4. When i hold down the volume and plug in the usb and tap the power button immediately my laptop comes up with a msg about it not recognising this device...usb port etc. Am I doing something wrong or is it my laptop that has the problem do you think? Im too scared to even turn on my Pendo 9.7 as now Im more than half way through the process Im not sure to check if its bricked or just to keep working on the last step in the hope it willstill work?? PPPLLLEEEAAASSEEE I am desperate for your legendary wisdom
emilylane1 is offline  
Reply With Quote
Old March 24th, 2013, 10:03 AM   #99 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey Emily,

Pretty sure it doesn't matter if Windows itself finds the drivers. It didn't for mine either.

Livesuit seems to work without Windows drivers. As long as you follow the instructions and all the prompts happen that are stated in the instructions then you should be fine
ze_muel is offline  
Reply With Quote
Old March 24th, 2013, 10:07 AM   #100 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just make sure you have the 9 inch version of the rom. You can get a single zip from post 83 and there are clear instructions in post 73
ze_muel is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Tablets & MIDs > DoDo Pendo Pad > Pendo Pad - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:30 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.