Go Back   Android Forums > Android Phones > ZTE Racer > Racer - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old December 6th, 2010, 07:13 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 50
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 21 Times in 9 Posts
Default [Rom] My Rom Mod

Heres My New Rom


this rom inculdes ..
  • A2sd
  • livewallpapes
  • new icons
  • fully rooted
  • all 3 crap removed
  • new zte boot screen
  • new launcher
---------------------------

first things frist

  • ok take out the battery and wait 5 secs then put it back in the press the vol + and the power button it should boot only to the green android logo and the red light stays on
  • extract it to your c:\ then inbstall the drives if needed then click install-recovery-windows.bat once done the fone will reboot

then

download this Update.zip

  • put the update.zip on your sd dont extract it
  • switch phone off the hold the vol- button and press the power button it will boot into recovery

  • if yo what a2sd to work youll need to partition your sd card look on the internet theres loads of ways to do it
  • a2sd will install all your application to your sd

-----------------------------------------------------

next ....
  • in recovery click wipe data/factory reset
  • click apply sdcard:update.zip
  • once complete click reboot system now
unlock sim card


find me here http://android.modaco.com/category/454/zte-racer-racer-modaco-com/

rickywyatt is offline  
Last edited by rickywyatt; December 13th, 2010 at 12:50 PM.
Reply With Quote
The Following 4 Users Say Thank You to rickywyatt For This Useful Post:
Baggy (December 14th, 2010), Nadir-russia (December 9th, 2010), pedja31 (January 6th, 2011), sergivaqx (December 30th, 2010)
sponsored links
Old December 6th, 2010, 11:57 AM   #2 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

Works !!!
:-)
ryanraven is offline  
Reply With Quote
Old December 6th, 2010, 12:27 PM   #3 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

Would love to try 2.2 Froyo :-)
ryanraven is offline  
Reply With Quote
Old December 6th, 2010, 12:55 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 50
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 21 Times in 9 Posts
Default

Quote:
Originally Posted by ryanraven View Post
Would love to try 2.2 Froyo :-)
so would i

it looks nice on my zte blade
rickywyatt is offline  
Reply With Quote
Old December 6th, 2010, 01:10 PM   #5 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

is it coming to the wildfire ?
ryanraven is offline  
Reply With Quote
Old December 6th, 2010, 01:27 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 50
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 21 Times in 9 Posts
Default

Quote:
Originally Posted by ryanraven View Post
is it coming to the wildfire ?
dont no lol you should have gone for the zte blade as its only 99 plus 10 top up
rickywyatt is offline  
Reply With Quote
Old December 6th, 2010, 01:29 PM   #7 (permalink)
Junior Member
 
RobertsAccount's Avatar
 
Join Date: Dec 2010
Location: Cornwall, England
Posts: 43
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 2 Posts
Default

I'd also love to have Froyo....
RobertsAccount is offline  
Reply With Quote
Old December 6th, 2010, 01:33 PM   #8 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

im on 3 mobile and the blade isn't on that network were i am.
iv tried the blade and hate ZTE phones their really badly built.
also the battery is pretty poor.
ryanraven is offline  
Reply With Quote
Old December 6th, 2010, 01:44 PM   #9 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 50
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 21 Times in 9 Posts
Default

Quote:
Originally Posted by ryanraven View Post
im on 3 mobile and the blade isn't on that network were i am.
iv tried the blade and hate ZTE phones their really badly built.
also the battery is pretty poor.
even with oled 512mb ram?
rickywyatt is offline  
Reply With Quote
Old December 7th, 2010, 05:29 AM   #10 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 50
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 21 Times in 9 Posts
Default

could someone try my new black theme pls

black-theme.zip
rickywyatt is offline  
Last edited by rickywyatt; December 7th, 2010 at 06:16 AM.
Reply With Quote
The Following User Says Thank You to rickywyatt For This Useful Post:
mharty72 (December 14th, 2010)
sponsored links
Old December 9th, 2010, 02:14 AM   #11 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi! If i install your mod...
and then install morelocale2 it will turn on Russian lang?

p.s. sorry for my english...
im russian
Nadir-russia is offline  
Reply With Quote
Old December 11th, 2010, 03:10 AM   #12 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 9
 
Device(s): ZTE Racer samsung galaxy tablet
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default awesome

thanks mate what a great mod works a treat.
mharty72 is offline  
Reply With Quote
Old December 11th, 2010, 04:39 PM   #13 (permalink)
Member
 
Baggy's Avatar
 
Join Date: Aug 2010
Location: Glasgow, Scotland
Posts: 167
 
Device(s): HTC Desire, HTC Wildfire, ZTE Racer, T Mobile G1 (rooted)
Carrier: Not Provided

Thanks: 52
Thanked 19 Times in 16 Posts
Default

Any idea how to do this using Ubuntu?
__________________
HTC DREAM (Rooted Cyanogen 4.2)
HTC WILDFIRE (2.2)
HTC DESIRE (2.2)
ZTE RACER (2.1)
Baggy is offline  
Reply With Quote
Old December 13th, 2010, 10:51 AM   #14 (permalink)
New Member
 
Join Date: Dec 2010
Location: London, UK
Posts: 14
 
Device(s): Asus Fonepad
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does the phone need to be rooted before doing your steps?
Will Skype app provided by 3 still work?
Also do you know how to make the phone into a wifi hotspot?
xiaokai is offline  
Reply With Quote
Old December 13th, 2010, 02:49 PM   #15 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

Can i overclock this phone ?
ryanraven is offline  
Reply With Quote
Old December 14th, 2010, 05:26 AM   #16 (permalink)
Member
 
Baggy's Avatar
 
Join Date: Aug 2010
Location: Glasgow, Scotland
Posts: 167
 
Device(s): HTC Desire, HTC Wildfire, ZTE Racer, T Mobile G1 (rooted)
Carrier: Not Provided

Thanks: 52
Thanked 19 Times in 16 Posts
Default

Quote:
Originally Posted by ryanraven View Post
is it coming to the wildfire ?
Yes but its getting it last
Baggy is offline  
Reply With Quote
Old December 14th, 2010, 01:42 PM   #17 (permalink)
Junior Member
 
RobertsAccount's Avatar
 
Join Date: Dec 2010
Location: Cornwall, England
Posts: 43
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 2 Posts
Default

Will I need administrative privileges to run install-recovery-windows.bat successfully? And as xiaokai said, you don't need to root before doing this I take it? Thanks guys you rule.
RobertsAccount is offline  
Reply With Quote
Old December 14th, 2010, 03:22 PM   #18 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

and more roms for this phone guys ?? i want to try some :-)
ryanraven is offline  
Reply With Quote
Old December 15th, 2010, 01:03 AM   #19 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 9
 
Device(s): ZTE Racer samsung galaxy tablet
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

like the black theme looks more stylish
mharty72 is offline  
Reply With Quote
Old December 15th, 2010, 09:47 AM   #20 (permalink)
New Member
 
Join Date: Dec 2010
Location: London, UK
Posts: 14
 
Device(s): Asus Fonepad
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

cool rom just tried.
any advice on if wifi hotspot is possible with this phone?
xiaokai is offline  
Reply With Quote
sponsored links
Old December 22nd, 2010, 06:28 AM   #21 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

Any new Roms ???
:-)
ryanraven is offline  
Reply With Quote
Old December 23rd, 2010, 03:07 AM   #22 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Default

rickywyatt; i've bben lurking, got my racer yesterday, had what seems to be a common problem of apps failing to d/l from marketplace. i installed your rom which worked first time and all is well with the world. i had to register to proffer you some kudos. keep up the good work
shady77 is offline  
Reply With Quote
Old December 23rd, 2010, 09:25 AM   #23 (permalink)
Junior Member
 
RobertsAccount's Avatar
 
Join Date: Dec 2010
Location: Cornwall, England
Posts: 43
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by shady77 View Post
rickywyatt; i've bben lurking, got my racer yesterday, had what seems to be a common problem of apps failing to d/l from marketplace. i installed your rom which worked first time and all is well with the world. i had to register to proffer you some kudos. keep up the good work
Nice one rickywayatt, and I'm glad your happy with his ROM shady77! I'm sure he appreciates you registering here just to thank him ;P

Just to second what he said, keep up the good work rickywyatt, please keep supporting us guys with these ROMs, we all appreciate it enormously!
RobertsAccount is offline  
Reply With Quote
Old December 29th, 2010, 11:02 AM   #24 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

Needs GSM mode in network :-)
ryanraven is offline  
Reply With Quote
Old December 30th, 2010, 06:01 AM   #25 (permalink)
New Member
 
Join Date: Dec 2010
Location: London
Posts: 4
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default Original Rom

Hi, I liked your room! specially the 4 screens instead the 2 of the original. I tried it for 2 days without trouble, But in some apps, like maildroid, I can put some rules about sound (deactivate sound in the night) and it seems no to work. Before I have my phone with froyo but I forget to make a backup... so I want to know if someone has the original room and share it. Thanks in advance!
sergivaqx is offline  
Reply With Quote
Old January 27th, 2011, 05:40 PM   #26 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

how long doese he needs to put recovery to phone?? mine is working 10 mins and still didnt puted..pls help
ikas is offline  
Reply With Quote
Old January 27th, 2011, 06:12 PM   #27 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

pls help.. i cant make it work
ikas is offline  
Reply With Quote
Old February 17th, 2011, 05:34 AM   #28 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm stuck at first step: battery out, battery in, press vol+ & poweron together. Then he boots as normal: android, black screen with 6 white dots, simcode-window. If I press vol- & poweron then I get FTM, but that's not the fastboot I suppose. Do I need something installed first to fastboot?
iammas is offline  
Reply With Quote
Old February 17th, 2011, 05:59 AM   #29 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

you have to keep the up volume pressed for at least 20 seconds after you press the power button
ryanraven is offline  
Reply With Quote
Old February 17th, 2011, 06:13 AM   #30 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope, that doesn't work either. Gives normal boot. For a few seconds I get the android and red flashlight, then the white dots, etc...
iammas is offline  
Reply With Quote
sponsored links
Old February 17th, 2011, 08:06 AM   #31 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

should stay on android logo if you done it right

Up Volume ( HOLD ) Press power button ( DONT HOLD )
Keep Holding Up Volume for 10 Seconds
Attached Images
File Type: jpg IMAG0158.jpg (943.8 KB, 5 views)
ryanraven is offline  
Last edited by ryanraven; February 17th, 2011 at 08:09 AM.
Reply With Quote
Old February 17th, 2011, 08:51 AM   #32 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, I must be clumsy. I tried it maybe 20 times, but it doesn't work. If I hold the volume - & power, then I get the FTM-screen (don't know if this is good or not, because you can do nothing there; you have to remove the battery), but with the volume + I only get normal boot. So, no rom for me, pitty. I hoped I could resolve my bluetooth-problem with it.
iammas is offline  
Reply With Quote
Old February 17th, 2011, 08:52 AM   #33 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

you sure your holding the up volume button and make sure you hold it for a while and only press the power button dont hold it down.
ryanraven is offline  
Reply With Quote
Old February 17th, 2011, 11:59 AM   #34 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I give up. I asked my son to do it, but it also doesn't work with him. Maybe I'm missing some systemfiles? I suppose there's no other way to fastboot? Anyway, ryanraven, many thanks for you efforts to help me.
iammas is offline  
Reply With Quote
Old February 17th, 2011, 12:37 PM   #35 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

try and isntall rom manager from the market and install clockwork mod from there
choose the
Huawei Pulse Mini
that worked for me
ryanraven is offline  
Reply With Quote
Old February 17th, 2011, 01:33 PM   #36 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, thanks. I did install huawei pulse mini. After (or while) installing I got the message "An error occured while attempting to run privileged commands!"
iammas is offline  
Reply With Quote
Old February 17th, 2011, 01:39 PM   #37 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

you need to root the phone first then.
http://bit.ly/aa4jxJ
download that and install it on phone
open it and click
root
then do the same as before in rom manager
ryanraven is offline  
Reply With Quote
Old February 17th, 2011, 02:19 PM   #38 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Universal Androot says that my device is already rooted (??), shall I root again or not?
iammas is offline  
Reply With Quote
Old February 17th, 2011, 02:42 PM   #39 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

yes see what happens
ryanraven is offline  
Reply With Quote
Old February 17th, 2011, 03:11 PM   #40 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did root it again. Then I installed Huawei Pulse Mini from Rom Manager. Then I partitioned the sd card. Then in ROM Manager I clicked on 'install ROM from SD Card'. I selected update.zip (rickywyatts file). Then clicked on Backup Existing ROM & Wipe Data and Cache? Then he wants to reboot into ClockworkMod Recovery but I get the message "An error occured while attempting to run privileged commands!" again. (??)

Edit: In Universal Androot I had select 'Superuser for Android 2.0-2.2'. Now I rooted again with selection 'Superuser for Android 1.5/1.6'. If I install the ROM I don't get the message anymore, but instead nothing is happening.
iammas is offline  
Last edited by iammas; February 17th, 2011 at 03:48 PM.
Reply With Quote
sponsored links
Old February 17th, 2011, 04:09 PM   #41 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

can you open up in clockwork mod thats all you need to do take battery out
hold down the down volume this time then press the power key holding down the down volume.
you should do a backup first before installing the rom
ryanraven is offline  
Reply With Quote
Old February 18th, 2011, 12:31 PM   #42 (permalink)
Junior Member
 
Join Date: Feb 2011
Posts: 16
 
Device(s): ZTE Racer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Wink

Hi ryanraven, your were very helpfull (i owe you a bottle of wine ). Nevertheless, It doesn't work on my phone. Like the fastboot, I can't boot into the recovery. Not with vol-/power, not with rom manager. Also, sometimes I get the message "An error occured while attempting to run privileged commands". I think something's wrong with my phone, although all functions work perfect, except for the bluetooth. Think I stop trying to put rickywyatts Rom on my phone.
iammas is offline  
Reply With Quote
Old February 23rd, 2011, 01:04 PM   #43 (permalink)
Member
 
Join Date: Nov 2010
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 29 Times in 28 Posts
Default

damn sorry to hear that so does the phone just reboot when you kep the volume UP + key held down and press the power button ?
ryanraven is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > ZTE Racer > Racer - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:01 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.