Go Back   Android Forums > Android Phones > HTC Rezound > Rezound - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old March 3rd, 2012, 01:11 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 72
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 17 Times in 7 Posts
Default Root stuck "waiting for device"

I'm having issues rooting. I get adb to reboot into fastboot, but then adb can't find the device or get the identifier token. Help?

Aremihc is offline  
Reply With Quote
sponsored links
Old March 3rd, 2012, 01:56 PM   #2 (permalink)
Member
 
thornev's Avatar
 
Join Date: Nov 2011
Location: Hudson Valley, NY
Posts: 309
 
Device(s): Samsung Galaxy S3 16GB, Stock ROM (VRBMA2), KT747 kernel o/c'ed to 2.1Ghz, Go Launcher EX, TWRP2 rec
Carrier: Verizon

Thanks: 78
Thanked 95 Times in 84 Posts
Default

Scottys noob friendly root guide-start to finish

If you haven't read it, read it. If you have read it, tell us the exact steps you're doing so we can better help you.
thornev is offline  
Reply With Quote
The Following User Says Thank You to thornev For This Useful Post:
scotty85 (March 3rd, 2012)
Old March 3rd, 2012, 02:37 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 72
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 17 Times in 7 Posts
Default

I'm following Scotty's guide. I've used adb to reboot into Fastboot, but then Fastboot Devices returns nothing and the token command says "waiting for device" I do hear the device connect sound, but I get no charging light. Phone says fastbootusb thanks.
Aremihc is offline  
Reply With Quote
Old March 3rd, 2012, 03:42 PM   #4 (permalink)
Junior Member
 
Join Date: Aug 2010
Posts: 93
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 7 Times in 5 Posts
Default

Exact same thing happening to me.
bryan.allen is offline  
Reply With Quote
Old March 3rd, 2012, 03:43 PM   #5 (permalink)
Member
 
thornev's Avatar
 
Join Date: Nov 2011
Location: Hudson Valley, NY
Posts: 309
 
Device(s): Samsung Galaxy S3 16GB, Stock ROM (VRBMA2), KT747 kernel o/c'ed to 2.1Ghz, Go Launcher EX, TWRP2 rec
Carrier: Verizon

Thanks: 78
Thanked 95 Times in 84 Posts
Default

So you're on Step 2 of Scotty's guide. Presumably you did everything in step 1 with no problems. Previously "adb devices" responded with info about your phone, you used adb to reboot the bootloader and the phone says "FASTBOOT USB" in red at the top on a white screen. "fastboot devices" returned nothing so you moved on to "fastboot oem ..." and that command did nothing? I'm not sure you could get thus far if you didn't, but let me ask... Did you:

- install on your PC the HTC USB drivers?
- disable HTC Sync on your PC?
- Enable USB Debugging on your phone?
- Disable Fastboot on your phone?
thornev is offline  
Reply With Quote
The Following User Says Thank You to thornev For This Useful Post:
scotty85 (March 3rd, 2012)
Old March 3rd, 2012, 04:07 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 72
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 17 Times in 7 Posts
Default

Could you clarify disabling fastboot on the phone? Thanks
Aremihc is offline  
Reply With Quote
Old March 3rd, 2012, 04:12 PM   #7 (permalink)
Member
 
rootbrain's Avatar
 
Join Date: Dec 2011
Location: Colorado, USA
Posts: 354
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 50 Times in 42 Posts
Default

Quote:
Originally Posted by Aremihc View Post
Could you clarify disabling fastboot on the phone? Thanks
It's under settings -> Power, make sure fastboot is disabled (unchecked)
rootbrain is offline  
Reply With Quote
Old March 3rd, 2012, 05:15 PM   #8 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 72
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 17 Times in 7 Posts
Default

Changed the fastboot setting, still nothing
Aremihc is offline  
Reply With Quote
Old March 3rd, 2012, 06:16 PM   #9 (permalink)
Member
 
thornev's Avatar
 
Join Date: Nov 2011
Location: Hudson Valley, NY
Posts: 309
 
Device(s): Samsung Galaxy S3 16GB, Stock ROM (VRBMA2), KT747 kernel o/c'ed to 2.1Ghz, Go Launcher EX, TWRP2 rec
Carrier: Verizon

Thanks: 78
Thanked 95 Times in 84 Posts
Default

I can't make sense out of how "adb fastboot" works and "fastboot devices" doesn't work. How can one command see your phone and the other one cannot? (rhetorical question to myself) When I get some time tonight, I will put my phone in fastboot and see if the command works for me. Oh wait, I can't do that as I'm already unlocked.
thornev is offline  
Last edited by thornev; March 3rd, 2012 at 06:19 PM.
Reply With Quote
Old March 3rd, 2012, 06:21 PM   #10 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 72
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 17 Times in 7 Posts
Default

Quote:
Originally Posted by thornev View Post
I can't make sense out of how "adb fastboot" works and "fastboot devices" doesn't work. How can one command see your phone and the other one cannot? (rhetorical question to myself) When I get some time tonight, I will put my phone in fastboot and see if the command works for me. Oh wait, I can't do that as I'm already unlocked.
No clue... but I pulled out my netbook and started over and it worked. I assume it is a driver issue on my main PC...
Aremihc is offline  
Reply With Quote
sponsored links
Old March 3rd, 2012, 09:23 PM   #11 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,647
 
Device(s):
Carrier: Not Provided

Thanks: 7,181
Thanked 6,785 Times in 4,267 Posts
Default

Quote:
Originally Posted by bryan.allen View Post
Exact same thing happening to me.
you never stated in your other thread where you were getting your adb/fastboot tools. if you havent figured it out yet,id suggest using my mini-adb file,and you can see this post for more info.

Quote:
Originally Posted by thornev View Post
I can't make sense out of how "adb fastboot" works and "fastboot devices" doesn't work. How can one command see your phone and the other one cannot? (rhetorical question to myself) When I get some time tonight, I will put my phone in fastboot and see if the command works for me. Oh wait, I can't do that as I'm already unlocked.
its actually very logical. "bootloader" and "booted to the OS with usb debugging checked" are 2 different modes,and thus require their own drivers,either of wich could get goofed up or not installed. also,if you look in your folder that you used to unlock, youll see that adb and fastboot are 2 seperate utilitys contained within. just becasue youre using them in the same command window doesnt mean that they are the same if either the adb or fastboot utilitys are missing,it will not work,while the other will.

you can put your phone in fastboot, and "fastboot devices" will return a serial number if you are unlocked or not. if you want to play with it,fastboot getvar all will tell you your main version number,as well as some other bits of inf. fastboot reboot-bootloader will reboot the bootloader(sometimes needed after changing bootloaders on s-off phones,or after running RUUs) fastboot boot <recoveryname>.img will boot your recovery even if its permanently installed. fastboot reboot will boot your phone back into the OS.

last and not least,you can see lists of available commands to us(tho some of them you should mess with ) with fastboot ? and fastboot oem ?

Quote:
Originally Posted by Aremihc View Post
No clue... but I pulled out my netbook and started over and it worked. I assume it is a driver issue on my main PC...
glad its working for you now. driver issues are often straightened out with reboots,or starting afresh on a virgin PC
__________________
The Delivery Guy
If someone has helped you,please click the THANKS button on that post.
Please post questions so others can benefit from the answers.
donate to my device fund
scotty85 is offline  
Last edited by scotty85; March 3rd, 2012 at 09:26 PM.
Reply With Quote
Old April 8th, 2012, 02:36 AM   #12 (permalink)
New Member
 
Join Date: Jan 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have this issue as well. Running Windows 7. I get to the place where I am trying to get the token ID. Using ADB it reboots fine to the bootloader. It says locked near the top of the screen, Fastboot several lines down, then it says Bootloader. After that it just hangs on "Waiting for Device". Several times using the ADB DEVICES command, it does give me my device number, so I think the drivers must be working right (if it's responding to the adb commands). I have tried manually following the way HTC says to do it, the Super Tool. and a variant of your instructions but can't get past that point. I'd be grateful for any help.

USB debugging is turned off, fastboot is turned off.

Mike
MiketheChap is offline  
Reply With Quote
Old April 8th, 2012, 06:38 AM   #13 (permalink)
AF Addict
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,647
 
Device(s):
Carrier: Not Provided

Thanks: 7,181
Thanked 6,785 Times in 4,267 Posts
Default

Quote:
Originally Posted by MiketheChap View Post
USB debugging is turned off
usb debugging must be turned on.

after turning usb debugging on,unchecking "fastboot" in settings/power,plug in the phone and select charge only mode.

now open your cmd window. if adb devices is returning the serial number,then adb reboot bootloader. this will take you to fastboot,wich is the screen you want to be on for using fastboot commands in the cmd window.

do NOT push the power button to select bootloader,as this will take you to hboot,and the fastboot comands will not work there.

after your phone boots to fastboot(wich may take several seconds) try fastboot devices if you get a serial number then,youre good to go.

if not,then it must be some sort of driver issue.

as said above,disable/uninstall htc sync and any other programs capable of communicating with your phone. with your phone plugged in and in fastboot mode,locate the phone in device manager. try installing the drivers manually,as described here: public:windows_hboot_driver_install [RootWiki] tho keep in mind that guide is for older,mtd devices. you want your phone to be in fastboot,not hboot.

id use these drivers: http://downloads.unrevoked.com/HTCDriver3.0.0.007.exe
they are a .exe file,so if you havent tried it allready,just try running the .exe and then repeat the steps above to see if you now ger a serial number from fastboot devices if that doesnt work,you can extract that file and direct windows to that unzipped folder when manually undating them with device manager.

hope that helps
scotty85 is offline  
Reply With Quote
The Following User Says Thank You to scotty85 For This Useful Post:
MiketheChap (April 8th, 2012)
Old April 10th, 2012, 10:37 PM   #14 (permalink)
Member
 
Join Date: Mar 2011
Posts: 123
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 11 Times in 9 Posts
Default

i usually dont post when people have issues cuz its something they didnt read, BUT i did root mine and my father in laws rezound with no issues, now just did my mother in law, and SAME PC , had issues like ur having - i used the mini-adb.zip file in tut and for some reason, had no issues getting it to see the device and DONE. so try that. i didnt turn fastboot off, left it on but i did turn on USB debugging

hope this helps
2011mazdaspeed is offline  
Reply With Quote
Old November 28th, 2013, 03:24 PM   #15 (permalink)
New Member
 
Join Date: Apr 2013
Posts: 14
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 0 Times in 0 Posts
Default

ignorethis
blu422 is offline  
Reply With Quote
Old March 16th, 2014, 02:13 AM   #16 (permalink)
New Member
 
Join Date: Mar 2014
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Old thread but, this is what worked for me.

Look at your USB ports. I noticed one of mine has a black plastic tab rather than blue (Sony Vaio). I plugged into the one with the black tab, waited (it takes a while for the phone to load), then all went as planned.

I assume that the black tabbed port is USB2.
Backslider is offline  
Reply With Quote
The Following User Says Thank You to Backslider For This Useful Post:
scotty85 (March 16th, 2014)
Reply


Go Back   Android Forums > Android Phones > HTC Rezound > Rezound - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:42 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.