Go Back   Android Forums > Android Phones > Samsung Exhibit 2 4G

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old January 22nd, 2012, 10:46 AM   #1 (permalink)
Member
Thread Author (OP)
 
surgerush's Avatar
 
Join Date: Oct 2011
Location: New York State
Posts: 454
 
Device(s): Samsung Galaxy S II T-Mobile
Carrier: Not Provided

Thanks: 43
Thanked 70 Times in 58 Posts
Default Messages constantly coming back failed!

I can't find where I have seen someone bring this up inside another thread, but in that thread they said that if you change your stock messenger app to a 3rd party messenger, it seems to have fixed the problem on the messages coming back failed.

I've been using gosms after I read about that, and it has not seemeed to halp. I am still getting my messages constantly coming back failed and it's driving me nuts. BUT, it turns out that even though they are coming back on my side failed, the other people seem to still be getting them. I just hate that I have no way of knowing if it ACTUALLY IS failed, or if it's just coming back failed because it's stupid. Even when I try to resend or if I copy the text and resend it, itr still comes back failed, but then the other side says the text sent through a bunch of times... I hate this about this phone.

Has anybody found a way around this at all? Is there a different app besides gosms that seems to work?

surgerush is offline  
Reply With Quote
sponsored links
Old January 22nd, 2012, 12:03 PM   #2 (permalink)
Member
 
Join Date: Oct 2011
Posts: 113
 
Device(s): Samsung Exhibit II 4G, LG Optimus V w/ BACKside
Carrier: Not Provided

Thanks: 11
Thanked 11 Times in 7 Posts
Default

I was the one that mentioned to you about a 3rd party sms app. Apparently, people had good luck with GOsms Pro and Handcent.

But just wait it out unfortunately, Samsung and Tmobile is working on a fix as we speak.
drfreeman is offline  
Reply With Quote
Old January 23rd, 2012, 06:12 PM   #3 (permalink)
Member
 
Join Date: Feb 2010
Location: Everett, WA
Posts: 342
 
Device(s): HTC Evo 4G - Sprint Samsung Exhibit 2 4G - T-Mobile/SIMpleMobile Get SIMpleMobile today at getsmart
Carrier: Not Provided

Thanks: 8
Thanked 47 Times in 31 Posts
Default

They aren't working on a fix...

This is a problem with almost EVERY Android device. When the device is in a poor coverage area (usually Sprint or T-Mobile in most cases) the device sends the message - but is unable to receive the confirmation from the network that the message has been sent. This creates a looping in the system - which means you will keep receiving the same error message over and over again until the system clears. You can initiate the clear by force closing the messaging app, clearing cache and data and then restarting the device.

The problem will begin again when you send/receive messages in poor coverage areas.
__________________
For current news and reviews - not the stuff that is coming in 5 years - visit The SmartPhone Report online!
zcarman is offline  
Reply With Quote
Old February 15th, 2012, 09:04 PM   #4 (permalink)
Member
 
Join Date: Apr 2011
Location: michigan
Posts: 171
 
Device(s): Samsung Exhibit 2 4G - T679
Carrier: Not Provided

Thanks: 0
Thanked 21 Times in 18 Posts
Default

Quote:
Originally Posted by surgerush View Post
I can't find where I have seen someone bring this up inside another thread, but in that thread they said that if you change your stock messenger app to a 3rd party messenger, it seems to have fixed the problem on the messages coming back failed.

I've been using gosms after I read about that, and it has not seemeed to halp. I am still getting my messages constantly coming back failed and it's driving me nuts. BUT, it turns out that even though they are coming back on my side failed, the other people seem to still be getting them. I just hate that I have no way of knowing if it ACTUALLY IS failed, or if it's just coming back failed because it's stupid. Even when I try to resend or if I copy the text and resend it, itr still comes back failed, but then the other side says the text sent through a bunch of times... I hate this about this phone.

Has anybody found a way around this at all? Is there a different app besides gosms that seems to work?

Yeah I actually went to a store and the guy there showed me a trick. How or why it works I have no clue but it worked.
1) While the phone is on the home screen page, do a battery pull.
2) then pull the sim card and then the SD card.
3) give it about 10 seconds with all that pulled from the phone.
4) Then insert the SD card, then the sim card, then the battery.
5) then restart phone.

I had the same issue you were having, and like I said, Have no clue how it helped but it fixed the problem instantly.
sreum is offline  
Reply With Quote
Old February 16th, 2012, 12:43 AM   #5 (permalink)
Member
 
Join Date: Feb 2010
Location: Everett, WA
Posts: 342
 
Device(s): HTC Evo 4G - Sprint Samsung Exhibit 2 4G - T-Mobile/SIMpleMobile Get SIMpleMobile today at getsmart
Carrier: Not Provided

Thanks: 8
Thanked 47 Times in 31 Posts
Default

The issue will start again... Just wait...
zcarman is offline  
Reply With Quote
Old February 16th, 2012, 03:21 PM   #6 (permalink)
Member
 
jntdroid's Avatar
 
Join Date: Aug 2010
Posts: 250
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 33 Times in 14 Posts
Default

It comes and goes, a simple reboot should fix it if it doesn't work on a resend. I called T-Mobile about it, and going through the automated system, got to the part about messages not sending/receiving, and the automated voice asked if I had rebooted the phone yet. I said no, and it told me to reboot and try again, and if it doesn't work, call back. Every time it's happened, a reboot fixed it. I'd be willing to bet it has something to do with some sort of authentication with the network. PITA either way... I've had a couple of T-Mobile phones, and it never happens on them.
jntdroid is offline  
Reply With Quote
Old February 18th, 2012, 11:57 PM   #7 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

I just bought this phone this week and was looking for this issue and found a couple of responses in the tmobile support community that I really think fixed the issue for me. Someone mentioned that they had the wifi calling turned off(as I did) and once they turned it back on, text messages were going through. So I did that first.
Then someone said to do this...
Go to Settings
Go to Wireless and Networks
Go to Mobile Networks
Go to Network Operators
Go to Search Now
Select T-Mobile
Exit out and re-start the phone

I did these two things this morning and I haven't had a failed text so far today so I'm assuming it worked. Not sure which one of the two fixed the issue but so far I'm glad its finally working!
SwiitDii is offline  
Reply With Quote
Old February 19th, 2012, 12:14 AM   #8 (permalink)
Member
Thread Author (OP)
 
surgerush's Avatar
 
Join Date: Oct 2011
Location: New York State
Posts: 454
 
Device(s): Samsung Galaxy S II T-Mobile
Carrier: Not Provided

Thanks: 43
Thanked 70 Times in 58 Posts
Default

Quote:
Originally Posted by SwiitDii View Post
I just bought this phone this week and was looking for this issue and found a couple of responses in the tmobile support community that I really think fixed the issue for me. Someone mentioned that they had the wifi calling turned off(as I did) and once they turned it back on, text messages were going through. So I did that first.
Then someone said to do this...
Go to Settings
Go to Wireless and Networks
Go to Mobile Networks
Go to Network Operators
Go to Search Now
Select T-Mobile
Exit out and re-start the phone

I did these two things this morning and I haven't had a failed text so far today so I'm assuming it worked. Not sure which one of the two fixed the issue but so far I'm glad its finally working!

Please keep us updated with whether or not it stays working.
surgerush is offline  
Reply With Quote
Old February 20th, 2012, 01:04 AM   #9 (permalink)
Member
 
JaeWeb's Avatar
 
Join Date: Aug 2010
Location: Phoenix, AZ
Posts: 144
 
Device(s): Samsung Galaxy SIII Pebble Blue 16GB (T-Mobile)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 4 Posts
Default

I've had this problem with every phone I've ever had (Android) and on every network I've been on. It was the worst when I had Verizon. I have 3 phones I switch between on T-Mobile and this happens every now and then. Usually going into airplane mode for a moment or so seems to work for me
__________________
Its MEEEEEE!!!! I was the turkey all alooooong!!
JaeWeb is offline  
Reply With Quote
Old February 20th, 2012, 11:23 AM   #10 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by surgerush View Post
Please keep us updated with whether or not it stays working.
Yep its still working! Two whole days in a row no failed messages. I even tested it while I was downloading a big file. Woo hoo!
SwiitDii is offline  
Reply With Quote
sponsored links
Old February 20th, 2012, 11:48 AM   #11 (permalink)
Member
 
Join Date: Feb 2010
Location: Everett, WA
Posts: 342
 
Device(s): HTC Evo 4G - Sprint Samsung Exhibit 2 4G - T-Mobile/SIMpleMobile Get SIMpleMobile today at getsmart
Carrier: Not Provided

Thanks: 8
Thanked 47 Times in 31 Posts
Default

Ok, so I decided to try and figure out why the messages were failing and it is the lack of the phone carrying a continuous 4G signal and failing to log back in to the network correctly (much like the Verizon LTE login issues.) Now for the good part, yes, reprovisioning the SIM card does help the issue, but the problem returns the next time you lose your coverage and fail to login correctly.

For now though, reprovisioning is the best method of 'solving' the problem. Just follow sreum's instructions above to reprovision it and you should be good until the problem rears its ugly head again. When it does, just repeat the reprovisioning and you will be good for a while again.

1) While the phone is on the home screen page, do a battery pull.
2) Pull the SIM card, then the SD card.
3) Wait 10-15 seconds.
4) Insert the SD card, then the SIM card, then the battery - in this order!
5) Restart the phone.
zcarman is offline  
Reply With Quote
Reply

Samsung Exhibit 2 4G
Current Rating:
Rate this Phone:

The Samsung Exhibit II 4G is T-Mobile's first off contract Android powered smartphone and the sequel to the Exhibit 4G which launched only a few months prior. The phone features a very affordable off contract price and a solid array of specs ... Read More



Go Back   Android Forums > Android Phones > Samsung Exhibit 2 4G
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:55 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.