Go Back   Android Forums > Android Phones > Samsung Exhibit 2 4G

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 17th, 2012, 04:39 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Samsung Exhibit ii Battery Problem

I just updated the firmware on my exhibit yesterday to android 2.3.6 and now every time i plug in the charger, a message will pop up after a few seconds saying that the battery is disconnected. Is anybody else experiencing this problem or know a solution to fix it?

Guitarman5 is offline  
Reply With Quote
sponsored links
Old June 17th, 2012, 05:36 PM   #2 (permalink)
AF Addict
 
Rush's Avatar
 
Join Date: Jan 2011
Location: Loganville, GA
Gender: Male
Posts: 18,529
 
Device(s): HTC ONE
Carrier: Sprint

Thanks: 2,852
Thanked 3,105 Times in 2,335 Posts
Default

Hello and welcome aboard. There are things you could do to narrow down the problem. 1.) Try using a different charger. 2.) Replace the battery. If after doing both things - and problem still persist, then it might be fair enough to say that the device is defective and need to be replaced.

Hopefully someone who has a better solution might chime in to help. Good luck. •﹏•
__________________
"Accept the things you cannot change, have the courage to change the things you can ...And have the Wisdom to know the difference".


Rush is offline  
Last edited by Rush; June 17th, 2012 at 05:39 PM.
Reply With Quote
The Following User Says Thank You to Rush For This Useful Post:
Guitarman5 (July 24th, 2012)
Old June 22nd, 2012, 07:17 AM   #3 (permalink)
Junior Member
 
Join Date: Aug 2011
Posts: 75
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Guitarman5 View Post
I just updated the firmware on my exhibit yesterday to android 2.3.6 and now every time i plug in the charger, a message will pop up after a few seconds saying that the battery is disconnected. Is anybody else experiencing this problem or know a solution to fix it?
A family member with the same phone just recently had the update and also has the same exact issue stated above, looks like a software glitch. Might have to complain to samsung in order to get another update to resolve it, or if you mod your phone, you could try to restore an earlier android version until the problem is solved.
anaconda691 is offline  
Reply With Quote
Old July 2nd, 2012, 09:41 PM   #4 (permalink)
Junior Member
 
Join Date: Feb 2012
Posts: 60
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Mine was doing that shortly after I got it and I was pretty sure the usb jack was damaged because it would stop if I held the plug the right way. Well it did it for a week or so and hasn't since. I probably should have just sent it in for warranty but I didn't want to be without a phone and I figured that warranty is a year and I seem to get a new one every year so I am just seeing what happens.
msaeger is offline  
Reply With Quote
Old July 10th, 2012, 04:33 AM   #5 (permalink)
New Member
 
Join Date: May 2012
Posts: 13
 
Device(s): Samsung Exhibit ii 4g
Carrier: Not Provided

Thanks: 7
Thanked 0 Times in 0 Posts
Default

Mine did that a couple times before and after the update but it's fine now.
starflower7 is online now  
Reply With Quote
Old July 24th, 2012, 02:12 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for the feedback guys. I ordered a replacement battery for my phone from amazon to see if that would help. The batteries i ordered were anker and came with two batteries and an external charger. I guess if all went wrong I could just use the external charger. But anyways, after I received them I tried them out right away. One of the still showed the same message but the other one worked correctly with no error message and charges correctly. I still have no idea why one would work and the other ones won't. I charged my other batteries with the external charger and now just keep them for backup.
Guitarman5 is offline  
Reply With Quote
Reply

Samsung Exhibit 2 4G
Current Rating:
Rate this Phone:

The Samsung Exhibit II 4G is T-Mobile's first off contract Android powered smartphone and the sequel to the Exhibit 4G which launched only a few months prior. The phone features a very affordable off contract price and a solid array of specs ... Read More



Go Back   Android Forums > Android Phones > Samsung Exhibit 2 4G
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:50 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.