Go Back   Android Forums > Android Phones > Samsung Galaxy Europa (5)

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old September 11th, 2010, 05:13 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Question Sensor problem in i5500

Hello,

I've just bought a Samsung i5500, but have discovered a problem. In google sky maps, rotating the phone only lets me move up and down, but not sideways. Also, the 'smart compass' app says that the magnetic field is too high and seems to point in a random direction. I have tried to calibrate the magnetic sensor by rotating the phone and moving it in a figure of 8, but this doesn't work. However, when I type '*#1*#' and go to the sensor test, the line seems to point north ok, but there is some text saying 'Need for calibration 0'.

Does anyone else have this problem or know how to solve it?

Any help is appreciated.

Also, should there not be a forum for the i5500?

scrasun is offline  
Reply With Quote
sponsored links
Old December 18th, 2010, 03:19 PM   #2 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Myself and a friend who also has the Galaxy 550 (Europa, GT-I5500) also have the same sensor problem. I searched around but found very little information on the topic, it would be nice to know if this is a general design issue or a specific handset defect.
nailuii is offline  
Reply With Quote
Old January 14th, 2011, 06:49 AM   #3 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 2
 
Device(s): Samsung Galaxy 5 (i5500)
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My problem is a bit different. I'm getting the message "Need calibration 0" in the *#0*# menu. It seems that points to north but east and west are in the opposite site. Weird. I read the you can calibrate with adb, I don't know exactly what does it means(maybe it's a tool or program). I'll keep searching...
myzsot is offline  
Reply With Quote
Old September 20th, 2011, 06:04 AM   #4 (permalink)
rpd
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Possible solution

I also have GT-I5500 and I also have the sensor problem. I installed 4, 5 compass applications from google market and all work faulty. When I turn the phone on left the compass needle does not stays steady pointing north, is also turns on left. So in 180 (not 360) degree left turn of the phone the compass needle shows the north again. Works the same in the sensor test app from *#0*# menu.
I was with the phone in service and they change the mainboard entirely. Unfortunately the problem persisted.
Then I remember about the Samsung Apps (the google market replacement) and I searched for compass app there. The only app that I found in search results was TiltAngle which I installed. And voila! Is seems that this application is the only one on the market that it is working for GT-I5500 devices.
This does not solve the problem entirely, because the problem seems to be from the compass driver in the linux kernel installed on the device (forum.xda-developers.com/showthread.php?t=1246060), but at least you can use the phone compass properly.
Hope this helps.
rpd is offline  
Reply With Quote
Old October 27th, 2011, 11:27 PM   #5 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 12
 
Device(s): galaxy 5 rom: cm7.1 btfx 4 cpu: 756 mhz launcher: ics 4.0
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

by the way myzsot adb is a android developer program which is with eclipse a program for developing android. without much training and knowledge of javascript or developing tbh you have absolutly no chance of useing it to fix the problem ur best bet is to find a local fone repair shop whos owner or person workin on desk nows how to use adb/sdk manager and see if they will try and fix the problem for u. hope this helped.
webzy is offline  
Reply With Quote
Old October 27th, 2011, 11:29 PM   #6 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 12
 
Device(s): galaxy 5 rom: cm7.1 btfx 4 cpu: 756 mhz launcher: ics 4.0
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

oh and i think this censor problem is there on most if not all galaxy 5 devices and as far as i no there is no other solution appart from reprograming thru adb.
webzy is offline  
Reply With Quote
Reply
Tags
i5500, magnetic sensor, problem, sensor


Go Back   Android Forums > Android Phones > Samsung Galaxy Europa (5)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:56 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.