Go Back   Android Forums > Android Phones > Samsung Galaxy Indulge

New Forums: Nexus Player | Nexus 9
Like Tree1Likes
  • 1 Post By DreamRaider

test: Reply
 
LinkBack Thread Tools
Old November 29th, 2011, 09:36 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
cafonez's Avatar
 
Join Date: Apr 2011
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 9 Times in 3 Posts
Post Solution to Wi-Fi Tethering Issues

Thanks to TRS-80's thread, and my own issues I had to find a solution because not everyone is having the issue, which means it could be market specific, maybe tower specific? I am not a cell phone guru...but I found a way around it. Browser Agent Headers, it appears its looking for the proper agent headers and can tell when your on the PC because the agent headers are different then those of the phone's browser.

Step by step solution

1) Get firefox and install addon User Agent Switcher
2) Go to Firefox menu bar and go to addons -> User Agent Switcher -> options
3) Then click New -> New User Agent
4) Clear out everything for the new user agent
5) Description Android
6) Copy and paste this for your user agent field

Mozilla/5.0 (Linux; U; Android 2.2.1; en-us; SCH-R910 Build/FROYO)

7) Click Ok
8) Move it up to the top of the list
9)Then when firefox is fully opened right click underneath the orange firefox icon and check menubar
10) Under Tools look for default user agent and select your Android browser agent
11) A circle should appear next to it to let you know its been selected

Happy browsing!@!

Advertisements
cafonez is offline  
Reply With Quote
The Following 3 Users Say Thank You to cafonez For This Useful Post:
CityBoy (December 4th, 2011), fvdante (May 6th, 2012), TRS-80 (November 30th, 2011)
sponsored links
Old November 30th, 2011, 01:58 AM   #2 (permalink)
Member
 
TRS-80's Avatar
 
Join Date: Dec 2010
Location: Safety Harbor, FL
Posts: 367
 
Device(s): LG Motion (MS770), Nook Tablet, Samsung Galaxy Exhibit (T599)
Carrier: MetroPCS (FTW!)

Thanks: 30
Thanked 63 Times in 45 Posts
Default Help for Opera users (changing to a custom user agent string)

As I said in another post, +100 cocktails to you, good sir. Excellent work.

It took me a few minutes to figure out how to enter a custom user agent string in Opera (I like Firefox, and use it for certain things, but Opera is my daily driver). Apparently, you cannot just enter a custom user string in there (there are only a few predefined options). So I actually ended up having to edit opera.dll in a hex editor.

So anyway, I have attached the edited opera.dll file. If anyone else is interested in using this, follow these instructions (for Windows):
1.Close any/all instances of Opera.
2.Navigate to \Program Files\Opera\ directory.
3.Rename the original opera.dll file to "backup of opera.dll", or somesuch, just in case.
4.Save the modified opera.dll file (zipped and attached to this post, below) into the \Program Files\Opera\ directory.
5.After that, you need to go into opera:config and go down to the bottom where it says User Agent. Select number 2 for Firefox emulation (the user agent string for Firefox is the one I replaced with the Android browser user agent string, it was the only one long enough). Be sure to hit save.
6.Exit, then restart Opera.
7.Then, go into Opera menu -> Help -> About Opera, and under Browser Identification, it should say the following:
Code:
Mozilla/5.0 (Macintosh; U; Intel Max OS X 10_6_3; en-us)
Edit 12/2/11: I changed the user agent string to the one for Dolphin browser, so you will get the full version of sites now, instead of the mobile version.

If it says the above, you have succeeded.

A few notes: I am using Opera 11.52 (the latest version). I am also running Windows XP, I'm not sure if that makes a difference in this dll file. Of course, when a new version comes out, this will probably break. PM me, and I will post an updated version.

If you don't like any of these options, you could always use a local proxy program on your http traffic that can read and modify headers, etc. to change your user agent... but I thought this would be easier.
Attached Files
File Type: zip opera_dll_dolphin.zip (6.69 MB, 97 views)
__________________
Previous devices: Samsung Galaxy Indulge, LG Connect
TRS-80 is offline  
Last edited by TRS-80; December 2nd, 2011 at 08:15 AM. Reason: changed user agent string to Dolphin in dll file
Reply With Quote
The Following 3 Users Say Thank You to TRS-80 For This Useful Post:
cafonez (November 30th, 2011), drtobaggan (December 1st, 2011), fvdante (May 6th, 2012)
Old November 30th, 2011, 02:02 AM   #3 (permalink)
Member
 
TRS-80's Avatar
 
Join Date: Dec 2010
Location: Safety Harbor, FL
Posts: 367
 
Device(s): LG Motion (MS770), Nook Tablet, Samsung Galaxy Exhibit (T599)
Carrier: MetroPCS (FTW!)

Thanks: 30
Thanked 63 Times in 45 Posts
Default

Quote:
Originally Posted by TRS-80 View Post
Although some pages will now give you the mobile version of the site (because they think you are coming from your phone). :/
I actually just had a thought. I'm pretty sure I can still browse from my phone, using Dolphin Browser, which I have set to desktop user agent emulation. So if we can get that user agent string, it should take care of the problem of getting the mobile versions of sites. But I'm too tired now, I will mess with that tomorrow.

Edit 12/2/11: Done. See updated post above.
TRS-80 is offline  
Last edited by TRS-80; December 2nd, 2011 at 08:17 AM.
Reply With Quote
Old November 30th, 2011, 05:22 AM   #4 (permalink)
Junior Member
Thread Author (OP)
 
cafonez's Avatar
 
Join Date: Apr 2011
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 9 Times in 3 Posts
Default

Awesome work on the opera browser. I will check it out today. I like opera as well.
cafonez is offline  
Reply With Quote
Old November 30th, 2011, 12:49 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
cafonez's Avatar
 
Join Date: Apr 2011
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 9 Times in 3 Posts
Default

Google Chrome Fix
On your desktop right click the google chrome shortcut and go to properties
under the target location put C:\Users\username\AppData\Local\Google\Chrome\Appl ication\chrome.exe --user-agent="Mozilla/5.0 (Linux; U; Android 2.2.1; en-us; SCH-R910 Build/FROYO)"

its important to have a spaces after .exe then --
screenshot attached

tested - works

Dolphin Emulation String C:\Users\username\AppData\Local\Google\Chrome\Appl ication\chrome.exe --user-agent="Mozilla/5.0 (Macintosh; U; Intel Max OS X 10_6_3; en-us)"

and tiede is correct!
cafonez is offline  
Last edited by cafonez; November 30th, 2011 at 08:06 PM.
Reply With Quote
The Following 5 Users Say Thank You to cafonez For This Useful Post:
Curster (August 29th, 2012), drtobaggan (December 1st, 2011), Knightsavior (May 30th, 2012), michael cl (March 5th, 2012), zefaia (August 2nd, 2013)
Old November 30th, 2011, 07:04 PM   #6 (permalink)
Senior Member
 
tiede's Avatar
 
Join Date: Mar 2011
Location: Orlando, Fl
Gender: Male
Posts: 1,494
 
Device(s): Samsung Galaxy Indulge, CWM+Basix 1.0 Rom, Samsung Galaxy SIII, Metropcs, $50/mo
Carrier: metroPCS

Thanks: 184
Thanked 522 Times in 322 Posts
marcarthur@gmail.com
Default

Or use a plain old Linux desktop user agent string. Mine works and I never experienced this problem cause I am and have always been on Linux.
My user agent string is: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
It seems metro's block is testing to make sure you are not using windows. Not if you are actually using a phone. So change your UA string to something other than windows and it should work... (in theory, at least... waiting for further feedback to confirm this.)
__________________
If I've helped you, please do hit the Thanks button.
And remember to pay it forward!
Or if you REALLY insist, there's always PayPal...
tiede is offline  
Reply With Quote
The Following User Says Thank You to tiede For This Useful Post:
cafonez (November 30th, 2011)
Old December 1st, 2011, 12:42 AM   #7 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 76
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 4 Times in 4 Posts
Default

Hey, it worked! thanks!
drtobaggan is offline  
Reply With Quote
Old December 1st, 2011, 03:33 PM   #8 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 96
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

So is there a way for other things other than web browsers? Like I've tried using my ipod touch. A few things work, such a facebook and pandora. But the textfree app, and other things do not
4saken1 likes this.
DreamRaider is offline  
Reply With Quote
Old December 2nd, 2011, 08:22 AM   #9 (permalink)
Member
 
TRS-80's Avatar
 
Join Date: Dec 2010
Location: Safety Harbor, FL
Posts: 367
 
Device(s): LG Motion (MS770), Nook Tablet, Samsung Galaxy Exhibit (T599)
Carrier: MetroPCS (FTW!)

Thanks: 30
Thanked 63 Times in 45 Posts
Default

Quote:
Originally Posted by DreamRaider View Post
So is there a way for other things other than web browsers? Like I've tried using my ipod touch. A few things work, such a facebook and pandora. But the textfree app, and other things do not
You would have to figure out a way in each program in question. For example, I have a standalone Pandora client (on PC) that I use that seems to not work now. When I get some time, I will see if there is any way to set something like a user agent in there.

Other than that, you are looking at setting up some kind of proxy on your machine, where you can monitor all the http traffic, and change your packet headers, etc...

This is not too hard to do on a PC, but forget about it on any iCrap. Unless you maybe jailbreak it or something? But I wouldn't know anything about how to go about that...
TRS-80 is offline  
Reply With Quote
Old December 3rd, 2011, 01:34 PM   #10 (permalink)
Senior Member
 
plasticarmyman's Avatar
 
Join Date: Oct 2011
Gender: Male
Posts: 892
 
Device(s): LG Motion 4G Nook Color PA, HTC One V CM10.1, Nexus 4 DIrty Unicorns
Carrier: Not Provided

Thanks: 90
Thanked 254 Times in 162 Posts
Default

this worked for me...i'm in Long Beach, CA....and yeah i was getting blocked from tethering...also there is another workaround

WIFI Tether with any browser!!!
plasticarmyman is offline  
Reply With Quote
sponsored links
Old December 10th, 2011, 06:45 PM   #11 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, I got this to work on my LG Esteem so thanks a lot!.......however....Site show up in tablet/mobile mode which I dont mind becuase I just change them to desktop BUT my twitter shows up in mobile and there is no option to change it to desktop! Is there anyway I can fix this? or better yet some code or program that will automatically make my sites show up in desktop mode? Thanks In Advance!
Kyle2011 is offline  
Reply With Quote
Old December 10th, 2011, 07:57 PM   #12 (permalink)
Senior Member
 
tiede's Avatar
 
Join Date: Mar 2011
Location: Orlando, Fl
Gender: Male
Posts: 1,494
 
Device(s): Samsung Galaxy Indulge, CWM+Basix 1.0 Rom, Samsung Galaxy SIII, Metropcs, $50/mo
Carrier: metroPCS

Thanks: 184
Thanked 522 Times in 322 Posts
marcarthur@gmail.com
Default

Quote:
Originally Posted by tiede View Post
...use a Linux desktop user agent string. [...]
My user agent string is: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
[...]
Do that
tiede is offline  
Reply With Quote
Old December 10th, 2011, 08:09 PM   #13 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tiede View Post
Do that
Well yes I am currently using that as my user agent but my sites are still on mobile. I am using firefox on windows 7 64-bit if that helps
Kyle2011 is offline  
Reply With Quote
Old December 10th, 2011, 08:30 PM   #14 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im sorry after reading my question I realized my mistake...what I met to say is that when I close my browser then open it to reuse it I have to click android user agent in order for it to work. I there a code or program that can make firefox run as 'android' user agent by default when I open the browser? I am using Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0 and it works only when I go to tools> Android> Android when I open my browser, but I would like for my browser to open with this automatically set. Also I have android moved to the top of the list of the user agents
Kyle2011 is offline  
Reply With Quote
Old December 13th, 2011, 01:13 PM   #15 (permalink)
Member
 
TRS-80's Avatar
 
Join Date: Dec 2010
Location: Safety Harbor, FL
Posts: 367
 
Device(s): LG Motion (MS770), Nook Tablet, Samsung Galaxy Exhibit (T599)
Carrier: MetroPCS (FTW!)

Thanks: 30
Thanked 63 Times in 45 Posts
Default

Quote:
Originally Posted by Kyle2011 View Post
Im sorry after reading my question I realized my mistake...what I met to say is that when I close my browser then open it to reuse it I have to click android user agent in order for it to work. I there a code or program that can make firefox run as 'android' user agent by default when I open the browser? I am using Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0 and it works only when I go to tools> Android> Android when I open my browser, but I would like for my browser to open with this automatically set. Also I have android moved to the top of the list of the user agents
I believe that's a bug with the user-agent switcher in Firefox. Yes, you will have to change it each time as far as I know. Try Opera? The fix I uploaded above for Opera doesn't do that...

Also (and don't want to start a browser flame war here) I think you will find Opera to be much faster, especially on startup.
TRS-80 is offline  
Reply With Quote
Old May 25th, 2012, 02:49 PM   #16 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

anyone have a fix for Explorer? My Mitchell on demand 5 will only work on that browser...
dcarrd is offline  
Reply With Quote
Old May 26th, 2012, 07:25 PM   #17 (permalink)
Junior Member
 
rt-hemiboy's Avatar
 
Join Date: Jul 2011
Location: Miami
Posts: 45
 
Device(s): Lg Optimus M. Samsung G Indulge. LG STEEM...
Carrier: Not Provided

Thanks: 7
Thanked 1 Time in 1 Post
Default

Good
rt-hemiboy is offline  
Reply With Quote
Old September 6th, 2012, 12:56 PM   #18 (permalink)
Senior Member
 
HoUdInI's Avatar
 
Join Date: Feb 2012
Location: Garland, Tx
Gender: Male
Posts: 505
 
Device(s): Note 3 with wicked rom
Carrier: Family Mobile

Thanks: 49
Thanked 55 Times in 37 Posts
Default

all i get when i add this string is target is invalid put it in just like you typed it any ideas why this is not working...i have a lg esteem and looking to get the wifi hotspot to work..thanks
HoUdInI is offline  
Reply With Quote
Reply
Tags
tether solution, wi-fi issues, wi-fi tethering, wifi tethering


Go Back   Android Forums > Android Phones > Samsung Galaxy Indulge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://androidforums.com/samsung-galaxy-indulge/454393-solution-wi-fi-tethering-issues.html
Posted By For Type Date
lg ESTEEM Metro Tether only able to go on facebook, youtube, and google. This thread Refback January 11th, 2012 03:51 PM


All times are GMT -5. The time now is 06:01 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.