Go Back   Android Forums > Archived Android Devices > Archived Phones > Samsung Galaxy Lite

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old June 12th, 2010, 02:16 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default XXJD4 Color Banding

Hi guys,

I just flashed my stock Spica with the XXJD4 firmware, all went well, but i noticed some troubling issues with color banding.
In every .avi file I play color banding really pops out, and the widgets show it too: for ex. the standard clock and YouTube widgets have a black shady background which should appear shiny, but on my phone you can clearly see 6-7 different bands of shades of gray.

What can I do ? Is this normal ? Because I read that the Spica screen actually has 16 million color support. Is it from the firmware or the hardware ?

vladvx is offline  
Reply With Quote
sponsored links
Old June 13th, 2010, 05:59 AM   #2 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Widget color banding somewhat solved

Looks like the horrible color banding on the widgets was caused by the launcher I was using, Helix. I switched to Launcher Pro and things got a lot better on the home screen front. Color banding is still there, but the bands are lot finer.

However, color banding is still very obvious in videos, both YouTube and local .avi files.

Any ideas ?
vladvx is offline  
Reply With Quote
Old June 14th, 2010, 11:12 AM   #3 (permalink)
Senior Member
 
Beerkan's Avatar
 
Join Date: Apr 2010
Location: Blighty
Posts: 718
 
Device(s): Samsung GT-I5700 Galaxy Spica/Portal/Lite : Rooted Android 2.1+
Carrier: Not Provided

Thanks: 3
Thanked 168 Times in 124 Posts
Default

Can you post a piccy?
__________________
Phone: Galaxy i9100 SII: Now using Galaxy TAB7.7. Sowheat!!
Beerkan is offline  
Reply With Quote
Old June 14th, 2010, 12:12 PM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's a photo I took of the phone while playing an .avi file (XVID, 624x352 pixels, 23 fps, 1186kbps) in Meridian Player.
I couldn't find a screen capture app for Android, but I think the photo is clear enough to see the obvious color banding on the wall. It's the same thing with the YouTube app.
Any ideas why this happens?

P.S. My phone info:
Baseband version:
i570EXXJD1
Kernel version:
2.6.29
root@SE-S610#2
Build number:
ECLAIR.XXJD4

The phone is not network locked and the software, apart from the unofficial XXJD4 firmware, is completely unmodified.
banding.jpg

Attached Images
File Type: jpg banding.jpg (24.5 KB, 18 views)
vladvx is offline  
Last edited by vladvx; June 14th, 2010 at 12:27 PM.
Reply With Quote
Old June 14th, 2010, 08:03 PM   #5 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

have you tried playing your videos on another phone with a similarly specd display? Because I see the same things on my phone too, but I just attribute it to mid level quality video encoding.

I'm on XXJCE btw.
goomba is offline  
Reply With Quote
Old June 15th, 2010, 10:34 AM   #6 (permalink)
Senior Member
 
Beerkan's Avatar
 
Join Date: Apr 2010
Location: Blighty
Posts: 718
 
Device(s): Samsung GT-I5700 Galaxy Spica/Portal/Lite : Rooted Android 2.1+
Carrier: Not Provided

Thanks: 3
Thanked 168 Times in 124 Posts
Default

Low quality video compression would definately be the cause for banding on images rather than a fault.

But you said you had banding on widgets. Can you show an example of that? If defo doesn't sound right.
Beerkan is offline  
Reply With Quote
Old June 15th, 2010, 12:24 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Tested using gradient image

@goomba
It's the only touchscreen phone I have, and none of my friends have phones with similar displays. So I can't test on other phones.

@beerkan
I had terrible color banding on widgets when I was using one the latest versions of Helix Launcher. Now I'm on Launcher Pro and things are a lot better. You can still see color banding, but only if you squint really hard.

I thought about what you said about low quality video encoding. I decided to test the screen by using a simple gradient image made in PS - a 24 bit-encoded (so 16 million colors) PNG file. I posted both the file and the image I took of the phone.

As you can see, color banding is there...and this time we can't blame it on poor video encoding.

Try this for yourselves and tell me what you see.

IMG_1506_small.png


test_gradient_small.png
Attached Images
File Type: png IMG_1506_small.png (112.1 KB, 14 views)
File Type: png test_gradient_small.png (4.4 KB, 11 views)
vladvx is offline  
Reply With Quote
Old June 15th, 2010, 02:32 PM   #8 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vladvx View Post
@goomba
It's the only touchscreen phone I have, and none of my friends have phones with similar displays. So I can't test on other phones.

@beerkan
I had terrible color banding on widgets when I was using one the latest versions of Helix Launcher. Now I'm on Launcher Pro and things are a lot better. You can still see color banding, but only if you squint really hard.

I thought about what you said about low quality video encoding. I decided to test the screen by using a simple gradient image made in PS - a 24 bit-encoded (so 16 million colors) PNG file. I posted both the file and the image I took of the phone.

As you can see, color banding is there...and this time we can't blame it on poor video encoding.

Try this for yourselves and tell me what you see.

IMG_1506_small.png


test_gradient_small.png

Aright, tested. There is color banding on mine too

I'm going to bug people at the office and see how this particular pic show up on their phones.
goomba is offline  
Last edited by goomba; June 15th, 2010 at 02:37 PM.
Reply With Quote
Old June 15th, 2010, 07:53 PM   #9 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had one of my mates test it on his Nokia 5530 which also displays 16M colors and the banding shows up there too. I don't think 16 million is enough to actually render images/videos without any kind of banding. But I'm no expert. I wasn't paying attention until you pointed it out.

Ok we need a display expert here.
goomba is offline  
Last edited by goomba; June 15th, 2010 at 08:01 PM.
Reply With Quote
Reply

Samsung Galaxy Lite
Current Rating:
Rate this Phone:

The Samsung Galaxy I7500 was the company's first Android phone and the Galaxy Lite will follow in its footsteps by offering a slightly toned down version of the original Galaxy. Although the Galaxy Lite has a 3.2MP Camera with no flash and 1GB ... Read More



Go Back   Android Forums > Archived Android Devices > Archived Phones > Samsung Galaxy Lite
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:38 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.