Go Back   Android Forums > Android Phones > Samsung Galaxy Precedent

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old September 9th, 2012, 12:25 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Suntrust App

I have a Samsung Galaxy Precedent from Straight Talk. I like the phone, it does what I need it to do. A few months ago I downloaded the Suntrust Mobile App. It works great!! Well, Suntrust has a new app that does more stuff. So I went to download it, and it says my device is not compatible. Suntrust says all Android devices 1.6 or above will work. Well my ph is 2.2.2. I did some reading and thought maybe if I "Root" my ph I could get the app. Well I "rooted" my ph this morning. Downloaded the "Root Checker" and it says my ph is now rooted. I went back to get the Suntrust app, and it still says my device is not compatible. Is there a way to maybe upgrade my OS?? Is that the problem? Any help would be greatly appreciated! Randy.

rainbowwar24 is offline  
Reply With Quote
sponsored links
Old September 9th, 2012, 10:41 PM   #2 (permalink)
AF Contributor
 
Join Date: Jan 2012
Location: Fayetteville, NC, USA
Gender: Male
Posts: 8,954
 
Device(s): Note3 stock (so far) been replaced. Working great so far.
Carrier: AT&T

Thanks: 6
Thanked 2,538 Times in 2,351 Posts
Default

Quote:
Originally Posted by rainbowwar24 View Post
I have a Samsung Galaxy Precedent from Straight Talk. I like the phone, it does what I need it to do. A few months ago I downloaded the Suntrust Mobile App. It works great!! Well, Suntrust has a new app that does more stuff. So I went to download it, and it says my device is not compatible. Suntrust says all Android devices 1.6 or above will work. Well my ph is 2.2.2. I did some reading and thought maybe if I "Root" my ph I could get the app. Well I "rooted" my ph this morning. Downloaded the "Root Checker" and it says my ph is now rooted. I went back to get the Suntrust app, and it still says my device is not compatible. Is there a way to maybe upgrade my OS?? Is that the problem? Any help would be greatly appreciated! Randy.
Is the app telling you that your device is not compatible, or is Google Play saying it? If it's Google Play, talk to someone at Suntrust who supports the app, and as them to incude your phone in the list of supported phones. If it's the app, speak to them (same people - the ones who write the app) and ask them to fix the error message, since your phone is running a version of Android OS above 1.6.

In either case, it's their problem and only they can fix it. (Unless you reverse engineer the app and modify it, which isn't easy, even if you're a programmer, it's illegal, and there's no reason to do it, since they should.)

Your chances of getting them to help you? Probably less than none, but that's the only way to go. (Don't feel bad - I can't use my phone as a scanner in my supermarket because my phone is incompatible with their scanner app, and they won't do anything about it - not even answer my very nice email.)
Rukbat is offline  
Reply With Quote
Reply

Samsung Galaxy Precedent
Current Rating:
Rate this Phone:

The Samsung Galaxy Precedent is an entry level device for Straight Talk. Unlike some of it's Galaxy S cousins, you wont find some of the higher end "Galaxy S" features and it doesn't have the familiar TouchWhiz interface seen on s... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy Precedent
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:29 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.