Go Back   Android Forums > Android Phones > Samsung Galaxy Prevail

Like Tree3Likes
  • 1 Post By Davidcha18
  • 1 Post By Davidcha18
  • 1 Post By cwhatever

test: Reply
 
LinkBack Thread Tools
Old December 1st, 2011, 10:01 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Unhappy PLEASE HELP! Battery charge notification wouldn't stop, powered off, unable to power back on.

Arrrgh! Normally not a pirate, but this is making me especially crazy. I've only had the phone for a week. This morning, the battery life was @ 47% when I unplugged it this morning.
I noticed that the battery charging notification wouldn't stop, so I tried turning off the phone. When I tried to power it back on, however, it wouldn't come on! It's making me want to karate chop an unsuspecting victim in the throat! I've tried holding the power on button, but the battery symbol comes on, goes off, then comes back up one more time, then....nothing. I've tried holding the power button down while touching the screen...same thing -battery symbol, then nothing.

Please help before someone gets unexpectedly assaulted. It's the last thing I want to do.

Thank you in advance!!

Advertisements
vickidenn is offline  
Reply With Quote
sponsored links
Old December 1st, 2011, 10:10 AM   #2 (permalink)
Member
 
Heloguy's Avatar
 
Join Date: Apr 2011
Location: Matawan,NJ
Gender: Male
Posts: 367
 
Device(s): HTC One SV
Carrier: Boost

Thanks: 98
Thanked 61 Times in 50 Posts
Default

try pulling the battery out for a minute or so. sometimes that clears the hangup.
Heloguy is offline  
Reply With Quote
The Following User Says Thank You to Heloguy For This Useful Post:
vickidenn (December 1st, 2011)
Old December 1st, 2011, 10:22 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Heloguy View Post
try pulling the battery out for a minute or so. sometimes that clears the hangup.
Well, I did that. Does it have to be for a solid minute, though? I just took it out and placed it right back in.

Just went out to my truck, plugged it back into the charger. The phone powered back on, however, the phone is still acting like it is plugged into the charger. What to do now?
vickidenn is offline  
Reply With Quote
Old December 1st, 2011, 10:35 AM   #4 (permalink)
Member
 
stingrays's Avatar
 
Join Date: Oct 2011
Location: Boise, Idaho
Posts: 101
 
Device(s): HTC Evo V 4G, Kyocera Hydro
Carrier: Not Provided

Thanks: 26
Thanked 33 Times in 16 Posts
Send a message via Yahoo to stingrays
Default

Sounds like a hardware problem. If you can take it back to the store where u purchased it, they should replace it since you've only had it a week. You will save yourself a lot of time not battling with your phone.
stingrays is offline  
Reply With Quote
The Following User Says Thank You to stingrays For This Useful Post:
vickidenn (December 1st, 2011)
Old December 1st, 2011, 04:47 PM   #5 (permalink)
Member
 
Join Date: Jul 2011
Location: Ohio
Posts: 131
 
Device(s): Samsung Galaxy S3
Carrier: Boost

Thanks: 35
Thanked 20 Times in 15 Posts
Default

Wow. This is odd. My phone just started doing this, this morning. I have had the phone for 6 months. Rooted, modded and never an issue. Now it shows thats its charging, when its not and then it won't charge when I need it to. It starts kicking on and off. I bought the phone at a sprint/boost dealer. Do they exchange or do I have to send the phone in to samsung for repairs and be without a phone for who nows how long? Wow, this is indeed odd. Thanks
scootmcdoot is offline  
Reply With Quote
Old December 1st, 2011, 06:04 PM   #6 (permalink)
Senior Member
 
johnny424's Avatar
 
Join Date: Nov 2011
Location: Washington Dc
Posts: 1,501
 
Device(s): AT&T SGS3-Google Nexus 7
Carrier: AT&T

Thanks: 438
Thanked 467 Times in 271 Posts
Default

if i had to guess after six months you would probally have to go through samsung...or boost maybe ..if you have some kind of insurance..i think its 5 extra bucks a month but if something happens to the phone i think they will still charge you like 65 maybe
johnny424 is offline  
Reply With Quote
Old December 1st, 2011, 06:44 PM   #7 (permalink)
Member
 
inigomontoyasr's Avatar
 
Join Date: Jul 2011
Posts: 383
 
Device(s):
Carrier: Not Provided

Thanks: 90
Thanked 216 Times in 118 Posts
Default

Have you tried making sure nothing is stuck in the USB port? Maybe use a small plastic toothpick or something similar to clear any debris. Pocket lint packed in may be shorting something out.
__________________
Just trying to help.
inigomontoyasr is offline  
Reply With Quote
Old December 1st, 2011, 06:48 PM   #8 (permalink)
Senior Member
 
Join Date: Sep 2011
Location: Riverside, CA
Posts: 532
 
Device(s): Galaxy Prevail: GB EJ06 Odin Root, CWM5, with Blood and Kouma's flavor of the week. Boost Galaxy S2
Carrier: Not Provided

Thanks: 258
Thanked 95 Times in 67 Posts
Default

Quote:
Originally Posted by inigomontoyasr View Post
Have you tried making sure nothing is stuck in the USB port? Maybe use a small plastic toothpick or something similar to clear any debris. Pocket lint packed in may be shorting something out.
Good idea! Worth a shot

Would it also be safe to hit it with "dust off" or spray some electronics cleaner in there? With the battery removed ofcourse
76ford90lx is offline  
Reply With Quote
Old December 1st, 2011, 07:56 PM   #9 (permalink)
Member
 
Join Date: Jul 2011
Location: Ohio
Posts: 131
 
Device(s): Samsung Galaxy S3
Carrier: Boost

Thanks: 35
Thanked 20 Times in 15 Posts
Default

Thanks for the ideas. After googling a bit, this seems to happen quite often. I tried (unsuccessfully) taking out the battery, using a small cloth, a small screwdriver and rubbing alcohol to gently clean the contacts. They were dirty, but the problem still exists. I can charge it, but after disconnecting the charger, it still shows that its charging. This seems to be a huge battery drainer.

Boost shrinkage is nice, but its gets costly replacing faulty hardware. I might just try to ride this out a bit. Thanks everyone.
scootmcdoot is offline  
Reply With Quote
Old December 2nd, 2011, 12:39 AM   #10 (permalink)
Junior Member
 
Join Date: Jun 2011
Location: Mesquite, Nevada
Posts: 42
 
Device(s): Samsung Galaxy Prevail : CT Mod
Carrier: Not Provided

Thanks: 30
Thanked 8 Times in 7 Posts
Default

I seen this on my friends phone after 3 weeks. Then the GB update happened and it went to normal.
Cheezee292 is offline  
Reply With Quote
sponsored links
Old December 2nd, 2011, 05:38 AM   #11 (permalink)
Senior Member
 
Join Date: Sep 2011
Location: Riverside, CA
Posts: 532
 
Device(s): Galaxy Prevail: GB EJ06 Odin Root, CWM5, with Blood and Kouma's flavor of the week. Boost Galaxy S2
Carrier: Not Provided

Thanks: 258
Thanked 95 Times in 67 Posts
Default

I would do a factory wipe just for kicks
76ford90lx is offline  
Reply With Quote
Old December 2nd, 2011, 01:39 PM   #12 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 30
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 7 Posts
Default I had the same prob

I had the exact same problem after plugging a charger into my phone that my son had smashed the tip in some chocolate brownie, then bam, it started flipping out, would say its charging when not plugged in, or wouldn't charge when plugged in, so i turned the phone off and scraped the contacts in the female usb slot on the bottom with a SMALL sewing needle ( the end with the hole not the pointy side ) and used the holed end to pull what ever was in there out, and it works great again hope this helps you
nsomniac is offline  
Reply With Quote
Old December 4th, 2011, 04:59 PM   #13 (permalink)
Member
 
Join Date: Jul 2011
Location: Ohio
Posts: 131
 
Device(s): Samsung Galaxy S3
Carrier: Boost

Thanks: 35
Thanked 20 Times in 15 Posts
Default

A new issue has appeared. My phone will show that its 100% charged and stay there. I have to reboot the phone with the charger plugged in to get it to take a charge. Everything works fine, but it is really a frustrating issue to deal with. At this point, I just have to hope that it does not get any worse. Just an update.
scootmcdoot is offline  
Reply With Quote
Old January 20th, 2012, 05:26 PM   #14 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Confused Happened to me too

This thing with the battery notification happened to me to sometime in December. I powered down and could not power back up... I did that because the phone was saying it was charging when CLEARLY, it was unplugged. To power back up, I removed the battery, put it back in, plugged the phone in and it was then able to power up. HERE IS A FIX FOR THAT CHARGING WHEN NOT ACTUALLY CHARGING THING...
1. Let the battery run ALL THE WAY DOWN until the phone turns itself off. Even when it says "Plug in your charger", DO NOT. Let the phone completely die.
2. With the phone off after completely dying, plug it in. DO NOT TRY TO TURN THE PHONE ON UNTIL IT IS FULLY CHARGED!
3. Once the phone indicates that it is fully charged, UNPLUG it and then power up the phone.

The issue SHOULD be gone. I believe it is an issue with the chip in the phone getting screwy... This fixed mine, but I had went through it several times because I would turn the phone on before it FULLY charged. That is an important step... let it fully die, then fully charge.

I hope this helps some one.
MPCReRuN is offline  
Reply With Quote
The Following 2 Users Say Thank You to MPCReRuN For This Useful Post:
blackbolo (November 9th, 2013), Davidcha18 (July 15th, 2012)
Old January 22nd, 2012, 01:15 PM   #15 (permalink)
New Member
 
JimDub's Avatar
 
Join Date: Jun 2011
Location: New York
Posts: 6
 
Device(s): Samsun Prevail, Augen Gentouch 78
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

If anyone is browsing this question because their phone is not charging properly, you can just buy a separate charger on Amazon. I got a spare 1800 mAh battery and a charger for about $30. The battery is from AceSoft and the charger is from Yiboyuan. If you can't find a charger for Prevail, it uses the same battery as the Sidekick and several other Samsung models.
JimDub is offline  
Reply With Quote
Old January 23rd, 2012, 12:32 AM   #16 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 30
Thanked 2 Times in 2 Posts
Default

A friend of mine had the same probllem. With his al it was was thw metal piece inside the phone where the chargeer is plugged in was bent. He bent it back and ut wrkd fine
josh hager is offline  
Reply With Quote
Old January 26th, 2012, 01:29 PM   #17 (permalink)
AJ1
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Has anyone else been able to fix this problem? The metal piece is not bent, and turning off the phone and fully recharging did not fix it.
AJ1 is offline  
Reply With Quote
Old January 26th, 2012, 01:42 PM   #18 (permalink)
▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
 
Lordvincent 90's Avatar
 
Join Date: Oct 2011
Location: grand rapids,mi
Gender: Male
Posts: 4,779
 
Device(s): Galaxy Prevail, Galaxy Prevail II, Kyocera Hydro, Nexus 7 (Grouper), Galaxy rush, Htc One SV
Carrier: of the deadly t-virus

Thanks: 1,709
Thanked 2,397 Times in 1,671 Posts
Default

did you try and clean the contacts? or see if there was lint jumping the connectors? happened to me, i just used a cloth and the tip of a small nail file to jently clean the contacts. if it continues to be a problem, contact samsung and you can probably get it replaced under warranty
__________________
(ノಠ益ಠ)ノ彡┻━┻
Lordvincent 90 is online now  
Reply With Quote
Old April 12th, 2012, 04:03 PM   #19 (permalink)
Junior Member
 
bumrocks's Avatar
 
Join Date: Dec 2011
Location: In a van, down by the river...
Gender: Male
Posts: 27
 
Device(s): Samsung Prevail, HTC EVO Design 4G
Carrier: Boost

Thanks: 14
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MPCReRuN View Post
This thing with the battery notification happened to me to sometime in December. I powered down and could not power back up... I did that because the phone was saying it was charging when CLEARLY, it was unplugged. To power back up, I removed the battery, put it back in, plugged the phone in and it was then able to power up. HERE IS A FIX FOR THAT CHARGING WHEN NOT ACTUALLY CHARGING THING...
1. Let the battery run ALL THE WAY DOWN until the phone turns itself off. Even when it says "Plug in your charger", DO NOT. Let the phone completely die.
2. With the phone off after completely dying, plug it in. DO NOT TRY TO TURN THE PHONE ON UNTIL IT IS FULLY CHARGED!
3. Once the phone indicates that it is fully charged, UNPLUG it and then power up the phone.

The issue SHOULD be gone. I believe it is an issue with the chip in the phone getting screwy... This fixed mine, but I had went through it several times because I would turn the phone on before it FULLY charged. That is an important step... let it fully die, then fully charge.

I hope this helps some one.
This fix did not help for me...

If the phone is shut down and you cannot power up, use the "volume up" button at the same time as the power button to get to a options menu. Then press the "Home" button to choose the first option "Reboot Now".

Other than that I know not what else to do but live whith it till a new phone is purchased as it does seem to be a hardware issue. Can anyone confirm if resetting the phone works...That is the next step I am going to take.
bumrocks is offline  
Reply With Quote
Old April 15th, 2012, 10:28 AM   #20 (permalink)
Member
 
Xruptor's Avatar
 
Join Date: Jun 2011
Posts: 409
 
Device(s):
Carrier: Not Provided

Thanks: 124
Thanked 142 Times in 82 Posts
Default

Quote:
Originally Posted by bumrocks View Post
This fix did not help for me...

If the phone is shut down and you cannot power up, use the "volume up" button at the same time as the power button to get to a options menu. Then press the "Home" button to choose the first option "Reboot Now".

Other than that I know not what else to do but live whith it till a new phone is purchased as it does seem to be a hardware issue. Can anyone confirm if resetting the phone works...That is the next step I am going to take.
Have you tried flashing the phone again? That may fix the problem. If it that doesn't work it's definitely a hardware issue.

I recommend you flash the phone to something like EJ06 or FA19. Someone in a previous post mention that it fixed it for their friend.

For more information refer to this thread: http://androidforums.com/galaxy-prevail-all-things-root/375550-odin-return-phone-stock-factory-updated-02-23-new-fa19-image.html
Xruptor is offline  
Reply With Quote
sponsored links
Old April 16th, 2012, 01:18 PM   #21 (permalink)
New Member
 
Join Date: Jun 2011
Location: Tampa, Florida
Gender: Female
Posts: 9
 
Device(s): Samsung Galaxy SII SPH-D710BST ANDROID 4.0.4 BASEBAND VERSION S:D710.10 S.FI22 KERNEL VERSIO
Carrier: Boost Mobile Sprint Network

Thanks: 13
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vickidenn View Post
Arrrgh! Normally not a pirate, but this is making me especially crazy. I've only had the phone for a week. This morning, the battery life was @ 47% when I unplugged it this morning.
I noticed that the battery charging notification wouldn't stop, so I tried turning off the phone. When I tried to power it back on, however, it wouldn't come on! It's making me want to karate chop an unsuspecting victim in the throat! I've tried holding the power on button, but the battery symbol comes on, goes off, then comes back up one more time, then....nothing. I've tried holding the power button down while touching the screen...same thing -battery symbol, then nothing.

Please help before someone gets unexpectedly assaulted. It's the last thing I want to do.

Thank you in advance!!


The same thing happened to me about 7 months ago, with my first Prevail. And it happened out of nowhere, I unplugged it and it went immediately down to only 30%, and the charging icon was indicated, and I tried to lock it and quickly try to unlock it again, because that has always helped snap by phone back into actimg right, but it wouldn't come back on. I plugged it back into the charger, but it would not take a charge and never came back on! Like 9 days before I got paid, too, so I was without my phone the whole time So I'm very curious to read about what ended up happening in your situation! I know EXACTLY how it feels
CrystalCin813 is offline  
Reply With Quote
Old April 16th, 2012, 01:33 PM   #22 (permalink)
New Member
 
Join Date: Jun 2011
Location: Tampa, Florida
Gender: Female
Posts: 9
 
Device(s): Samsung Galaxy SII SPH-D710BST ANDROID 4.0.4 BASEBAND VERSION S:D710.10 S.FI22 KERNEL VERSIO
Carrier: Boost Mobile Sprint Network

Thanks: 13
Thanked 0 Times in 0 Posts
Default

Wiping it out, letting it die more dead than it already was then letting it charge completely, 15 different chargers, dust off, nothing worked when this happened to me. The phone simply fried out. But if you pay the $5 extra on your bill every month for the insurance, you just call the insurance Company, Assurion, and they file your claim right then, and you pay the $65 deductible, by credit or debit or whatever gets it to them as fast as possible, because your new, NOT refurbished, phone arrives Fed Ex within 24 hours of payment. That is just one of the reasons I stay with Boost. It's horrible how it's done at Metro PCS! Hope you figured something out on your phone actin cray...
CrystalCin813 is offline  
Reply With Quote
Old June 13th, 2012, 09:02 AM   #23 (permalink)
New Member
 
Join Date: Apr 2010
Location: Eastern NC
Posts: 3
 
Device(s): Motorola Android
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Battery Charging Issue!?! After Update!

I've had my boost mobile samsung prevail for a few months-no insurance, I've always had it with other phones, don't know why I didn't get it!-
Just 2 days ago my phone received an UPDATE!
ONLY SINCE the update have I experienced the battery charging indicating all the time issue, and the phone not being able to turn back on once it turns off, without plugging it in.
I've done the factory reset.
"Cleaned it out".
No damage from plugging or unplugging it!
Let it completely die, completely charge, then turn on, or rather try to turn on, it will not turn on at all unless plugged in!
& of course it indicates that it's charging, all the time!
So, I'm curious if anyone has had this problem AFTER an update?
The phone worked great, not a problem beforehand!
So I'm really at a loss as of to what I can do!
Any other suggestions-Completely welcome!
Banana is offline  
Reply With Quote
Old June 13th, 2012, 10:56 AM   #24 (permalink)
▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
 
Lordvincent 90's Avatar
 
Join Date: Oct 2011
Location: grand rapids,mi
Gender: Male
Posts: 4,779
 
Device(s): Galaxy Prevail, Galaxy Prevail II, Kyocera Hydro, Nexus 7 (Grouper), Galaxy rush, Htc One SV
Carrier: of the deadly t-virus

Thanks: 1,709
Thanked 2,397 Times in 1,671 Posts
Default

The not turning on part, I'm not sure, but most times when you get the charging-when-not-plugged-in issue is when something gets stuck in the charging port (lint, string, etc) that jumps the contacts. Try GENTLY cleaning them or using a can of air to blow it out...
Lordvincent 90 is online now  
Reply With Quote
Old July 15th, 2012, 12:45 AM   #25 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default I have the same problem :(

My phone does the same thing. I'm hoping the method "let the battery die and charge it" works!!! But the notification lights up crazy and my screen flashes showing me the message "USB and charge" and when it's on vibration it goes crazy vibrating and when the ringtone is on it beeps. In scared what other method does anyone have. I think I might have to take it to the repair shop. Any more suggestions??? LMK. Thanks
Davidcha18 is offline  
Reply With Quote
Old July 15th, 2012, 01:07 AM   #26 (permalink)
AF Contributor
 
wetbiker7's Avatar
 
Join Date: Jun 2011
Location: So-Cal
Gender: Male
Posts: 7,208
 
Device(s): SamsungGalaxy S3, LG Marquee, Asus TF300T 32GB w/ dock, SamsungGalaxy Prevail
Carrier: Boost

Thanks: 1,898
Thanked 3,216 Times in 2,122 Posts
Default

Quote:
Originally Posted by Davidcha18 View Post
My phone does the same thing. I'm hoping the method "let the battery die and charge it" works!!! But the notification lights up crazy and my screen flashes showing me the message "USB and charge" and when it's on vibration it goes crazy vibrating and when the ringtone is on it beeps. In scared what other method does anyone have. I think I might have to take it to the repair shop. Any more suggestions??? LMK. Thanks

I would try what LordVincent mentioned and make sure that your charging port is clean. If that doesn't work, try doing a factory reset? You'll lose everything on the phone if it's not backup up with an app like Titanium but as long as you have a gmail account you'll be able to get your contacts back. I don't know if you're rooted or not but you can do a factory reset even if you don't have root.

From a powered off phone, press volume up and power at the same time until a black screen with blue writing comes up, then let go of the buttons. Using the volume buttons, scroll down to the wipe data/ factory reset option. Use the camera button to select and do a factory reset. Hopefully that will fix your phone.
__________________
Is there a reason you're not rooted yet??
Do the right thing and hit THANKS!
wetbiker7 is online now  
Reply With Quote
The Following User Says Thank You to wetbiker7 For This Useful Post:
Davidcha18 (July 15th, 2012)
Old July 15th, 2012, 02:31 PM   #27 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wetbiker7 View Post
I would try what LordVincent mentioned and make sure that your charging port is clean. If that doesn't work, try doing a factory reset? You'll lose everything on the phone if it's not backup up with an app like Titanium but as long as you have a gmail account you'll be able to get your contacts back. I don't know if you're rooted or not but you can do a factory reset even if you don't have root.

From a powered off phone, press volume up and power at the same time until a black screen with blue writing comes up, then let go of the buttons. Using the volume buttons, scroll down to the wipe data/ factory reset option. Use the camera button to select and do a factory reset. Hopefully that will fix your phone.
Hello, I already did that. I lost everything and it was still doing it Thank you for you're help But yea i did that turning off thing yesterday at night. I turned it on today and it was still doing it. Like yesterday it stopped for 2 hours. I guess when I was on Facebook and Instgram. But the worst thing is that it eats my battery. If you have any more suggestions, I would appreciated. Once again thank you for you're help
wetbiker7 likes this.
Davidcha18 is offline  
Reply With Quote
Old July 15th, 2012, 03:51 PM   #28 (permalink)
AF Contributor
 
wetbiker7's Avatar
 
Join Date: Jun 2011
Location: So-Cal
Gender: Male
Posts: 7,208
 
Device(s): SamsungGalaxy S3, LG Marquee, Asus TF300T 32GB w/ dock, SamsungGalaxy Prevail
Carrier: Boost

Thanks: 1,898
Thanked 3,216 Times in 2,122 Posts
Default

Quote:
Originally Posted by Davidcha18 View Post
Hello, I already did that. I lost everything and it was still doing it Thank you for you're help But yea i did that turning off thing yesterday at night. I turned it on today and it was still doing it. Like yesterday it stopped for 2 hours. I guess when I was on Facebook and Instgram. But the worst thing is that it eats my battery. If you have any more suggestions, I would appreciated. Once again thank you for you're help

2 things that I would suggest.

1st- if the phone is still under warranty, send it back. Samsung will pay for everything and it normally takes less than 10 days. I know it'll BITE to be without your phone but at least they'll give it a complete run through. They may even replace the entire phone instead of just replacing the defective part.

2nd- if it's out of warranty, I would try using Odin and flash a whole new image. You can actually try this method too before sending it in for warranty if that option is available.

Odin (Return phone to Stock/Factory)

Post back and let us know what happens.
wetbiker7 is online now  
Reply With Quote
The Following User Says Thank You to wetbiker7 For This Useful Post:
Davidcha18 (July 16th, 2012)
Old July 16th, 2012, 05:23 PM   #29 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wetbiker7 View Post
2 things that I would suggest.

1st- if the phone is still under warranty, send it back. Samsung will pay for everything and it normally takes less than 10 days. I know it'll BITE to be without your phone but at least they'll give it a complete run through. They may even replace the entire phone instead of just replacing the defective part.

2nd- if it's out of warranty, I would try using Odin and flash a whole new image. You can actually try this method too before sending it in for warranty if that option is available.

Odin (Return phone to Stock/Factory)

Post back and let us know what happens.
Hi thank you for you're suggestion. I went to a phone repair shop. They said that they cn't fix it. However, (finger's crossed) it stopped doing it like 4 hours ago. I am going to see what happens tonight and tomorrow when I charge it and unplug it. I'll try the "let the phone die and charge it to 100%" once again and I'll let you know if it had some work. If you find anything new let me know, thanks
Davidcha18 is offline  
Reply With Quote
Old July 16th, 2012, 08:36 PM   #30 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

So it been like 7 hours that it stop doing that notification thing so idk yet. Don't wanna get my hopes up. So I'll see later on today or tomorrow my phone is about to die. I 'll let you all know if it has FINALLY stop
wetbiker7 likes this.
Davidcha18 is offline  
Reply With Quote
sponsored links
Old July 16th, 2012, 11:26 PM   #31 (permalink)
AF Contributor
 
wetbiker7's Avatar
 
Join Date: Jun 2011
Location: So-Cal
Gender: Male
Posts: 7,208
 
Device(s): SamsungGalaxy S3, LG Marquee, Asus TF300T 32GB w/ dock, SamsungGalaxy Prevail
Carrier: Boost

Thanks: 1,898
Thanked 3,216 Times in 2,122 Posts
Default

Great. I hope that it's fixed.
wetbiker7 is online now  
Reply With Quote
Old August 5th, 2012, 10:42 AM   #32 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default Why did this happen?

Hello again ,
I wanted to know why my did that? Why would it beep, vibrate, and flash thinking it was charging when really it was unplugged ? I never dropped my phone and it's in good condition with cover and everything ? Why did it that ?
Davidcha18 is offline  
Reply With Quote
Old August 5th, 2012, 11:04 AM   #33 (permalink)
▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
 
Lordvincent 90's Avatar
 
Join Date: Oct 2011
Location: grand rapids,mi
Gender: Male
Posts: 4,779
 
Device(s): Galaxy Prevail, Galaxy Prevail II, Kyocera Hydro, Nexus 7 (Grouper), Galaxy rush, Htc One SV
Carrier: of the deadly t-virus

Thanks: 1,709
Thanked 2,397 Times in 1,671 Posts
Default

Most times it occurs because there it's something in the charging port (lint, or some other obstruction) that is making the phone think there is a charger attached. This has happened to me several times.
Each time i just folded a dollar Bill to a point and fished around GENTLY and then used a can of compressed air (Duster) to blow into the port and everything went back to normal.
Ymmv.

Edit-just read that you already tried this... Lol.
Lordvincent 90 is online now  
Last edited by Lordvincent 90; August 5th, 2012 at 11:07 AM.
Reply With Quote
The Following User Says Thank You to Lordvincent 90 For This Useful Post:
Davidcha18 (August 5th, 2012)
Old August 8th, 2012, 06:09 PM   #34 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My phone is charging backwards. What's going on with that?
Vandan is offline  
Reply With Quote
Old October 22nd, 2012, 11:54 PM   #35 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default There is no fiix for samsung

This problem is caused by malfunction of internal logic circuit usually appers in the first days or weeks, samsumg previal and transform they have the same problem ,
The only way to get fixed is claim the samsung factory defects warranty ,
They know about it, but they shutt off the mouth, to save some money from this defect and let the end user pay for it and the surence company and also the end user.
rosher2000 is offline  
Reply With Quote
Old July 29th, 2013, 12:48 AM   #36 (permalink)
New Member
 
Join Date: Jul 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

even i faced the same thing...when i am charging my battery..its showing an indication.then when i took out the charger ...still the battery indication was showing. I didnt noticed that ..and i kept the mobile aside and slept of...morning when i got up...i saw my mobile battery is full. then i switched of my mobile and switched it on...now again battery came down to 40% ...i dnt know what is this different type of problem...i read the thread....now thinking to drain of the battery and when its 0% , i will start charging....if that also dnt work ..then i will reset the devicce....not sure that gonna solve the problem or not.
karishma247 is offline  
Reply With Quote
Old July 29th, 2013, 03:09 AM   #37 (permalink)
Junior Member
 
Join Date: Jul 2013
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 2 Times in 2 Posts
Default

Hey, I have a problem with my samsung galaxy s2 as well although it is a bit different from the problem of this thread. My phone keeps turning off randomly after I use it for about 10 minutes and I factory reseted my phone but it still does that. Also, the battery looks a bit bloated and I don't know what to do Please help!
garbam is offline  
Reply With Quote
Old July 29th, 2013, 05:42 AM   #38 (permalink)
Life Goes On
 
cwhatever's Avatar
 
Join Date: Mar 2012
Location: south central fla
Gender: Male
Posts: 2,896
 
Device(s): galaxy s3 rooted on wicked or carbon, galaxy prevail ctmod 3.8 ssm(mp3 player)
Carrier: Boost Mobile

Thanks: 532
Thanked 745 Times in 553 Posts
Default

Quote:
Originally Posted by garbam View Post
Hey, I have a problem with my samsung galaxy s2 as well although it is a bit different from the problem of this thread. My phone keeps turning off randomly after I use it for about 10 minutes and I factory reseted my phone but it still does that. Also, the battery looks a bit bloated and I don't know what to do Please help!
You might want to check out the S2 threads, they will be able to help you better than in this prevail section. Not sure which S2 you have but here is one of them Samsung Galaxy S2 (Boost Mobile) - Android Forums Hope this helps you
wetbiker7 likes this.
__________________
EVERYTHING HAPPENS FOR A REASON/TODAY IS THE LAST DAY BEFORE TOMORROW SO USE IT WISELY !!!!!!!!! Thanks Button Is The Right Thing To Do!!
The One Who Dies With The Most Toys WINS
At First If You Don't Succeed Try Try Again & Ask"S
http://androidforums.com/Site-Rules/Guidelines
cwhatever is offline  
Reply With Quote
Reply

Samsung Galaxy Prevail
Current Rating:
Rate this Phone:

The Samsung Galaxy Prevail is an entry level device for Boost Mobile. Unlike some of it's Galaxy S cousins, you wont find some of the higher end "Galaxy S" features and it doesn't have the familiar TouchWhiz interface seen on so m... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy Prevail
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:18 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.