Go Back   Android Forums > Android Phones > Samsung Galaxy S

Like Tree1Likes

test: Reply
 
LinkBack Thread Tools
Old October 19th, 2010, 03:24 AM   #51 (permalink)
New Member
 
Join Date: Oct 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I was having a hell of a time and it's getting better thanks to you wonderful folks but there are still a few kinks in my transferring adventures. I was copying files over to my internal drive and though I could see them in MY COMPUTER as having been successfully moved to my SGS, as soon as I tried to play them on the SGS Mp3 player they weren't there. I also got a few more MP3 players aside from the stock one to see if that was the problem but they were still missing. Finally, after using the 'debugging' option, I can put files on my internal drive.

However, the same thing as before is now happening with my SD drive. According to my computer, the files are there, and according to my phone's memory reader SOMETHING is taking up the right amount of space, but the files won't come up in my MP3 player. Weird!

Thanks in advance for any advice!

Rob

Advertisements
mcgenghis is offline  
Reply With Quote
sponsored links
Old October 19th, 2010, 05:42 AM   #52 (permalink)
Member
 
ArmadaTattoo's Avatar
 
Join Date: Feb 2010
Location: Limerick Ireland
Posts: 112
 
Device(s): Sony Xperia S TuRdZzROM v1.3.0 ROM
Carrier: Not Provided

Thanks: 35
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by mcgenghis View Post

...but the files won't come up in my MP3 player. Weird!

Rob
Hi Rob, could the problem be that the media scanner has not been run and thus the media players don't know the files are there?

For instance when I take a photo, the pictures don't come up in Gallery until the media scanner runs again. this would the same for video and music.

There is a control in the Extended Controls widget to run the media scanner manually so I presume there is a way to do it in the Settings menu somewhere. Have a look around, I am sure you will find it.

Also you could use the file manager or a free (much better) alternative such as Astro File Manager or ES File Manager (availablel in Market) to manually find the files and play them.
__________________
Sony Xperia S
ArmadaTattoo is offline  
Reply With Quote
The Following User Says Thank You to ArmadaTattoo For This Useful Post:
mcgenghis (October 20th, 2010)
Old October 20th, 2010, 02:22 AM   #53 (permalink)
New Member
 
Join Date: Oct 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks, that Astro program is great. Still, even it won't read my extra SC card for some reason. The card wasn't standard with the phone and just given to me by a friend. Perhaps I need a driver or something to help the phone recognize it? Once again, the computer does but the phone does not. Thanks Armada!

Edit: I think I got it finally. ^^
mcgenghis is offline  
Last edited by mcgenghis; October 20th, 2010 at 03:46 AM. Reason: Addendum
Reply With Quote
Old October 25th, 2010, 01:50 PM   #54 (permalink)
New Member
 
Join Date: Oct 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Apologies if this has been answered, this is my first time on this site but haven't found an answer as yet.
I have a problem with my htc wildfire connecting to my pc. I have Window 7 with the latest version of HTC Sync 3.0 on my pc. when I connect the Wildfire to the pc with the USB cable and select the Sync option on the phone, I get a message saying HTC Sync isn't installed on the computer or isn't open. It is installed and it was open at the time. It won't even let me use it as a mass storage device.

Little help!!!! Anyone???
Tooms82517 is offline  
Reply With Quote
Old June 1st, 2011, 10:49 PM   #55 (permalink)
New Member
 
Join Date: Jun 2011
Location: Thailand
Posts: 2
 
Device(s): Galaxy S, Galaxy Tab,
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK after having the "connecting" caption sit in kies for 5 hours solid, I figured that it wasn't going too well, in desparation I took my sim card out and the extra SD card and loh! it connected and upgraded, WAHEY!!!!

Hope this helps

Incidently: Win XP and Gingerbread (post upgrade)
badchild is offline  
Last edited by badchild; June 1st, 2011 at 10:51 PM. Reason: more info
Reply With Quote
Old June 13th, 2011, 01:47 AM   #56 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, I have a question regarding on HOW TO INSTALL APPLICATIONS on SGS through USB connection. I'm a new android user, and is completely clueless on how it works. Whenever I try to download apps it keeps connecting to my phone (but I do not have Wi-Fi, hence I do not receive the apps I download). How do I download through the USB or how do I move the downloaded files to my phone? I have no SD card and I am also a Mac user. THANK YOU!
essandoval is offline  
Reply With Quote
Old July 3rd, 2011, 06:26 PM   #57 (permalink)
Senior Member
 
Join Date: Jul 2010
Posts: 2,279
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 266 Times in 223 Posts
Default

Quote:
Originally Posted by essandoval View Post
Hi, I have a question regarding on HOW TO INSTALL APPLICATIONS on SGS through USB connection. I'm a new android user, and is completely clueless on how it works. Whenever I try to download apps it keeps connecting to my phone (but I do not have Wi-Fi, hence I do not receive the apps I download). How do I download through the USB or how do I move the downloaded files to my phone? I have no SD card and I am also a Mac user. THANK YOU!
Android app installation packages have the extension .apk. If you download a file with this extension, simply save it somewhere on you SD card, and then navigate to it with any file explorer app. (Similar to installing .exe files on Windows. Not sure what is the Mac equivalent. )

However, there is no official way to obtain apk files from the app market. Installation from the market can only be done via wifi or 3G.
snapper.fishes is offline  
Reply With Quote
Old July 22nd, 2011, 05:33 AM   #58 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had two problems with USB connection

1. USB connection not detected by the phone- I cleaned microUSB connector of phone using alcohol and toothbrush 3-4 times after some gap. This removed the corrosion of microUSB port pins and the phone sharted detecting USB cooncetion as well got detcted properly by Windows Vista as "Samsung Composite device" (and not as unknown device). At this point Galaxy S started getting recgnised and mouted and USB drive in " mass storage mode". Thanks to this forum which mentios microUSB corrosion in several posts.

2. However, Still Kies was not able to make connection to phone in "kies mode". The "connectiing" icon use to keep rotating endlessly". After 3 hours of troubleshooting including reinstall, reinstall drivers, removing files with log file name extensions, I found that Windows defender (antimalware protection) service was slowing the detection of the phone. I went to control panel -> classic view-> windows defender and disabled the real time scan and rebooted. This resolved the issue.
Please check if Windows defender or any other realtime antivirus protection is causing the malfunction.
with best wishes,
Rajesh.
Rajesh Desai is offline  
Reply With Quote
Old August 23rd, 2011, 12:37 AM   #59 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 1
 
Device(s): Samsung Galaxy S, BlackBerry Curve 9300
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to eezaortile
Default

Thank you ogami_ito for starting such a useful thread. I just really wanted to share how I got over the stupid glitch because I was really at wits end trying to figure out why my phone wouldn't even connect to my computer. Some of the readers who happen to stumble upon this might find it useful.

1. Uninstalled Samsung Kies. I was told by a friend to uninstall the latest version I have and instead of updating the software through the Samsung Kies itself, download the latest version and install that. (I'm not really sure how much this contributed to my success, but hey it was worth a try).

2. Connected Galaxy S in Samsung Kies mode and uninstalled the MTP device drivers through Device Manager. Closed Kies, and reconnected phone. (Nothing really happened at this point. I still got the same error -- saw a bright yellow splat on the device in Device Manager still).

3. Downloaded Windows Mobile Device Center. I figured this would maybe download some drivers that my device would need to connect it to my computer. I'm not sure how much this step helped though because the phone still refused to connect to Kies.

3. Unmounted the internal SD card then connected device in Samsung Kies mode. I saw a considerable difference here. The screen on the device itself stopped flickering. I noticed that when I first started all this, it would say "Initialising" on the device and "Connecting" on Samsung Kies. It would then sort of flicker or refresh, then go to the same screen. At this point, after doing this step, the device stopped doing it. I was really hopeful that it'd connect to Samsung Kies, which it unfortunately didn't. Which led me to:

4. Connect Galaxy S in Mass Storage device mode, copy all files from internal SD card. Unmount internal SD card, wait 5 seconds, format internal SD card. (My heart fell when I had to do this step because it's one of the things that I knew I had to consider, but was hoping I wouldn't have to do).

I put the device back into Samsung Kies mode, opened Samsung Kies on the computer and connected the device. IT FINALLY WORKED.

I've had this phone since February and I haven't really considered upgrading it because it catered to whatever needs I had at that moment. So this is really a refreshing change. I was aiming for Froyo but am happily tinkering with my new Gingerbread device. Hope you guys find your happily ever after too!
eezaortile is offline  
Reply With Quote
Old August 25th, 2011, 12:35 AM   #60 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

I've deleted the files with more than 16 character extensions but Kies still won't connect to the phone. It says 'this device is not supported by Kies 2.0'. Any solution for this please ?

I'm just trying to updrage to the latest version of Android. That's all that I really need Kies for. Thanks in advance !
AlgHuh is offline  
Reply With Quote
sponsored links
Old August 28th, 2011, 09:48 PM   #61 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Updated to FROYO - now Mac freezes

about 2 months ago I used a friends PC to update the firmware on my SGS Captivate to 2.2 Froyo.

Now, I cannot connect to Mac through the USB.

-- It recognizes it just fine, I go in through DEBUG mode, it mounts and all that...I can see every file (FOLDER) on my phone.
As soon as I click on one of those folders ie. "Camera" (I mostly just want my pics off there) I get the Mac beachball and can't do anything. Turn off the phone, comp still the same until manual shut down.

Is FROYO THAT incompatible with Mac?

Help me please - I have found 12 other ways to transfer files, but none as convenient or fast (obviously) as straight up USB.

super frustrated.
streetsays is offline  
Reply With Quote
Old September 12th, 2011, 12:23 PM   #62 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Simply stated, my USB to PC cable was removed from the phone while connected to the PC with mass storage enabled and the USB connected via the notification drop down for the connection. Then it wouldn't connect completely, meaning that it beeped but was not available in Computer. Attempting USB tethering the phone told me that "no USB device is connected" even though I could access the SD card. Debug mode did not help.

I also am unable to connect to any wireless network that worked before.

While trying several options to fix this I tried to install PdaNetA302x64. First it installed the proper working drivers but then it quit on me saying that it couldn't handshake.

I am running Win 7 Ultimate 64-bit with no additional connection software or Samsung drivers (worked fine before my gaff).

I am still able to connect via USB and access the SD card. What I want to be able to do is enable USB tethering to use the internet access on a PC with no wireless available. A wireless adapter is a quick fix, but I can't connect wirelessly anymore. Phone has 2.2.2 OTA update.

Will a factory reset fix this? My gf is afraid that she will lose her data, etc. that is on the phone if I reset it for about the 5th time (flaked out phone, erroneous screen captures, vibrations, etc. Also our 3rd refurbished galaxy sd). She won't let me do it until I get more info.

Short of doing it anyway, does anyone have any good ideas or answers.

Also, no need to post things like "I did it just fine ha ha".
bigredox is offline  
Reply With Quote
Old September 30th, 2011, 07:01 AM   #63 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default USB connection problems - another possibility.

I have discovered when using my Galaxy S and Kies that not all USB to micro USB leads will work despite them appearing to.

My Samsung original USB lead works all the time with Kies on all PCs (XP and Win7) however I have two other leads for using the phone elsewhere and have discovered the following.

One works as well as the Samsung original with no problems, however the other, whilst allowing the phone to charge via the USB port and also prompting Kies to indicate "Connecting" never lets connection complete.

The simplest check I have found for seeing if a cable is suitable is if, on connection to the PC / Galaxy S before (or during) the Kies flash screen showing, whether you get the Windows "What operation do you wish to do?" window popping up.

If this pop up window does appear then your cable will work with Kies; if the window doesn't appear then despite Kies saying it is connecting, it will never do so.

Hopefully this might help some people.

Masterice
masterice is offline  
Reply With Quote
Old October 2nd, 2011, 09:22 AM   #64 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was having a huge problem with my USB that came with my phone and found the connection to the phone wasn't as secure fitting. I ended up using a Blackberry USB and it worked.
daveyboy2 is offline  
Reply With Quote
Old October 6th, 2011, 03:37 AM   #65 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 9
 
Device(s): Samsung Galaxy Ace S5830
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

My galaxy ace unable to connect to pc - installed Kies c/w phone..
after re-install updated version Kies (Sept 2011), it works without any problem. I have discovered that driver/os caused the problem..



Samsung Galaxy Tips & Tricks
----------------------------
http://samsung-galaxy-accessories.blogspot.com
enrich2u is offline  
Reply With Quote
Old November 4th, 2011, 12:35 PM   #66 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Is this issue of USB connections issues just with regard to Windows XP? I have a Samsung Galaxy S, sync it with a Windows 7 PC and I have not experienced any of these issues.

I installed Kies on my PC. Frankly, I'm not too worried how much space the Kies programme takes up on my Harddrive. I tried to use the Galaxy as a Mass Storage device for transferring music and it was horrible: It sounded like listening to a song down a tin pipe. Only when I transferred the music files via Kies did they sound as good as they should. I have a programme called eWallet to store passwords, user names and private information and I can only sync the file in the Android version of the programme on the Galaxy to the Desktop version by changing the USB settings from Kies to Mass Storage.

I have read a bit of the thread above and I have only seen the mention of issues with XP. I may be that issues do not exist with Windows 7.
DaggaDraad is offline  
Last edited by DaggaDraad; November 4th, 2011 at 12:38 PM. Reason: Just to further my point.
Reply With Quote
Old December 18th, 2011, 08:54 PM   #67 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default texting from computer

Can anyone tell me if there is an app or anything that allows me to get sms notifications on my computer when i have the usb plugged up.
jblu069 is offline  
Reply With Quote
Old December 27th, 2011, 09:14 PM   #68 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Help!

Help! I bought a USB connector today for my Samsung galaxy touch screen cell because I want to upload a few files/images from my cell onto my computer, but whenever I connect the cable to my computer a message on my phone pops-up saying "bluetooth dial up networking or serial port cannot be used at the same time as USB connection" what does it mean and how can I peacefully upload my photo's! HELP please?
simabkhan is offline  
Reply With Quote
Old January 13th, 2012, 10:13 AM   #69 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 31
 
Device(s): Galaxy S Gingerbread- rooted
Carrier: ATT

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by simabkhan View Post
Help! I bought a USB connector today for my Samsung galaxy touch screen cell because I want to upload a few files/images from my cell onto my computer, but whenever I connect the cable to my computer a message on my phone pops-up saying "bluetooth dial up networking or serial port cannot be used at the same time as USB connection" what does it mean and how can I peacefully upload my photo's! HELP please?
Check the wifi and the Bluetooth, try with those off.
jc1843 is offline  
Reply With Quote
Old April 1st, 2012, 07:30 AM   #70 (permalink)
Senior Member
 
Join Date: Sep 2010
Posts: 547
 
Device(s): HTC One
Carrier: EE-Orange

Thanks: 97
Thanked 11 Times in 11 Posts
Default

any help on updating the software through kies it jsut says device not supported but it is connected to the phone
gabbyevs is offline  
Reply With Quote
sponsored links
Old May 5th, 2012, 03:18 PM   #71 (permalink)
New Member
 
Join Date: May 2012
Location: Buckinghamshire, UK
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to jj63
Default

I have tried everything listed and my phone will still not connect via usb. Nothing works! Downloaded Odin...no result. Kies is a piece of garbage. Done everything possible and can't get anything to recognise the usb connection.

Going back to Nokia if I don't get a result soon. Cant say my Android experience has been pleasant at all. Could be a Samsung issue, who knows. But, after weeks of trying and constantly having to factory reset my handset, I really give up.
jj63 is offline  
Last edited by jj63; May 5th, 2012 at 03:33 PM.
Reply With Quote
Old May 16th, 2012, 03:06 PM   #72 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi does anyone know how to get a computer running windows xp proffesional to use my phone via usb tethering?
samsungman2012 is offline  
Reply With Quote
Old May 16th, 2012, 03:08 PM   #73 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Tongue

Quote:
Originally Posted by jj63 View Post
I have tried everything listed and my phone will still not connect via usb. Nothing works! Downloaded Odin...no result. Kies is a piece of garbage. Done everything possible and can't get anything to recognise the usb connection.

Going back to Nokia if I don't get a result soon. Cant say my Android experience has been pleasant at all. Could be a Samsung issue, who knows. But, after weeks of trying and constantly having to factory reset my handset, I really give up.

im sure if, depending on what your computer is running, try and find the drivers for the usb via the microsoft website
samsungman2012 is offline  
Reply With Quote
Old August 9th, 2012, 12:54 PM   #74 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This forum seems to be primarily focused on PC issues, but I'm having connection issues with my Mac. I'll throw it out there in case anyone can help.

I have never had any issues connecting via USB until recently. Now, I can connect fine according to my phone, but can't find the phone on my computer, neither on the desktop nor in a finder window.

Any ideas?
StevenML is offline  
Reply With Quote
Old September 7th, 2012, 07:27 AM   #75 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 8
 
Device(s): Samsung Galaxy S FW Ver: 2.3.3 Baseband Ver: I9000DDJV5 Kernel: 2.6.35.7 Build: GINGERBREAD.DDJV
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I read through this post, but I'm not sure of my problem had a solution in there.

I have a Galaxy S (GT-I9000/2.3.3 FW/Build: GINGERBREAD.DDJV9). My laptop is IBM running XP Proff.

I use My Phone Explorer over USB to sync to Corporate Exchange etc - worked like a charm till yesterday (for over 2 yrs) - on the same laptop - same USB port.

All of a sudden since the morning it's stopped working. The phone charges, but MPE gives me an error "Connection to phone could not be established. No device attached to USB". I tried other USB ports on the laptop - same problem - just that the phone would keep beeping continuously as if something was wrong. (It always beeps once when connected to the laptop). The laptop also shows a USB icon on the system try and when I double-click on it, the error message is "Unknown Device on USB root Hub". The device manager on the laptop also shows the same description about the USB port that the phone is connected to.

I connected a wireless mouse on the USB ports and everything works - so I'm assuming my USB ports are fine.

I've tried restarting the phone & laptop - No luck.
Checked and unchecked the "USB Debugging mode" on the phone - No luck.
Tried blowing air to all ports - phone, cable & laptop - no luck.

I don't know what else to try. I read somewhere about trying to edit the registry Local Machine/Mounted devices etc - but haven't tried it coz it doen't show the U.S.B.S.T.O.R.A.G.E key entry.

I have KIES as well on the laptop - same problem. Won't work.

Any help/ideas on next steps would be greatly appreciated. I live by the calendar on my phone for meetings/tasks etc .. and it's driving me crazy coz now I have to memorize meetings/tasks etc....

Thanks !
mukerjichinmoy is offline  
Reply With Quote
Old September 9th, 2012, 02:48 PM   #76 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hy, if I posted in wrong section, please forgive.
I have an i9000XXJVS with Gingerbread 2.3.5 frimware.
USB controller is broke. Can I root this phone for unlocking network on whitout cable?
Thanks,
Ovidiu
ovidiucro is offline  
Reply With Quote
Old October 7th, 2012, 11:55 AM   #77 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey there!


I have just updated my phone and I'm having this connectivity issue.

I don't have any option to set the phone to ask me when connect it using USB.
When I connect it to the PC and the option for Debugging is on, I'm able to use my phone as Mass Storage, but if the option for Debugging is unchecked when connect it's going automatically in MTP Samsung Kies mode...

How to make the phone to ask me when connect USB?

And I have another bug that my camera has lost touch to focus option. It's auto focusing when pressed shoot button. How to enable the option again?

I just saw that I don't have turning off sound. How to reenable it?
kracho is offline  
Last edited by kracho; October 7th, 2012 at 12:25 PM.
Reply With Quote
Old June 9th, 2013, 02:03 AM   #78 (permalink)
New Member
 
Join Date: Jun 2013
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have update my Galaxy I9000 to Slim Bean 4.22 build 6, however when connecting via usb, I get a message usb not recognized. Any ideas to fix this. Have tried downloading drivers etc..
utampannu is offline  
Reply With Quote
Reply

Samsung Galaxy S
Current Rating:
Rate this Phone:

The Samsung Galaxy S was announced in March of 2010 was a high-end feature packed phone during its day. This was the start of Samsung's global takeover and although this particular phone saw many iterations and variants here in the state and ov... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:57 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.