Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (Boost Mobile)

test: Reply
 
LinkBack Thread Tools
Old October 14th, 2012, 06:29 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: May 2012
Posts: 54
 
Device(s):
Carrier: Not Provided

Thanks: 5
Thanked 0 Times in 0 Posts
Default has anyone been experiencing any bugs with the ICS OS

HI everyone

I'm thinking of getting the galaxy s2 on boost but not sure what to do....
I believe that ICS is flawed..can I get some feedback on this phone...

Advertisements
smartphone45 is offline  
Reply With Quote
sponsored links
Old October 14th, 2012, 08:29 PM   #2 (permalink)
Senior Member
 
Codegerm's Avatar
 
Join Date: Jul 2011
Location: Gainesville, FL
Gender: Male
Posts: 3,733
 
Device(s): Samsung Galaxy S II Running Jelly Bean GB27 32gig class 10 sd card
Carrier: Not Provided

Thanks: 181
Thanked 1,256 Times in 936 Posts
Default

I am not having problems with it, and am enjoying the phone a lot. You can always root it and put a different ROM on it. The phone is the same as an Samsung epic 4g touch. So it will use any ROM that phone does.

Codegerm
Codegerm is offline  
Reply With Quote
Old October 14th, 2012, 09:01 PM   #3 (permalink)
AF Contributor
 
Join Date: Jul 2011
Location: Chicago, IL
Posts: 1,244
 
Device(s): SGS2- GB08, Samsung Prevail- CTMod 3.75
Carrier: Not Provided

Thanks: 154
Thanked 278 Times in 167 Posts
Default

Boost S2 stock ICS was flawless for me, very smooth.
kevincott is offline  
Reply With Quote
Old October 15th, 2012, 12:26 PM   #4 (permalink)
Junior Member
 
Join Date: Aug 2012
Posts: 30
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 4 Times in 4 Posts
Default

My samsung galaxy S2 isn't rooted and works like a charm...it's worth the $$$ I spent
traciefly is offline  
Reply With Quote
Old October 15th, 2012, 03:24 PM   #5 (permalink)
Senior Member
 
kevindroid's Avatar
 
Join Date: Oct 2010
Location: baltimore
Gender: Male
Posts: 923
 
Device(s): htc one m8/nexus 5/nexus 7 v2
Carrier: t-mobile

Thanks: 226
Thanked 226 Times in 189 Posts
Default

the update that was pushed to the sprint version has the flaws you refer to the boost version came factory installed. i have not had the problems sprint users speak of
kevindroid is online now  
Reply With Quote
Old October 15th, 2012, 04:23 PM   #6 (permalink)
Senior Member
 
Codegerm's Avatar
 
Join Date: Jul 2011
Location: Gainesville, FL
Gender: Male
Posts: 3,733
 
Device(s): Samsung Galaxy S II Running Jelly Bean GB27 32gig class 10 sd card
Carrier: Not Provided

Thanks: 181
Thanked 1,256 Times in 936 Posts
Default

True, plus I also know that not all GS2 phones even though the model number may be the same have all the same chips (supply of chips during manufacturing runs often causes this), as evidenced by running the eMMC brick bug check, some phones will have the eMMC chip that along with the firmware can cause the brick problem, and some do not.

Codegerm
Codegerm is offline  
Reply With Quote
Old October 16th, 2012, 09:29 AM   #7 (permalink)
Member
 
Join Date: Jul 2011
Posts: 153
 
Device(s):
Carrier: Not Provided

Thanks: 16
Thanked 5 Times in 5 Posts
Default

mine have hanged twice and shut down on me with battery drain. in about 3 weeks. Not rooted. everything original : (
janathan is offline  
Reply With Quote
Old October 16th, 2012, 12:01 PM   #8 (permalink)
Senior Member
 
Codegerm's Avatar
 
Join Date: Jul 2011
Location: Gainesville, FL
Gender: Male
Posts: 3,733
 
Device(s): Samsung Galaxy S II Running Jelly Bean GB27 32gig class 10 sd card
Carrier: Not Provided

Thanks: 181
Thanked 1,256 Times in 936 Posts
Default

Quote:
Originally Posted by janathan View Post
mine have hanged twice and shut down on me with battery drain. in about 3 weeks. Not rooted. everything original : (

have you gotten the update? Look in settings and about phone and let us know what you are running?

Codegerm
Codegerm is offline  
Reply With Quote
Old October 28th, 2012, 05:36 PM   #9 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Notsure

I am also running 4.0.4 not rooted or anything, just got phone a week ago. And my phone has shut off on me about 3 times. Any possibile reasons or solutions??
kmarie450 is offline  
Reply With Quote
Old October 28th, 2012, 06:26 PM   #10 (permalink)
AF Contributor
 
Join Date: Jul 2011
Location: Chicago, IL
Posts: 1,244
 
Device(s): SGS2- GB08, Samsung Prevail- CTMod 3.75
Carrier: Not Provided

Thanks: 154
Thanked 278 Times in 167 Posts
Default

Quote:
Originally Posted by kmarie450 View Post
I am also running 4.0.4 not rooted or anything, just got phone a week ago. And my phone has shut off on me about 3 times. Any possibile reasons or solutions??
Happened to me when I first got my S2, had me worried.

Last month or so I have had no issues.
kevincott is offline  
Reply With Quote
sponsored links
Old October 29th, 2012, 01:48 AM   #11 (permalink)
Junior Member
 
Join Date: Dec 2010
Location: Southern Cali
Posts: 23
 
Device(s): Samsung Galaxy S2 Epic Touch 4G
Carrier: Boost Mobile

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by kmarie450 View Post
I am also running 4.0.4 not rooted or anything, just got phone a week ago. And my phone has shut off on me about 3 times. Any possibile reasons or solutions??

this has also happened to me from time to time
Since the FI22 update, it has not happened at all..the only thing that continues to happen is sometimes I receive force closure errors with certain apps...
johnbobie is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (Boost Mobile)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:16 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.