Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (International)

Like Tree3Likes

test: Reply
 
LinkBack Thread Tools
Old May 9th, 2011, 06:50 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: May 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default S2 keeps rebooting

Hi,

just want to if anyone S2 doing the same thing like mine.

I have the S2 for 3 days now and just now and yesterday the phone just shut itself down and restart again. I think it happened 3 times in two days. So, I want ask if anyone experiencing the same thing and should I return the phone and get a new one?

Cheers

Advertisements
Kingdan is offline  
Reply With Quote
sponsored links
Old May 9th, 2011, 08:05 PM   #2 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: Auckland, New Zealand
Posts: 1,824
 
Device(s): Galaxy S, HTC Desire
Carrier: Not Provided

Thanks: 112
Thanked 771 Times in 407 Posts
Default

Doesn't sound right...

Can you trace back to an app you've installed maybe?
__________________
Blogs: androidNZ.net and blog.clove.co.uk
Twitter: @NZtechfreak Facebook: http://goo.gl/baZHQ
Galaxy Note Mega Review: http://goo.gl/Lnoe9
Galaxy SIII Review Part 1 & 2: http://goo.gl/8GCHG & http://goo.gl/gDYkA
Galaxy SIII & Nexus 7 Root guides: http://goo.gl/DMN5v & http://goo.gl/pQbUB
NZtechfreak is offline  
Reply With Quote
Old May 10th, 2011, 02:52 AM   #3 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

I've just had something similar where the operator welcome screen came up out of nowhere. However checked the uptime and it has not reset?
stokesd3 is offline  
Reply With Quote
Old May 10th, 2011, 03:01 AM   #4 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have had the same issue. Got the phone on Thursday and has rebooted randomly approx once a day. I think it did it last night, you can tell by looking at the battery usage graph...there is a big drop when it restarts plus the time on battery does not match the actual time it has been on.
I've been advised to factory reset the phone and see if it disappears.
NuckinFutz is offline  
Reply With Quote
Old May 10th, 2011, 03:16 AM   #5 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Only got it a few days ago so don't think a factory reset will help. I'll basically be back to square one once I've got the apps on again

For anyone that has the same issue, have you checked the uptime in settings...about phone. Only say that because need a distinction between reboot and the splash screen coming up.
stokesd3 is offline  
Reply With Quote
Old May 10th, 2011, 06:21 AM   #6 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've reset it today so I'll see how it goes. I'll report back here.
NuckinFutz is offline  
Reply With Quote
Old May 13th, 2011, 02:14 AM   #7 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

So far so good, hasn't restarted as yet - touch wood.
NuckinFutz is offline  
Reply With Quote
Old May 13th, 2011, 02:55 PM   #8 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Haven't seen it again myself either (unless of course it did it in silent mode when I wasn't looking!). At least this doesn't look like a daily issue
stokesd3 is offline  
Reply With Quote
Old May 16th, 2011, 04:07 AM   #9 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's back! Done it twice in the last couple of days. Have seen some other people having the same issue, think I may have to return the unit.
NuckinFutz is offline  
Reply With Quote
Old May 16th, 2011, 04:14 AM   #10 (permalink)
Member
 
Join Date: Jan 2010
Posts: 197
 
Device(s):
Carrier: Not Provided

Thanks: 40
Thanked 6 Times in 6 Posts
Default

are you using a task/memory killer?
maybe one of these apps are set to auto kill the OS service (or similar), hence the restart.
tauran121 is offline  
Reply With Quote
sponsored links
Old May 16th, 2011, 04:19 AM   #11 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

No I don't. I have kept apps to a minimum to try and resolve the issue.
NuckinFutz is offline  
Reply With Quote
Old May 22nd, 2011, 12:09 PM   #12 (permalink)
Junior Member
 
Join Date: Sep 2010
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

this is strange i have a Galaxy s and just updated to 2.3.3 gingerbread and that has started to the same trick and it's not a app as i have the same apps as i had before
Northerndj is offline  
Last edited by Northerndj; May 22nd, 2011 at 12:22 PM.
Reply With Quote
Old May 22nd, 2011, 02:10 PM   #13 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: UK
Posts: 1,020
 
Device(s): OnePlus One on 3 - UK
Carrier: Not Provided

Thanks: 62
Thanked 120 Times in 86 Posts
Default

mines turned off a few times for no reason - doesnt restart though
bonerp is online now  
Reply With Quote
Old May 25th, 2011, 06:01 AM   #14 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 85
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 9 Posts
Default S2 keeps rebooting

It's not a constant problem, but at least every three or four days my new S2 (unbranded, sim free, from CPW, on KE2) suddenly reboots. It does it quite quickly, and occasionally two or three times in an hour or so.

Has anyone else experienced this? I love the phone, it's the beast the SGS should have ben in the first place, but the random reboots are irritating.
Lol mahmood is offline  
Reply With Quote
Old May 25th, 2011, 06:13 AM   #15 (permalink)
Member
 
xmjox's Avatar
 
Join Date: May 2011
Location: Bournemouth, UK
Posts: 186
 
Device(s): Samsung Galaxy S II
Carrier: Not Provided

Thanks: 25
Thanked 15 Times in 14 Posts
Default

I've had my SGS2 for 7 days now and it has never rebooted itself on me. Sounds like it's a problem with your handset...
xmjox is offline  
Reply With Quote
Old May 26th, 2011, 01:37 AM   #16 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Mine did it again last night. Anyone any idea of the best way to help localise the issue? Doesn't seem to be a pattern.
stokesd3 is offline  
Reply With Quote
Old May 26th, 2011, 12:17 PM   #17 (permalink)
New Member
 
Join Date: May 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

my galaxy s 2 resets when shaken
dancouto is offline  
Reply With Quote
The Following User Says Thank You to dancouto For This Useful Post:
charlinsky (December 21st, 2011)
Old May 26th, 2011, 02:36 PM   #18 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 84
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 7 Posts
Default

just to give you guys heads up, I've had my SGS2 for a week now and not a single reset.. I'm running KE7 and rooted... a handful of apps... Never had a crash (apart from trying to run Dungeon Defenders but that crashes on every SGS2, still, it was a ctd, not a restart).
eclap is offline  
Reply With Quote
Old May 26th, 2011, 03:10 PM   #19 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: UK
Posts: 1,020
 
Device(s): OnePlus One on 3 - UK
Carrier: Not Provided

Thanks: 62
Thanked 120 Times in 86 Posts
Default

Mine did it twice more just yesterday where the screen just locks and can't restart it easily, so swapped it for a new one at CPW. No problems with them at all and very helpful. New one has all the latest upgrades on so it must be a new build.

No problems today. Also headphone socket is ok on this one.
bonerp is online now  
Reply With Quote
Old May 26th, 2011, 03:20 PM   #20 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

Quote:
Originally Posted by bonerp View Post
Mine did it twice more just yesterday where the screen just locks and can't restart it easily, so swapped it for a new one at CPW. No problems with them at all and very helpful. New one has all the latest upgrades on so it must be a new build.

No problems today. Also headphone socket is ok on this one.
what was wrong with your headphone socket before?
__________________
Galaxy Nexus i9250 unlocked and rooted
mrvirginia is offline  
Reply With Quote
sponsored links
Old May 26th, 2011, 03:27 PM   #21 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: UK
Posts: 1,020
 
Device(s): OnePlus One on 3 - UK
Carrier: Not Provided

Thanks: 62
Thanked 120 Times in 86 Posts
Default

caused crackles through the headphones. Would only get worse - seen a few people with same issue.

Someone mentioned Samsung has great quality control...they clearly dont have many Samsung products....Samsung are a long way from perfect.
bonerp is online now  
Reply With Quote
Old May 26th, 2011, 03:34 PM   #22 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 84
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by bonerp View Post
caused crackles through the headphones. Would only get worse - seen a few people with same issue.

Someone mentioned Samsung has great quality control...they clearly dont have many Samsung products....Samsung are a long way from perfect.
yeah, but so is everyone else...
eclap is offline  
Reply With Quote
Old May 26th, 2011, 03:37 PM   #23 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: UK
Posts: 1,020
 
Device(s): OnePlus One on 3 - UK
Carrier: Not Provided

Thanks: 62
Thanked 120 Times in 86 Posts
Default

Quote:
Originally Posted by eclap View Post
yeah, but so is everyone else...
not wrong there
bonerp is online now  
Reply With Quote
Old May 26th, 2011, 04:01 PM   #24 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

Quote:
Originally Posted by bonerp View Post
caused crackles through the headphones. Would only get worse - seen a few people with same issue.

Someone mentioned Samsung has great quality control...they clearly dont have many Samsung products....Samsung are a long way from perfect.
meh. it may have been me lol
i've owned 3 Samsung tvs and never had issues with either except when two of them were shipped one was broken (screen) and the other got a thick vertical line down the left side after a week. i blame this on shipping companies not being careful, though. tbh, only Samsung products i think i've owned...

iunno, here's to hoping i have no issues!
thanks for the reply on the headphone jack. will definitely check it.
mrvirginia is offline  
Reply With Quote
Old May 27th, 2011, 04:33 AM   #25 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 85
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by Kingdan View Post
Hi,

just want to if anyone S2 doing the same thing like mine.

I have the S2 for 3 days now and just now and yesterday the phone just shut itself down and restart again. I think it happened 3 times in two days. So, I want ask if anyone experiencing the same thing and should I return the phone and get a new one?

Cheers
Mine's been doing the same. Just upgraded firmware to KE7; crossed fingers that'll solve the problem.
Lol mahmood is offline  
Reply With Quote
Old June 1st, 2011, 05:40 AM   #26 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Lol mahmood View Post
Mine's been doing the same. Just upgraded firmware to KE7; crossed fingers that'll solve the problem.
How is the KE7 working for you? I live in Sweden and need it for the same reason and I really hope it will solve the rebooting problem. But as you understand the upgrade is not yet released here. Anyone heard when it will be available for everyone?
aggeyee is offline  
Reply With Quote
Old June 1st, 2011, 11:04 AM   #27 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 85
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 9 Posts
Default

Had it on KE7 for several days now and only one random reboot, and that was when I was absolutely caning the processor, doing about 5 things at once (including downloading, online, moving a large file in My Files, etc.). Don't think battery life is any better, though.
Lol mahmood is offline  
Reply With Quote
Old June 1st, 2011, 11:08 AM   #28 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 85
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by Lol mahmood View Post
Had it on KE7 for several days now and only one random reboot, and that was when I was absolutely caning the processor, doing about 5 things at once (including downloading, online, moving a large file in My Files, etc.). Don't think battery life is any better, though.
Oh yeah, calendar has stopped working! All my appointments are still there online, and on my Galaxy Tab calendar, but the SGS2 calendar (for the same gmail account) is now empty!
Lol mahmood is offline  
Reply With Quote
Old June 1st, 2011, 07:04 PM   #29 (permalink)
Member
 
garment69's Avatar
 
Join Date: Jan 2010
Posts: 271
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 31 Times in 24 Posts
Default

I have had the GS2 for about a week. I have not made it through a day without having to pull the battery becuase it froze. Today, I had my first random reboot.

so torn, becuase I swear, this is the greatest phone I have ever used.
garment69 is offline  
Reply With Quote
Old June 2nd, 2011, 12:12 PM   #30 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by garment69 View Post
I have had the GS2 for about a week. I have not made it through a day without having to pull the battery becuase it froze. Today, I had my first random reboot.

so torn, becuase I swear, this is the greatest phone I have ever used.
Would suggest a factory reset for this and check the firmware via Kies. I personally have the odd problem but it ain't that bad. Can you narrow it down to any particular app you may be running?
stokesd3 is offline  
Reply With Quote
sponsored links
Old June 2nd, 2011, 12:13 PM   #31 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Lol mahmood View Post
Oh yeah, calendar has stopped working! All my appointments are still there online, and on my Galaxy Tab calendar, but the SGS2 calendar (for the same gmail account) is now empty!
Have you tried clearing the calendar cache and then resyncing? Fixed previous issues I was having.
stokesd3 is offline  
Reply With Quote
Old June 2nd, 2011, 04:55 PM   #32 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default possible SD card problem?

I read this from another forum, that it might have something to do with a corrupted SD card - music stored on it or apps being moved to it. Not sure but worth a read:
[Q] Galaxy S2 spontaneously rebooting - xda-developers
ShreddedDiesel is offline  
Reply With Quote
Old June 4th, 2011, 06:29 AM   #33 (permalink)
Junior Member
 
elektrobix's Avatar
 
Join Date: Oct 2009
Location: UK
Posts: 98
 
Device(s): HTC Hero, Motorola Milestone, Samsung Galaxy S2
Carrier: Not Provided

Thanks: 6
Thanked 13 Times in 5 Posts
Default

I've also started having this problem. The phone was fine for the first two weeks and then out of nowhere it started restarting. I've made no changes to the phone for over a week, installed no new apps, it's running the latest firmware. No idea what is is?
elektrobix is offline  
Reply With Quote
Old June 4th, 2011, 06:35 AM   #34 (permalink)
Member
 
Join Date: Apr 2011
Location: australia
Posts: 301
 
Device(s): -SGS2- one and only. 5800 Xpress = now used for an alarm clock! lolz
Carrier: Not Provided

Thanks: 34
Thanked 89 Times in 31 Posts
Default

according to the XDA forums, an SD card can sometimes be the issue, but otherwise it seems to be a ram issue i think. but dont take this as the answer.
loony is offline  
Reply With Quote
Old June 4th, 2011, 05:50 PM   #35 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Posted the issue here Issue 17365 - android - OS rebooting on Android 2.3.3 - Android - An Open Handset Alliance Project - Google Project Hosting and submitted my log file from the time. Response was

too many local references in the USB native code:

06-03 09:56:41.654 D/Usbhost (2692)usb_host_run :: new device /dev/bus/usb/001/001
06-03 09:56:41.654 D/UsbServiceJNI(2692)usb_device_added ::
06-03 09:56:41.654 D/Usbhost (2692)usb_device_open :: /dev/bus/usb/001/001
06-03 09:56:41.654 D/Usbhost (2692)usb_device_new :: /dev/bus/usb/001/001 fd: 182
06-03 09:56:41.654 D/Usbhost (2692)usb_device_new :: read returned 43 errno 4
06-03 09:56:41.660 W/dalvikvm(2692)ReferenceTable overflow (max=1024)
06-03 09:56:41.660 W/dalvikvm(2692)Last 10 entries in JNI local reference table:
06-03 09:56:41.660 W/dalvikvm(2692)1014: 0x40a2d5c0 cls=Ljava/lang/String; (28 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1015: 0x4097a170 cls=Ljava/lang/String; (36 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1016: 0x408cf358 cls=[I (36 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1017: 0x408cf380 cls=[I (36 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1018: 0x408de270 cls=Ljava/lang/String; (28 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1019: 0x409700f8 cls=[I (180 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1020: 0x40bcad40 cls=[I (212 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1021: 0x405a9388 cls=Ljava/lang/String; (36 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1022: 0x40b4ff98 cls=Ljava/lang/String; (28 bytes)
06-03 09:56:41.660 W/dalvikvm(2692)1023: 0x4099d2d0 cls=Ljava/lang/String; (36 bytes)
06-03 09:56:41.670 W/dalvikvm(2692)JNI local reference table summary (1024 entries):
06-03 09:56:41.670 W/dalvikvm(2692)461 of Ljava/lang/String; 28B (461 unique)
06-03 09:56:41.670 W/dalvikvm(2692)51 of Ljava/lang/String; 36B (51 unique)
06-03 09:56:41.670 W/dalvikvm(2692)248 of [I 36B (248 unique)
06-03 09:56:41.670 W/dalvikvm(2692)8 of [I 44B (8 unique)
06-03 09:56:41.670 W/dalvikvm(2692)61 of [I 60B (61 unique)
06-03 09:56:41.670 W/dalvikvm(2692)57 of [I 68B (57 unique)
06-03 09:56:41.670 W/dalvikvm(2692)10 of [I 76B (10 unique)
06-03 09:56:41.670 W/dalvikvm(2692)63 of [I 180B (63 unique)
06-03 09:56:41.670 W/dalvikvm(2692)1 of [I 188B
06-03 09:56:41.670 W/dalvikvm(2692)64 of [I 212B (64 unique)
06-03 09:56:41.670 W/dalvikvm(2692)Memory held directly by tracked refs is 57416 bytes
06-03 09:56:41.670 E/dalvikvm(2692)Failed adding to JNI local ref table (has 1024 entries)
06-03 09:56:41.670 I/dalvikvm(2692)"UsbService host thread" prio=5 tid=46 RUNNABLE
06-03 09:56:41.670 I/dalvikvm(2692)| group="main" sCount=0 dsCount=0 obj=0x408e7ed0 self=0x212d10
06-03 09:56:41.670 I/dalvikvm(2692)| sysTid=2813 nice=0 sched=0/0 cgrp=default handle=1917160
06-03 09:56:41.670 I/dalvikvm(2692)| schedstat=( 865486887 29969830513 4579 )
06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService.monitorUsbHostBus(Na tive Method)
06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService.access$700(UsbServic e.java:63)
06-03 09:56:41.680 I/dalvikvm(2692)at com.android.server.UsbService$2.run(UsbService.jav a:600)
06-03 09:56:41.680 I/dalvikvm(2692)at java.lang.Thread.run(Thread.java:1019)
06-03 09:56:41.680 I/dalvikvm(2692)
06-03 09:56:41.680 E/dalvikvm(2692)VM aborting

I have no idea what this means though! Note I have had the issue with and without the SD card inserted and my USB port was not being used at the time.
stokesd3 is offline  
Reply With Quote
Old June 4th, 2011, 10:32 PM   #36 (permalink)
Member
 
Join Date: Apr 2011
Location: australia
Posts: 301
 
Device(s): -SGS2- one and only. 5800 Xpress = now used for an alarm clock! lolz
Carrier: Not Provided

Thanks: 34
Thanked 89 Times in 31 Posts
Default

at com.android.server.UsbService.access$700

wtf does that mean!! lol
loony is offline  
Reply With Quote
Old June 9th, 2011, 04:39 PM   #37 (permalink)
New Member
 
Join Date: Jun 2011
Location: Gloucestershire, England
Posts: 2
 
Device(s): HTC HD2, Motorola Xoom, Samsung Galaxy S II
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Wink Resetting and freezing problem fix

Hi people,
I'm fairly sure I've figured this out and come up with an easy fix
First the cause:
Poor fitting battery, made worse by a badly designed micro-SD slot position.
When you have an SD-card fitted this can push the battery away from its contacts. I found my battery had about 0.5 mm of movement up and down. Every time my phone reset it was when it was in my pocket and subject to movement.
Riding my bike to or from work.

The fix:
Lovely and simple just place a bit of paper placed under the bottom of the battery to push it up towards the battery contacts.
I used a UK lotto ticket (loosing one) it was just the right thickness to stop the movement. (Tesco till receipts work just as well.) Tear your lotto ticket in half then half again, wrap your quarter ticket over the bottom edge of the battery, push the battery into the phone and check for movement. You may have to double up, I found just one layer was enough to stop the vertical movement.
fit the cover and turn on your phone.

Enjoy.
0ryn is offline  
Reply With Quote
Old June 9th, 2011, 10:00 PM   #38 (permalink)
Junior Member
 
Join Date: Aug 2010
Location: Brisbane, Australia.
Posts: 23
 
Device(s): Galaxy SIII
Carrier: Not Provided

Thanks: 6
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by 0ryn View Post
Hi people,
I'm fairly sure I've figured this out and come up with an easy fix
First the cause:
Poor fitting battery, made worse by a badly designed micro-SD slot position.
When you have an SD-card fitted this can push the battery away from its contacts. I found my battery had about 0.5 mm of movement up and down. Every time my phone reset it was when it was in my pocket and subject to movement.
Riding my bike to or from work.

The fix:
Lovely and simple just place a bit of paper placed under the bottom of the battery to push it up towards the battery contacts.
I used a UK lotto ticket (loosing one) it was just the right thickness to stop the movement. (Tesco till receipts work just as well.) Tear your lotto ticket in half then half again, wrap your quarter ticket over the bottom edge of the battery, push the battery into the phone and check for movement. You may have to double up, I found just one layer was enough to stop the vertical movement.
fit the cover and turn on your phone.

Enjoy.
How long has it been now since your last 'random reset' after using your method?

I was thinking this was a software fault with android 2.3.3 because I know on my desire after flashing to 2.3.3 oxygen rom everyone was having random reset issues until someone fixed googles code up in the rom and now everything is fine.
brad1601 is offline  
Reply With Quote
Old June 10th, 2011, 02:31 AM   #39 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

This looks to be a different problem to the one I have experienced as I have the issue with and without an SD card inserted. Will be interesting to see if the above helps any of you guys out though

In the meantime I have raised the issue on mine to Samsung direct - my thread on the Android forum at Issue 17365 - android - OS rebooting on Android 2.3.3 - Android - An Open Handset Alliance Project - Google Project Hosting seems to point towards the issue being with Samsung rather than Android.
stokesd3 is offline  
Reply With Quote
Old June 10th, 2011, 01:45 PM   #40 (permalink)
New Member
 
Join Date: Jun 2011
Location: Gloucestershire, England
Posts: 2
 
Device(s): HTC HD2, Motorola Xoom, Samsung Galaxy S II
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Cry

Quote:
Originally Posted by brad1601 View Post
How long has it been now since your last 'random reset' after using your method?

I was thinking this was a software fault with android 2.3.3 because I know on my desire after flashing to 2.3.3 oxygen rom everyone was having random reset issues until someone fixed googles code up in the rom and now everything is fine.
I think you could be right, or it could be a proper hardware fault, my phone locked up again today despite my paper battery fix. A phone that runs cold for hours shouldn't suddenly lock up and get hot, mine gets hot in the top left corner. I wonder if its due to the camera firmware I flashed. No matter its getting sent back on Monday for a replacement. the online store have actually arranged for a courier to collect it at no charge to me.
0ryn is offline  
Reply With Quote
sponsored links
Old June 20th, 2011, 07:06 PM   #41 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Tried to get Samsung to look into this but they just kept coming back with the generic 'take back to the shop to have it reflashed'.

This ain't gonna help since I had the issue with the original firmware and also the latest. The operator was also adamant that the reflash would fix the bug. Couldn't convince her of the difference between corrupt software and buggy software oh dear

Will just have to hope a future update sorts this I guess.
stokesd3 is offline  
Reply With Quote
Old June 21st, 2011, 07:52 PM   #42 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Have reflashed from xwke2 to xwke7 so hoping this makes a difference.

One thing I have noticed is the speed increase on the phone now. Noticed it in particular when opening Copilot
stokesd3 is offline  
Reply With Quote
Old August 23rd, 2011, 11:09 PM   #43 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I'm having the same problem. It turns itself off at least twice a day while in my pocket. If i shake it or tap it it doesn't turn off, the battery is very well fitted and secure.
Does anyone have an answer for this I would really like to avoid taking back for repairs if possible
Ballverine is offline  
Last edited by Ballverine; September 14th, 2011 at 11:02 PM.
Reply With Quote
Old August 28th, 2011, 01:18 PM   #44 (permalink)
Junior Member
 
jimmysgs2's Avatar
 
Join Date: Aug 2011
Posts: 15
 
Device(s): Samsung Galaxy S II
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via Yahoo to jimmysgs2
Lightbulb

Hey folks, my S2 has done this as well. It seems to do it when i tap an app and it doesnt matter which one i dont think. Last time was when i went to open Twitter and the screen went black and i got the samsung start up screen followed by the 02 welcome message.

I have tried taking battery out and putting back in to ensure its in firm, ive rebooted it myself every night in case its the RAM getting too clogged even though i clear the RAM regularly.

I have an appointment with 02 tomorrow to get this sorted so will report back when i know whats what. Although them replacing it would be good, it would also mean i have to pay another 12 screen protector.

Thanks
jimmysgs2 is offline  
Reply With Quote
Old August 28th, 2011, 05:30 PM   #45 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 0 Times in 0 Posts
Default

im having the same problem. i bought my fone last aug 1st and after 1 week it keeps on shutting down it doesn't restart though. what do you think is the problem?
nikko86 is offline  
Reply With Quote
Old August 29th, 2011, 01:45 PM   #46 (permalink)
Junior Member
 
jimmysgs2's Avatar
 
Join Date: Aug 2011
Posts: 15
 
Device(s): Samsung Galaxy S II
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via Yahoo to jimmysgs2
Default

I have been to 02 this morning who advised that it could be the following things or combination there of:
  • An app or two that conflict
  • An issue with the software
  • A problem with the RAM
  • Another hardware issue

Up until today I have seen it suddenly reboot itself after tapping an app 4 times with a gap between each even varying from a couple of days to a week. But today I have 3 incidents. The first was 5 minutes before my appointment. The second was on the way home and the final one was a few hours later. I have now booked myself in for another appointment. Does anyone think if i request a replacement it will happen or will they force the issue to be looked at by sending it away?
jimmysgs2 is offline  
Reply With Quote
Old September 14th, 2011, 11:06 PM   #47 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I tried jamming a thin bit of underr the end of the battery as someone suggested, it has worked 100%!
I did it about 3 weeks ago and it hasn't happened once since.
No doubt there is multiple issues here, but that was definitely the solution for me, I would recommend trying it.
Ballverine is offline  
Reply With Quote
The Following User Says Thank You to Ballverine For This Useful Post:
jimmysgs2 (September 25th, 2011)
Old September 15th, 2011, 05:11 AM   #48 (permalink)
Member
 
Join Date: Apr 2011
Location: australia
Posts: 301
 
Device(s): -SGS2- one and only. 5800 Xpress = now used for an alarm clock! lolz
Carrier: Not Provided

Thanks: 34
Thanked 89 Times in 31 Posts
Default

its great that fix works, but if mine was doing that, i'd be taking it back and demanding another one.
loony is offline  
Reply With Quote
Old September 21st, 2011, 02:40 AM   #49 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I've got the same problem. Usually happens when I have the phone in my pocket, and I suspect it has something to do with the battery connection
dogsoldier is offline  
Reply With Quote
The Following User Says Thank You to dogsoldier For This Useful Post:
ranadera (February 28th, 2012)
Old September 25th, 2011, 01:20 AM   #50 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I came here because I have a very similar issue. Spontaneous reboots that happens when I listen to music. Although I usually do this while doing housework or walking or something so it's possible it's the battery shifting slightly but I figured it was something with the music and/or music player. Just using the standard Android music player.

Will try the paper solution to see if it fixes it and will report back.
LindaDe is offline  
Reply With Quote
Reply

Samsung Galaxy S2
Current Rating:
Rate this Phone:

The Galaxy S2 (sometimes known as the Galaxy S II) is the follow up to Samsung's widely successful Galaxy S lineup. This time, the Galaxy S2 raises all the stakes and Samsung has found a way to double almost every spec in a true, one of a kind ... Read More

Tags
galaxy s2, galaxy s2 ice cream sandwich, reboot, reboot rebooting bootloop restarting switching off, restart, samsung


Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (International)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:57 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.