Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (International)

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old July 22nd, 2011, 12:55 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Please Help - No Sound - Galaxy s2

My phone was fine until this morning, now ive noticed there's no sound at all, except when I use my head phones. I've checked all the settings and there all on, volume is turned up, but still no sound when phone is rung or when i receive a text or when I listen to music or play a game, nothing unless I plug my head phones in, then the sound is normal. What have I missed or is going wrong, please help.........

Regards

David....

bilko007 is offline  
Reply With Quote
sponsored links
Old July 22nd, 2011, 02:15 PM   #2 (permalink)
Senior Member
 
steslatt's Avatar
 
Join Date: Jul 2010
Location: Manchester
Gender: Male
Posts: 1,145
 
Device(s): Nexus 4
Carrier: 3

Thanks: 38
Thanked 303 Times in 220 Posts
Default

This happened on an old phone of mine and it was something to do with the jack port where you plug your headphones in. It was acting like the headphones were still in and no sound was coming from the speaker. All I did was plug and unplug the headphones a few times and it worked again.
steslatt is offline  
Reply With Quote
Old July 23rd, 2011, 09:21 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Steslatt, I tried that, but i still have no sound at all, I can't even hear the other person when I receive a call......please someone help me lol, this can't just be a one off can it?
bilko007 is offline  
Reply With Quote
Old July 23rd, 2011, 10:21 PM   #4 (permalink)
Senior Member
 
Gearu's Avatar
 
Join Date: Apr 2011
Posts: 766
 
Device(s): Samsung Galaxy Note 3, Samsung Galaxy SII Silver Edition
Carrier: Not Provided

Thanks: 61
Thanked 85 Times in 57 Posts
Default

So you've definately checked the 4-pack of volume settings in the Sound part of settings?
Gearu is offline  
Reply With Quote
Old July 24th, 2011, 12:08 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes Gearu, one of the first things i checked....Ive done everything i can think of, still no luck, but thankyou for your suggestion...
bilko007 is offline  
Reply With Quote
Old July 25th, 2011, 03:31 AM   #6 (permalink)
Senior Member
 
Gearu's Avatar
 
Join Date: Apr 2011
Posts: 766
 
Device(s): Samsung Galaxy Note 3, Samsung Galaxy SII Silver Edition
Carrier: Not Provided

Thanks: 61
Thanked 85 Times in 57 Posts
Default

Only thing you could try is opening the phone and checking the connection, from memory there are copper connectors that are simply copper spots that are pressed together due to the phone being screwed together, could be dirty/have dust.
You need a credit card to prise between the shadow chrome and black plastic after you get your fingernail in, slow and easy does it.

This is the most comprehensive teardown guide I've found:
Samsung Galaxy S 2 Teardown - iFixit
Gearu is offline  
Reply With Quote
Old August 24th, 2011, 06:02 AM   #7 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had the exact same problem.

Do you run some customisation app like SPB shell 3D or something like that. I lost my sound and just powered my phone off/on and started it in the normal mode and then it worked fine. (luckily)
Mischaonline is offline  
Reply With Quote
Old September 6th, 2011, 01:14 AM   #8 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My Samsung Galaxy S2 also having this problem. I think we should ask Samsung Company to collect those Samsung Galaxy S2 from all the world. Im from Malaysia, i bought this phone about 1 week only.

I think samsung no pro technician/engineer/manager. Is they hire all certificated student? lolx. Got bug why still sell to market? omg......

We should return the phone back to Samsung company asap. No S2. it worst!

Note : If you dont want to send it for Warranty. i have 1 solution. Plug in your 3.5mm Earphone into the phone halfway until you hear little "shorted", take the jack out and try until u have the sound. Samsung jack hole problem. so messy.
nich0las is offline  
Last edited by nich0las; September 6th, 2011 at 01:18 AM.
Reply With Quote
Old September 21st, 2012, 01:25 AM   #9 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

My phone was fine until this morning, now ive noticed there's no sound at all, except when I use my head phones. I've checked all the settings and there all on, volume is turned up, but still no sound when phone is rung or when i receive a text or when I listen to music or play a game, nothing unless I plug my head phones in, then the sound is normal. What have I missed or is going wrong, please help.........

Regards

Atif
atifjamshaid is offline  
Reply With Quote
Old February 6th, 2013, 12:21 PM   #10 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found that I lost my media sound through the speakers and the headphones. All volumes were turned up and no sound. Text sounds and ringers were working okay.
My issue was to do with the clock...yes, the clock.
Click on clock icon.
Slide over to Desk Clock and click on it.
Click on the "expansion" icon in the upper corner.
You will see a sound icon there or possibly a vibrate icon. if it is on vibrate, that is your problem. Touch it and it will turn sound back on.
Hope this fixes your trouble.
ShawnB is offline  
Reply With Quote
sponsored links
Old July 22nd, 2013, 12:17 PM   #11 (permalink)
New Member
 
Join Date: Dec 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Check your Bluetooth

If you have a bluetooth connect device it may be getting the audio signal instead of your speaker, I did this once after freaking out about no sound then it dawned on me to check it out and voila, problem solved.
danny6114 is offline  
Reply With Quote
Old October 7th, 2013, 11:00 AM   #12 (permalink)
Junior Member
 
Join Date: Oct 2013
Posts: 19
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a problem with media starting and stopping, and no sound from youtube, although I had sound from ringtones, so I knew the physical speaker worked. After some research, I did a factory reset. No luck. I uninstalled all apps. No luck. So I did a 5 minute battery pull. No luck. Finally, I did an overnight battery pull = remove battery for 8 hours. Woke up, and assembled the battery to phone. My homescreen had 2 old icons that were right on right before I deleted the apps the night before. Maybe there is a buffer stack overflow in the droid deletion routine? (question for the devs). And so to continue, I started up my tunein radio and the sound and program work perfectly! Long story short, just try taking the battery out for 8 hours to fix your phone! ;-)
TigerRussell is offline  
Reply With Quote
Reply

Samsung Galaxy S2
Current Rating:
Rate this Phone:

The Galaxy S2 (sometimes known as the Galaxy S II) is the follow up to Samsung's widely successful Galaxy S lineup. This time, the Galaxy S2 raises all the stakes and Samsung has found a way to double almost every spec in a true, one of a kind ... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (International)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:00 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.