Go Back   Android Forums > Android Phones > Samsung Galaxy S2 Skyrocket

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 7th, 2011, 04:18 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Mad Skyrocket has battery meter issue... i.e. stuck at 100%

my phone went dead today @ work, cannot get screen to come on, tried calling it and nothing, bluetooth is dead as well... I thought maybe battery went dead due to app looking to update but no service...plugged in to car charger, nothing.... off to best buy I go....





####Users still experiencing this issue please see post #78 ####
Skyrocket has battery meter issue... i.e. stuck at 100%

The unofficial issue is bad firmware in the battery. Contact your carrier or Samsung for a replacement battery.

joeynym is offline  
Last edited by Mr. Ed; December 27th, 2011 at 04:43 PM. Reason: changed subject
Reply With Quote
sponsored links
Old November 7th, 2011, 06:19 PM   #2 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

false alarm... I feel like a jerk...

well it turns out my battery was completely dead, when I plugged in my phone into car charger it did not chirp, just vibrated every 5-10 seconds since battery was completely drained and my phone was on silent mode. Best buy chic smirked when she plugged into a actually wall charger and phone rebooted, I guess with car charged u have to charge it a couple of minutes before u can reboot... I felt like an idiot, now I gotta find out what the culprit of the battery drain was, I think it was due to i left a app running that was trying to refresh and there was no service...

Anyways I do miss my iphone for another reason, if this was my iphone and it went dead, when u click the power button it gives u a red empty battery icon to let u know, not with the sammy... 1st lesson learned with the galaxy...
joeynym is offline  
Reply With Quote
The Following User Says Thank You to joeynym For This Useful Post:
shel673 (April 1st, 2012)
Old November 7th, 2011, 08:45 PM   #3 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by joeynym View Post
false alarm... I feel like a jerk...

well it turns out my battery was completely dead, when I plugged in my phone into car charger it did not chirp, just vibrated every 5-10 seconds since battery was completely drained and my phone was on silent mode. Best buy chic smirked when she plugged into a actually wall charger and phone rebooted, I guess with car charged u have to charge it a couple of minutes before u can reboot... I felt like an idiot, now I gotta find out what the culprit of the battery drain was, I think it was due to i left a app running that was trying to refresh and there was no service...

Anyways I do miss my iphone for another reason, if this was my iphone and it went dead, when u click the power button it gives u a red empty battery icon to let u know, not with the sammy... 1st lesson learned with the galaxy...
Hem...so far mine has given me a battery with a red slash.

Keep an eye on those apps
__________________
I'm back....
Mr. Ed is offline  
Reply With Quote
Old November 7th, 2011, 08:55 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by Mr. Ed View Post
Hem...so far mine has given me a battery with a red slash.

Keep an eye on those apps

thanks mr ed... what I mean is whenever my iphone went 100% dead and it has been shut down, when I press the power button to reboot, it will give a red empty battery meter which I know it was dead due to battery... with that galaxy all i got was a vibrate, i think due to silence mode, but nothing on the screen, so I was a little lost, especially when i plugged into the car charger and all it did was vibrate every 5 seconds, I thought it was going crazzzyy... if a lil screen popped up and said battery dead or at least battery icon showed up that it was charging when I plugged it into the charger I would have been ok...

will keep an eye out on the apps...
joeynym is offline  
Reply With Quote
Old November 8th, 2011, 06:13 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

it went dead again today!!!! OMG!!!!!!

ok there is something wrong with the battery meter because it read full battery all day, which I thought was because it had an really good battery and I had turned off wifi, bluetooth, but when I was driving home, same thing just went dead....
joeynym is offline  
Last edited by joeynym; November 8th, 2011 at 06:41 PM.
Reply With Quote
Old November 8th, 2011, 10:24 PM   #6 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Att adjusts the battery meter on all of their phones. Your meter drops in 15-20% increments and is not a 1-1 meter (1% increments)

I use status bar battery from the market ..
Mr. Ed is offline  
Reply With Quote
Old November 8th, 2011, 10:54 PM   #7 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 32
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by joeynym View Post
it went dead again today!!!! OMG!!!!!!

ok there is something wrong with the battery meter because it read full battery all day, which I thought was because it had an really good battery and I had turned off wifi, bluetooth, but when I was driving home, same thing just went dead....

Same thing here

My battery meter showed 100% all day then died. Pluged it in and said 0%/charging,,,
realized is offline  
Reply With Quote
Old November 9th, 2011, 08:37 AM   #8 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem. I noticed it after I installed Juice Defender - battery was at 100% after a charge and I was like "wow this JD thing is really amazing" and then all of a sudden phone was dead. Plugged it in and turned out JD not so awesome after all. :--)

I installed a third party battery meter, same issue - so it's not the pre-installed app that's the problem.

Others that have this problem - I am wondering if installing JD caused the issue. Any thoughts?
DanBn is offline  
Reply With Quote
Old November 9th, 2011, 12:44 PM   #9 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My skyrocket also is having a battery meter issue. I charge my phone to 100% and then it stays at 100% all day even though its not, and then dies even though it says its fully charged. The only way I can fix it is to reset the phone and then it works for the rest of the day until I charge it back to 100 and then the battery meter gets stuck again. What the hell? Haha.
blakethomass is offline  
Reply With Quote
Old November 9th, 2011, 02:01 PM   #10 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by blakethomass View Post
My skyrocket also is having a battery meter issue. I charge my phone to 100% and then it stays at 100% all day even though its not, and then dies even though it says its fully charged. The only way I can fix it is to reset the phone and then it works for the rest of the day until I charge it back to 100 and then the battery meter gets stuck again. What the hell? Haha.
Very interesting guys...

this is NOT normal.

Throughout the day, if you go to menu.settings.about phone

does the battry percent there show to be 100% all day also?

have you run a factory reset, install no apps and run through an entire day? (ensure there is not app conflict causing this)
Mr. Ed is offline  
Reply With Quote
sponsored links
Old November 9th, 2011, 02:40 PM   #11 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 3 Times in 3 Posts
Default

My phone is pretty much stock. Installed dropbox and skitch on it.

Yesterday everything was working great. Today it's sitting at 100% and did not change at all.

After reading this post I decided to just plug it in - see how much battery power is left.

Interestingly enough, it beeped and said - disconnect from charger 100% charged.

Just turned the phone off, took the battery out, waited 10 secs, put battery back in and now it shows battery almost empty.... Hooked it up and it started charging correctly.

Hmnnnn.....
Gertex is offline  
Reply With Quote
Old November 9th, 2011, 03:34 PM   #12 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mr. Ed View Post
Very interesting guys...

this is NOT normal.

Throughout the day, if you go to menu.settings.about phone

does the battry percent there show to be 100% all day also?

have you run a factory reset, install no apps and run through an entire day? (ensure there is not app conflict causing this)
Yeah, even when I go to the status of the phone in settings it still says 100%! It's so weird! Maybe an app is what's causing it, although I have no idea which app it could be. I might just do a factory reset if the problem continues, but at least I'm not alone and other people are having this problem too it seems. I don't know if I should try exchanging the phone or not because the phone works perfect except for the battery meter issue, and I'm not completely sure this problem is even the actual phone itself or something else. Maybe it will resolve with a future software update?
blakethomass is offline  
Reply With Quote
Old November 9th, 2011, 10:50 PM   #13 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

I am glad I was not the only one experiencing this... Also I was 3g connection issues with certain sites that would not load, Android Forums at AndroidCentral.com, slickdeals.net, and a couple of other sites that just would not load, or I had to keep refreshing it and it took like 2-3 minutes to load, I did hard reset back to factory same issues w/ websites and battery,also I problems over the weekend connecting to yahoo fantasy football app... so i went to att store to try some other 3g android phones, well the other phones loaded the same pages up in heartbeat, no delays... I did not have same problem when wifi was on.... also I noticed the weather app when loading current location thru gps, that kept getting errors w/ gps... Also the speakerphone was horrible, also every time I made a call that conditional call forwarding icon pops up, well with the skyrocket it makes a click noise that is very annoying...

what a headache in the past 3 days...i returned the skyrocket to best buy for Samsung galaxy s2... works flawlessly... that skyrocket needs some serious updates...
joeynym is offline  
Reply With Quote
Old November 9th, 2011, 11:56 PM   #14 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I as well have this battery issue. I thought the battery was rocking, showing 100%, then decided to do a restart and pow! 42%. This is a pretty bad bug. I just came to android after 4 years with iOS, and 4 years with windows mobile. There better be a patch quick or this thing is getting returned.
thekaptn is offline  
Reply With Quote
Old November 10th, 2011, 10:01 AM   #15 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 14
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Battery Issues

As an iphone user for many years, I got used to having a decent battery life on my devices. The battery life on the new Skyrocket sucks. I commute to and from work, it takes an hour each way. If I listen to music or watch a movie, I lose about 30% battery each way. If I use it as a phone only during my 8 hour day, I lose another 60%. I make it a point to terminate all apps so nothing is running. I only talk about an hour during the day. This battery life is HORRIBLE.
colton033 is offline  
Reply With Quote
Old November 11th, 2011, 01:10 AM   #16 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Mine started doing this today
Mr. Ed is offline  
Reply With Quote
Old November 11th, 2011, 01:24 AM   #17 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I too have this problem. Add this bug to other occasional weird stuff like random scrolling to the bottom of pages, registering a click when my finger is just hovering over an area, much crappier autocorrect/predictive text than iphone, problems selecting text (in emails, webpages, and other areas), apps and widgets crashing, and other odd behavior after just 4 days of owning the thing, and you have a recipe for buyer's remorse. Kinda wishing I had picked up a 4S now, or just stuck with my 3GS for another few months or so until iphone 5 comes out (hopefully with a bigger screen, finally).
leveleyed is offline  
Last edited by leveleyed; November 11th, 2011 at 02:13 AM.
Reply With Quote
Old November 11th, 2011, 01:29 AM   #18 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

A battery pull fixed mine right up. I will trade it back to best buy when I get back in town. I need to read up in the vivid forums. Looks like they are having similar issues you our data at least
Mr. Ed is offline  
Reply With Quote
The Following User Says Thank You to Mr. Ed For This Useful Post:
FireAndroid (November 12th, 2011)
Old November 11th, 2011, 02:09 AM   #19 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did a soft reset as well and pulled the battery out and everything and it solved the problem it seems. It hasn't done it at all since I did this and Ive charged it up a few times now.
blakethomass is offline  
Reply With Quote
Old November 11th, 2011, 03:56 PM   #20 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got the skyrocket at launch and haven't had this issue yet. My guess would be the settings on power saving mode could be shutting the phone down, But that was the first thing i adjust. Also use active application and battery widgets to keep an eye on whats draining
Azoneiybelial is offline  
Reply With Quote
sponsored links
Old November 11th, 2011, 04:42 PM   #21 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by Azoneiybelial View Post
Got the skyrocket at launch and haven't had this issue yet. My guess would be the settings on power saving mode could be shutting the phone down, But that was the first thing i adjust. Also use active application and battery widgets to keep an eye on whats draining
Completely unrelated. Mine was fine for about a week and then suddenly did it. No time to narrow down the cause right now but I am watching it.

Has not done it again since the battery pull
Mr. Ed is offline  
Reply With Quote
Old November 11th, 2011, 09:35 PM   #22 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

I tried everything u guys tried, plus the headaches with trying to get on certain websites... Thank god I switched back to sgs2
joeynym is offline  
Reply With Quote
Old November 13th, 2011, 06:45 AM   #23 (permalink)
Junior Member
 
Join Date: Nov 2009
Posts: 44
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 14 Times in 10 Posts
Default

I had the exact same issue on the SGS2 and returned it for that reason. The battery meter would look great and would immediately drop to 18% or even shut the phone down and not have enough power to power up. So far, I have not had this problem on the Skyrocket. Time will tell.
Gdwheel is online now  
Reply With Quote
Old November 13th, 2011, 06:26 PM   #24 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine battery work's just great, just keep my screen at 10 % and I remove all the sync option for most off my apps to keep my Galaxy S2 LTE running all day.
qc2az is offline  
Reply With Quote
Old November 14th, 2011, 07:12 AM   #25 (permalink)
New Member
 
Join Date: Nov 2011
Location: Toronto
Posts: 5
 
Device(s): Galaxy S2 LTE (Rogers) Asus Transformer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine is doing the same thing; 100%, even though other apps say its discharging, it stays at 100% and won't recharge (if I plug in, says full, remove cable).

A reboot fixes. But issue comes back every time I charge to 100%.

I'm going to try a different charger (i.e. different wall charger, and also see if it does it after charging from a computer USB). I'll let you guys know if any charging methods I try make a difference.

A battery "pull" only works for the first time (after I recharge to 100%, issue comes back).

Anyone found a "fix" for this?

Thanks,
marcusone is offline  
Reply With Quote
Old November 14th, 2011, 09:56 AM   #26 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 57
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 2 Posts
Default

Same thing happens to me, I have to power it off/on.
SteveISU is offline  
Reply With Quote
Old November 14th, 2011, 11:18 AM   #27 (permalink)
Junior Member
 
Join Date: Nov 2011
Location: Arlington, VA (Washington, DC)
Posts: 82
 
Device(s): (AT&T) Samsung Galaxy S II Skyrocket
Carrier: Not Provided

Thanks: 9
Thanked 8 Times in 4 Posts
Default

Weird....mine hadn't done this until today for the first time....wonder if it had anything to do with me unplugging it at home, and then getting in the car and charging it there too (basically charging with 100% already on board)... Had to cycle it off/on to get the battery meter to work correctly.
jslanger is offline  
Reply With Quote
Old November 14th, 2011, 08:13 PM   #28 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by qc2az View Post
Mine battery work's just great, just keep my screen at 10 % and I remove all the sync option for most off my apps to keep my Galaxy S2 LTE running all day.
Quote:
Originally Posted by Azoneiybelial View Post
Got the skyrocket at launch and haven't had this issue yet. My guess would be the settings on power saving mode could be shutting the phone down, But that was the first thing i adjust. Also use active application and battery widgets to keep an eye on whats draining

guys i am not complaining or having issues with the life of the battery, I am talking about the meter not working properly...
joeynym is offline  
Reply With Quote
Old November 14th, 2011, 11:09 PM   #29 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue.

I drained the battery down to zero a few times, seems to have fixed it for me, will report back if the issue comes back
ruben00 is offline  
Reply With Quote
Old November 15th, 2011, 03:01 AM   #30 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Issue has not returned
Mr. Ed is offline  
Reply With Quote
sponsored links
Old November 15th, 2011, 06:27 AM   #31 (permalink)
New Member
 
Join Date: Nov 2011
Location: Toronto
Posts: 5
 
Device(s): Galaxy S2 LTE (Rogers) Asus Transformer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found that this issue only occurs after an over night charge to 100%... If I charge to 100% and remove the charge cable within a few minutes, everything works fine.

I'll try the fully discharge to '0' - a battery pull doesn't seem to have done anything to help the problem.
marcusone is offline  
Reply With Quote
Old November 15th, 2011, 09:00 AM   #32 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 57
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 2 Posts
Default

Anyone notice a difference with a given charger?? I had been using some spare micro usb chargers that were laying around the house, had the issue. Used the one that came with the phone, meter is working fine today.
SteveISU is offline  
Reply With Quote
Old November 15th, 2011, 02:57 PM   #33 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by marcusone View Post
I found that this issue only occurs after an over night charge to 100%... If I charge to 100% and remove the charge cable within a few minutes, everything works fine.

I'll try the fully discharge to '0' - a battery pull doesn't seem to have done anything to help the problem.
It isn't charging to 100% and leaving on charger....I have tested that repeatedly and can't get it to do it again.


Quote:
Originally Posted by SteveISU View Post
Anyone notice a difference with a given charger?? I had been using some spare micro usb chargers that were laying around the house, had the issue. Used the one that came with the phone, meter is working fine today.

This could definitely be the trigger. While we are on vacation we have about 8 charging cables....I just have to figure out which one caused it.


I am pretty certain it was the iPhone wall adapter with an HTC cable the day I had the issue
Mr. Ed is offline  
Reply With Quote
Old November 15th, 2011, 03:36 PM   #34 (permalink)
Junior Member
 
Join Date: Nov 2011
Location: Arlington, VA (Washington, DC)
Posts: 82
 
Device(s): (AT&T) Samsung Galaxy S II Skyrocket
Carrier: Not Provided

Thanks: 9
Thanked 8 Times in 4 Posts
Default

I plug mine in at night, let it charge while I'm asleep and it must be fully charged and still plugged in for several hours, so I don't think that that is the issue (at least not in my case).

I only have used the included cable, so I don't think that it can be definitely associated with a non-Samsung micro-USB cable either.

The only thing I did differently the 1 day that this occurred on (and I have done the same thing since, and it has not happened again, however), is that I used an off brand car charger (to USB), and used the standard cable.

I'm clearly limited to an n=1 here, but that has been my experience.
jslanger is offline  
Reply With Quote
Old November 15th, 2011, 04:57 PM   #35 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 57
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 2 Posts
Default

Quote:
Originally Posted by Mr. Ed View Post
It isn't charging to 100% and leaving on charger....I have tested that repeatedly and can't get it to do it again.





This could definitely be the trigger. While we are on vacation we have about 8 charging cables....I just have to figure out which one caused it.


I am pretty certain it was the iPhone wall adapter with an HTC cable the day I had the issue

That's funny, because I asked the same question to a guy having the same issue on Android Central and he said he used the cable that came with the phone and a iPhone block wall adapter.
SteveISU is offline  
Reply With Quote
Old November 16th, 2011, 10:35 AM   #36 (permalink)
New Member
 
Join Date: Nov 2011
Location: Toronto
Posts: 5
 
Device(s): Galaxy S2 LTE (Rogers) Asus Transformer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SteveISU View Post
That's funny, because I asked the same question to a guy having the same issue on Android Central and he said he used the cable that came with the phone and a iPhone block wall adapter.
I've tried using the block that came with the phone and that didn't work... I'll try using only what came with the phone and charge over night and see what happens.

That said; the cables and blocks I have been using have never caused any issues with any phone I've every charged with them (and I have used the same "setup" with numerous phones without issue, so really, it shouldn't be causing one now with the SGS2 IMHO).
marcusone is offline  
Reply With Quote
Old November 16th, 2011, 10:44 AM   #37 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by marcusone View Post
I've tried using the block that came with the phone and that didn't work... I'll try using only what came with the phone and charge over night and see what happens.

That said; the cables and blocks I have been using have never caused any issues with any phone I've every charged with them (and I have used the same "setup" with numerous phones without issue, so really, it shouldn't be causing one now with the SGS2 IMHO).
Same here.

Having another charging issue on my end too....while line ut is hooked up and charging there is a ton of feedback
Mr. Ed is offline  
Reply With Quote
Old November 16th, 2011, 10:50 AM   #38 (permalink)
New Member
 
Join Date: Nov 2011
Location: Toronto
Posts: 5
 
Device(s): Galaxy S2 LTE (Rogers) Asus Transformer
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mr. Ed View Post
Same here.

Having another charging issue on my end too....while line ut is hooked up and charging there is a ton of feedback
I haven't tried being on a call during charging... as for the battery charge issue a guy on xda says he is sure its a bad battery (due to the NFC firmware) as replacing the battery has solved the issue for him.
marcusone is offline  
Reply With Quote
Old November 16th, 2011, 11:51 AM   #39 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Both of my batteries do it
Mr. Ed is offline  
Reply With Quote
Old November 17th, 2011, 11:13 AM   #40 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Confirmed....this is a charger issue. In my case at least. It only occurs when I use the charger and cable pictured below

Samsung cable from my infuse + apple wall piece
Info from wall piece
model a1265
Input 100-240v
~50-60 Hz
.15A
Output 5v π 1A

Mr. Ed is offline  
Last edited by Mr. Ed; November 17th, 2011 at 12:10 PM.
Reply With Quote
sponsored links
Old November 17th, 2011, 11:28 AM   #41 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 57
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 2 Posts
Default

God damn it I'm brilliant! lol
SteveISU is offline  
Reply With Quote
Old November 17th, 2011, 11:29 AM   #42 (permalink)
Junior Member
 
Join Date: Nov 2011
Location: Arlington, VA (Washington, DC)
Posts: 82
 
Device(s): (AT&T) Samsung Galaxy S II Skyrocket
Carrier: Not Provided

Thanks: 9
Thanked 8 Times in 4 Posts
Default

^^^ Interesting....I've been using the charger from my HP Touchpad (Output 5V 2.0 A) without issue (with the Samsung cord). I haven't tried the Apple charger yet, however. The Apple and Samsung charger that came with the phone look almost identical, and have the same specs on them...wonder why it'd make any difference...
jslanger is offline  
Reply With Quote
Old November 17th, 2011, 12:19 PM   #43 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

odd indeed

we have a number of chargers, but so far, this combo is the only one that has caused the issue so far.

right now I am trying to charge via the samsung cable on the laptop, next I will try some of our other cables with the wall block.
Mr. Ed is offline  
Reply With Quote
Old November 17th, 2011, 01:35 PM   #44 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Issue came back for me today as well

and I've been draining it regularly, but using the Iphone Charger (Same specs as samsung)

I will try only using samsung chargers and see what happens
ruben00 is offline  
Reply With Quote
Old November 17th, 2011, 01:42 PM   #45 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Just finished charging via the laptop and the same cable that was plugged in to the apple wall piece...let's see what happens


edit...discharging fine...it's the apple wall thingy
Mr. Ed is offline  
Last edited by Mr. Ed; November 17th, 2011 at 03:04 PM.
Reply With Quote
Old November 17th, 2011, 11:55 PM   #46 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a theory about what may be causing the problem. Do any of you hear a high-pitched noise coming from the Samsung AC-USB adapter when you're phone is plugged into it and has 100% charge? I do, and so far I've only experienced the "100% battery" inaccuracy issue after charging overnight using either my old iPhone AC-USB adapter, or having the phone connected to a USB port on my PC. I suspect the Samsung AC adapter may have a bypass circuit, or basically a capacitor in it that disconnects the power from the phone's battery once it is fully charged to prevent overcharging. That may account for the high-pitched noise, which I can also hear if the adaptor is plugged in and the phone isn't connected. Maybe the iPhone adapter doesn't have this, and the bypass circuit is in the iPhone itself, because I don't notice this noise using the iPhone adapter, but I do hear it from the Samsung one. The noise is faint, though - kind of like the noise made by an old CRT television. It may be hard to hear unless you get the adapter close to your ear. Please let me know if any of you notice it too.
leveleyed is offline  
Reply With Quote
Old November 18th, 2011, 07:05 PM   #47 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Mine just did this. Stock chager as well.
TheTurtleMan is offline  
Reply With Quote
Old November 19th, 2011, 01:19 AM   #48 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

No issues here since I stopped using the apple wall charger.

I ave yet to try the stock charger. I will try that.

for the record for those that are not aware...ATT uses a 15% meter...your battery indicator will not drop until the phone is at 85%

the last 8 android devices I have purchased on att have done this, and it is the reason I use an app called status bar battery (it displays actual number percentage in the status bar)

without custom software with a modified battery meter it will always do this

In the past (evo) for a very short while I noticed a few developers doing this. It fools the owner into thinking they have fabulous battery life, then all the sudden WTH...battery is dying. Needless to say they pretty much all modify the framework files to read in 1% increments now
Mr. Ed is offline  
Reply With Quote
Old November 24th, 2011, 07:01 PM   #49 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

The Samsung Infuse car dock seems to create the 100% issue as well (when plugged in overnight). I think it is a correct assumption that the docks (wall and car) seem to not have the "overcharge" protection that the charger which came with the SR has. It could be an Amp issue, but I think the circuit that stops the overcharge is needed for the battery meter to opperate properly. The question is, are the docks that do not have overcharge protection causing damage to the phone or battery or it it as simple as a software issue?
scott14719 is offline  
Reply With Quote
Old November 25th, 2011, 12:05 AM   #50 (permalink)
Junior Member
Thread Author (OP)
 
joeynym's Avatar
 
Join Date: Oct 2011
Posts: 37
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

just an fyi to the battery charging issues... Ok I use the belkin surge protector w/ usb, I use this same unit to charge my samsung galaxy s2 and I have no issues at all.... here is the surge protector...
http://www.amazon.com/Belkin-Mini-Surge-Protector-Charger/dp/B0015DYMVO/ref=sr_1_1?s=electronics&ie=UTF8&qid=1322201040&sr =1-1
joeynym is offline  
Reply With Quote
Reply

Samsung Galaxy S2 Skyrocket
Current Rating:
Rate this Phone:

The Samsung Galaxy S II Skyrocket is AT&T's version of the Galaxy S II LTE. As one can figure, the phone features 4G connectivity via AT&T's LTE network. It was among the first phones on the carrier's network to feature next-gen... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S2 Skyrocket
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:53 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.