Go Back   Android Forums > Android Phones > Samsung Galaxy S2 Skyrocket

test: Reply
 
LinkBack Thread Tools
Old November 19th, 2011, 11:08 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't make outgoing calls. Please HELP!

I got my first android phone (Samsung Galaxy S2 LTE "Skyrocket") switched from iphone. So far I love it. However it's giving me a little headache. I'll try and explain what happens and hopefully someone can help me because if not I have to do another factory restore and start over again

First day I got the phone I started installing apps. Later I realized I wasn't receiving any calls. I tried calling on it as well and it doesn't even ring and straight drops. I got some help from my carrier and he had me do three things: 1st. Rebooted connection (from the carrier side) 2nd. Switch network mode to GSM (which worked I could phone but I had no wireless connection) 3rd. Factory restore and fix the problem.

So problem was fixed, I went back installing apps. It happened again. I can't make a call. I thought the problem was maybe some app is preventing me from making calls. So I unistalled a few of them like LookOut, JuiceDefender, IMDB. Still can't get my phone to make a call.

What do I do here? I need this fixed by tonight ( PLEASE HELP!

Advertisements
dsp0704 is offline  
Reply With Quote
sponsored links
Old November 19th, 2011, 11:27 PM   #2 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,230
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,331
Thanked 16,332 Times in 8,739 Posts
Default

Hi DSP, I'm not sure I can assist with your issue, but I've moved your query to the S2 LTE subforum where folk who own the phone might be able to assist.

Are you having problems with the mobile internet at all, or is it just calls? Can you make calls when the mobile internet is turned off?
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is offline  
Reply With Quote
Old November 19th, 2011, 11:50 PM   #3 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

You might try a factory reset and then running for 6 or so hours without any apps at all. It is not unheard of for an app to cause such a problem, especially juice defender, which does access the radios (are you by chance using the aggressive setting?)

then, once you have determined it is not the phone, install the apps one by one, leaving half an hour or so between installation of each app. Attempt making and receiving calls during that time until you find which app or setting is causing the issue
__________________
I'm back....
Mr. Ed is offline  
Reply With Quote
The Following User Says Thank You to Mr. Ed For This Useful Post:
El Presidente (November 20th, 2011)
Old November 20th, 2011, 09:46 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you guys. So far this is what I did. I restored to factory settings. Phone works again. I changed the settings around. Phone still works. Left it as is for overnight. Phone still works. Now I'm going to download the apps one by one to find the culprit app causing this problem. However this is assuming a single app caused this problem. If so how come there isn't thousands of reports where outgoing call drops even before it rings after downloading a certain problematic app? I only downloaded popular ones.
dsp0704 is offline  
Reply With Quote
Old November 20th, 2011, 01:01 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok this is what happened. I started first by updating 4 pre-installed apps: Youtube, Google Maps, Google StreetView, Adobe Flash Player 11. Phone still worked. Checked phone again 30min later, it still worked. So far so good. So I installed 2 apps: Zedge Ringtones&Wallpapers, and Tiny Flashlight+LED. Checked the phone, it still worked. But then 30min later, checked the phone, it doesn't call. No ringtone, just drops the call. So I uninstalled these two apps (one by one checking phone in between) but the phone still doesn't work. I'm starting to think it is not the apps.

I think I'm going to return this phone for a new one because now I'm starting to think it is the device that is the problem. If an app (especially popular apps) was causing a phone to not make calls, then there will be ton of negative comments but there isn't. And I haven't found any one with this problem. I really think I have a buggy device.

What do you guys think I should do?
dsp0704 is offline  
Reply With Quote
Old November 20th, 2011, 01:51 PM   #6 (permalink)
Member
 
Join Date: Sep 2011
Posts: 103
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 34 Times in 24 Posts
Default

go back and tell them your phone doesn't make calls, and have them give you a new one, i wouldn't even mention the apps, just be like 'hey this thing is giving me problems, it won't make calls(demonstrate), say you've tried factory resets etc, and just ask if you can exchange it'
BKayrac is offline  
Reply With Quote
Old November 20th, 2011, 04:24 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah so I went to the store and talked to the guy who sold it to me. I told him it didn't make/receive calls and when I tried to demonstrate it doesn't guess what it made the call. He said it might be that I was using LTE (in the network setting) and said I can use GSM or HSPA/GSM. I stayed on HSPA/GSM which gave me "4G" connection and now it make/receive calls at my home (where it was not working before.

I'm really disappointed that I can't use LTE. The reason I bought this phone was to use LTE. I can switch between these two settings but that is such a hassle. Also I might miss calls. So sad.

Does that mean people in Vancouver, Canada area have the same problem as me? Should I have still asked for a new phone? Hmmmmm......
dsp0704 is offline  
Reply With Quote
Old November 20th, 2011, 10:09 PM   #8 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by dsp0704 View Post
Yeah so I went to the store and talked to the guy who sold it to me. I told him it didn't make/receive calls and when I tried to demonstrate it doesn't guess what it made the call. He said it might be that I was using LTE (in the network setting) and said I can use GSM or HSPA/GSM. I stayed on HSPA/GSM which gave me "4G" connection and now it make/receive calls at my home (where it was not working before.

I'm really disappointed that I can't use LTE. The reason I bought this phone was to use LTE. I can switch between these two settings but that is such a hassle. Also I might miss calls. So sad.

Does that mean people in Vancouver, Canada area have the same problem as me? Should I have still asked for a new phone? Hmmmmm......
Can you specify EXACTLY where the setting he changed is? I make calls when in lte just fine. The phone should auto switch between the radios.
Mr. Ed is offline  
Reply With Quote
Old November 20th, 2011, 10:51 PM   #9 (permalink)
Junior Member
 
Join Date: Apr 2011
Location: Canada
Posts: 28
 
Device(s): Samsung Galaxy S2 LTE ROGERS Samsung Galaxy S2 Unlocked HTC EVO 3D BB Bold 9900
Carrier: Not Provided

Thanks: 5
Thanked 1 Time in 1 Post
Default lte

Im in vancouver and i cant get a steady or at all lte connection but soon as i go into richmond i get full bars of lte but soon as i cross the bridge back into vancouver i get no service and it switches to hspa does anyone no whats wront
sm625614 is offline  
Reply With Quote
Old November 21st, 2011, 01:26 AM   #10 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Quote:
Originally Posted by sm625614 View Post
Im in vancouver and i cant get a steady or at all lte connection but soon as i go into richmond i get full bars of lte but soon as i cross the bridge back into vancouver i get no service and it switches to hspa does anyone no whats wront
Maybe someone local to you can chime in but it sounds like Richmond does not have Ltd
Mr. Ed is offline  
Reply With Quote
sponsored links
Old November 22nd, 2011, 07:44 PM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I live in Vancouver DT and I get almost full bars everywhere but my home I get single bar.
dsp0704 is offline  
Reply With Quote
Old November 23rd, 2011, 06:26 PM   #12 (permalink)
New Member
 
Join Date: Nov 2011
Location: Vancouver BC Canada
Posts: 1
 
Device(s): Samsung Galaxy S2 LTE
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey, this is my first post here.
Like a lot of lower mainland dwellers, I am also having quite a bit of trouble with being able to make and receive calls when I'm on LTE. I live just outside of the downtown core and can make and receive calls easily, but when I do go downtown, it's a major problem. I can see my phone switching from LTE to 4G, just before it prematurely ends the call. Very frustrating. I have yet to do a factory reset or attempt to exchange the hardware.
Thanks and hope we can figure this thing out soon.
imachubchub is offline  
Reply With Quote
Old March 8th, 2012, 02:15 PM   #13 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s): Samsung Galaxy S2 LTE
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't call and receive calls in LTE mode

I had the same problem. I couldn't make any calls while on LTE mode. To fix it I went to the dial pad and dialed *#2263#* that will take you to the Service mode menu. Just select "[1]Automatic" from the list. This works for Rogers Samsung Galaxy S2 LTE. It may or may not work for other cariers
msaylica is offline  
Reply With Quote
Old October 17th, 2012, 09:01 AM   #14 (permalink)
Junior Member
 
Join Date: May 2010
Location: Maryland, USA
Gender: Male
Posts: 27
 
Device(s): Samsung Galaxy S Vibrant
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
spinsheet
Default

My Galaxy S was doing the same thing. I removed the battery, removed the SIM and let it sit for a minute. I put it all back together, turned it on, and was then able to make calls. I just got the phone a few days ago so I have no idea if this will be recurring or not. I did not have to do a factory reset.
__________________
I would rather be sailing...
spinsheet is offline  
Reply With Quote
Old September 15th, 2013, 10:46 AM   #15 (permalink)
New Member
 
Join Date: Sep 2013
Gender: Male
Posts: 1
 
Device(s): Samsung galaxy mini, Samsung galaxy S3, Samsung galaxy Note2.
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default New solution. ..

Hi guys, I'm new at this site and Im here with a solution for the "can't make outgoing calls" thread... I've noticed that the problem would be persistent and frustrating and got tired of it! but that's not a reason to hate your Android device.

There are few easy steps:
1: In your Home screen tap "phone"

2: press the "menu" button and tap "call settings"

3: scroll down and tap "additional setting"

4: tap on "Caller ID" and set it to "Network default"..

(There will be 3 options; network default, hide number and show number..
It seems that some kind of "virus" changes that from "network default " to "hide number".

please let Know if this solution has Worked so that I Can have Confirmation...
Luck!
Gabriel Muteca is offline  
Reply With Quote
Reply

Samsung Galaxy S2 Skyrocket
Current Rating:
Rate this Phone:

The Samsung Galaxy S II Skyrocket is AT&T's version of the Galaxy S II LTE. As one can figure, the phone features 4G connectivity via AT&T's LTE network. It was among the first phones on the carrier's network to feature next-gen... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S2 Skyrocket
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.