Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (T-Mobile)

test: Reply
 
LinkBack Thread Tools
Old October 15th, 2011, 09:59 AM   #1 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default Strange Battery Behavior

It's been two days with this situation. When the battery is 100% full charge, my phone will show the battery at full for a very long time. Even though I have talked on the phone, surf the web, left it on over night.... it will still say full charge. All of a sudden, it will show to actual battery level which is like 45% or 60%.

It is a problem because at full charge, the phone will say charging complete and to disconnect the charger.

Do you guys have the same problem?

Advertisements
LunchBB is offline  
Reply With Quote
sponsored links
Old October 15th, 2011, 07:03 PM   #2 (permalink)
Junior Member
 
GAMERIG's Avatar
 
Join Date: Apr 2010
Posts: 40
 
Device(s): T-MO SGSII 4G
Carrier: Not Provided

Thanks: 1
Thanked 10 Times in 7 Posts
Default

Quote:
Originally Posted by LunchBB View Post
It's been two days with this situation. When the battery is 100% full charge, my phone will show the battery at full for a very long time. Even though I have talked on the phone, surf the web, left it on over night.... it will still say full charge. All of a sudden, it will show to actual battery level which is like 45% or 60%.

It is a problem because at full charge, the phone will say charging complete and to disconnect the charger.

Do you guys have the same problem?
Given how much I use my phone during the all day, its not battery*drain*quickly..see below..

GAMERIG is offline  
Reply With Quote
Old October 16th, 2011, 07:54 PM   #3 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I didn't say the battery drain quickly. I was saying... at 100% full charge, the phone is showing 100% even after it has been used.
LunchBB is offline  
Reply With Quote
The Following User Says Thank You to LunchBB For This Useful Post:
GAMERIG (October 16th, 2011)
Old October 16th, 2011, 11:04 PM   #4 (permalink)
Junior Member
 
GAMERIG's Avatar
 
Join Date: Apr 2010
Posts: 40
 
Device(s): T-MO SGSII 4G
Carrier: Not Provided

Thanks: 1
Thanked 10 Times in 7 Posts
Default

Quote:
Originally Posted by LunchBB View Post
I didn't say the battery drain quickly. I was saying... at 100% full charge, the phone is showing 100% even after it has been used.
Oh I got that... I believe its glitch. need to remove battery from device then return it in device to see if same behavioral after few hours. then go the local tmobile for exchange. G'Luck

Thank you for clarification.
GAMERIG is offline  
Last edited by GAMERIG; October 16th, 2011 at 11:06 PM.
Reply With Quote
Old October 16th, 2011, 11:05 PM   #5 (permalink)
Senior Member
 
MisterEd's Avatar
 
Join Date: Apr 2010
Location: New Joisey
Posts: 773
 
Device(s): Samsung Infuse
Carrier: Not Provided

Thanks: 14
Thanked 117 Times in 81 Posts
Default

Quote:
Originally Posted by LunchBB View Post
I didn't say the battery drain quickly. I was saying... at 100% full charge, the phone is showing 100% even after it has been used.
My Samsung Infuse does that as well, more so on custom roms than the stock rom. It seems to go down in 15% chunks except for the last 10%.

Haven't got the GS2 yet.
__________________
I'm the ORIGINAL MisterEd and no, I am NOT related to Mr. Ed.
MisterEd is offline  
Reply With Quote
Old October 17th, 2011, 08:43 AM   #6 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I have the same problem. After fully charging my SGSII I get the full battery notification then when I use it for a while it still stays 100%. If I turn the phone off and on then it will change. Anybody have any idea how to fix this?
kvntrn28 is offline  
Reply With Quote
The Following User Says Thank You to kvntrn28 For This Useful Post:
John Jason (November 1st, 2011)
Old October 17th, 2011, 01:12 PM   #7 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

Glad I'm not the only one who has this problem.

It just happened again. I woke up the phone showing 100% charge. I know it's not true. I power off and on the phone. Then it shows 20% remaining.

It becomes a real problem because when the phone is show 100% charge, it will refuse to charge.

I just reset the phone entirely. If it behaves the same, I will bring it back to exchange.
LunchBB is offline  
Reply With Quote
Old October 17th, 2011, 11:26 PM   #8 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I reset the phone and it behaves the same. Taking it back to TMo store for an exchange tmrw.
LunchBB is offline  
Reply With Quote
Old October 18th, 2011, 04:47 PM   #9 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I think I found out what's wrong. I have been using a MicroUSB charger from my Nexus One to charge the phone. Now I switched to USB cable with computer. It is working fine now.
LunchBB is offline  
Reply With Quote
Old October 18th, 2011, 04:48 PM   #10 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 66
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 6 Posts
Default

Do a factory reset and remove the battery and reinstall. Also cycle the battery a few times. That means let it run all the way down the fully charge it. If you still have problems then dentally exchange the phone out.
Jimbo droid is offline  
Reply With Quote
sponsored links
Old October 18th, 2011, 04:49 PM   #11 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

Already reset the phone and cycle the battery. Now using USB cable to charge the phone, it is working as it should be.
LunchBB is offline  
Reply With Quote
Old October 19th, 2011, 03:36 PM   #12 (permalink)
Junior Member
 
GAMERIG's Avatar
 
Join Date: Apr 2010
Posts: 40
 
Device(s): T-MO SGSII 4G
Carrier: Not Provided

Thanks: 1
Thanked 10 Times in 7 Posts
Default

In the dial pad type: *#*#4636#*#* for Battery info without go to setting>application>battery use nor nstalling 3rd party software.

look like this:
GAMERIG is offline  
Reply With Quote
The Following User Says Thank You to GAMERIG For This Useful Post:
nsandymary (October 26th, 2011)
Old October 23rd, 2011, 01:51 PM   #13 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I exchanged the phone at Tmo store. THe same thing occurred. Everything works fine if I charge with USB cable to computer. However, if I use an AC adapter, or any external charger, after 100% full charge, the phone will report 100% even it is not (even after half a day). And during full charge, it will refuse further charging even the battery has 20% left. To get the battery level showing again, I have to reboot the phone.
LunchBB is offline  
Reply With Quote
Old November 1st, 2011, 06:54 PM   #14 (permalink)
Junior Member
 
Join Date: Sep 2011
Posts: 66
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 6 Posts
Default

Could be a problem with certain build dates of the tmobile s2 will have to report to samsung.
Jimbo droid is offline  
Reply With Quote
Old November 1st, 2011, 07:55 PM   #15 (permalink)
Member
 
John Jason's Avatar
 
Join Date: Feb 2011
Location: Portland, left side North America
Posts: 298
 
Device(s): T-Mobile MyTouch 3G, T-Mobile-USA Samsung Galaxy Note 3
Carrier: T-Mobile - USA

Thanks: 19
Thanked 32 Times in 30 Posts
Default

Quote:
Originally Posted by kvntrn28 View Post
I have the same problem. After fully charging my SGSII I get the full battery notification then when I use it for a while it still stays 100%. If I turn the phone off and on then it will change. Anybody have any idea how to fix this?
Thanks for telling me to reboot. That solves the problem for me, although there is definitely a bug somewhere. This should not be happening.

Strangely, it did not happen when I first got the phone a couple of weeks ago. It just started doing it in the past couple of days. And recently I installed a couple of battery monitor apps from the marketplace, specifically Battery Notifier (big text), Battery Status Bar, and Battery Status. I was looking for something that would display the battery charge in the panel as a percentage instead of an icon. Of these, Battery Status is still installed.
John Jason is offline  
Reply With Quote
Old November 2nd, 2011, 01:13 PM   #16 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

Other than just reboot, if I just plug the phone back USB cable through computer, the battery will be working fine again. This is definitely a bug.
LunchBB is offline  
Reply With Quote
Old November 2nd, 2011, 02:35 PM   #17 (permalink)
Member
 
John Jason's Avatar
 
Join Date: Feb 2011
Location: Portland, left side North America
Posts: 298
 
Device(s): T-Mobile MyTouch 3G, T-Mobile-USA Samsung Galaxy Note 3
Carrier: T-Mobile - USA

Thanks: 19
Thanked 32 Times in 30 Posts
Default

Quote:
Originally Posted by LunchBB View Post
Other than just reboot, if I just plug the phone back USB cable through computer, the battery will be working fine again. This is definitely a bug.
This morning, with the phone at 100% from being on the wall charger overnight, I used the phone for about an hour. The battery status remained at 100%. Just now I tried your suggestion of plugging it into the USB port on my computer, but the battery status remained at 100%, even though I knew it must be down to 80% or so.

Then I uninstalled the My Battery Status app, but still got 100% in Settings > Status. So I rebooted, and then Settings > Status said it was at 84%. Finally, I made a couple calls, after which Settings > Status said it was down to 78%. So it appears to be working correctly now. However, now I need to charge it back up to 100% to see if it stays fixed. I'll charge it up this time with the USB port on the computer instead of the wall charger to see if that makes a difference.

I really suspect one of the battery status apps that I installed is the culprit, since I never had a problem until after installing them.

I'll continue to test things to see if I can offer more troubleshooting information.
John Jason is offline  
Reply With Quote
Old November 2nd, 2011, 05:06 PM   #18 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I also have a battery widget running on the home screen. I will uninstall and try the charging again. So far, it seems once it is charged 100% by AC adapter, it is locked into that 100% even without that widget. hmm...
LunchBB is offline  
Reply With Quote
Old November 2nd, 2011, 06:47 PM   #19 (permalink)
Member
 
John Jason's Avatar
 
Join Date: Feb 2011
Location: Portland, left side North America
Posts: 298
 
Device(s): T-Mobile MyTouch 3G, T-Mobile-USA Samsung Galaxy Note 3
Carrier: T-Mobile - USA

Thanks: 19
Thanked 32 Times in 30 Posts
Default

Quote:
Originally Posted by LunchBB View Post
I also have a battery widget running on the home screen. I will uninstall and try the charging again. So far, it seems once it is charged 100% by AC adapter, it is locked into that 100% even without that widget. hmm...
After charging to 100% with the USB port on the computer a couple hours ago I made and answered a few phone calls, and surfed the web for 15 minutes or so. The battery status remains at 100%. It is probably really down to 85% or so.

So charging with the USB port works for you, but not for me.

I'm going to send a query to Samsung to see if they are already aware of the issue.
John Jason is offline  
Reply With Quote
Old November 2nd, 2011, 07:12 PM   #20 (permalink)
Member
 
John Jason's Avatar
 
Join Date: Feb 2011
Location: Portland, left side North America
Posts: 298
 
Device(s): T-Mobile MyTouch 3G, T-Mobile-USA Samsung Galaxy Note 3
Carrier: T-Mobile - USA

Thanks: 19
Thanked 32 Times in 30 Posts
Default

OK, just got off a troubleshooting live chat with someone at Samsung. Here is the (edited) chat:

You are now chatting with 'Margaret'. There will be a brief survey at the end of our chat to share feedback on my performance today.
Your Issue ID for this chat is [deleted]

Margaret: Hi, thank you for contacting Samsung Technical Support. How may I help you today?
Visitor: I am having strange battery behavior on my T-Mobile Galaxy S2 (SGH-T989). The battery status stays at 100% even after it has been used for hours. If I reboot the phone the status is then reported correctly. It only gets "stuck" when it has been charged to 100%, such as overnight.
Visitor: Here is a link to a discussion on the Android forums where many people are reporting the same problem: Strange Battery Behavior - Android Forums.
Margaret: I understand that your phone shows 100 percent battery life even after hours. Am I correct?
Visitor: Yes.
Margaret: Since how long are you experiencing the issue?
Visitor: For the past several days.

Margaret: Okay. Have you tried with the soft reset on the device and checked the status of the issue?
Margaret: Performing Soft reset will clear the internal circuitry of the phone and it will refresh all the applications on the phone.
Margaret: Please follow the instructions to perform a soft reset on the phone.
Margaret: 1.Turn off the handset.
Margaret: 2.Remove the battery and wait for 30 seconds.
Margaret: 3.Reinsert the battery and turn ON the device.
Visitor: Yes, and it does nothing to help the problem. Note that just rebooting the device will make it show the correct percentage. But then after recharging to 100% it will be stuck at 100% again.
Margaret: Okay. Are you using the same battery that came along with the phone?
Visitor: Yes
Margaret: Okay. The issue might be with the Hardware or software part of the device. Let us try performing the Factory data reset/hard reset on the device and check the status of the issue.
Margaret: Performing the Hard reset will erase all the data on the device and set the device to factory default settings. If there is any issue with the phone software performing the Factory data/Hard reset should fix the issue.
Visitor: I have already tried a hard reset to factory standards, and it did not change the issue.
Margaret: I am sorry to hear that.
Margaret: As you have tried with all the possible trouble shooting steps and see that the issue is still persisting, it seems that there might be some issue with the device. The issue might be with the internal phone settings or hardware settings of the device.
Margaret: The phone needs to be examined and serviced. I am going to provide you our Samsung voice support contact number here, it is toll-free. Our Voice support team are going to raise an service request issue regarding your device, examines the complete software of the device and isolates the issue. I suggest you to contact below given number.
Margaret: You can contact our dedicated Galaxy S phones voice support team at 1-877-EZ2GALAXY (1-877-392-4252).They are available 24/7. You will need to registered to avail 24x 7 service.


OK, I lied a bit to "Margaret." I have not done a factory reset yet, because that would require reinstalling all my apps and settings, and would be a major pain. I'll do it if it turns out that it will really solve the problem, but I suspect it will not.


However, I did do a soft reset (remove battery for 30 seconds) as "Margaret" suggested. Now I will recharge to 100% and see if the soft reset fixed the problem.
John Jason is offline  
Reply With Quote
sponsored links
Old November 3rd, 2011, 09:50 AM   #21 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by LunchBB View Post
Other than just reboot, if I just plug the phone back USB cable through computer, the battery will be working fine again. This is definitely a bug.
the USB+ ac Adapter that came witht the phone works fine and @ different Blackberry USB cables connected to the PC.

i also use a AC adapter from blackberry thats fine as well too.

But an aftermarket charger i use causes the phone to freeze as soon as it is connected. and when i try to scroll through the phone it just goes crazy. apps start opening up and the phone is unusable. but i think the charging part is ok.
just fyi...

I guess some straight wall chargers make the phone act up.
Mansquared is offline  
Reply With Quote
Old November 3rd, 2011, 01:32 PM   #22 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

I did try factory reset, as well as exchanging to a new phone at Tmo store. Both phones behaves the same way.

I also tried uninstalled the battery widget. The phone is still stuck at 100% even when the battery is depleting. That will not be a problem when charging with USB cable connect to computer.

I have the same problem with charging with AC adapter (the one comes with Nexus One), as well as two external extended battery charging devices.

but it's good that I'm not the only one who has this problem.
LunchBB is offline  
Reply With Quote
Old November 6th, 2011, 08:30 AM   #23 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Lucky ppl who don't have the android OS bug...
Dumberdoor is offline  
Reply With Quote
Old December 27th, 2011, 12:34 PM   #24 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

The battery stuck at 100% is now fixed with the latest update.
LunchBB is offline  
Reply With Quote
Old January 9th, 2012, 12:32 PM   #25 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by LunchBB View Post
The battery stuck at 100% is now fixed with the latest update.
Do you mean the latest android update (2.3.6)?

I just started having the exact same battery issue here in Canada, but unfortunately Telus hasn't released this patch yet.

Weird that it's only happened once in the past month though....
GoodCode is offline  
Reply With Quote
Old January 9th, 2012, 02:20 PM   #26 (permalink)
Senior Member
Thread Author (OP)
 
LunchBB's Avatar
 
Join Date: Jan 2011
Posts: 570
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 70 Times in 55 Posts
Default

Yes it was fixed by the update from Tmobile
LunchBB is offline  
Reply With Quote
Reply

Buy the Samsung Galaxy S II 4G
Sign up for instant notification when the Samsung Galaxy S II 4G goes on sale!
Samsung Galaxy S II 4G

The Galaxy S2 (sometimes known as the Galaxy S II) is the follow up to Samsung's widely successful Galaxy S lineup. This time, the Galaxy S2 raises all the stakes and Samsung has found a way to double almost every spec in a true, one of a kind ... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (T-Mobile)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:05 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.