Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (T-Mobile)

New Forums: Nexus 6 | Nexus Player | Nexus 9
Like Tree9Likes

test: Reply
 
LinkBack Thread Tools
Old June 21st, 2012, 07:17 AM   #1 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default [GUIDE] How to revert to Gingerbread from ICS (or go to ICS from GB)

I've posted this in some other threads but I keep seeing people asking about it so I'm posting its own thread. You do not need to be rooted to do this.

This is for the T-Mobile Galaxy S2 SGH-T989 phone ONLY.

Please see this guide for more instructions.

If you're running ICS and want to go back to Gingerbread:

Make sure on your phone USB Debugging is checked in Settings > Developer Options

Make a folder on your PC to put these files.

Odin 1.85 - Make a sub folder and extract Odin in it.

download this file. It is the updated stock UVLDE rom. Extract it in your folder.

You should already have Samsung USB drivers on your PC. If you don't, download and install Kies. It comes with the latest drivers.


1 - Launch Odin by double clicking the Odin3 v1.85 file. Plug your USB cable to your computer but not your phone.

2 - Power off your phone. Then hold down both volume buttons and plug the USB cable into your phone. Press the volume up button when you see this menu.



You will then go to the download screen.

3 - Wait for the Com port in Odin to turn yellow as in the pic. You do not need to check anything that isn't already. Just be sure that Re-Partition is NOT checked. It shouldn't be.



4 - Select PDA in Odin and browse to the stock UVLDE file you downloaded and extracted. Select it. Now press Start and Odin will flash the stock rom. When it is finished you will see a green PASS in the top section.

5 - Odin should reboot your phone. You should now be in the stock updated Gingerbread ROM.

When you reboot you may have force closes in processes. Don't Panic. This is normal. Follow the steps below.

Power off your phone again. Hold both volume buttons and the power button at the same time. When the phone vibrates, let go of the power button but keep holding both volume buttons. In a few seconds you should be in the recovery menu. Use volume buttons to move up/down and power button to select. *if power button doesn't work, use your home key*. Go to wipe data/factory reset and select it and then select yes. Next, select format cache partition and next select yes. Now select reboot.

You can also go from Gingerbread to ICS using the same method. Just use the stock ICS file instead of the Gingerbread file. Download it from one of the links at the top of this thread.
Blaurad likes this.

Advertisements
Atma is offline  
Last edited by Atma; December 1st, 2012 at 09:28 PM.
Reply With Quote
The Following 12 Users Say Thank You to Atma For This Useful Post:
alextop30 (June 21st, 2012), Bandaid (June 25th, 2012), Captain Mal 78 (July 29th, 2012), chasmyn (April 29th, 2013), chris70 (August 8th, 2012), flightwriter (June 25th, 2012), jadziab (July 25th, 2012), Sarfa (June 29th, 2012), sleedeane (July 30th, 2012), thickanatomy (October 23rd, 2012), tlc10039 (August 29th, 2012), UnknownAlly (November 2nd, 2012)
sponsored links
Old June 21st, 2012, 10:36 AM   #2 (permalink)
Senior Member
 
alextop30's Avatar
 
Join Date: Oct 2010
Location: Windy City of Chicago
Gender: Male
Posts: 791
 
Device(s): Samsung Galaxy S4 (T-Mobile) (rooted stock), Samsung Galaxy S 2 (T-Mobile) (retired), HP Touchpad (R
Carrier: T-Mobile (2gig data plan)

Thanks: 38
Thanked 123 Times in 104 Posts
Send a message via AIM to alextop30
Default

Great Job Atmazzz I am sure this will help a lot of people since ICS is pretty wonchy! Way To Go!!!
__________________
Is it bad that I like code???
alextop30 is offline  
Reply With Quote
The Following 2 Users Say Thank You to alextop30 For This Useful Post:
Atma (June 21st, 2012), sleedeane (November 13th, 2012)
Old June 25th, 2012, 02:26 PM   #3 (permalink)
Junior Member
 
Join Date: Nov 2008
Location: Albuquerque, NM... circa 1982
Posts: 39
 
Device(s): Galaxy s2 (T-Mobile)
Carrier: Not Provided

Thanks: 15
Thanked 2 Times in 1 Post
Default

Thank you, Atmazzz!!!!!!!!!
flightwriter is offline  
Reply With Quote
The Following 2 Users Say Thank You to flightwriter For This Useful Post:
Atma (June 25th, 2012), sleedeane (November 13th, 2012)
Old June 25th, 2012, 02:37 PM   #4 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

You're welcome. Hope it helped.
Atma is offline  
Reply With Quote
The Following User Says Thank You to Atma For This Useful Post:
sleedeane (November 13th, 2012)
Old June 25th, 2012, 04:42 PM   #5 (permalink)
Junior Member
 
Join Date: Nov 2008
Location: Albuquerque, NM... circa 1982
Posts: 39
 
Device(s): Galaxy s2 (T-Mobile)
Carrier: Not Provided

Thanks: 15
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by Atmazzz View Post
You're welcome. Hope it helped.
Well, there is one problem: I no longer seem to have access to the actual phone, my contacts list, or Gmail?

When the phone rebooted, it asked me to log into my Google Account. Since then (going on an hour) the "sync" symbol has been on in the notifications bar... but when I actually press the "Phone" or "Contact" icons, the screen goes black and then returns to the home screen. And I no longer have a Gmail app anywhere.

Help!
flightwriter is offline  
Reply With Quote
Old June 25th, 2012, 05:12 PM   #6 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Go to recovery.

Power off your phone. Hold both volume buttons and the power button at the same time. When the phone vibrates, let go of the power button but keep holding both volume buttons. In a few seconds you should be in the recovery menu.

Use volume buttons to move up/down and power button to select. Go to format data/factory reset and select it. Next, select format cache partition. Now select reboot and see if things are normal.
Atma is offline  
Reply With Quote
The Following User Says Thank You to Atma For This Useful Post:
flightwriter (June 25th, 2012)
Old June 25th, 2012, 05:51 PM   #7 (permalink)
Junior Member
 
Join Date: Nov 2008
Location: Albuquerque, NM... circa 1982
Posts: 39
 
Device(s): Galaxy s2 (T-Mobile)
Carrier: Not Provided

Thanks: 15
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by Atmazzz View Post
Go to recovery.

Power off your phone. Hold both volume buttons and the power button at the same time. When the phone vibrates, let go of the power button but keep holding both volume buttons. In a few seconds you should be in the recovery menu.

Use volume buttons to move up/down and power button to select. Go to format data/factory reset and select it. Next, select format cache partition. Now select reboot and see if things are normal.
I see a "wipe data/factory reset" option... same?
flightwriter is offline  
Reply With Quote
Old June 25th, 2012, 05:52 PM   #8 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by flightwriter View Post
I see a "wipe data/factory reset" option... same?

Yep, same thing. Select it and on the next screen select yes.
Atma is offline  
Reply With Quote
The Following User Says Thank You to Atma For This Useful Post:
flightwriter (June 25th, 2012)
Old June 25th, 2012, 06:54 PM   #9 (permalink)
Junior Member
 
Join Date: Nov 2008
Location: Albuquerque, NM... circa 1982
Posts: 39
 
Device(s): Galaxy s2 (T-Mobile)
Carrier: Not Provided

Thanks: 15
Thanked 2 Times in 1 Post
Default

Well, it took some doing... and at one point I was afraid I had fried my SIM card (it wouldn't work with either the Galaxy S2 or my old Nexus One) but as of now, I have a stable, Gingerbread-ed phone again.

For the second time in less than five hours, Atmazzz, thanks!

(BTW, I saw your instructions earlier about rebooting the phone, but it didn't occur to me to try doing so as the phone did seem to reboot fine... it just didn't work afterwards! It's been that kind of day.)
flightwriter is offline  
Reply With Quote
Old June 25th, 2012, 07:19 PM   #10 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

You're welcome. Glad everything's working now.
Atma is offline  
Reply With Quote
sponsored links
Old June 26th, 2012, 11:19 AM   #11 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default And if it's on a Mac...

So, I did the whole ICS for my S2 and I literally hate this thing. It's bogged down my phone and opening and operating programs on it is a pain. I've read through this post, but can't find anywhere in here on how to restore back to Gingerbread from ICS if you're using a Mac. Odin doesn't work with Mac unless you install a windows option, which I'd prefer not to do. Anyone have any suggestions on this?
Reedman99 is offline  
Reply With Quote
Old June 26th, 2012, 11:39 AM   #12 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Welcome to the forums Reedman.

I'm afraid I can't help much with the Mac. Maybe someone will come along that has one and be able to help.

You could try a factory reset. A lot of times that will help with problems, although you would have to reload apps. Check out this thread, and disable the apps in his list that you don't use.
Atma is offline  
Reply With Quote
Old June 28th, 2012, 11:28 AM   #13 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Many thanks

Thanks for the warm welcome. I've read through a number of threads, but unfortunately these forums as they get larger are hard to navigate to the info you want.

I appreciate your feedback. I'll check it out and see if that helps. Stay tuned...
Reedman99 is offline  
Reply With Quote
Old June 29th, 2012, 11:01 AM   #14 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you, Atmazzz!

The incredibly lame version of ICS that Samsung/T-Mobile rolled out for the GS2 was driving me nuts (bluetooth wasn't connecting, GPS signal strength was weak, telephone reception got worse, Wifi reception got worse, memory usage & battery drain skyrocketed, etc.) and I'm VERY happy to be back in Gingerbread!

S
Sarfa is offline  
Reply With Quote
Old June 29th, 2012, 11:05 AM   #15 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by Sarfa View Post
I'm VERY happy to be back in Gingerbread!

Welcome to the forums Sarfa.

You're welcome and I'm happy its working for you.
Atma is offline  
Reply With Quote
Old July 3rd, 2012, 10:49 PM   #16 (permalink)
Senior Member
 
alextop30's Avatar
 
Join Date: Oct 2010
Location: Windy City of Chicago
Gender: Male
Posts: 791
 
Device(s): Samsung Galaxy S4 (T-Mobile) (rooted stock), Samsung Galaxy S 2 (T-Mobile) (retired), HP Touchpad (R
Carrier: T-Mobile (2gig data plan)

Thanks: 38
Thanked 123 Times in 104 Posts
Send a message via AIM to alextop30
Default

Can we maybe get one of the Moderators to sticky this thread it is very very useful and it should be really easy to find!!! Just saying :-)
alextop30 is offline  
Reply With Quote
Old July 5th, 2012, 01:43 AM   #17 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi I installed ICS in the hope it would get rid of horrendous echo for people phoning me, but ICS is horrendous and has lost me all my 3G functionallity. I want to revert to Gingerbread but when I plug the phone into the USB port with both volume buttons pressed I just get the battery charging image on the phone and a message on the laptop saying the divice has not been recognised. I have enabled USB debugging and have Kies installed. Any ideas with what I am doing wrong?

Thanks
mongalooman is offline  
Reply With Quote
Old July 5th, 2012, 05:36 AM   #18 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by mongalooman View Post
when I plug the phone into the USB port with both volume buttons pressed I just get the battery charging image on the phone and a message on the laptop saying the divice has not been recognised.

Thanks
Hi mongalooman. Welcome to the forums.

Is your phone the SGH-T989 or the SGH-T989D Telus?

You aren't letting go of the volume buttons before you plug in the phone? Is your phone powered off when you hold the buttons and plug it in?
Atma is offline  
Reply With Quote
Old July 5th, 2012, 07:30 AM   #19 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default uh oh

I went through the steps you listed to get back to GB. At the end, it do not say PASS. It said FAIL. Where do I go from there? I unplugged it from Odin bc it wasn't doing anything. The phone screen is now stuck on "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again"

Well, it won't connect to Kies and won't let me enter recovery mode in the way listed by you.

Are you able to help? Thanks.
pugdogcrazy is offline  
Reply With Quote
Old July 5th, 2012, 07:49 AM   #20 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default wrong model

I have the at&t sgh-i777. do you have a link to the GB uvlde for that? would that fix the problem?
pugdogcrazy is offline  
Reply With Quote
sponsored links
Old July 5th, 2012, 08:08 AM   #21 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default fixed

I found a tutorial to root the phone using Odin. ics siyah kernel (?) is now on the phone which got it working again. So, thank you for your post and you don't have to respond to my earlier plea.
pugdogcrazy is offline  
Reply With Quote
Old July 5th, 2012, 08:19 AM   #22 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by pugdogcrazy View Post
I have the at&t sgh-i777. do you have a link to the GB uvlde for that? would that fix the problem?

Hi pugdogcrazy. I hope you haven't bricked your phone flashing the wrong rom. I'm at work and don't have a lot of time to look. Try the at&t sgh-i777 forum at XDA. There might be a stock rom there although I'm not sure if you use the same procedure. Read through the threads in the development forum and maybe post in the Q&A forum and tell them your situation. I'll also look around when I get time. Also, check the AT&T root forum here.

Good luck!
Atma is offline  
Last edited by Atma; July 5th, 2012 at 08:58 AM.
Reply With Quote
Old July 5th, 2012, 08:55 AM   #23 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

pugdogcrazy, I got an email for your reply but it doesn't seem to be showing up in the thread. Anyway, glad you got it working!
Atma is offline  
Reply With Quote
Old July 5th, 2012, 11:22 AM   #24 (permalink)
Senior Member
 
alextop30's Avatar
 
Join Date: Oct 2010
Location: Windy City of Chicago
Gender: Male
Posts: 791
 
Device(s): Samsung Galaxy S4 (T-Mobile) (rooted stock), Samsung Galaxy S 2 (T-Mobile) (retired), HP Touchpad (R
Carrier: T-Mobile (2gig data plan)

Thanks: 38
Thanked 123 Times in 104 Posts
Send a message via AIM to alextop30
Default

Quote:
Originally Posted by pugdogcrazy View Post
I have the at&t sgh-i777. do you have a link to the GB uvlde for that? would that fix the problem?
That is the problem exactly you attempted to install software on your phone that contains the wrong drivers. I hope you were rooted before you did the install. If you were check out what recovery you have if you still cwm recovery restore from your backup to fix your phone. If you have stock recovery connect the phone in download mode to the computer and install cwm recovery.

Here is your site that takes you step by step of how to fix your phone - including all files that you need for the AT&T version of the Samsung Galaxy S2 code name (Skyrocket).

http://forum.xda-developers.com/showthread.php?t=1313659

In the future please read what you are flashing because there can be extensive damage to your phone from the incorrect software being placed. I hope that you can fix it and get it back to gingerbread once you get through these steps.

Hope to have helped a little


Alex
alextop30 is offline  
Last edited by alextop30; July 5th, 2012 at 11:46 AM.
Reply With Quote
Old July 5th, 2012, 11:58 AM   #25 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by alextop30 View Post
I hope that you can fix it and get it back to gingerbread once you get through these steps.
I don't know why his post showed in email and not in this thread, but he got it fixed.

Quote:
I found a tutorial to root the phone using Odin. ics siyah kernel (?) is now on the phone which got it working again. So, thank you for your post and you don't have to respond to my earlier plea.
Atma is offline  
Reply With Quote
Old July 5th, 2012, 12:38 PM   #26 (permalink)
Senior Member
 
alextop30's Avatar
 
Join Date: Oct 2010
Location: Windy City of Chicago
Gender: Male
Posts: 791
 
Device(s): Samsung Galaxy S4 (T-Mobile) (rooted stock), Samsung Galaxy S 2 (T-Mobile) (retired), HP Touchpad (R
Carrier: T-Mobile (2gig data plan)

Thanks: 38
Thanked 123 Times in 104 Posts
Send a message via AIM to alextop30
Default

Quote:
Originally Posted by Atmazzz View Post
I don't know why his post showed in email and not in this thread, but he got it fixed.

Yea and for some reason his post was the last one in tapatalk on my phone which was the one I was responding to. Something weird happening today. I don't know if what I gave was redundant. Anyway I am glad the problem was all fixed, hopefully the weird thing will stop happening!!! :-)

Also You should go for the sticky too! I have used this post like 5 times already myself and it would be nice to be up there so people can see it right off the bat!!!
alextop30 is offline  
Reply With Quote
Old July 5th, 2012, 01:05 PM   #27 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by alextop30 View Post
Also You should go for the sticky too!
That just seems like shameless self-promotion. I'll leave it up to the mods.

As slow as this forum is it doesn't get too far anyway.
Atma is offline  
Reply With Quote
Old July 5th, 2012, 02:17 PM   #28 (permalink)
Senior Member
 
alextop30's Avatar
 
Join Date: Oct 2010
Location: Windy City of Chicago
Gender: Male
Posts: 791
 
Device(s): Samsung Galaxy S4 (T-Mobile) (rooted stock), Samsung Galaxy S 2 (T-Mobile) (retired), HP Touchpad (R
Carrier: T-Mobile (2gig data plan)

Thanks: 38
Thanked 123 Times in 104 Posts
Send a message via AIM to alextop30
Default

Quote:
Originally Posted by Atmazzz View Post
That just seems like shameless self-promotion. I'll leave it up to the mods.

As slow as this forum is it doesn't get too far anyway.


Nothing wrong with promoting something good that you have come up with! By the way what's with that Nexus 7 in your devices? They have not shipped them yet or did you find some sneaky way of getting one which I do not know about! I ordered mine on the first they of the I/O and it has not shipped!
alextop30 is offline  
Reply With Quote
Old July 5th, 2012, 02:20 PM   #29 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by alextop30 View Post
By the way what's with that Nexus 7 in your devices? They have not shipped them yet or did you find some sneaky way of getting one which I do not know about! I ordered mine on the first they of the I/O and it has not shipped!

I'm just planning ahead.

I ordered mine within an hour of it being listed on the play store.
Atma is offline  
Reply With Quote
Old July 6th, 2012, 02:03 AM   #30 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello

Does this step voids the warranty on the phone? Thank You
liljoke is offline  
Reply With Quote
sponsored links
Old July 6th, 2012, 05:35 AM   #31 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by liljoke View Post
hello

Does this step voids the warranty on the phone? Thank You

Hi liljoke. Welcome to the forums.

That's a good question and I'm not sure of the answer. This isn't like rooting which would void the warranty and it really is no different than using Kies to to download an official update.

Technically, if they knew you did it through Odin, it probably would but this isn't a custom rom that would void the warranty. This is their official stock Gingerbread and ICS roms. I don't see how they could know the method you used to put it on your phone.
Atma is offline  
Reply With Quote
Old July 6th, 2012, 02:56 PM   #32 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Big Thank You

Thank you for all the help, guys! I did finally get it working after bricking it twice. I have learned a lot about flashing and roms and so forth from the experience but I am done messing with this phone for now. It's back on stock gingerbread.
I want to root badly, but probably just shouldn't mess with it for a little while. You all have fun and I expect I won't be able to resist the temptation for long and will be looking for advice.
pugdogcrazy is offline  
Reply With Quote
Old July 6th, 2012, 02:59 PM   #33 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by pugdogcrazy View Post
Thank you for all the help, guys!



Glad its working. Check those links for the AT&T forums before you go rootin' next time.
Atma is offline  
Reply With Quote
Old July 7th, 2012, 02:50 PM   #34 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 0 Times in 0 Posts
Default

Hi I have a quick question. Do I have to be rooted to use this method?
jonnyboi950 is offline  
Reply With Quote
Old July 7th, 2012, 03:13 PM   #35 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by jonnyboi950 View Post
Hi I have a quick question. Do I have to be rooted to use this method?

No, no root required. If you were rooted it would unroot you anyway.
Atma is offline  
Reply With Quote
Old July 7th, 2012, 04:15 PM   #36 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 0 Times in 0 Posts
Default

Alright thanks! I'll give ICS a try now.
jonnyboi950 is offline  
Reply With Quote
Old July 10th, 2012, 11:10 AM   #37 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Helppppp!!!!!!

Okay so followed all the steps and ODIN said it passed

so when the phone powered on, it said click on android to start, so i did but it would go next, so then i decided to do a recovery since you mentioned if anything goes wrong do that

so im in recovery mode now and i go down to wipe data/factory reset, and when i go to click on it my power button wont click on it....
it wont click on any of them...
so now im stuck on this recovery mode

please helpppp
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:14 AM   #38 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

So you can't select with your power button? Try your home button.
Atma is offline  
Reply With Quote
Old July 10th, 2012, 11:16 AM   #39 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
So you can't select with your power button? Try your home button.
its a tmobile s2 it doesnt have a home button, its a touch home

and im trying to redo the processes with ODIN lets see what happens
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:18 AM   #40 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
So you can't select with your power button? Try your home button.
does it really matter if i did not remove my sim card during this process?
akamanny is offline  
Reply With Quote
sponsored links
Old July 10th, 2012, 11:19 AM   #41 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
So you can't select with your power button? Try your home button.
and should i unplug my phone when ODIN is done doing its thing?
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:20 AM   #42 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
So you can't select with your power button? Try your home button.
and should i unplug my phone when ODIN is done doing its thing?

it says "sorry! the application Google Services Framework has stopped unexpenctedly. please try again"

its giving a couple errors like that when i try to tap on the android
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:23 AM   #43 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by akamanny View Post
its a tmobile s2 it doesnt have a home button, its a touch home
Right, that's the button I meant. I saw one other person have this problem. He touched the home button and it worked. Did you try it.

He also had the same problem with Google. A factory reset fixed it.

Yes, you can unplug when Odin reboots it.

No, you don't need to remove sim card.
Atma is offline  
Reply With Quote
Old July 10th, 2012, 11:26 AM   #44 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
Right, that's the button I meant. I saw one other person have this problem. He touched the home button and it worked. Did you try it.

He also had the same problem with Google. A factory reset fixed it.

Yes, you can unplug when Odin reboots it.

No, you don't need to remove sim card.

okay home button worked

i clicked yes on the next screen and it did its magic
and not i click reboot system?
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:27 AM   #45 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by akamanny View Post
okay home button worked

i clicked yes on the next screen and it did its magic
and not i click reboot system?
While you are there, go ahead and select wipe cache partition and then reboot.
Atma is offline  
Reply With Quote
Old July 10th, 2012, 11:30 AM   #46 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
While you are there, go ahead and select wipe cache partition and then reboot.
omg dude youre God lmao

Drinks on me bro lets go
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:32 AM   #47 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by akamanny View Post
omg dude youre God lmao

Drinks on me bro lets go

lol .. so everything is working now?
Atma is offline  
Reply With Quote
Old July 10th, 2012, 11:34 AM   #48 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Atmazzz View Post
lol .. so everything is working now?
Yeah bro looks great

if anything i wont hesitate to come back to this post
akamanny is offline  
Reply With Quote
Old July 10th, 2012, 11:37 AM   #49 (permalink)
Senior Member
Thread Author (OP)
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,069
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,907 Times in 1,852 Posts
Default

Quote:
Originally Posted by akamanny View Post
Yeah bro looks great

if anything i wont hesitate to come back to this post

Great! Glad to hear it and welcome to the forums.
Atma is offline  
Reply With Quote
Old July 10th, 2012, 01:41 PM   #50 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

I tried to gather the files for this last night and the T989UVLDE from hotfile would not download. Is there a trick I am missing?

Regular download, wait my 30 seconds, then nothing. Do I need some kind of ftp client? I rebooted my pc just for S&G's and tried again (among other 15 times or so).
mrdeath2000 is offline  
Reply With Quote
Reply

Buy the Samsung Galaxy S II 4G
Sign up for instant notification when the Samsung Galaxy S II 4G goes on sale!
Samsung Galaxy S II 4G

The Galaxy S2 (sometimes known as the Galaxy S II) is the follow up to Samsung's widely successful Galaxy S lineup. This time, the Galaxy S2 raises all the stakes and Samsung has found a way to double almost every spec in a true, one of a kind ... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (T-Mobile)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:55 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.