Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 12th, 2011, 09:15 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2011
Location: California
Posts: 18
 
Device(s): Samsung Galaxy S2
Carrier: Not Provided

Thanks: 4
Thanked 4 Times in 4 Posts
Default Warning Camera Failed Error Message(SGS2)

Just got a "Warning Camera Failed" error when opening my camera app. I had to drop the battery out and put it back in - appears to be working fine now. Is there a better fix out there? If so, how do I get it?

MrPhotog is offline  
Reply With Quote
The Following User Says Thank You to MrPhotog For This Useful Post:
eezil74 (December 28th, 2011)
sponsored links
Old November 27th, 2011, 05:23 PM   #2 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default same

I have had the same issue for over a month now.. I have installed two phone updates since I got the phone in June. I bought this unlocked from the UK. I have also tried installing the new camera firmware apk floating around in forums to no avail. I start the camera and 999 times out of 1000 it comes up black. I have done about everything aside from a factory reset. Some people are reporting that the reset does not correct the issue so I'm not that excited about trying it. Sometimes a reboot will get it to come up sometimes it won't. I can only assume there is something else that got installed that is accessing the camera that's conflicting with something else.

My phone is not rooted. All the updates I've installed were official. This is unacceptable and irritating. FIX IT!
mghtbgiant is offline  
Reply With Quote
Old November 28th, 2011, 12:35 PM   #3 (permalink)
Member
 
SGS2's Avatar
 
Join Date: Mar 2011
Location: top secret, undisclosed location
Posts: 216
 
Device(s): was a samsung captivate, but now a sgs2.
Carrier: Not Provided

Thanks: 230
Thanked 34 Times in 28 Posts
Default

did you also try to delete all the data on the camera app? this will mean you will need to re-enter your camera settings. just a thought. i have not had this problem.
SGS2 is offline  
Last edited by SGS2; December 6th, 2011 at 05:10 PM.
Reply With Quote
Old November 28th, 2011, 08:42 PM   #4 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am in an inexplicable and unprecedented (since the issue first arose) trend of the camera working more often than not as of today. I did just clear there camera data and the camera is still opening as expected. I noticed the flashlight lite app which utilizes the camera LED would only shine it for about 5 seconds before the flash would shut off and the flashlight app would barf and force close. does anyone else thats having camera issues have this app and experience similar behavior?

thanks for the 'clear data' suggestion!
mghtbgiant is offline  
Reply With Quote
Old December 6th, 2011, 04:55 PM   #5 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

No dice.. The camera was working for a little bit so any tests were probably moot. I can reboot and have the camera SOMETIMES actually open. IF it does open, I can let the phone sit without using it for some undetermined timeframe (let's say 10 minutes) and then go to open the camera and have it not work. I have tried clearing the Camera application's data, Task Manager > Clear RAM, rebooting..

Nothing solves the problem predictively. the flash light application, when the camera isn't working, also doesn't work. When the camera IS working, the LED light for the flashlight app will come on for about 5 seconds and then the app crashes.

Absolutely ridiculous. I still haven't tried a factory reset because of the reports that it doesn't solve the problem. Maybe I should start backing up my information.
mghtbgiant is offline  
Reply With Quote
Old December 7th, 2011, 09:05 AM   #6 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

SURVEY SAYS!!!

NO WORKIE

I bought this phone from the UK in June before the US release. I am in the US. Adding my google account worked flawlessly the first time when I first set up the phone. Now, I can't do much on it without getting it set up. If it doesn't give me the "Could not connect to a reliable server" message, it tells me the username/password is incorrect. And, some of you knee-jerk forum posters might think something smarmy like "well, are you sure it IS correct??" the answer is yes.

I can't for the life of me seem to manage to wind up with a phone that doesnt have some sort of malfunction.

So, Samsung Customer Care here I come...
mghtbgiant is offline  
Last edited by mghtbgiant; December 7th, 2011 at 10:53 AM.
Reply With Quote
Old December 23rd, 2011, 08:23 AM   #7 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: JBLM, Washington
Gender: Male
Posts: 61
 
Device(s): AT&T Samsung Galaxy SII... I know, its old... :(
Carrier: Not Provided

Thanks: 1
Thanked 14 Times in 14 Posts
Default

I just got my Galaxy SII (refurbished) in the mail last night andtried out the camera, all seemed to be fine until I tried to change the filter to cartoon and it said the camera failed. There was an update I downloaded so hopefully it fixed it, I haven't tried it since that first time.
leo9891 is offline  
Reply With Quote
Old December 26th, 2011, 02:08 AM   #8 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mghtbgiant View Post
SURVEY SAYS!!!

NO WORKIE

I bought this phone from the UK in June before the US release. I am in the US. Adding my google account worked flawlessly the first time when I first set up the phone. Now, I can't do much on it without getting it set up. If it doesn't give me the "Could not connect to a reliable server" message, it tells me the username/password is incorrect. And, some of you knee-jerk forum posters might think something smarmy like "well, are you sure it IS correct??" the answer is yes.

I can't for the life of me seem to manage to wind up with a phone that doesnt have some sort of malfunction.

So, Samsung Customer Care here I come...

I'm having the same issue and I'm running the Samsung S2X from Telus in Canada. Come to think of it I started getting the "Could not connect to a reliable server" message a few days ago just when the problems started. My phone freezes up with every phone app I try now including the stock app along with paper camera, panorama and my favorite camscanner. When it freezes the screen turns black and the phone shuts down. I then have to hold the power button down for approx 10 seconds before the phone powers back on.

I've done a factory reset without signing into my Google account and without downloading a single app with the same issue after trying the stock camera app.

I'm now getting similar problems visiting several websites and can't seem to watch any Youtube videos without the phone freezing and shutting down.

Not sure what the problem is but I've done everything I know including the factory reset, clearing the memory and cache in all problematic apps and avoiding signing into my Google account.

Anyone else have the same problem with there S2 or S2X? This is very annoying as my phone was running solid with NO problems since September until a few days ago now. Please help!
Yielar is offline  
Reply With Quote
Old December 28th, 2011, 10:42 PM   #9 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i finally got ahold of samsung service UK and got them to start the claim process for me. the crappy part is that i now get to ship this overseas from the US and be galaxy less for who knows how long. i would suggest finding out what camera firmware your phone is running; there were apparently 3 different camera modules samsung used in these phones. 2 out of 3 are good. such is my luck in life.
mghtbgiant is offline  
Reply With Quote
Old December 28th, 2011, 10:50 PM   #10 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Yielar View Post
Come to think of it I started getting the "Could not connect to a reliable server" message a few days ago just when the problems started.
did you happen to install a new ROM? i have been installing everything i could get ahold of hoping my problem was firmware and not hardware. in any case, something i installed wiped my APN for my carrier here and i then was unable to receive packet data via my mobile provider. i got the above message when i noticed i had no data connection.

hth!
mghtbgiant is offline  
Last edited by mghtbgiant; December 28th, 2011 at 10:53 PM. Reason: bad quote tag
Reply With Quote
sponsored links
Old January 14th, 2012, 12:25 PM   #11 (permalink)
New Member
 
Join Date: Jan 2012
Location: UK
Posts: 2
 
Device(s): Samsung Galaxy S2
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same camera issue

I had the same issue with the camera error message on my galaxy s2 after uninstalling some video chat software
I couldn't get stickam to work either so uninstalled it too.
After searching the forums with no real success I resorted to the old IT adage of "have you turned it off and back on again". I cleared the camera data then rebooted the phone. And it worked!
I know a previous poster has had issues after rebooting but it is always the best thing to try first.
If the camera error comes back I will repost.
harkin is offline  
Reply With Quote
Old January 20th, 2012, 08:58 AM   #12 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 15
 
Device(s): Samsung Galaxy W, Samsung Wave 525
Carrier: Not Provided

Thanks: 1
Thanked 14 Times in 1 Post
Default

How to clear the camera data?
Sneddy is offline  
Reply With Quote
Old January 24th, 2012, 11:49 PM   #13 (permalink)
New Member
 
Join Date: May 2011
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 5
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by harkin View Post
If the camera error comes back I will repost.
Any updates?
TheAdvocator is offline  
Reply With Quote
Old December 27th, 2012, 04:11 PM   #14 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone has been able to fix this problem? Is it a hardware/firmware problem??
@mghtbgiant
I'm facing the same intermittent working problem. It doesn't work most of the times. Did you find a solution??
About the camera modules can you throw some light??
On typing *#34971539# and then press Phone/CAM FW Ver Check I get these:
Cam FW Ver: SCEF02
Phone FW Ver: TBEC28
Please help me out. I'm highly frustrated. Its been since Sept I'm facing this issue
gavinch is offline  
Reply With Quote
Old September 14th, 2013, 12:21 PM   #15 (permalink)
New Member
 
Join Date: Apr 2012
Location: Pennsylvania, USA
Gender: Male
Posts: 13
 
Device(s): Samsung Galaxy S2 (SGH-S959G)
Carrier: Straight Talk

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Been getting a black screen for about a month nopw. Sometimes it says camera failed and sometimes I get a picture but with fuzzy white lines going around the edges of the abjects. It almost looks like a camera effect. Anyway. I did the factory restart, reinstalled ROM and kernel. Nothing. Its a hardware failure, I am sure of it.

I just ordered a new camera and it should be here early next week. I am gonna try and install it myself. THIS is a very good YouTube video on taking this phone apart. If you are somewhat handy, you might want to consider it. Anyway I will get back here to post when I get it installed.

EDIT: I just replaced the camera module and that did not do the trick.. Having the same issues. Seems like Samsung is getting a phone call. Sorry everyone, I really thought that would do the trick, but obviously, it didnt.
NY Yankees 23 is offline  
Last edited by NY Yankees 23; September 15th, 2013 at 12:46 PM.
Reply With Quote
Reply
Tags
camera, error, warning


Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:58 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.