Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)

New Forums: Nexus 6 | Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old August 23rd, 2012, 11:29 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Battery or motherboard problem? Yellow triangle with exclamation mark !

Hi,

I am very new to the Android world. Got a SGH-i777 from AT&T in US in February 2012 and had to move back to India in June. I got the unlock code from AT&T and used the device for 2 months without issues here on the local network.

Yesterday, the phone showed me a critically low battery message all of a sudden (I had fully charged it the night before) and turned off. When connected to the charger, I get the image of the battery with a yellow triangle with an exclamation mark in it.

Thinking it may be a battery issue, I took it to a local Samsung repair center and he tried using a working battery in it, but still got the same image. He suggested that it may be a motherboard isssue.

Please help !!! I am still in the AT&T contract. Any chance they will honor a replacement at this point?

I tried a long continuous charge and got a battery 100% charge indication, but when I try to power up the phone the same thing happens and the phone doesnt power on.

Advertisements
prashantkd is offline  
Reply With Quote
sponsored links
Old August 24th, 2012, 02:55 AM   #2 (permalink)
Member
 
Join Date: Jul 2012
Posts: 267
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 33 Times in 32 Posts
Default

It could be a problem with your USB plug.

Spurious Battery Temperature Warning
kadimi is offline  
Reply With Quote
Old August 24th, 2012, 11:59 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

An update:

When I connect the phone to my laptop and after a few minutes of charging, I get a 100% charge indication and a message to unplug the charger cable. When I do so, the charge percentage suddenly drops down to 78% and stays that way noo matter how long I use my phone.

When I plug the charger to a wall, the charge percent stays at 78% even after 3-4 hours of charge.

THe phone works now, but I am worried that because of this incorrect charge percentage showing up, the phone should not die on me when I need it the most.

Any ideas??
prashantkd is offline  
Reply With Quote
Old August 25th, 2012, 09:19 AM   #4 (permalink)
Moderati ergo sum
 
lunatic59's Avatar
 
Join Date: Jun 2010
Location: Pennsylvania
Posts: 25,379
 
Device(s): Galaxy Note 10.1 (2014), Nexus 4, Galaxy S II, Captivate, Nexus 1, Nook Color, Asus Transformer T-1
Carrier: AT&T

Thanks: 8,567
Thanked 13,612 Times in 7,453 Posts
Default

Quote:
Originally Posted by prashantkd View Post
An update:

When I connect the phone to my laptop and after a few minutes of charging, I get a 100% charge indication and a message to unplug the charger cable. When I do so, the charge percentage suddenly drops down to 78% and stays that way noo matter how long I use my phone.

When I plug the charger to a wall, the charge percent stays at 78% even after 3-4 hours of charge.

THe phone works now, but I am worried that because of this incorrect charge percentage showing up, the phone should not die on me when I need it the most.

Any ideas??
It sounds like a bad battery. Can you take it to the store, explain the situation and ask to pop a different battery into the phone to see if it solves your problem?
__________________
_
If the information is useful, Like the post, if the person was helpful, Thank the member.
RULES: Lest we forget | This part of signature intentionally left blank.
_________________________________________________

No Ivory-Billed Woodpeckers were harmed in the composition of this message.
lunatic59 is online now  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:15 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.