Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)

test: Reply
 
LinkBack Thread Tools
Old January 11th, 2013, 11:29 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Posts: 2
 
Device(s): Samsung SGH-I777 Galaxy SII
Carrier: AT&T

Thanks: 0
Thanked 1 Time in 1 Post
Default Phone acting like constantly plugged in then unplugged

Edit: I didn't notice there's an SII AT&T forum. If this could be moved there.....

My AT&T SGH-I777, unrooted, stock everything has recently started (beginning and stopping and random) to vibrate and display the "Media scanner running" notification, and show that is it charging (then revert to its normal unplugged state) as frequently as twice a second. This only happens when the phone is unplugged, is halted by plugging in the phone, but may proceed to resume 'toggling' as soon as the phone is unplugged. It happens in spurts, lasting from one second to several minutes, perhaps longer if I wasn't removing the battery to get it to shut the hell up.

When this is happening, the screen becomes unresponsive (or rather, each "plug"/"unplug" interrupts any touchscreen gestures) rendering the phone unusable.

Even more bizzare is that this sometimes happens even when the phone is off. It will show the battery charging screen either at the correct battery level, or at empty, depending on how long it's been "buzzing". When this happens, it is almost impossible to turn the phone on, since I would need a full uninterrupted second of holding down the power button.

Since this is happening even with the phone off, I feel like it's a hardware issue, but I wanted to see if anyone has had this problem or has any ideas on what might be causing it.

I've thought it could be some foreign object in the usb port shorting it out, but have looked and can't see anything, or maybe a problem with the battery itself supplying inconsistent voltage, but I don't know enough about the mechanics to be certain.

Does anyone now what might be the problem? Has anyone else had this problem?

Thanks in advance.

Advertisements
droyd0 is offline  
Last edited by droyd0; January 11th, 2013 at 11:54 AM.
Reply With Quote
sponsored links
Old January 11th, 2013, 12:41 PM   #2 (permalink)
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,906 Times in 1,852 Posts
Default

Hi droyd0 Welcome to AF.

I moved your thread to the AT&T forum for you.

I don't know what would be causing your problem but a factory reset may fix it. Maybe someone else will have a better idea.
Atma is offline  
Reply With Quote
Old January 11th, 2013, 03:41 PM   #3 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

The only thing I don't like about Android phones is the charger for them. They tend to break a lot and do this, just the smallest movement will make it stop charging and then charge again. Have you tried a different charger? If so, it's your charging port on your phone. At that point you're better off getting another phone. I've been through about 30 chargers this year. .__. Hope this helped!
Dean M is offline  
Reply With Quote
Old January 11th, 2013, 06:33 PM   #4 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 25
 
Device(s): Samsung Galaxy S II
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 4 Posts
Default

Some people have had some success with blowing out the charger port with compressed air or using a small brush and alcohol to clean it (remove the battery first!). You may have some lint or other debris in the port that is causing the problem. If the port is damaged you'll have to replace it. I've heard that it's not too hard to do so, but you'll need some small tools to do it.
mvi57 is offline  
Reply With Quote
Old January 15th, 2013, 07:06 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Posts: 2
 
Device(s): Samsung SGH-I777 Galaxy SII
Carrier: AT&T

Thanks: 0
Thanked 1 Time in 1 Post
Default

In case anyone finds this thread and is having the same problem:

Try cleaning with compressed air and a brush. If that doesn't work, just swap out the phone; AT&T device center still stocks these as of Jan 2013 and says this is a common problem.
droyd0 is offline  
Reply With Quote
The Following User Says Thank You to droyd0 For This Useful Post:
Atma (January 15th, 2013)
Reply
Tags
battery problem, charging issue, hardware problem, samsung galaxy s2


Go Back   Android Forums > Android Phones > Samsung Galaxy S2 (AT&T)
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:33 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.