Go Back   Android Forums > Android Phones > Samsung Galaxy S3

test: Reply
 
LinkBack Thread Tools
Old November 14th, 2012, 09:33 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default allshare register pc

Hello,

I'm not sure where to post this question. I'd be glad to post elsewhere if you have any suggestions.

I'm trying to register my PC with Samsung's AllShare but I keep getting the message "Unable to verify MAC address of the PC. AllShare Play does not operate in virtualization environments.". I am not using virtualization. Samsung support said it could also be due to the manufacturer of the network adapter reusing MAC addresses. I therefore removed my nic and installed a different one (from a different manufacturer) and I still get the same error. I then installed AllShare on my laptop and yes I still get the same message. I'm either very unlucky with my three nics or many or all manufacturers reuse MAC addresses (in which case Samsung should not be using MAC address to register PCs) or Samsung's registration is somehow flawed. No idea which.

Has anyone had this issue in the past and if so were you able to work around it or fix it?

Thanks,
Mark

Advertisements
markt74 is offline  
Reply With Quote
sponsored links
Old November 14th, 2012, 09:53 PM   #2 (permalink)
Senior Member
 
Musky's Avatar
 
Join Date: Mar 2010
Posts: 1,749
 
Device(s): Samsung Galaxy S3. Unrevoked Rooted Incredible (retired)
Carrier: Not Provided

Thanks: 400
Thanked 338 Times in 214 Posts
Default

If you are behind a router, then all it can see is the router's MAC address. Unplug from the router and connect directly through the modem.
Musky is offline  
Reply With Quote
Old January 28th, 2013, 12:45 PM   #3 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Depending on your computer setup I was finally able to solve this issue.

If you are using Windows XP Home the Allshare Play program uses a program called getmac to find the mac address of your computer.

The problem is XP Home does not include this program it is only included in XP Professional and above. The solution copy it from a xp professional installation paste it into windows\system directory and restart allshare on the pc

I did this and it registered the PC without a problem

Jeff
nightsbird is offline  
Reply With Quote
Old February 14th, 2013, 07:00 AM   #4 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nightsbird View Post
Depending on your computer setup I was finally able to solve this issue.

If you are using Windows XP Home the Allshare Play program uses a program called getmac to find the mac address of your computer.

The problem is XP Home does not include this program it is only included in XP Professional and above. The solution copy it from a xp professional installation paste it into windows\system directory and restart allshare on the pc

I did this and it registered the PC without a problem

Jeff
I have the same problem and I followed your instructions, I copied getmac from Win7 to my XP, restarted AllShare, but it's still not working.
LaheaAtxkxeftu is offline  
Reply With Quote
Old February 14th, 2013, 07:35 AM   #5 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by LaheaAtxkxeftu View Post
I have the same problem and I followed your instructions, I copied getmac from Win7 to my XP, restarted AllShare, but it's still not working.
I'm not sure Win7 version of getmac would work on XP, did you try opening a commmand prompt and running getmac on your XP machine.

I would locate getmac from WinXP Professional thats the specific one
I used

Jeff
nightsbird is offline  
Reply With Quote
Old February 15th, 2013, 02:39 AM   #6 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nightsbird View Post
I'm not sure Win7 version of getmac would work on XP, did you try opening a commmand prompt and running getmac on your XP machine.

I would locate getmac from WinXP Professional thats the specific one
I used

Jeff
I am reading the thread with interest since i have the same problem. I have installed getmac.exe in my system directory and this shows the mac address via command prompt. I believe the problem is my router has a mac address snd this is seen first when allshare is attempting to register the pc. I am going to try via a modem only connected as suggested here. Samsung are not particularly helpful their response is standard. OS i have is XP Home Edition

Barry
barry694 is offline  
Reply With Quote
Old February 15th, 2013, 07:47 AM   #7 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by barry694 View Post
I am reading the thread with interest since i have the same problem. I have installed getmac.exe in my system directory and this shows the mac address via command prompt. I believe the problem is my router has a mac address snd this is seen first when allshare is attempting to register the pc. I am going to try via a modem only connected as suggested here. Samsung are not particularly helpful their response is standard. OS i have is XP Home Edition

Barry
AllShare actually doesn't look or see your external mac address, the registration only uses getmac. getmac can only see local macs on your computer. Your router may be blocking communication with its firewall, or windows may be. Try uninstalling allshare rebooting and reinstalling allshare.
nightsbird is offline  
Last edited by nightsbird; February 15th, 2013 at 07:54 AM. Reason: Added information
Reply With Quote
Old February 15th, 2013, 08:38 AM   #8 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have disabled firewalls norton and windows but still no difference. I am useing 5.0.21.28.1 version of getmac and this is in system32 directory. When called from commmant prompt is does display the mac address. There is a different address for the router. I have tried uninstalling Allshare but again no difference. Nearby device settings in Allshare shows my computer so it knows it is there. Do you have the link where you obtained your copy of getmac? would be helpful Thanks

Barry
barry694 is offline  
Reply With Quote
Old February 15th, 2013, 09:16 AM   #9 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by barry694 View Post
I have disabled firewalls norton and windows but still no difference. I am useing 5.0.21.28.1 version of getmac and this is in system32 directory. When called from commmant prompt is does display the mac address. There is a different address for the router. I have tried uninstalling Allshare but again no difference. Nearby device settings in Allshare shows my computer so it knows it is there. Do you have the link where you obtained your copy of getmac? would be helpful Thanks

Barry
My verision is 5.1.2600.0 from XP Professional, its in the C:\Windows Directory. I got it from one of my computers running XP professional.
As far as I know XP started at version 5.1. I believe 5.0 is windows 2000 don't quote me on that though.

you might try downloading an xp service pack and extracting the files it will probably be getmac.ex_ just expand it via command line "expand getmac.ex_ getmac.exe"
nightsbird is offline  
Last edited by nightsbird; February 15th, 2013 at 09:32 AM. Reason: Added info
Reply With Quote
Old February 15th, 2013, 09:41 AM   #10 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also not sure what router you are running. at command prompt when I type
getmac it only shows items listed in network connections which in my case is a ieee1394 interface and the network card. the 1394 interface shows disabled disconnected and doesnt show the mac address. I have tested both a linksys wrt54g running dd-wrt and stock firmware both work. I tested a netgear it works, and I was even able to connect dual natted. router connected to a router
nightsbird is offline  
Reply With Quote
sponsored links
Old February 15th, 2013, 01:35 PM   #11 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nightsbird View Post
Also not sure what router you are running. at command prompt when I type
getmac it only shows items listed in network connections which in my case is a ieee1394 interface and the network card. the 1394 interface shows disabled disconnected and doesnt show the mac address. I have tested both a linksys wrt54g running dd-wrt and stock firmware both work. I tested a netgear it works, and I was even able to connect dual natted. router connected to a router
Router is Huawei HG533 Fibre. The getmac.exe is so small i wonder if i might request you send it. I am unsure if this is possible because of security etc. I am no pc expert but i believe the router mac address is being read first by Allshare Play. What is frustrating is 'nearby device connection settings' shows my PC'. It looks increasing likely i will not pursue this problem. Samsung should have a better system to intergrate PC's into Allshare Play
barry694 is offline  
Reply With Quote
Old February 16th, 2013, 11:57 AM   #12 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by barry694 View Post
Router is Huawei HG533 Fibre. The getmac.exe is so small i wonder if i might request you send it. I am unsure if this is possible because of security etc. I am no pc expert but i believe the router mac address is being read first by Allshare Play. What is frustrating is 'nearby device connection settings' shows my PC'. It looks increasing likely i will not pursue this problem. Samsung should have a better system to intergrate PC's into Allshare Play
Further investigation of this problem has provided the following Getmac from command prompt shows the following

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
C:\Documents and Settings\Barry>getmac
Transport Address Transport Name
----------------- --------------
00-00-00-00-00-00 \Device\NetbiosSmb
XX-XX-XX-XX-XX-X \Device\NetBT_Tcpip_{XXXXXXXX-66A4-4007-9FE6-02785438ADF0}

The X is to hide my mac address - unsure if necessary. 5.1.2600 refers to XP not Getmac version. The information provided by Getmac I expect is the same whatever version?. I have disabled the firewall, disconnected the router and connected via a USB Modem. The result after this effort is the same THE MAC ADDRESS IS NOT READ BY ALLSHARE

The solution to this problem might be altering NetbiosSmb etc but this has become too technical and beyond my capabilty. I am now resigned to fail this task. Pity i never like to give up. There must be others that have experienced this problem but where are they?

Barry
barry694 is offline  
Reply With Quote
Old June 17th, 2013, 03:05 PM   #13 (permalink)
New Member
 
Join Date: Jun 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It seems that the problem comes from some invalid entries in the registry.
Solution: look for a key named 'MAC Access Control', locate in 'Windows Media Player NS'.
Remove the '00-00-00-00-00-00' entry from 'MAC Access Control' (and from Devices, a couple of keys above).
Exit Samsung link application and restart. Now you should be able to register your PC.

Enjoy!
sitronif is offline  
Reply With Quote
Reply

Buy the Samsung Galaxy S III
Sign up for instant notification when the Samsung Galaxy S III goes on sale!
Samsung Galaxy S III

  The Samsung Galaxy S3 is the company's flagship device of 2012. As one of the most anticipated devices of the year, this device is the first to come with a Exynos 4 Quad processor. It also has Android 4.0, a 4.8-inch 720p Super AMOLED ... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S3
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:29 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.