Go Back   Android Forums > Android Phones > Samsung Galaxy S3

test: Reply
 
LinkBack Thread Tools
Old December 5th, 2012, 09:00 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Need help with my GPS.

I have had a Galaxy s3 for about 3 weeks now, and I noticed today that my home screen weather widget has not updated for 2 days. When I hit refresh it doesn't pick up my location. Is there a way I can reset my gps and get it working again?

Advertisements
dunwoodydawg is offline  
Reply With Quote
sponsored links
Old December 5th, 2012, 09:11 AM   #2 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by dunwoodydawg View Post
I have had a Galaxy s3 for about 3 weeks now, and I noticed today that my home screen weather widget has not updated for 2 days. When I hit refresh it doesn't pick up my location. Is there a way I can reset my gps and get it working again?
In Settings/Location services make sure that "use wireless networks" is checked, this allows the phone to use the mobile network and wireless networks (if available) to help quickly get a basic location. I installed beautiful widgets & couldn't figure out why it wouldn't update, ticked off that box & voila!

Hope this helps...
rcsrich is offline  
Reply With Quote
Old December 5th, 2012, 09:24 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have that box checked, and it still won't update.
dunwoodydawg is offline  
Reply With Quote
Old December 5th, 2012, 09:29 AM   #4 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by dunwoodydawg View Post
I have that box checked, and it still won't update.
Huh. Are we talking about the stock widget on the main homescreen?

I use a different launcher & , as I said before, Beautiful Widgets, but my wife's phone is dead stock, I can take a look at her settings this evening.

Also, are you on ICS 4.0 or Jelly Bean 4.1?
rcsrich is offline  
Reply With Quote
Old December 5th, 2012, 09:32 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure. I says Android version 4.1.1.
dunwoodydawg is offline  
Reply With Quote
Old December 5th, 2012, 09:36 AM   #6 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by dunwoodydawg View Post
I'm not sure. I says Android version 4.1.1.
OK- so you're on Jell Bean 4.1.1. Well, my wife is still on ICS, but I'll take a look & report back tomorrow- hopefully someone else will have some advice in the meantime.
rcsrich is offline  
Reply With Quote
Old December 5th, 2012, 09:38 AM   #7 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by rcsrich View Post
OK- so you're on Jell Bean 4.1.1. Well, my wife is still on ICS, but I'll take a look & report back tomorrow- hopefully someone else will have some advice in the meantime.
Oh- one additional thing to try- open up Google Maps & let it get a location fix on you, then try again to update the widget...you shouldn't have to do this every time obviously, but just see if that helps kick it in the rear...
rcsrich is offline  
Reply With Quote
Old December 5th, 2012, 09:44 AM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried that, and it didn't work. I am really confused as to what is going on with the GPS. The navigator isn't working either. The gps appears to not be working.
dunwoodydawg is offline  
Reply With Quote
Old December 5th, 2012, 10:04 AM   #9 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by dunwoodydawg View Post
I tried that, and it didn't work. I am really confused as to what is going on with the GPS. The navigator isn't working either. The gps appears to not be working.
I'm assuming you've tried toggling GPS on & off & rebooting? You could try backing up all your photos & music & doing a factory reset to see if that fixes the issue. It is possible that the GPS radio has crapped out, in which case you'll want to exchange your phone for a new one...

Hopefully the reset will put everything straight if it's just a fluke in the OS...
rcsrich is offline  
Reply With Quote
Old December 5th, 2012, 11:48 AM   #10 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Fixed it!! This was really a duh moment. I rebooted my phone and the gps started working again.
dunwoodydawg is offline  
Reply With Quote
sponsored links
Old December 5th, 2012, 11:52 AM   #11 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: Virginia, USA
Posts: 772
 
Device(s): Samsung GS3 stock, Nexus 7 stock, Nook Color CM 10.1,
Carrier: T-Mobile

Thanks: 125
Thanked 120 Times in 101 Posts
Default

Quote:
Originally Posted by dunwoodydawg View Post
Fixed it!! This was really a duh moment. I rebooted my phone and the gps started working again.
Excellent! SO happy it wasn't something that required a reset/exchange.

Rebooting often helps with quirks like that- sometimes a "battery pull" is even in order (remove battery while phone is on & leave out for a minute, causes a sort of "soft reset").

Hope the phone stays trouble free!
rcsrich is offline  
Reply With Quote
Reply

Buy the Samsung Galaxy S III
Sign up for instant notification when the Samsung Galaxy S III goes on sale!
Samsung Galaxy S III

  The Samsung Galaxy S3 is the company's flagship device of 2012. As one of the most anticipated devices of the year, this device is the first to come with a Exynos 4 Quad processor. It also has Android 4.0, a 4.8-inch 720p Super AMOLED ... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S3
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:22 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.