Go Back   Android Forums > Android Phones > Samsung Galaxy S4

test: Reply
 
LinkBack Thread Tools
Old June 8th, 2013, 03:42 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default Chrome won't stay set as default browser

Every time I click on a link, either in Google search or in an email, it asks me which browser I want. I always choose Chrome and click the "always" button, but it never stays as default. Any clue how to fix this?

Thanks!

Advertisements
Wildo6882 is offline  
Reply With Quote
sponsored links
Old June 9th, 2013, 06:47 AM   #2 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Anyone else have this problem? I had it set before bed and this morning I had to select my default browser again. This is incredibly annoying.
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 07:29 AM   #3 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 209
Thanked 729 Times in 616 Posts
Default

It depends on what application requests access to a browser and what protocol is requested.
__________________
OT MaxDB, CD1, CD5, J5, GD96, ME45, T68i, X6, CX65, A925, E398, MPx200, X6-2, OT715, D600E, W810, M600i, BB8100, W880, N95-2, P1i, Ignito, W880, X1, MS1, MS2, TP851, XT910, GTab 10.1, SGS3, SGS4, SGNote 10.1, Nexus 7 II
Szadzik is offline  
Reply With Quote
Old June 9th, 2013, 07:55 AM   #4 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Quote:
Originally Posted by Szadzik View Post
It depends on what application requests access to a browser and what protocol is requested.
I'll use the same email to test it out. It'll work for about an hour and then it'll ask me again.
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 08:28 AM   #5 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 209
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by Wildo6882 View Post
I'll use the same email to test it out. It'll work for about an hour and then it'll ask me again.
That sounds strange. Have you tried clearing defaults on the stock browser and on Chrome?
Szadzik is offline  
Reply With Quote
Old June 9th, 2013, 09:01 AM   #6 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Quote:
Originally Posted by Szadzik View Post
That sounds strange. Have you tried clearing defaults on the stock browser and on Chrome?
Yeah. I've done it multiple times. And it still asks me.
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 10:40 AM   #7 (permalink)
Member
 
shmn's Avatar
 
Join Date: Feb 2011
Location: WA State
Posts: 484
 
Device(s): Sprint HTC EVO 4G, Sprint Galaxy S4
Carrier: Sprint

Thanks: 137
Thanked 131 Times in 96 Posts
Default

Try uninstalling Chrome and then use the stock browser for a short time to see if becomes the default browser. If it does and the phone stops asking you to set a default browser, then re-install Chrome and set it as default.
shmn is offline  
Reply With Quote
Old June 9th, 2013, 01:07 PM   #8 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Quote:
Originally Posted by shmn View Post
Try uninstalling Chrome and then use the stock browser for a short time to see if becomes the default browser. If it does and the phone stops asking you to set a default browser, then re-install Chrome and set it as default.
Thanks. I'll give that a try and report back.
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 01:47 PM   #9 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Nope, definitely didn't work. Each link in twitter made me pick which browser I wanted.

If I don't get this figured out this may be a deal breaker.
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 01:54 PM   #10 (permalink)
Member
 
shmn's Avatar
 
Join Date: Feb 2011
Location: WA State
Posts: 484
 
Device(s): Sprint HTC EVO 4G, Sprint Galaxy S4
Carrier: Sprint

Thanks: 137
Thanked 131 Times in 96 Posts
Default

I guess your last option is a factory reset. Or take the phone back if you still can. If you are taking the phone back you will have to do a factory reset anyway to clear all your info off the phone...so it's worth a shot.
shmn is offline  
Reply With Quote
sponsored links
Old June 9th, 2013, 02:03 PM   #11 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Quote:
Originally Posted by shmn View Post
I guess your last option is a factory reset. Or take the phone back if you still can. If you are taking the phone back you will have to do a factory reset anyway to clear all your info off the phone...so it's worth a shot.
Yeah. I think I'll try that. I have helium so I can resync all my app data if I want. It wouldn't be a huge issue. I think I'll give it a shot.

Have you tried it out on yours?
Wildo6882 is offline  
Reply With Quote
Old June 9th, 2013, 02:10 PM   #12 (permalink)
Member
 
shmn's Avatar
 
Join Date: Feb 2011
Location: WA State
Posts: 484
 
Device(s): Sprint HTC EVO 4G, Sprint Galaxy S4
Carrier: Sprint

Thanks: 137
Thanked 131 Times in 96 Posts
Default

Quote:
Originally Posted by Wildo6882 View Post
Have you tried it out on yours?
Factory reset? No.

I use Chrome and don't have your problem. I set it as default once and it has been used as default by the system and all apps from day one.
shmn is offline  
Reply With Quote
Old June 9th, 2013, 02:23 PM   #13 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Location: Illinois
Posts: 149
 
Device(s): Nexus 5/GPE G-Pad 8.3
Carrier: AT&T

Thanks: 15
Thanked 22 Times in 20 Posts
Default

Quote:
Originally Posted by shmn View Post
Factory reset? No.

I use Chrome and don't have your problem. I set it as default once and it has been used as default by the system and all apps from day one.
Yeah that's what I meant. Have you tried setting it as default. I just used it on my DNA and didn't have that issue. I'm still in my return window so I'll probably reset it and see if that works. If not, it's going back.
Wildo6882 is offline  
Reply With Quote
Old July 29th, 2013, 12:20 PM   #14 (permalink)
New Member
 
Join Date: Jul 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you ever get this issue resolved? If so, how? I am experiencing the same issue and don't want to do a factory reset if I don't have to.
code_joe is offline  
Reply With Quote
Old July 30th, 2013, 12:28 PM   #15 (permalink)
Junior Member
 
tytlyf's Avatar
 
Join Date: Jun 2013
Posts: 72
 
Device(s): Galaxy S4 SCH-1545
Carrier: Verizon

Thanks: 0
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by code_joe View Post
Did you ever get this issue resolved? If so, how? I am experiencing the same issue and don't want to do a factory reset if I don't have to.
I know you get a pop up but it should ask you to use the program "Always or just once". Additionally, you can go into your Settings>More>Application Manager and swipe over to the "all" category. From there you can disable the other internet apps or go to your Internet app that you use, open it, and scroll down to set defaults.
tytlyf is offline  
Reply With Quote
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:00 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.