Go Back   Android Forums > Android Phones > Samsung Galaxy S4

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 23rd, 2013, 06:12 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Sensors not working on S4

I have always been an iPhone user and just recently switched to Galaxy S4, so I'm relatively new to android. After 3 weeks of usage the sensors suddenly stopped working, so accelerometer is not functioning, neither are the light and proximity sensors and these are the most important ones for most of the features to work. I did some basic troubleshooting, checked the settings and even did factory reset a couple of times but no change. This led me to believe that its a hardware issue but I just noticed that accelerometer is working for the camera but not for any other app. So, now I'm not sure if there are some android tricks that I'm missing. Any suggestions?

isandroid4me is offline  
Reply With Quote
sponsored links
Old June 23rd, 2013, 07:18 AM   #2 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Are you sure you have not turned screen rotation off? Download an app that allows testing sensors. Something like CPU-z even.
__________________
OT MaxDB, CD1, CD5, J5, GD96, ME45, T68i, X6, CX65, A925, E398, MPx200, X6-2, OT715, D600E, W810, M600i, BB8100, W880, N95-2, P1i, Ignito, W880, X1, MS1, MS2, TP851, XT910, GTab 10.1, SGS3, SGS4, SGNote 10.1, Nexus 7 II
Szadzik is offline  
Reply With Quote
Old June 23rd, 2013, 09:31 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm sure all the settings are fine. I have tried apps like Android Sensor Box, Hardware Tests etc. The sensors are recognized by these apps but they're just not working. Not even the light and proximity sensors. The only exception is rotation working for camera
isandroid4me is offline  
Reply With Quote
Old June 23rd, 2013, 10:05 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just tried CPU-Z as well. Once again, all sensors are recognized and listed but still not workin
isandroid4me is offline  
Reply With Quote
Old June 23rd, 2013, 12:13 PM   #5 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Which means the problem is with software and not hardware. A simple hard reset should be a good start at troubleshooting.
Szadzik is offline  
Reply With Quote
Old June 23rd, 2013, 10:06 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Since I'm not very familiar with Android, how do I do a hard rest? How is it different from doing a factory reset?
isandroid4me is offline  
Reply With Quote
Old June 23rd, 2013, 10:11 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

What I have already tried is the factory reset under settings and "Wipe data/factory reset" option while booting (it came by keeping the volume key pressed while booting)
isandroid4me is offline  
Reply With Quote
Old June 23rd, 2013, 11:49 PM   #8 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by isandroid4me View Post
What I have already tried is the factory reset under settings and "Wipe data/factory reset" option while booting (it came by keeping the volume key pressed while booting)
Factory reset is the same as hard reset.

So after factory reset it is still not working?
Szadzik is offline  
Reply With Quote
Old June 24th, 2013, 01:22 AM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

That is correct. Sensors still wont work even after doing the factory reset twice.
isandroid4me is offline  
Reply With Quote
Old June 24th, 2013, 01:52 AM   #10 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

get it serviced or replaced.
Szadzik is offline  
Reply With Quote
sponsored links
Old June 24th, 2013, 02:08 AM   #11 (permalink)
Junior Member
 
Join Date: Jun 2013
Location: USA
Gender: Male
Posts: 33
 
Device(s): Samsun SII ,SIII,SIV
Carrier: Not Provided

Thanks: 8
Thanked 1 Time in 1 Post
Tongue

Warranty Issue, Requires Replacement....
leekevin is offline  
Reply With Quote
Old June 24th, 2013, 02:15 AM   #12 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is under warranty so that would certainly be the best option for now
isandroid4me is offline  
Reply With Quote
Old October 18th, 2013, 11:13 AM   #13 (permalink)
New Member
 
Join Date: Oct 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I have a similar issue only in my case restarting the phone solves the issue.
After restarting the phone everything will work but after several minutes the screen rotation, air gestures, proximity etc. will stop working.
Once again, a simple restart solves it temporarily.
Did anyone encounter this behavior?

Thanks,
Bueno
bueno_n is offline  
Reply With Quote
Old October 19th, 2013, 10:51 AM   #14 (permalink)
New Member
 
Join Date: Oct 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Did anyone encounter the issue I mentioned above?
It is driving me nuts!
I have to restart the phone 4-5 times a day

Thanks,
Bueno
bueno_n is offline  
Reply With Quote
Old October 19th, 2013, 01:51 PM   #15 (permalink)
New Member
 
Join Date: Oct 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try flash a rom.
ebenhe is offline  
Reply With Quote
Old October 19th, 2013, 03:02 PM   #16 (permalink)
Check six!
 
Slug's Avatar
 
Join Date: Aug 2009
Location: Inverness, UK
Gender: Male
Posts: 17,424
 
Device(s): Sony Xperia Z
Carrier: EE

Thanks: 2,651
Thanked 10,881 Times in 5,530 Posts
Send a message via Skype™ to Slug slugbrem@gmail.com
Default

Quote:
Originally Posted by ebenhe View Post
Try flash a rom.
A factory reset is easier, safer and does the same job. If that doesn't work then, as suggested by several others previously, it's a hardware fault that should be dealt with by the warranty.
Slug is offline  
Reply With Quote
Old October 20th, 2013, 09:22 AM   #17 (permalink)
New Member
 
Join Date: Oct 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I already tried both.
Are you sure it's hardware?
Seems like software since restart solves it.
I voided my warranty due to the new eFuse thingy so I wanna resort to that solution after I've tried everything.

Thanks!
bueno_n is offline  
Reply With Quote
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More

Tags
samsung galaxy s4


Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:22 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.