Go Back   Android Forums > Android Phones > Samsung Galaxy S4

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old August 21st, 2013, 05:50 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Sensors Not Working And Lag On S4

The sensors on my S4 (GT-i9505) are currently not working. There is also a lag, sometimes up to 10s, from pressing the home button till the unlock screen shows. The sensors are recognized on cpu-z but are not shown as working. I have factory reset the phone several times and occasionally they work for 5-10 minutes before stopping again so I'm guessing this is a software fault not a hardware fault?

I have read on another thread about someone having similar problems and that it was a warrenty case. However I had to replace the screen on mine 3 months back myself as the digitizer broke in my pocket (I'm guessing from bending) and now my warranty is void.

I have tried flashing the same UK firmware with odin and also tried a German version... still no luck

Does anyone have any ideas as I'm stuck? Any help or recommendations would be greatly appreciated.

Thanks in advance! Jack

Advertisements
jackabutlers is offline  
Reply With Quote
sponsored links
Old August 21st, 2013, 06:13 AM   #2 (permalink)
Senior Member
 
Join Date: Oct 2011
Location: Kuala Lumpur, Malaysia
Posts: 737
 
Device(s): Galaxy S III, Galaxy S4, Note 2, Nexus 10, Galaxy Gear
Carrier: DIGI

Thanks: 55
Thanked 219 Times in 176 Posts
Default

Quote:
Originally Posted by jackabutlers View Post

I have read on another thread about someone having similar problems and that it was a warrenty case. However I had to replace the screen on mine 3 months back myself as the digitizer broke in my pocket (I'm guessing from bending) and now my warranty is void.

I have tried flashing the same UK firmware with odin and also tried a German version... still no luck


Thanks in advance! Jack
I have nothing helpful to contribute, sorry Jack.

But I like to let you know, that what you described above, is very common to people who fix their own screens. It's either sensor problem or touchscreen response and misfiring.
The display (digitizer) and front glass are fused, with a layer of optical adhesive. I suppose self repair is never as good as factory bound. Which result in such problems down the line.
If factory reset didn't fix it, I don't think there is much you can do, on the software end. I suspect it's a hardware. I had similar problems with other phones. Home buttons, sensors etc.. they would work fine for a while after a reset, but would quickly go back to normal as I would use them. Hence why I rather buy costly parts and get service to fix it for me, than play around myself, and possibly cause more problems.

Try to test the sensors, by opening the dial pad and keying in *#0*#
How do they respond while testing ?
SebaKL is offline  
Reply With Quote
The Following User Says Thank You to SebaKL For This Useful Post:
jackabutlers (August 21st, 2013)
Old August 21st, 2013, 06:32 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

When I replaced the screen myself I replaced the whole front bezel as I didn't trust myself to stick the digitizer on myself. Do you think it would be worth opening up again to check everything is fully connected? Seems odd it would only start to occur about 3 months after I did the replacement?

Thanks for the quick response!
jackabutlers is offline  
Reply With Quote
Old August 21st, 2013, 06:35 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SebaKL View Post

Try to test the sensors, by opening the dial pad and keying in *#0*#
How do they respond while testing ?
Have done this several times it shows FAIL as expected
When I do reset it shows PASS in the 10 mins before they fail again.

Thanks
jackabutlers is offline  
Reply With Quote
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More

Tags
faulty, galaxy s4, lag, sensors


Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:00 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.