Go Back   Android Forums > Android Phones > Samsung Galaxy S4

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old October 28th, 2013, 06:15 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Replaced VZW S4 Digitizer & Screen, Now Having Issues With 4G and Phone Freezing

I dropped my VZW Galaxy S4 (stock, unrooted, running 4.2.2), cracking the screen and damaging the digitizer. I ordered a replacement digitizer/screen and installed it and everything went fine. However I'm now dealing with a number of odd issues with my phone that were not there before installing the new parts a week ago:
  • 4G doesn't work. I never had any issues getting 4G before replacing the digitizer but now it will only connect using 3G. I've used both the Global and LTE/CDMA network modes and it doesn't help.
  • The phone will randomly freeze up and require a battery pull to fix it. This only occurs when I'm actually using the phone and there's no pattern to what causes it. It can be using the internet, multiple apps, going through the pic gallery, etc. It happens 8-12 times a day, though that frequency is directly based on how much I'm using my phone in a given day. Whenever this happens, the phone will get very hot in the SD and SIM slot area.
  • The camera only works intermittently. About half the time I open the camera app, the app's HUD appears but it's just a black screen behind it, as if the camera is not seeing anything. When this happens, nothing happens for 30 seconds at which point a 'Camera Failed' dialogue box pops up and I click OK and try again.
  • Other actions on the phone seem slower or laggier than before but perhaps this is psychosomatic.
I pulled the back off of the phone again to confirm that everything looks correct and make sure all of the connections are secure but everything looked fine. I have no idea what to do next. The digitizer I bought is for VZW S4s and came from an Amazon seller with good reviews and none of the reviews mention an issue like mine. Does anyone have any suggestions or info on this issue? I searched online for similar issues but I haven't been able to find anything like this.


Thanks.

dmeloche1 is offline  
Last edited by dmeloche1; October 28th, 2013 at 06:18 AM.
Reply With Quote
sponsored links
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:14 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.