Go Back   Android Forums > Android Phones > Samsung Galaxy S4

test: Reply
 
LinkBack Thread Tools
Old December 20th, 2013, 07:27 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Location: Australia
Gender: Male
Posts: 12
 
Device(s): iPhone 2G iPhone 3GS iPhone 4G HTC Inspire 4G (In use)
Carrier: Telstra (3G) Changing to 4g asap.

Thanks: 2
Thanked 2 Times in 2 Posts
Default S4 Screen, Camera, Update issue

Hi Guys

Got myself a Galaxy S4 around 2 months ago and has been beautiful.

But now.. It's terrible.

Earlier today i went to 4.3 android, And now? It has an issue.. If you adjust the brightness to the lowest setting it's like huge amounts of contrast are applied and the screen is blue/ purple almost impossible to use.. and if it's all the way up the screen is a kinda orange/ green tint and impossible to use.. but you can kinda get a sweet spot in the middle..

And also the camera app is unusable due to a similar issue yet it's perfect in snapchat?

Have performed factory reset but i believe maybe the firmware didn't apply properly.. Is there anyway to reapply previous version?


I'll be honest, it's been dropped.. but only around 1m to soft grass, and the issue only started occuring after the firmware update..

Please help!!

Advertisements
jonoc93 is offline  
Reply With Quote
sponsored links
Old December 21st, 2013, 06:41 AM   #2 (permalink)
Member
 
Join Date: Apr 2013
Location: NW Arkansas, USA
Posts: 164
 
Device(s): Samsung S4, HTC Evo 4G LTE, Samsung S3, Several older Android and WinMo phones
Carrier: Sprint

Thanks: 6
Thanked 33 Times in 28 Posts
Default

Sounds like the firmware didn't apply correctly. Were you rooted? Did you get it back to fully stock before the update?
jejb is offline  
Reply With Quote
Old December 22nd, 2013, 04:12 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Location: Australia
Gender: Male
Posts: 12
 
Device(s): iPhone 2G iPhone 3GS iPhone 4G HTC Inspire 4G (In use)
Carrier: Telstra (3G) Changing to 4g asap.

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Yeah that's what i was thinking too, And now the screen isn't responding properly 1/3rd of the time when trying to enter my password when i unlock.. The camera momentarily started working and is now back the same, and NOW the back and menu buttons down the bottom are not responding..

Phone is stock as rock out of the box
Have done factory restore

Is there any way to take it back to 4.2? I believe this would fix it
jonoc93 is offline  
Reply With Quote
Old December 22nd, 2013, 05:09 AM   #4 (permalink)
Member
 
Join Date: Apr 2013
Location: NW Arkansas, USA
Posts: 164
 
Device(s): Samsung S4, HTC Evo 4G LTE, Samsung S3, Several older Android and WinMo phones
Carrier: Sprint

Thanks: 6
Thanked 33 Times in 28 Posts
Default

No. Unfortunately, once you go to 4.3, you're stuck there. Odd that the update did this on a stock phone. I'd recommend taking it into your carriers store and have them fix it, if possible.
jejb is offline  
Reply With Quote
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:37 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.