Go Back   Android Forums > Android Phones > Samsung Galaxy S4

test: Reply
 
LinkBack Thread Tools
Old January 26th, 2014, 03:39 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2014
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default "ok google" not working

For some reasons, the "ok google" voice activation is not working on my s4. Anyone else have this problem. It was working fine until a few days ago. I try restart and reboot my phone, active the hotword and everything, and the google voice activation still not working. After I ask "ok google" once, the mic becomes hallow and I can't voice activate it again. Any help is appreciate it!

Advertisements
androidguy011 is offline  
Reply With Quote
sponsored links
Old January 26th, 2014, 05:01 PM   #2 (permalink)
Senior Member
 
Join Date: Jan 2012
Posts: 937
 
Device(s): rooted AT&T GS4 w/ Android 4.3
Carrier: Not Provided

Thanks: 282
Thanked 201 Times in 157 Posts
Default

Quote:
After I ask "ok google" once, the mic becomes hallow and I can't voice activate it again
Can you explain what hallow means?
Does it always work the first time or that sometimes doesn't work either?
electricpete is offline  
Reply With Quote
Old January 26th, 2014, 05:02 PM   #3 (permalink)
Senior Member
 
Join Date: Jan 2012
Posts: 937
 
Device(s): rooted AT&T GS4 w/ Android 4.3
Carrier: Not Provided

Thanks: 282
Thanked 201 Times in 157 Posts
Default

One thing that seems to come up regularly (but may not exactly fit here).
Make sure you are talking to the mic port on the bottom of the phone and that it is not filled up with lint or covered with your case.

I looked at my case and saw the hole for the mic was TINY and partially covering the tiny mic, so I enlarged the hole in the case (with a drill) and Google understands me better now.
electricpete is offline  
Reply With Quote
Old January 26th, 2014, 05:34 PM   #4 (permalink)
Senior Member
 
Join Date: Jan 2012
Posts: 937
 
Device(s): rooted AT&T GS4 w/ Android 4.3
Carrier: Not Provided

Thanks: 282
Thanked 201 Times in 157 Posts
Default

Another thing to double check (although I don't know why it would change).
Settings / my device / language and input / voice search /
make sure there is a checkmark next to "hotword detection" for ok google
electricpete is offline  
Reply With Quote
Old January 26th, 2014, 10:18 PM   #5 (permalink)
Member
 
AeolianReflex's Avatar
 
Join Date: Jul 2010
Location: Southern California
Gender: Male
Posts: 388
 
Device(s): Samsung Galaxy S4
Carrier: Verizon

Thanks: 41
Thanked 60 Times in 36 Posts
Default

I had the same problem. The prompt in the search bar "Say Ok Google" was missing. I went into settings > applications and cleared the cache for Google Search and haven't had the problems since.
AeolianReflex is offline  
Reply With Quote
Old January 27th, 2014, 09:52 AM   #6 (permalink)
Member
 
Join Date: Jan 2011
Location: Staffordshire, UK
Posts: 259
 
Device(s): Galaxy S4 AP:I9505XXUDMH8. Galaxy Tab SM-T800. Galaxy Tab 101 Original Three Samsung laptops
Carrier: EE

Thanks: 7
Thanked 17 Times in 15 Posts
Default

Perhaps look here
How to use 'OK Google' voice command to use Voice Search on Android phone - PC Advisor
wunay is offline  
Reply With Quote
Old February 19th, 2014, 03:03 PM   #7 (permalink)
New Member
 
Join Date: Feb 2014
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Interfering app

This has been driving me nuts for weeks. Finally spent a bit of time on it and found the conflict (which in hindsight makes sense). I have MacroDroid installed and set to read my texts to me when I have headphones connected.
After trying all the other things people have recommended, I turned off my macros in MacroDroid. Still no "OK Google" option and the microphone was an outline. I uninstalled MacroDroid and "OK Google" worked and the microphone symbol in the Google Search box is filled in (i.e. All grey)! (note - it does not say "OK Google" in the search box, as I guess I passed the number of training searches before this goes away, but saying "OK Google" works.)
I then reinstalled MacroDroid and turned on my macros and it still works. So, check if you have any apps that have voice notifications and try uninstalled them, checking if "OK Google" works and then reinstalling them.
Hope this helps someone else.
fezzik is offline  
Reply With Quote
Old July 29th, 2014, 12:07 PM   #8 (permalink)
New Member
 
Join Date: Jul 2014
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Apps

My "ok google" was working great when I first got the Galaxy S5. I installed several apps into it that I had on my S3 and missed them. Next thing I know my "ok google" wasn't working! I played around with shutting down or removing many apps but it still didn't work. Then it dawned on me, I also put back the missing app that the Galaxy S3 used to have called " Active Weather Wallpaper ". I changed the wallpaper to one of the stock ones in the phone and everything was working again. This app when running was blocking the "ok google" from listening.

Quote:
Originally Posted by androidguy011 View Post
For some reasons, the "ok google" voice activation is not working on my s4. Anyone else have this problem. It was working fine until a few days ago. I try restart and reboot my phone, active the hotword and everything, and the google voice activation still not working. After I ask "ok google" once, the mic becomes hallow and I can't voice activate it again. Any help is appreciate it!
Mcgiveral is offline  
Reply With Quote
Reply

Samsung Galaxy S4
Current Rating:
Rate this Phone:

The all-new Samsung Galaxy S4 is all but guaranteed to be the next top-selling device. The new device is dubbed the "Life Companion" due to its intuitive features. The Galaxy S4 sports a 5-inch 1080p Super AMOLED display, an awesome 13 MP... Read More



Go Back   Android Forums > Android Phones > Samsung Galaxy S4
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:22 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.