Go Back   Android Forums > Android Phones > Orange San Francisco (ZTE Blade) > San Francisco - All Things Root

test: Reply
 
LinkBack Thread Tools
Old April 23rd, 2011, 04:19 AM   #1 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default Gen2 - Please Read

Gen2 refers to the new partition layout used on ZTE Blades with Froyo
It increases the Recovery and Boot partitions to more reasonable sizes, and crucially, updates the Radio firmware giving HSDPA, stronger reception, and 850MHz support

However this breaks compatibility with Gen1 ROMs
There are two Gen2 ROMs; Swedish Spring (Android 2.2, based on Swedish Froyo update), and CyanogenMod7 (Android 2.3.4, Community built Android distribution)

If your Blade came with Android 2.1, its probably Gen1 - in doubt? Ask Mr Pigfish (Android app)

Updating or not? See Below

Advertisements
ElasticNinja is offline  
Last edited by ElasticNinja; May 19th, 2011 at 12:32 PM.
Reply With Quote
sponsored links
Old April 23rd, 2011, 04:19 AM   #2 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

Updating to Gen2

Here is the safest way, no need for computer, and unlike the Windows based update, keeps TPT, and allows for easy downgrade to Gen1
http://forum.xda-developers.com/showthread.php?t=1258855

This is the best way to upgrade
ElasticNinja is offline  
Last edited by El Presidente; October 3rd, 2012 at 04:13 PM.
Reply With Quote
The Following User Says Thank You to ElasticNinja For This Useful Post:
squitten (April 25th, 2011)
Old April 23rd, 2011, 04:20 AM   #3 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

I don't want to update to Gen2
- What does this mean for me?

It means you wont have the latest Radio, and a partition layout designed for Android 2.1

It also means that you can't use CyanogenMod7 (Post Nightly 40) officially , however by patching it with Kallt_Kaffe's Converter you can (do not file bug reports if you use this)
ElasticNinja is offline  
Last edited by ElasticNinja; April 23rd, 2011 at 04:34 AM.
Reply With Quote
Old April 24th, 2011, 04:16 AM   #4 (permalink)
Junior Member
 
squitten's Avatar
 
Join Date: Dec 2010
Location: UK
Gender: Male
Posts: 94
 
Device(s): Samsung Galaxy s3 Mini, Samsung Galaxy Tab 8.9.
Carrier: o2

Thanks: 12
Thanked 15 Times in 14 Posts
Default

Quote:
Originally Posted by shadowninty View Post
Updating to Gen2

Here is the safest way, no need for computer, and unlike the Windows based update, keeps TPT, and allows for easy downgrade to Gen1
Gen1 to Gen2 TPT upgrade

This is the best way to upgrade
I've tried it & it works a treat!!

I've installed Swedish Spring RLS 5 ROM on my phone for now & it said my phone was GEN 2 on CWM when installing. I was gonna switch to CM7 but people are still having problems with the latest nightly's!!

Thanx shadowninty for sharing!!
squitten is offline  
Reply With Quote
The Following User Says Thank You to squitten For This Useful Post:
ElasticNinja (April 24th, 2011)
Old April 24th, 2011, 06:08 AM   #5 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

no problem!
I really regret not waiting as I could've kept TPT
ElasticNinja is offline  
Reply With Quote
Old April 25th, 2011, 08:59 AM   #6 (permalink)
Junior Member
 
squitten's Avatar
 
Join Date: Dec 2010
Location: UK
Gender: Male
Posts: 94
 
Device(s): Samsung Galaxy s3 Mini, Samsung Galaxy Tab 8.9.
Carrier: o2

Thanks: 12
Thanked 15 Times in 14 Posts
Default

Quote:
Originally Posted by shadowninty View Post
no problem!
I really regret not waiting as I could've kept TPT
I guess you did it using windows then??

BTW there's a new stable version of CM7 been released for GEN 2 phones today!!
squitten is offline  
Reply With Quote
Old April 25th, 2011, 12:52 PM   #7 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

Quote:
Originally Posted by squitten View Post
I guess you did it using windows then??
yup

Quote:
Originally Posted by squitten View Post
BTW there's a new stable version of CM7 been released for GEN 2 phones today!!
Yeah read it on Phandroid
GPS fixed apparently
ElasticNinja is offline  
Reply With Quote
Old April 25th, 2011, 01:37 PM   #8 (permalink)
Junior Member
 
squitten's Avatar
 
Join Date: Dec 2010
Location: UK
Gender: Male
Posts: 94
 
Device(s): Samsung Galaxy s3 Mini, Samsung Galaxy Tab 8.9.
Carrier: o2

Thanks: 12
Thanked 15 Times in 14 Posts
Default

Quote:
Originally Posted by shadowninty View Post
yup



Yeah read it on Phandroid
GPS fixed apparently
I got it on my phone right now, all seems good so far but I can't comment on GPS don't use it!!
squitten is offline  
Reply With Quote
Old April 28th, 2011, 05:25 AM   #9 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

If i'm a Gen 1 with Sweedish 2.2 If I go to Gen 2 do I then need to install Sweedish Spring as well??
Lupine_smurf is offline  
Reply With Quote
Old April 28th, 2011, 06:49 AM   #10 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

Quote:
Originally Posted by Lupine_smurf View Post
If i'm a Gen 1 with Sweedish 2.2 If I go to Gen 2 do I then need to install Sweedish Spring as well??
Swedish Spring or CyanogenMod 7
ElasticNinja is offline  
Reply With Quote
sponsored links
Old June 17th, 2011, 05:30 PM   #11 (permalink)
Senior Member
Thread Author (OP)
 
ElasticNinja's Avatar
 
Join Date: Aug 2010
Location: Cork City, IMF, EU
Posts: 4,488
 
Device(s): Galaxy S3 Mini, ZTE Blade
Carrier: Not Provided

Thanks: 811
Thanked 460 Times in 408 Posts
ciaranhurley0@gmail.com
Default

Thanks to hedgepigdaniel and wbaw I now have TPT enabled on my phone
ElasticNinja is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Orange San Francisco (ZTE Blade) > San Francisco - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:54 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.