Go Back   Android Forums > Android Phones > Sony Ericsson Xperia Mini

test: Reply
 
LinkBack Thread Tools
Old December 23rd, 2011, 10:08 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with WiFi

Hi all! I recently bought a Xperia Mini, however, there are problems when i try to connect to wireless networks.

At home the phone loses connection about every half minutes for a few secs, starts searching a network and reconnects. Meanwile my wife's LG has no such problems.

At work it's even worse. The signal is worse than on other phones and it keeps disconnecting nearly every 10-15 seconds, so its really useless.

Any ideas? Or should i return it to the store (which I dont really want, i started really liking this phone). Oh, and leave me alone with those 'set sleep policy to never' type of advice.

Thanks in advance.

Advertisements
somerandomname is offline  
Reply With Quote
sponsored links
Old December 23rd, 2011, 10:27 AM   #2 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,222
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,326
Thanked 16,329 Times in 8,738 Posts
Default

Welcome to AF!

Do you have 3G on in the background? On some handsets, if the phone thinks it can get a better connection to the net, it will cut off WiFi and use the 3G connection instead. try and make sure that when connected to WiFi, you turn of Mobile Network in Settings -> Wireless & Networks and see if that makes a difference.

Also, assigning yourself a static IP can make the connection a bit more stable, have you tried that? If you need instructions on that, let me know.
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is offline  
Reply With Quote
Old December 23rd, 2011, 10:38 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

3G is disabled, and I have already tried assigning a static IP at home, but it makes no difference unfortunately.
somerandomname is offline  
Reply With Quote
Old December 23rd, 2011, 10:41 AM   #4 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,222
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,326
Thanked 16,329 Times in 8,738 Posts
Default

I'm not sure what else to suggest then, sorry.

Do you have any 3rd party apps installed which might potentially control connectivity? I'm thinking Juice Defender/Green Power etc?
El Presidente is offline  
Reply With Quote
Old December 23rd, 2011, 10:45 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope, it's 2 weeks old and I didn't install any apps like that. I was hoping somebody had the same problem as I do, but I guess it will be a hardware problem then.
somerandomname is offline  
Reply With Quote
Old December 23rd, 2011, 11:14 AM   #6 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,222
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,326
Thanked 16,329 Times in 8,738 Posts
Default

It might be a software issue, I don't actually have the handset, I was just looking through the unanswered threads and stumbled across this. Generally the fixes I suggested work across a number of handsets.

Someone who owns the handset might be able to chime in before you take it back though.
El Presidente is offline  
Reply With Quote
Old December 23rd, 2011, 02:51 PM   #7 (permalink)
Member
 
Josh-SonyXperia's Avatar
 
Join Date: Feb 2011
Posts: 389
 
Device(s): Sony Xperia™ S, Xperia™ Arc, Play & Neo
Carrier: Not Provided

Thanks: 5
Thanked 65 Times in 61 Posts
Default

As suggested by El Presidente this might be a software problem. I'd suggest to run the Repair Phone option on the PC Companion, this might solve the issue and if it doesn't then you know that you need to either bring the phone back to the store where you bought it to have it replaced or to a Sony Ericsson service center so it could be evaluated be a repair technician.
Josh-SonyXperia is offline  
Reply With Quote
Reply

Sony Ericsson Xperia Mini
Current Rating:
Rate this Phone:

Sony Ericsson is following the Xperia X10 Mini up with a device that's just as small but not nearly as weak. Beneath the hood, it can stand toe-to-toe with some of the highest of high-end devices. It has a 1GHz processor inside, a camera that c... Read More

Tags
wifi problem disconnect


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia Mini
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:26 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.