Go Back   Android Forums > Android Phones > Sony Ericsson Xperia Pro

test: Reply
 
LinkBack Thread Tools
Old March 13th, 2013, 07:09 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Connection Issues with a newly purchased Xperia Pro?

Hi, I had previously bought one and it worked great. I loved the phone, but due to some water damage it finally died on me. I recently purchased a new one off a friend, which was listed as unlocked. After putting the SIM card in, it seems to work great, although after usage I have discovered the network randomly cuts out. It will drop calls, or not let me make them at all. The data won't work. I am on Rogers, I even purchased a new SIM card, but can't figure out the issue. A friend seemed to think that it is "simlocked" and im lucky to get signal at all. Another thought I had was a faulty antenna. Any ideas? Any help is greatly appreciated!

Advertisements
krazyglue is offline  
Last edited by krazyglue; March 13th, 2013 at 07:15 PM.
Reply With Quote
sponsored links
Reply

Sony Ericsson Xperia Pro
Current Rating:
Rate this Phone:

Sony Ericsson launched their Xperia line with the high-end Xperia X10. While the "Mini" versions offered both keyboard (Xperia Mini Pro) and non-keyboard options (Xperia X10 Mini), the high-end X10 was touchscreen only. Until now. The S... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia Pro
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:37 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.