Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini Pro

test: Reply
 
LinkBack Thread Tools
Old July 20th, 2010, 01:33 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Touchscreen stops responding

Hey all,

Has anyone had any problems with their touchscreen not responding occasionally? I've only had my X10 mini pro for a day and it's done it like 4 times already.

I don't seem to see a pattern to when it occurs - usually it's after you wake it up from sleep, and the touchscreen doesn't respond anymore. hardware buttons and the keyboard works, but not the touchscreen.

I've been using the power button + keyboard to shutdown and restart the phone as a workaround but it's getting kinda annoying.


Thanks!

Advertisements
cuteseal is offline  
Reply With Quote
sponsored links
Old July 23rd, 2010, 01:45 PM   #2 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've got the same problem and no solution yet!
Please let me know if you find something about that..
vancal is offline  
Reply With Quote
Old July 24th, 2010, 05:44 AM   #3 (permalink)
Member
 
Join Date: Apr 2010
Location: UK
Posts: 388
 
Device(s): Too many (but they're not all mine!)
Carrier: Not Provided

Thanks: 1
Thanked 72 Times in 50 Posts
Default

Is it the whole screen or part of it? I've had two problems; sometimes I can't press easily at the bottom of the screen.

The other is the touchscreen not working at all, but needing a reset. However, this wasn't the X10 mini pro, but the HTC Magic (on Android 1.5) which makes me wonder if it's an OS problem - something to do with coming out of sleep/standby.

It's a rare problem but one that might happen for a single purpose, and you've each got a similar setup and suffer it regularly while others don't suffer it at all.

Sorry I can't actually help solve the problem, but it might give some pointers on how to get it fixed (or 2.1 may do so).
__________________
Editor of What Mobile magazine (www.whatmobile.net)
jonmorris is offline  
Reply With Quote
Old July 24th, 2010, 07:05 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey guys, glad I'm not the only one. It's the whole touchscreen that's not responding. It's quite weird - I find that when I put the phone down on a flat surface - e.g. desk at work and then come back to it about 30 mins or an hour later, the phone turns on but doesn't respond to touchscreen presses. I find it happens as well when I put it on my bedside, and wake up the next morning.

I have to restart the phone again, and then it works normally. If the phone is off for just for a short period, like a few minutes in my pocket, I find I have no problems.

To me it sounds like a software problem but (1) I have done a factory reset multiple times, and even not changing any settings whatsoever, no SIM card in even - the problem keeps occurring. Also (2) if it's the software, then how come not more people are affected by it / complaining about it?

I have tried to do a software update, but it says it's the latest version.

More info if it helps:

Model: U20i
Firmware version: 1.6
Kernel version: SEMCUser@SEMCHost #1
Build number: 1.1.A.0.8

Appreciate any further tips!
cuteseal is offline  
Reply With Quote
Old July 28th, 2010, 05:33 AM   #5 (permalink)
Junior Member
 
spatuluk's Avatar
 
Join Date: Jun 2010
Location: Manchester, UK
Posts: 50
 
Device(s): Sony Xperia X10 Mini Pro
Carrier: Not Provided

Thanks: 2
Thanked 2 Times in 1 Post
Send a message via MSN to spatuluk Send a message via Skype™ to spatuluk
Default

It shouldn't be freezing after a factory reset and nothing else going on.. Have you installed any apps? Is GPS turned on? Have you set up WiFi or an email address?

It sounds like it might be a faulty touchscreen, as mine's never locked up like that (had it about 3 weeks now). Mine does get a bit slow waking up, sometimes, but the screen starts responding after a couple of seconds. I think it might be JuiceDefender reactivating 3G, and all the programs waking up and trying to send and receive their data.
spatuluk is offline  
Reply With Quote
Old July 29th, 2010, 12:52 AM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey thanks for the reply.

Yes, even if I do a factory data reset, with the SIM card out, and don't change any settings, it still occurs. (i.e. everything is as if I had just taking it out of the box)

Anyway, I'm returning my unit for a replacement. Wish me luck!
cuteseal is offline  
Reply With Quote
Old July 29th, 2010, 11:21 AM   #7 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Mine does this too

Hmmm. I'll be interested to hear your experience once you get a replacement. Mine does exactly the same thing.
gadgetjunkie is offline  
Reply With Quote
Old August 1st, 2010, 10:34 PM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm so apparently at least 3 people have this issue so far. Just wondering where everyone purchased theirs from? I wonder if it's a bad batch or something.

Those with problems - what are you doing to get around it? Are you just putting up with it and doing a reset each time?

I bought mine from ebay - I think the seller was from Hong Kong. Hope I don't get a dodgy replacement...
cuteseal is offline  
Reply With Quote
Old August 6th, 2010, 04:36 AM   #9 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there

Has anyone managed to resolve this? I've had my phone for 3 weeks now and the freezing thing is getting quite irritating now. It doesn't seem to freeze during work hours, but it bloody hopeless outside of work. I have tried everything with the settings.
davidking is offline  
Reply With Quote
Old August 6th, 2010, 06:35 AM   #10 (permalink)
Member
 
Join Date: Apr 2010
Location: UK
Posts: 388
 
Device(s): Too many (but they're not all mine!)
Carrier: Not Provided

Thanks: 1
Thanked 72 Times in 50 Posts
Default

Do the firmware upgrade and the problem should go away.

See here: X10 mini pro firmware update
jonmorris is offline  
Reply With Quote
sponsored links
Old September 9th, 2010, 10:04 AM   #11 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've had the problem that the lower part of the screen, specifically the X in the right corner with the keyboard folded out, to close the "language input bar", often is incredibly annoying to hit properly.

It does not appear to be a problem with the hardware... if I load for instance a paint application response is great in that corner. As is the mainscreen button on the lower left if I hold it in vertical mode.

Very weird...
grape is offline  
Reply With Quote
Old April 24th, 2012, 02:01 PM   #12 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Registering McAfee or uninstalling it would solve ur Touch Screen Problem on Sony Ericsson Xperia.
droidmasterkk is offline  
Reply With Quote
Old May 3rd, 2012, 10:06 AM   #13 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anybody have the problem where they touch the screen and it only pulls the top info bar down?
bigamzz is offline  
Reply With Quote
Old May 15th, 2012, 05:09 AM   #14 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey, touch screen is not working on some area like top right, left corner & middle sometimes. i had restored factory setting but no improvement. i have purchased a month back & troubleshooting from last couple of days. could you pls advise me what i should do to get rid. also notification bar on the top is not working.
Mamun Rahman is offline  
Reply With Quote
Old March 15th, 2013, 12:09 PM   #15 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey,

i have the same problem. but my phone is a Xperia Ray
the touch screen seems not responding to my finger touches when typing a message, url, tel no etc. if i stay for about 5sec and click it then one letter gets typed. but when i try to type a lot of letters in a normal speed some of the letters dnt get typed. i have been using this phone for about 8 months. I run ICS
I tried resetting the phone, offing and oning, shaking the phone can any of you guys help me on this????
CarlyleZ is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10 Mini Pro
Current Rating:
Rate this Phone:

The Xperia X10 Mini Pro is exactly the same as the X10 Mini but theres one clear difference - the Pro has a full slideout QWERTY keyboard. The X10 mini and Pro are the younger and more pocketable versions of the original Xperia X10 having a smaller... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini Pro
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.