Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini Pro

test: Reply
 
LinkBack Thread Tools
Old November 24th, 2011, 02:45 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Sony Ericsson Xperia Mini Pro WiFi Internet Problem

Hello, I just got a Sony Ericsson Xperia x10 mini pro. I had a very old phone before so i am not very familiar with all these apps and features on this Sony phone.

The first day I was able to use the internet through Wi-Fi ( I think... ). I stop using the next day because I was afraid of paying for all the data because I don’t have a data plan.

Since I don’t have a data plan, I was told I would not get charge for using internet through Wi-Fi. I read some where that for safety, I can call my cell phone company and disable the data completely so I didn’t accidentally use any data and get charge for it.

Now, here’s the problem. After calling in the company to disable any data service, I cannot connect to internet. I didn’t change any settings. There are only three network name under “Wi-Fi network” I saw the name of my home network. So I punch in the WEP key. The status of the connection is “Fair”

I try to Google something to test the internet and I get this message “ Data connectivity problem --- The server failed to communicate. Try again later.”

The icon on the top of the phone with the “E” appeared with the up and down arrow going on and off.

PS: On my phone under

setting> Wi-Fi >>>checked.
mobile network> the data traffic>>>>> checked.


Was I wrong to call the company to disable the data completely. I don’t get it, was I using Wi-Fi before I did this?

I need help.

Advertisements
wflead is offline  
Reply With Quote
sponsored links
Old November 24th, 2011, 03:09 PM   #2 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,270
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,352 Times in 8,751 Posts
Default

Welcome to AF!

If you've got an E, that looks like Data is enabled. Uncheck the mobile network -> data traffic and see if that changes things.
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is online now  
Reply With Quote
Old November 24th, 2011, 03:22 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by El Presidente View Post
Welcome to AF!

If you've got an E, that looks like Data is enabled. Uncheck the mobile network -> data traffic and see if that changes things.
Thank you I went ahead and try what you told me.

I unchecked the data traffic and E symbol with the up and down arrow is gone. Then i went to the browser and it said " Web page not available."

Thank you for your help, do u have another suggestions. I would greatly appreciate it.
wflead is offline  
Reply With Quote
Old November 24th, 2011, 03:25 PM   #4 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,270
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,352 Times in 8,751 Posts
Default

On your phone, can you see an option to assign yourself a static IP address?

If you head into the WiFi Settings, Click Menu, then Advanced, is there anything on that page which says "Static IP"?
El Presidente is online now  
Reply With Quote
Old November 24th, 2011, 09:17 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by El Presidente View Post
On your phone, can you see an option to assign yourself a static IP address?

If you head into the WiFi Settings, Click Menu, then Advanced, is there anything on that page which says "Static IP"?
Yes, i found under Wi-Fi setting>>> Advance>>> "Use Static IP"

But it is not checked.

Should I check it?
wflead is offline  
Reply With Quote
Old November 25th, 2011, 04:39 AM   #6 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,270
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,352 Times in 8,751 Posts
Default

Yeah, no harm in giving it a shot. You'll need to enter some info though. It will relate to your home network. Do you know whats required or do yo want a walk through?
El Presidente is online now  
Reply With Quote
Old November 25th, 2011, 10:23 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by El Presidente View Post
Yeah, no harm in giving it a shot. You'll need to enter some info though. It will relate to your home network. Do you know whats required or do yo want a walk through?
A walk through would be great.

Thank you
wflead is offline  
Reply With Quote
Old November 26th, 2011, 04:07 AM   #8 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,270
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,352 Times in 8,751 Posts
Default

Here you go: desire hd wifi problem

It's for a different phone, but it should be roughly the same procedure.
El Presidente is online now  
Reply With Quote
Old November 30th, 2011, 06:03 AM   #9 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s): HTC Desire HD, Sony Xperia K10 mini pro
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default I also have a very similar problem.

These didn't work for me. Can anyone please detail me what to do?

My xperia k10 mini is detecting my home wifi. but after the message "Connecting" it is showing disconnected. Password for my wifi given in the phone is also correct.
gopu18 is offline  
Reply With Quote
Old March 27th, 2012, 02:43 PM   #10 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i faced this problem today and found that this issue Related with router so you have to Disable MAC address in wireless setting and it will be work !
in shaa Allah = Allah willing,
shreteh is offline  
Reply With Quote
sponsored links
Reply

Sony Ericsson Xperia X10 Mini Pro
Current Rating:
Rate this Phone:

The Xperia X10 Mini Pro is exactly the same as the X10 Mini but theres one clear difference - the Pro has a full slideout QWERTY keyboard. The X10 mini and Pro are the younger and more pocketable versions of the original Xperia X10 having a smaller... Read More

Tags
internet problem, sony ericsson, sony ericsson xperia mini pro, wifi access, wifi problem


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini Pro
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:40 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.