Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini

test: Reply
 
LinkBack Thread Tools
Old September 2nd, 2010, 01:26 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default xperia x10 mini - mobile internet not working

Hello,
I got my sony ericsson xperia x10 mini couple of weeks ago and only thing I`m struggling with is mobile internet. I am able to turn it on (3G sign appears on the top) and I can browse the internet by browser but I am not able to use market,facebook,twitroyd,maps...basically, any other application except internet browser. However, when I connect to wifi, everything works just perfect. I dont know where the problem is, can anybody help me pls?

Advertisements
yarin66 is offline  
Reply With Quote
The Following User Says Thank You to yarin66 For This Useful Post:
saharan.balbir (November 10th, 2010)
sponsored links
Old September 4th, 2010, 06:47 AM   #2 (permalink)
cfc
Junior Member
 
Join Date: Jul 2010
Posts: 49
 
Device(s):
Carrier: Not Provided

Thanks: 5
Thanked 2 Times in 2 Posts
Default

i think you need to switch on background data, you need it to use the market app
cfc is offline  
Reply With Quote
Old September 4th, 2010, 08:41 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

actually,I have it on and it makes no difference at all...
yarin66 is offline  
Reply With Quote
Old February 23rd, 2011, 02:51 AM   #4 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default same

Same issue with my mini pro . I hope there is a solution, I will search for it..
szveronika is offline  
Reply With Quote
Old February 23rd, 2011, 03:04 AM   #5 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default SIM card

I found on another forum that they asked their provider to change SIM card and it works well. Some old sim cards cause this problem. I will try also.
szveronika is offline  
Reply With Quote
Old April 28th, 2011, 01:38 AM   #6 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Cry

Exactly the same problem here. GPRS is active, background data is on. Internet browser works, but not the applications.

My SIM card is old though (a "Hutch" printed SIM card). That might be a problem. I'll get it changed.

Hope it works.
coolprosu is offline  
Reply With Quote
Old April 28th, 2011, 11:32 AM   #7 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,
Finally I didn't change my SIM. I called my provider they told me the exact internet settings which I already tried to setup.
Then I have setup again everything how they said and reboot my phone (!!) and it worked well!! Now everything works great.
My SIM also an old one so maybe this is not the problem.
Good luck.

Quote:
Originally Posted by coolprosu View Post
Exactly the same problem here. GPRS is active, background data is on. Internet browser works, but not the applications.

My SIM card is old though (a "Hutch" printed SIM card). That might be a problem. I'll get it changed.

Hope it works.
szveronika is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10 Mini
Current Rating:
Rate this Phone:

The Xperia X10 Mini is exactly what it says on the tin - a "mini" version of the original S.E X10. We first come across this bitesize handset when pictures leaked back in January 2010, at the time it was codenamed "Robyn" but wh... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10 Mini
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:09 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.