Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 25th, 2010, 01:16 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 131
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 2 Times in 2 Posts
Default LED Flash

Hi All,

Got my Xperia X10 a few days back, and although I think its not exactly the most user friendly phone, Im finding my way around it, and hoping I havent made a mistake... Love the look and feel of the phone but have a few complaints that most people have...

Soooo, That being said, does anyone know how the heck I can activate or turn on the LED flash? I have tried Googling but cannot seem to come up with anything. One post said I must go to advanced settings, which I cannot find for love or money :-)

Thanks a million guys,

Lee

Dbnguy is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 02:09 PM   #2 (permalink)
Member
 
frankbonatelli's Avatar
 
Join Date: May 2010
Location: Kelowna, BC Canada
Posts: 203
 
Device(s): Motorola Droid PRO
Carrier: Not Provided

Thanks: 24
Thanked 30 Times in 26 Posts
Send a message via Yahoo to frankbonatelli randy.lloyd
Default

The LED flash dose not function as a flash when needed for fotos. Its an on or off flash activated from camera settings when in camera app. Haveing said this tho I have just updated to the German frimware R2BA020 and the flash is now set as an as needed option with Vignette camera app that I purchased but it stil is an on or off only.
__________________
"People not things effect change."
Steve needs to learn this, ditch the iPhone for an open world.
Android - Linux for the people.
The Techno Mage

Moto D PRO | HTC DhD | NOOK COLOR cm7bt
frankbonatelli is offline  
Reply With Quote
Old June 25th, 2010, 03:06 PM   #3 (permalink)
New Member
 
Join Date: Apr 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't think LED flash is capable on 1.6 which is what the Xperia is on, But it will be available when it gets 2.1
corruptfate is offline  
Reply With Quote
Old June 25th, 2010, 05:44 PM   #4 (permalink)
Member
 
Join Date: May 2010
Location: Edmonton, Alberta, Canada
Posts: 191
 
Device(s): Samsung Galaxy S3 (Pebble Blue 16GB) Sony-Ericsson Xperia X10A
Carrier: Not Provided

Thanks: 4
Thanked 24 Times in 23 Posts
Default

Quote:
Originally Posted by corruptfate View Post
I don't think LED flash is capable on 1.6 which is what the Xperia is on, But it will be available when it gets 2.1
This. Though as was mentioned it seems the latest update allows flash to be used with the Vignette app but not the stock app which is limited by the Android 1.6 as corrupt has already mentioned.

Also, you can get an app that is aptly named Xperia Flashlight which gives you a widget that allows you to toggle the light on/off from the Home screen. I have used this instead of having to go into the Camera Settings every time I want to use it.
JDwan is offline  
Reply With Quote
Old June 25th, 2010, 06:53 PM   #5 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

Quote:
Originally Posted by JDwan View Post
Also, you can get an app that is aptly named Xperia Flashlight which gives you a widget that allows you to toggle the light on/off from the Home screen. I have used this instead of having to go into the Camera Settings every time I want to use it.
Thats odd as mine does not do that it just turns the light off and when I go back the light is still off but the widget thinks its on???

Unless it's down to mine being branded I and yours is A but I just thought it was the antenna hardware that was the only change between the two.

What build number are you on? I'm on R1FA014.
powerkiter is offline  
Reply With Quote
Old June 25th, 2010, 08:01 PM   #6 (permalink)
Member
 
Join Date: May 2010
Location: Edmonton, Alberta, Canada
Posts: 191
 
Device(s): Samsung Galaxy S3 (Pebble Blue 16GB) Sony-Ericsson Xperia X10A
Carrier: Not Provided

Thanks: 4
Thanked 24 Times in 23 Posts
Default

Quote:
Originally Posted by powerkiter View Post
Thats odd as mine does not do that it just turns the light off and when I go back the light is still off but the widget thinks its on???

Unless it's down to mine being branded I and yours is A but I just thought it was the antenna hardware that was the only change between the two.

What build number are you on? I'm on R1FA014.
Weird. It sounds like that is the only difference (I vs. A) as I am also on that firmware. When do you turn on the light? Before or after opening the Camera app?

EDIT: Actually upon rechecking this......you're right, the widget still thinks it's on but the light shuts off as soon as the Camera app loads. So, I guess, disregard my previous post unless you're looking for a good flashlight app for your X10.
JDwan is offline  
Last edited by JDwan; June 25th, 2010 at 09:37 PM.
Reply With Quote
Old June 26th, 2010, 01:45 AM   #7 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 131
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 2 Times in 2 Posts
Default

Well you guys are all still much "clever'er" than me LOL Ive just figured out that what ever app I go into, all I need to do is press settings hardware key and they come up.

Gawd what a moron I am :-p FINALLY I now have a phone im starting to understand, and actually, its really not as bad as I thought. Starting to love it now...

You guys downloaded SWYPE yet??? AWESOME App, that makes using the keypad such a breeze???

Lee
Dbnguy is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:24 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.