Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

test: Reply
 
LinkBack Thread Tools
Old June 28th, 2010, 07:19 AM   #1 (permalink)
fuf
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Bluetooth and wifi problem

Welcome Everyone!
I have SE Xperia X10 for about a week and i have already encountered a problem with my wi-fi and bluetooth modules. They just won't turn on: error message "Unable to start wi-fi" appears all the time i try to turn it on. Simillar thing with bluetooth but there's actually even no error message, bluetooth is just "Turning on..." and it never does

I run on stock software with no possibility to update (probably no updates for my region; only option is manual update with software from other region, but the modules still don't work). I have to add that both wi-fi and bluetooth work several minutes after reset or after fixing it with Update Service. Then after few turning on and off procedures i cannot use it anymore. When i look in Settings>>About Phone>>Status there is something like that: Wi-Fi MAC adress Unavailable, Bluetooth adress Unavailable. The adresses are available for several minutes after reset, then it changes status to Unavailable and i can't turn them on again

I searched forums and found no information on possible solution for Xperia.
On one forum i was given an advice to bring phone to my operator service, and it can be problem with internal drivers. But before i'll do that i want to ask you guys if there is other solution? I don't want to wait a month or two before they fix it or give me a new phone.

Phone is of course new and on the guarantee.

I really appreciate any help.

Advertisements
fuf is offline  
Reply With Quote
sponsored links
Old June 28th, 2010, 09:24 AM   #2 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 93
 
Device(s): Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 20
Thanked 8 Times in 8 Posts
Default

You dont say were your from but if it was me I'd be bangging on the door of my service provider.
Dunc-x10 is offline  
Reply With Quote
Old June 28th, 2010, 09:31 AM   #3 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

Well if the phone is new why would you be waiting months to get it back?

If it's new then just go back to the shop and demand a replacement! Simple and no twatting about they sold you a faulty phone so it's up to them to replace it with a working one, well thats how it works in the UK.
powerkiter is offline  
Reply With Quote
Old June 28th, 2010, 09:44 AM   #4 (permalink)
fuf
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for replies! I'm from Poland. I hoped that this is software problem which can be repaired in home. But if You say i should demand a replacement then i will do that I'll probably have to wait some time. Here it isn't that simple. They will not give me new phone without complaiments i think, but it looks like it's the only way.
fuf is offline  
Reply With Quote
Old June 28th, 2010, 09:52 AM   #5 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

Just read a thread on here a few down from this one and apparently there is a bug which causes the issues you have and Sony Ericsson know about them so just ask for a replacement phone
powerkiter is offline  
Reply With Quote
Old June 28th, 2010, 10:03 AM   #6 (permalink)
fuf
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you very much for help!
fuf is offline  
Reply With Quote
Old June 28th, 2010, 10:38 AM   #7 (permalink)
Member
 
Join Date: Jun 2010
Posts: 180
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 25 Times in 23 Posts
Default

Yeah i've not heard of the Bluetooth one but there are some issues with wifi.

I walked into my phone shop the other day with my X10 and said its broken and they gave me a new one without even looking at it, or looking at my debit card or anything! As you say though, Poland may be more difficult
huntleth is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More

Tags
bluetooth, wi-fi, wifi, xperia x10


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:36 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.