Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old August 31st, 2010, 05:59 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 195
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 7 Posts
Default My Phone Restarted Itself Out of Nowhere - ?????

I was sitting at my work desk and my phone restarted itself out of nowhere. No updating was done, I was at 55% battery and it wasn't even touched. I was at my desk for about 30 minutes straight, it's laying face up and I saw the phone restart.

Any clue what is going on?

cwepruk is offline  
Reply With Quote
sponsored links
Old August 31st, 2010, 06:41 PM   #2 (permalink)
Member
 
wynney666's Avatar
 
Join Date: Jul 2010
Location: Sheffield, UK
Posts: 343
 
Device(s): HTC One X
Carrier: Not Provided

Thanks: 62
Thanked 34 Times in 32 Posts
Not Yet
Default

sorry no clues as to why, but mine does this too, quite often.
my thinking is it is an app causeing it, maybe like a blue screen in windows.
__________________
Scan my barcode and Support the cause
HTC ONE X [Stock ICS]
Sony X10i [Cyanogen6.1.3]gingerbread[v01]
Virgin Mobile UK
wynney666 is offline  
Reply With Quote
Old August 31st, 2010, 06:52 PM   #3 (permalink)
Member
 
Join Date: Apr 2010
Location: London city where the weather is bad and the attitudes shitty
Posts: 164
 
Device(s): X10 vodafone ggrrrrr
Carrier: Not Provided

Thanks: 10
Thanked 6 Times in 6 Posts
lol no no no
Default

this is kinda like what my vodafone one is experiencing.. charged up turns itself off turns back on by itself does this a few times then gets stuck at 1st sony erricsson screen then refuses to power up ggrrr voda have had it twice now last time they said they could find nothing wrong with it ggrrrrrrr they better fix it this time... either way vodafone have lost this customer come contract renewal as the customer care is appalling to be kind...
Hunted is offline  
Reply With Quote
Old August 31st, 2010, 11:06 PM   #4 (permalink)
Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 195
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 7 Posts
Default

Yeah, I think I noticed this 1-2 times before, but today it was right in my face and I hadn't touched it in a while.

I have had the phone freeze up a couple times in the last two weeks. One time required me to pull the battery. I hope that doesn't continue.
cwepruk is offline  
Reply With Quote
Old August 31st, 2010, 11:52 PM   #5 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: Alberta
Posts: 38
 
Device(s): Motorola Defy
Carrier: Not Provided

Thanks: 8
Thanked 0 Times in 0 Posts
Default

I experienced this and other (dropped calls) issues...did a factory reset, totally wiping the system and since that it has been solid. Battery life vastly improved as well.

I'm suspecting an (or some) apps I had installed, I put back everything I had prior except a launcher app and all the battery "helper"/task killer apps. Apparently they weren't "helping".

YMMV etc, but that was my experience.
bjack56 is offline  
Reply With Quote
Old September 1st, 2010, 01:50 AM   #6 (permalink)
Senior Member
 
gunny5821's Avatar
 
Join Date: Aug 2010
Location: Richmond, VA (USA)
Posts: 501
 
Device(s): Sony Ericsson Xperia X10a
Carrier: Not Provided

Thanks: 37
Thanked 30 Times in 25 Posts
Default

Quote:
Originally Posted by bjack56 View Post
I experienced this and other (dropped calls) issues...did a factory reset, totally wiping the system and since that it has been solid. Battery life vastly improved as well.

I'm suspecting an (or some) apps I had installed, I put back everything I had prior except a launcher app and all the battery "helper"/task killer apps. Apparently they weren't "helping".

YMMV etc, but that was my experience.
Curious, but what launcher were you using and what apps did you not reinstall? The reset you are referring to, is that the one from the settings screen? The reason I ask as that does not seem to erase everything, leaving some items in the internal phone memory.. ????
gunny5821 is offline  
Reply With Quote
Old September 1st, 2010, 07:57 AM   #7 (permalink)
Junior Member
 
Join Date: Jul 2010
Location: Alberta
Posts: 38
 
Device(s): Motorola Defy
Carrier: Not Provided

Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gunny5821 View Post
Curious, but what launcher were you using and what apps did you not reinstall? The reset you are referring to, is that the one from the settings screen? The reason I ask as that does not seem to erase everything, leaving some items in the internal phone memory.. ????
Yes, it was the reset in settings --> sd card and phone storage --> factory data reset.

Launcher was ADW+ ADWipad theme, the apps I remember (there were a few) ultimatejuice, systempanel, battery indicator pro, advanced task killer, k9 and maildroid email apps, handcent.

Also startup auditor but I re-installed it to keep timescape and moxier under control.

Like I said, could of been just me and a bad combo but all's well now.

Cheers!
bjack56 is offline  
Last edited by bjack56; September 1st, 2010 at 07:59 AM. Reason: remembered more apps...
Reply With Quote
Old September 1st, 2010, 09:46 PM   #8 (permalink)
Member
 
Join Date: Aug 2010
Location: Halifax, Nova Scotia
Posts: 204
 
Device(s): sony x10 lemon returned, former captivate on way out... ..i have a Galaxy S2 i am hoping 2 love
Carrier: Not Provided

Thanks: 27
Thanked 13 Times in 10 Posts
Default

mine does this...several times a day. simply turns itself off then reboots. Today everytime it got to the point of establishing service it would reboot again and again and again.
i finally got tired of hearing the noises as it powers up and had to remove the battery. then again its well known i got a lemon and am still fighting thru some other issues before i get it replaced...or not.
sharkhark is offline  
Reply With Quote
Old September 3rd, 2010, 05:44 AM   #9 (permalink)
Junior Member
 
Pigusmaximus's Avatar
 
Join Date: Jul 2010
Location: Ireland
Posts: 16
 
Device(s): Xperia x10
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Ya mine does this also, try removing the back cover and see if you smell a kind of burning smell? Thats what happened to mine. i sent it off for repair yesterday, o2 gave me an E65 as a temp phone.
Pigusmaximus is offline  
Reply With Quote
Old September 3rd, 2010, 03:03 PM   #10 (permalink)
Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 195
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 7 Posts
Default

Just did it three times in front of me. No clue why. I pulled the battery for a hard reset. Hopefully that helps.

I'm not sure what to do now since phone warranties are such a nightmare (send it off for 4 weeks and get stuff with a loaner POS).

Also, these restarts KILL battery life. I'm down from 95% to 48% since after about 8 hours. Before this issue, I went two days and still had 50%.
cwepruk is offline  
Last edited by cwepruk; September 3rd, 2010 at 04:35 PM.
Reply With Quote
sponsored links
Old September 5th, 2010, 02:06 PM   #11 (permalink)
Member
 
Join Date: Aug 2010
Location: Halifax, Nova Scotia
Posts: 204
 
Device(s): sony x10 lemon returned, former captivate on way out... ..i have a Galaxy S2 i am hoping 2 love
Carrier: Not Provided

Thanks: 27
Thanked 13 Times in 10 Posts
Default

Quote:
Originally Posted by cwepruk View Post
Just did it three times in front of me. No clue why. I pulled the battery for a hard reset. Hopefully that helps.

I'm not sure what to do now since phone warranties are such a nightmare (send it off for 4 weeks and get stuff with a loaner POS).

Also, these restarts KILL battery life. I'm down from 95% to 48% since after about 8 hours. Before this issue, I went two days and still had 50%.
i returned mine..had enough..i know one could argue that every brand has a few lemon units..but too many forums with half saying theirs work flawlessly dont understand the other half who have so many issues.
mine frustrated me to no end..its gone back..using a loaned older unit... until a new samsung captivate later this mth...comes out..........
sharkhark is offline  
Reply With Quote
Old September 5th, 2010, 04:45 PM   #12 (permalink)
Member
 
BingoRingo's Avatar
 
Join Date: Aug 2010
Location: Aylmer, Quebec
Posts: 399
 
Device(s): Galaxy S3 - SGH-T999
Carrier: Not Provided

Thanks: 6
Thanked 54 Times in 34 Posts
Default

Maybe it's just haunted?
BingoRingo is offline  
Reply With Quote
Old September 6th, 2010, 09:30 PM   #13 (permalink)
Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 195
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 7 Posts
Default

I pulled the battery and re-checked the sim/SD card. Now I've been going for a while and it's back to normal. Something must have been bumped out of place (or just a good hard restart is what it needed).
cwepruk is offline  
Reply With Quote
Old September 17th, 2010, 11:22 AM   #14 (permalink)
Member
 
Join Date: Jul 2010
Location: Toronto
Posts: 256
 
Device(s): Galaxy S Glide (Rogers), Xperia X10 (Rogers)
Carrier: Not Provided

Thanks: 16
Thanked 29 Times in 26 Posts
Default

My x10 just did this for the very first time.
Normally my phone is kept on 24/7 and I rarely reboot it.
The only thing I did was activate Moxier Mail with setting to link to my work email last night. I *think* it may of rebooted when an incoming call was coming.

I have startup auditor (works liks shat anyway unless you root), and Advanced Task killer. decided to uninstall the ATF for now to see how that goes.

But I think it's called a SMARTphone because it's learned to now shut off when my mother calls me when I normally avoid answering it. LOL They should call it Sony Ericsson Skynet Edition.
clockwork58 is offline  
Reply With Quote
Old September 17th, 2010, 11:57 AM   #15 (permalink)
Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 195
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 7 Posts
Default

Since that bad day, it has not happened once that I am aware of, so hopefully it was a case of the SIM/USB card or battery not sitting properly...hopefully.
cwepruk is offline  
Reply With Quote
Old September 17th, 2010, 12:03 PM   #16 (permalink)
Hiding behind a mystery
 
Roze's Avatar
 
Join Date: Jan 2010
Location: Where the Sakura grows
Posts: 9,847
 
Device(s): Moto Atrix [lovin'] Nexus One [Lost] LG Vu [Lost]
Carrier: Not Provided

Thanks: 809
Thanked 2,192 Times in 1,489 Posts
Default

If this is your first time, you shouldn't worry about it too much. If this starts to happen on a regular basis...then something is definitely wonk. My phone have randomlly shut down and restarted by itself a handful of times in the 6 months I've had it.
__________________
Sign up with Dropbox using my referral and get an additional 1/2GB on top of the 2GB you get for signing up http://db.tt/YbULMZX

Many thanks,
Roze
Roze is offline  
Reply With Quote
Old September 17th, 2010, 04:46 PM   #17 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 4 Times in 4 Posts
Default

Hello all just thought I'd give my tuppence on this one. After a week of my phone restarting every 30 minutes I finally tracked down the culprit. ADW Launchers latest version. I've switched back to the SE home app for about a week now and no crashes and better battery life. Yeah I lose the 5 home screens but at least my phone works! Don't forget peeps this only going to be for a week or so because 2.1 is coming! So ditch ADW and save your phone!
manxape is offline  
Reply With Quote
Old September 17th, 2010, 05:14 PM   #18 (permalink)
Member
 
Join Date: Jul 2010
Location: Toronto
Posts: 256
 
Device(s): Galaxy S Glide (Rogers), Xperia X10 (Rogers)
Carrier: Not Provided

Thanks: 16
Thanked 29 Times in 26 Posts
Default

Quote:
Originally Posted by manxape View Post
Hello all just thought I'd give my tuppence on this one. After a week of my phone restarting every 30 minutes I finally tracked down the culprit. ADW Launchers latest version. I've switched back to the SE home app for about a week now and no crashes and better battery life. Yeah I lose the 5 home screens but at least my phone works! Don't forget peeps this only going to be for a week or so because 2.1 is coming! So ditch ADW and save your phone!
I don't use nor have I never installed an ADW Launcher type app.

Prob just a glitch from the OS being on for so long. But hope it all gets solved when 2.1 gets released.
clockwork58 is offline  
Reply With Quote
Old September 18th, 2010, 01:33 AM   #19 (permalink)
Premium Member
 
rosered's Avatar
 
Join Date: Jul 2010
Location: UK
Posts: 2,129
 
Device(s): X8, X10, Xperia Neo T-Mobile UK
Carrier: Not Provided

Thanks: 58
Thanked 316 Times in 273 Posts
Default

Mine does do it occasionally too. No idea why either. I just have an alarm on the sd card being initialized and thats what tends to alert me to the fact that the phone has reset itself.
rosered is offline  
Reply With Quote
Old September 19th, 2010, 06:10 AM   #20 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 4 Times in 4 Posts
Default

Damn it my phone has started playing up again! So much for clever ideas about unstalling adw! I hope 2.1 solves this problem or its getting sent back for fixing!
manxape is offline  
Reply With Quote
sponsored links
Old September 19th, 2010, 06:07 PM   #21 (permalink)
Member
 
Join Date: Jul 2010
Location: Toronto
Posts: 256
 
Device(s): Galaxy S Glide (Rogers), Xperia X10 (Rogers)
Carrier: Not Provided

Thanks: 16
Thanked 29 Times in 26 Posts
Default

I don't know if my phone reboot was the tip of the iceberg.
The past few days my phone has froze (momentarily) on the dialer screen and then it force closes. I reboot the phone after for it work again.

I've uninsalled any Task manager or startup auditor.
cleared out my call log.

Hope I don't have to do a repair on the OS.
clockwork58 is offline  
Reply With Quote
Old September 20th, 2010, 04:58 AM   #22 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 4 Times in 4 Posts
Default

Right well after my phone wouldnt swith on for longer than 5mins last night i did a reinstall of the os today. I will let you know if this works. Im also sending an email to se as i am slightly concerned about the smouldering / piney smell coming from the circuit board. Will let guys know if the reinstall works.
manxape is offline  
Reply With Quote
Old September 20th, 2010, 07:33 AM   #23 (permalink)
Junior Member
 
Join Date: May 2010
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 4 Times in 4 Posts
Angry

Quote:
Originally Posted by manxape View Post
Right well after my phone wouldnt swith on for longer than 5mins last night i did a reinstall of the os today. I will let you know if this works. Im also sending an email to se as i am slightly concerned about the smouldering / piney smell coming from the circuit board. Will let guys know if the reinstall works.

Well that didn't work. I have contacted SE and will be sending this bugger back for repairs. Fuming
manxape is offline  
Reply With Quote
Old September 20th, 2010, 08:57 AM   #24 (permalink)
Hiding behind a mystery
 
Roze's Avatar
 
Join Date: Jan 2010
Location: Where the Sakura grows
Posts: 9,847
 
Device(s): Moto Atrix [lovin'] Nexus One [Lost] LG Vu [Lost]
Carrier: Not Provided

Thanks: 809
Thanked 2,192 Times in 1,489 Posts
Default

Quote:
Originally Posted by manxape View Post
Right well after my phone wouldnt swith on for longer than 5mins last night i did a reinstall of the os today. I will let you know if this works. Im also sending an email to se as i am slightly concerned about the smouldering / piney smell coming from the circuit board. Will let guys know if the reinstall works.
Quote:
Originally Posted by manxape View Post
Well that didn't work. I have contacted SE and will be sending this bugger back for repairs. Fuming
Yeah, if a factory reset did not fix the problem, then it's the phone's stock hw/sw that's at fault. Hope SE fixes the phone and you get it back soon
Roze is offline  
Reply With Quote
Old January 9th, 2011, 10:32 PM   #25 (permalink)
Junior Member
 
Join Date: Jan 2011
Location: Houston/Baton Rouge
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by sharkhark View Post
mine does this...several times a day. simply turns itself off then reboots. Today everytime it got to the point of establishing service it would reboot again and again and again.
i finally got tired of hearing the noises as it powers up and had to remove the battery. then again its well known i got a lemon and am still fighting thru some other issues before i get it replaced...or not.
Just got my phone last week and since then its had this problem almost once a day.

But its not random. Almost always when im doing something on it. Like I was trying to snyc gmail and it crashed. Using ESPN game cast and it crashed.

and it will just restart and say I have no service. Then if I try to unlock it, screen will go black and say activating phone and wont do anything. I have to take the battery our 3-4 times before it starts up with service..

any update with you guys.
does 2.1 fix this?
BlownGP is offline  
Last edited by BlownGP; January 10th, 2011 at 05:50 PM.
Reply With Quote
Old January 10th, 2011, 03:15 AM   #26 (permalink)
Premium Member
 
rosered's Avatar
 
Join Date: Jul 2010
Location: UK
Posts: 2,129
 
Device(s): X8, X10, Xperia Neo T-Mobile UK
Carrier: Not Provided

Thanks: 58
Thanked 316 Times in 273 Posts
Default

I guess the first thing to try is running a repair/reset via PC COmpanion Support section. This will wipe your phone and hopefully clear any software glitch that is causing the issue. Make sure you have your contacts backed up to SD card or synced to Google/SE sync. Apps can be reinstalled from the market once you have set the phone up again.

If this doesn't work then I would return it for a replacement or at the very least a repair by the professionals. My phone does occasionally restart but it certainly is nothing like you have on yours, that is not how the device should be operating!
rosered is offline  
Reply With Quote
Old January 15th, 2011, 08:43 PM   #27 (permalink)
Junior Member
 
Join Date: Jan 2011
Location: Houston/Baton Rouge
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 6
Thanked 1 Time in 1 Post
Default

Well, said F today and went to ATT and got a new X10.

So far so good. Been messing with it all day and loading apps. Old I know would have reset by now...Must have been just a bad phone..
BlownGP is offline  
Reply With Quote
Old June 20th, 2011, 06:44 PM   #28 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,
I have had a x10, after 2 weeks of normal use, it started to reboot by itself, noticing it, I tried to stress it with apps using GPS, 3G and it shutdown. So I reset the system and stressed it the same way and the phone shutdown the same way with a smell burned plastic. I returned it to the provider specifying that I reset it and the phone would do the same so they replaced it with a new one.

Unfortunately, 3 months later, the new phone started to shutdown unexpectedly. The phenomenum happened the first time when using google maps (3G) and the GPS to find my way. Now, it does the same when I am playing a game for 30s. It is even faster to shutdown after some trials.

I guess it comes from an overheating of the processor which triggers an emergency shutdown from the system, in brief ; your phone is f****d.

We have three solutions:
- return the phone to the provider and try to get a different model
- dont use demanding apps and ask your way to real people
babounours is offline  
Last edited by babounours; June 20th, 2011 at 06:49 PM.
Reply With Quote
Old June 21st, 2011, 09:52 AM   #29 (permalink)
Hiding behind a mystery
 
Roze's Avatar
 
Join Date: Jan 2010
Location: Where the Sakura grows
Posts: 9,847
 
Device(s): Moto Atrix [lovin'] Nexus One [Lost] LG Vu [Lost]
Carrier: Not Provided

Thanks: 809
Thanked 2,192 Times in 1,489 Posts
Default

Quote:
Originally Posted by babounours View Post
Hello,
I have had a x10, after 2 weeks of normal use, it started to reboot by itself, noticing it, I tried to stress it with apps using GPS, 3G and it shutdown. So I reset the system and stressed it the same way and the phone shutdown the same way with a smell burned plastic. I returned it to the provider specifying that I reset it and the phone would do the same so they replaced it with a new one.

Unfortunately, 3 months later, the new phone started to shutdown unexpectedly. The phenomenum happened the first time when using google maps (3G) and the GPS to find my way. Now, it does the same when I am playing a game for 30s. It is even faster to shutdown after some trials.

I guess it comes from an overheating of the processor which triggers an emergency shutdown from the system, in brief ; your phone is f****d.

We have three solutions:
- return the phone to the provider and try to get a different model
- dont use demanding apps and ask your way to real people
Ouch That really sucks :/ How hot does it get before the phone shuts off? Playing a game for 30s...that's quite bad that your X10 can't handle just that much processing.
Roze is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:10 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.