Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

test: Reply
 
LinkBack Thread Tools
Old October 25th, 2010, 08:11 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Oct 2010
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Confused how to install the USB driver for sony ericsson x10

So i searched and cant seem to find the answer to my question, How do you installed the USB driver for Sony Ericsson x10?! I already downloaded SEMC_Android_Driver_Signed, i just dont know where to put the files, if they go any where at that, or how to install it. Please Help

Advertisements
luisells is offline  
Reply With Quote
sponsored links
Old October 25th, 2010, 08:18 AM   #2 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

All I did was plug the phone in via USB and let it auto install the drivers from the phone and that was it sorted
powerkiter is offline  
Reply With Quote
Old October 25th, 2010, 08:24 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Oct 2010
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

well im tryin to install the HTC keyword and one of the steps is to download that, so i download it. I honestly have no idea what it's for (even though i was able to access my folders on the phone before and after the installation).
luisells is offline  
Reply With Quote
Old October 25th, 2010, 10:07 AM   #4 (permalink)
Premium Member
 
rosered's Avatar
 
Join Date: Jul 2010
Location: UK
Posts: 2,129
 
Device(s): X8, X10, Xperia Neo T-Mobile UK
Carrier: Not Provided

Thanks: 58
Thanked 316 Times in 273 Posts
Default

If you want to install the drivers on to your PC, turn your phone off then plug in the USB into the PC and this should then start the phone and the PC will then 'see' it and install the drivers.
rosered is offline  
Reply With Quote
Old October 25th, 2010, 11:09 AM   #5 (permalink)
Member
 
ChudleyOne's Avatar
 
Join Date: Oct 2010
Location: Glendale, AZ
Posts: 113
 
Device(s): Pantech Discover, HTC Vivid, Sony Xperia X10, Velocity Micro Cruz T301, Lenovo IdeaPad A2109
Carrier: Not Provided

Thanks: 10
Thanked 12 Times in 11 Posts
Default

luisells - You're running into all the same issues I saw over the weekend while tweaking my new X10.

To get the phone recognized for the sideloader app, I had to install the SDK Tools - leave the phone plugged into USB & restart the computer. I had to do it on both my XP machine at work & my W7 machine at home.

If you run the loader.bat file directly (in the sideloader files), does it show you a serial number for your phone? When mine didn't, I had to get the SDK Tools. If yours already does, I'm not sure you need to get more drivers.
ChudleyOne is offline  
Reply With Quote
Old October 31st, 2010, 11:27 PM   #6 (permalink)
Member
 
highaltitude's Avatar
 
Join Date: Oct 2010
Posts: 241
 
Device(s): SE Xperia X10a AT&T
Carrier: Not Provided

Thanks: 8
Thanked 11 Times in 11 Posts
Default

I had the same problem, then I installed SDk and all was good. The Side Loader worked great yesterday. Now today my serial doesn't show up again. Is there any set way to get it to work all the time?
highaltitude is offline  
Reply With Quote
Old October 31st, 2010, 11:48 PM   #7 (permalink)
Member
 
ChudleyOne's Avatar
 
Join Date: Oct 2010
Location: Glendale, AZ
Posts: 113
 
Device(s): Pantech Discover, HTC Vivid, Sony Xperia X10, Velocity Micro Cruz T301, Lenovo IdeaPad A2109
Carrier: Not Provided

Thanks: 10
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by highaltitude View Post
I had the same problem, then I installed SDk and all was good. The Side Loader worked great yesterday. Now today my serial doesn't show up again. Is there any set way to get it to work all the time?
I wasn't able to figure out how to make it work more than once. I rooted & debranded my phone which lets me now load apps without the AT&T restrictions.

I'd say hang on until 2.1 is updated for you before going this route unless you don't mind voiding warranties by unlocking the phone.
ChudleyOne is offline  
Reply With Quote
Old November 2nd, 2010, 07:18 AM   #8 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Oct 2010
Posts: 21
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by highaltitude View Post
I had the same problem, then I installed SDk and all was good. The Side Loader worked great yesterday. Now today my serial doesn't show up again. Is there any set way to get it to work all the time?
Same here I got nothing so i reinstall and i try and Try and still nothing. My serial number aswell doesn't show up
luisells is offline  
Reply With Quote
Old November 3rd, 2010, 10:39 PM   #9 (permalink)
Member
 
highaltitude's Avatar
 
Join Date: Oct 2010
Posts: 241
 
Device(s): SE Xperia X10a AT&T
Carrier: Not Provided

Thanks: 8
Thanked 11 Times in 11 Posts
Default

anyone have any other ideas?
highaltitude is offline  
Reply With Quote
Old November 4th, 2010, 06:51 AM   #10 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

I'm assuming you're all using the same usb port. Run the attachment, and remove anything to do with S.E, but don't have your phone plugged in when you do it, then try connecting your phone again.
Attached Files
File Type: zip usbdeview.zip (65.0 KB, 468 views)
X10iUser is offline  
Reply With Quote
The Following User Says Thank You to X10iUser For This Useful Post:
ChudleyOne (November 4th, 2010)
sponsored links
Old November 4th, 2010, 08:15 AM   #11 (permalink)
Member
 
highaltitude's Avatar
 
Join Date: Oct 2010
Posts: 241
 
Device(s): SE Xperia X10a AT&T
Carrier: Not Provided

Thanks: 8
Thanked 11 Times in 11 Posts
Default

I just want to fully clarify, remove everything from SE the company as far as their software etc. or also stuff from rooting software also? I think I had SE companion or something installed. And it sound like from your response and from some other stuff I was reading that you need to use the same USB port every time?
highaltitude is offline  
Reply With Quote
Old November 4th, 2010, 08:38 AM   #12 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

Quote:
Originally Posted by highaltitude View Post
I just want to fully clarify, remove everything from SE the company as far as their software etc. or also stuff from rooting software also?
Just what the program lists, which is only the usb drivers installed on your system...



Quote:
Originally Posted by highaltitude View Post
And it sound like from your response and from some other stuff I was reading that you need to use the same USB port every time?
Yes, every time as your dev id changes if you use another port so it's important that you do use the same one.
X10iUser is offline  
Reply With Quote
Old November 4th, 2010, 11:03 AM   #13 (permalink)
Member
 
ChudleyOne's Avatar
 
Join Date: Oct 2010
Location: Glendale, AZ
Posts: 113
 
Device(s): Pantech Discover, HTC Vivid, Sony Xperia X10, Velocity Micro Cruz T301, Lenovo IdeaPad A2109
Carrier: Not Provided

Thanks: 10
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by X10iUser View Post
I'm assuming you're all using the same usb port. Run the attachment, and remove anything to do with S.E, but don't have your phone plugged in when you do it, then try connecting your phone again.
Another excellent piece of software. Thanks for sharing.

FYI - If anyone has problems with the program deleting/uninstalling needed files, set the EXE to have Admin privileges.
ChudleyOne is offline  
Reply With Quote
Old November 4th, 2010, 11:08 AM   #14 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

Quote:
Originally Posted by ChudleyOne View Post
Another excellent piece of software. Thanks for sharing.
You're welcome. Doesn't get much use, but is good to have for when you do.
X10iUser is offline  
Reply With Quote
Old July 11th, 2012, 02:39 AM   #15 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default how to install the USB driver for sony ericsson

Quote:
Originally Posted by luisells View Post
So i searched and cant seem to find the answer to my question, How do you installed the USB driver for Sony Ericsson x10?! I already downloaded SEMC_Android_Driver_Signed, i just dont know where to put the files, if they go any where at that, or how to install it. Please Help

this would hel worked for me
theberrycracks.co.in/2012/07/sony-pc-companion-problem-solved.html
nick6974 is offline  
Reply With Quote
Old July 11th, 2012, 10:29 PM   #16 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Cry

I have a sort of similar problem with my phone..
Whenever I plug it into my laptop it does not bring up the "found new hardware wizard" which I need it to bring up so that I can install the driver software onto my laptop because I would like to use USB tethering on the laptop to connect to the internet..
What do I do?
Reenniiee is offline  
Reply With Quote
Old July 14th, 2012, 10:12 PM   #17 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by Reenniiee View Post
I have a sort of similar problem with my phone..
Whenever I plug it into my laptop it does not bring up the "found new hardware wizard" which I need it to bring up so that I can install the driver software onto my laptop because I would like to use USB tethering on the laptop to connect to the internet..
What do I do?
Right Click My Computer -> Manage

Click on Device Manager on the left

The on the right find the phone...or scan for new hardware....or find the unknown device and right click and install it's drivers in one of the sub menus
beau420 is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:57 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.