Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old November 22nd, 2010, 04:39 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to download or upgrade apps from Android Market

Hello, Over the last few weeks I tried to download or upgrade apps but it always fails. I always get the message: "Download was unsuccessful please try again". When I go to the android market and look at the help front page there is a link called "Download Issues Troubleshooting page". The fix described in here does not work for my phone.

How do I make my phone work properly again.

Also, I am on Android 1.6 but I cannot upgrade to 2.2. The PC Companion says that I have an up to date phone.

All help appreciated

meld51 is offline  
Reply With Quote
sponsored links
Old November 22nd, 2010, 05:00 PM   #2 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

And another one.

Android Market "download unsuccessful" error fix

Market doing my nut in

market downloads unsucessful?

Can the mods make one these Market threads a sticky.
X10iUser is offline  
Reply With Quote
Old November 22nd, 2010, 06:22 PM   #3 (permalink)
Senior Member
 
gunny5821's Avatar
 
Join Date: Aug 2010
Location: Richmond, VA (USA)
Posts: 501
 
Device(s): Sony Ericsson Xperia X10a
Carrier: Not Provided

Thanks: 37
Thanked 30 Times in 25 Posts
Default

Do the following:

Homescreen > Settings > Applications > Manage Applications > Market (Uninstall Updates)

Than try the Market again. Should be good to go..
__________________
Semper Fidelis,

Gunny
(USMC Retired/Disabled)
gunny5821 is offline  
Reply With Quote
The Following 3 Users Say Thank You to gunny5821 For This Useful Post:
Andima (December 7th, 2011), bcgshankar (January 13th, 2011), tallapudi (October 30th, 2011)
Old November 23rd, 2010, 12:19 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: May 2010
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default That seems to work OK

That seems to work OK thanks.
meld51 is offline  
Reply With Quote
Old November 29th, 2010, 06:08 AM   #5 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i am using LG GT540. Download from market says unsucessfrll for all applications
help
brama1972 is offline  
Reply With Quote
Old November 29th, 2010, 06:42 AM   #6 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

Quote:
Originally Posted by brama1972 View Post
i am using LG GT540. Download from market says unsucessfrll for all applications
help
Try the steps posted above.
X10iUser is offline  
Reply With Quote
Old November 29th, 2010, 09:40 AM   #7 (permalink)
Senior Member
 
Wisenos's Avatar
 
Join Date: Aug 2010
Posts: 516
 
Device(s): Samsung Galaxy s3 16gb marble white, Acer Iconia a501, Xperia PLAY black, Samsung Nexus S
Carrier: Not Provided

Thanks: 9
Thanked 23 Times in 22 Posts
Default

Quote:
Originally Posted by meld51 View Post
Also, I am on Android 1.6 but I cannot upgrade to 2.1 The PC Companion says that I have an up to date phone.

All help appreciated
where are you from? and what'S your carrier
__________________
current: Samsung Galaxy SIII 16gb marble white/Iconia a501(Rogers) / Oldies: xperia PLAY(Rogers), x10a (Rogers) x3, Iphone 3g (Rogers) x2, SE K790a (Rogers), LG 8100 (Telus), Nokia 3125 (Rogers), Audiovox CMD-8400 (Bell), Nokia 5125 (Rogers) and my first ever: Nokia 252c (Bell)
Wisenos is offline  
Reply With Quote
Old December 1st, 2010, 04:24 PM   #8 (permalink)
Junior Member
 
Join Date: Dec 2010
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I'm using a HTC Desire - I have tried the uninstall updates but apps still fail to install, so annoying. The Desire is rooted
paulm22 is offline  
Reply With Quote
Old December 1st, 2010, 04:26 PM   #9 (permalink)
Junior Member
 
Join Date: Dec 2010
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

and if the same question applies to me im in the UK on the network '3'
paulm22 is offline  
Reply With Quote
Old December 1st, 2010, 04:33 PM   #10 (permalink)
Senior Member
 
X10iUser's Avatar
 
Join Date: Oct 2010
Location: Here
Posts: 1,328
 
Device(s): Xperia X10i - O2
Carrier: Not Provided

Thanks: 14
Thanked 336 Times in 196 Posts
Default

Quote:
Originally Posted by paulm22 View Post
and if the same question applies to me im in the UK on the network '3'
It applies to all Android users.
X10iUser is offline  
Reply With Quote
sponsored links
Old December 3rd, 2010, 04:49 PM   #11 (permalink)
Junior Member
 
Join Date: Dec 2010
Posts: 17
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

so do you have any advice?
paulm22 is offline  
Reply With Quote
Old December 4th, 2010, 02:01 AM   #12 (permalink)
Premium Member
 
rosered's Avatar
 
Join Date: Jul 2010
Location: UK
Posts: 2,129
 
Device(s): X8, X10, Xperia Neo T-Mobile UK
Carrier: Not Provided

Thanks: 58
Thanked 316 Times in 273 Posts
Default

The best advice if removing automatic updates doesn't sort it for you is to keep trying.... the problem seems intermittent and judging by the Android Market forum is pretty wide spread. Also try over wifi than 3g as again this seems to have worked for some people. Turning the phone off and on has also been reported to get it to work too at times.
rosered is offline  
Reply With Quote
Old December 5th, 2010, 07:24 AM   #13 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have just got a lg Optimus GT540 from Tesco Direct, i can't download free or paid apps from the Android market. The free one says starting download but doesn't The paid one says authorising purchase but does nothing, downloading via my home wifi network.
cooldood48 is offline  
Reply With Quote
Old December 11th, 2010, 08:14 AM   #14 (permalink)
New Member
 
Join Date: Dec 2010
Location: Washington DC
Posts: 3
 
Device(s): Motorola DROID A855
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've been having this DOWNLOAD UNSUCCESSFUL problem for days and I just resolved it (at least for now). I had tried all the clearing cache suggestions and nothing made any difference. I found the app I wanted on a different download site than android market and was able to download it from there. Then I went back to the market and tried the download of the same app and IT WORKED! So, maybe folks having this problem could try that??
susanephan is offline  
Reply With Quote
Old October 30th, 2011, 09:32 PM   #15 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

thank you very much!it worked for me!
tallapudi is offline  
Reply With Quote
Old November 4th, 2011, 09:58 PM   #16 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Brilliant. THANKS!
Quote:
Originally Posted by gunny5821 View Post
Do the following:

Homescreen > Settings > Applications > Manage Applications > Market (Uninstall Updates)

Than try the Market again. Should be good to go..
nikwhitwham is offline  
Reply With Quote
Old December 1st, 2011, 08:11 AM   #17 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

*I feel the need to repost my (the following) rant in applicable threads because nobody seems to have picked up on this and a lot of people have had this problem (I'm still suffering from it now.)*

I've been pouring over the various threads regarding this issue and am stunned by the incompetence of the internet. All this blah blah about clearing this or that cache and reformatting this or that sd card are nonsense. Want to know why? Because this can happen to two entirely different devices on your google account AT THE SAME TIME. My tablet and my phone (different carriers, same google account) both came down with this affliction simultaneously last night, so obviously it has nothing to do with all of these local fixes everyone is spewing. End of rant. Let's get this right, people.
goathouse774 is offline  
Reply With Quote
Old December 1st, 2011, 12:18 PM   #18 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by goathouse774 View Post
*I feel the need to repost my (the following) rant in applicable threads because nobody seems to have picked up on this and a lot of people have had this problem (I'm still suffering from it now.)*

I've been pouring over the various threads regarding this issue and am stunned by the incompetence of the internet. All this blah blah about clearing this or that cache and reformatting this or that sd card are nonsense. Want to know why? Because this can happen to two entirely different devices on your google account AT THE SAME TIME. My tablet and my phone (different carriers, same google account) both came down with this affliction simultaneously last night, so obviously it has nothing to do with all of these local fixes everyone is spewing. End of rant. Let's get this right, people.
There is no 1 way to fix every single problem.

If tells you in the instructions when upgrading from 2.1 to 2.3 to do a factory reset after 2.3 is installed to wipe out old userdata from 2.1 that can affect the .conf files in 2.3.

Very very few do it.

But doing a factory reset will prevent some of these problems people are having. As does clearing cache after an upgrade.....it basically wipes out that old userdata.

What good does your ranting do?

I have had problems on the market where it is just some apps that aren't downloading. I have had other issues where it is completely not accessing it. I have had missing settings that have cause it.

There are several ways to fix issues. Even if the problem is the same, there are different reasons.

If you want help, please create a new thread and explain your issue. Hopefully your issue does get resolved, but people on here won't be helpful if you just rant and knock people's proven solutions.
beau420 is offline  
Reply With Quote
Old December 1st, 2011, 05:04 PM   #19 (permalink)
Senior Member
 
Sam-SonyXperia's Avatar
 
Join Date: Jun 2011
Posts: 1,042
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 150 Times in 138 Posts
Default

Quote:
Originally Posted by goathouse774 View Post
*I feel the need to repost my (the following) rant in applicable threads because nobody seems to have picked up on this and a lot of people have had this problem (I'm still suffering from it now.)*

I've been pouring over the various threads regarding this issue and am stunned by the incompetence of the internet. All this blah blah about clearing this or that cache and reformatting this or that sd card are nonsense. Want to know why? Because this can happen to two entirely different devices on your google account AT THE SAME TIME. My tablet and my phone (different carriers, same google account) both came down with this affliction simultaneously last night, so obviously it has nothing to do with all of these local fixes everyone is spewing. End of rant. Let's get this right, people.
This issue generally occurs when there has been an issue with the applying of an update to the Market application itself. This can generally be resolved by following the steps below:

Main Menu > Settings > Applications > Manage Applications > All > Market > Uninstall Updates > Re-Launch Market.
Sam-SonyXperia is offline  
Reply With Quote
Old December 13th, 2011, 10:19 AM   #20 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a rooted Nook color and have been unable to download from the Android Market most of the time. If I get up at 4 a.m. PST sometimes I can get it to work but this is very frustrating. I tried the Uninstall Updates trick mentioned in this thread but I still got an error when I try to download Blood and Glory this morning. Qwest (Century Link) is my internet provider and I have 20 mbps internet speed. My Amazon App Store works smoothly without a hitch but Blood and Glory is not available there. I don't mean to sound cranky but since this seems to be such a common problem with so many people (based on threads I have read), why doesn't Google redesign the Market delivery program so that it will work as smoothly as Amazon's does? This issue will only get worse with the plethora of Android tablets now being sold for Christmas gifts.

One suggestion I have not tried is to clone the MAC address on the router. Could someone explain that process please? My router is a Motorola 3347.

Quite honestly, though, how does Google expect the Android Market to be a success if people have to have a technology background to get their devices to work with it? If the problem is in the autodetect device compatibility issue, why don't they give us a setting to turn that sequence off and let us decide for ourselves if we are going to chance it or not? Or give us a list of basic requirements like accelerometer, etc. required for this app and let us make the decision? If accessing the Apple App Store had been this difficult, iTunes would have been a total disaster.
mharrsch is offline  
Reply With Quote
sponsored links
Old February 15th, 2012, 02:14 PM   #21 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

This is resolved mods. The simple fix to bypass the block put on in order to cause illegal down loads from verious sites in order to take them out of business and to push cloud into fame over megaupload and usurp thier monies was to just install clockworkmod recovery for your specific phone and boot to recovery, then wipe cache and dalvik cach and viola! reason this had to be done is that the block was put on by android developers and hardware manufacturers in order to boost illegal downloading before they tried to push p.i.p.a. and s.o.p.a., that way they removed wiping dalvik cache and blocking most users from ever recovering thier market ability. Current investigation is linked to the one going on over the FAST and FURIOUS scandal. the creation of ideological subverts "THE ANONYMOUS" hackers group and subsequently the "trigger capture" ploy that was then used on the hacking communities soviet "sleeper" cells.
Current investigation has over four agencies with possible rogue agents, including the west coast F.B.I.
Frederick1337 is offline  
Reply With Quote
Old November 27th, 2012, 05:42 PM   #22 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Media background data must be enabled.

I had the same issue....

I tried the whole remove updates thing, I tried the delete apps, turn off gmail, gtalk etc. etc. etc.

What you need to try before all of that is to confirm that Media background data is not turned off. Download Manager is a component of Media.

Settings>Usage>Media make sure Media back ground data is not disabled, i.e. is not ticked. I ticked this when I was tinkering with the settings... and for 3 weeks I couldn't work out why I couldn't download apps via 3g/4g.
smitzer6 is offline  
Reply With Quote
Old December 19th, 2013, 11:44 PM   #23 (permalink)
New Member
 
Join Date: Dec 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default pls help me out market on my phone dosent work its boring most of the app to dosent work

I have lg gt 540 it says vending market has stoped doesent work i cant download
shariff gold is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:56 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.