Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 23rd, 2010, 03:59 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 14
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 2 Times in 1 Post
Exclamation X10i unable to receive/make calls/SMS but data ok?

I have the latest update 2.1, but I have a very worrying problem.

After a couple of days the phone is unable to make or receive calls, or send or receive txt messages.

If I try and make a call it attempts to start the call, but immediately comes back with unavailable.

Incoming calls go straight to voicemail.

Outgoing txt messages don't work.

What is strange is that if I try and browse the web (over 3G) then that works fine!

I have tried doing a network scan again, and reregistering to Tmobile, but that doesn't make a difference.

If I turn the phone off and on again, then it is fine and all calls/txts are working again.

I have seen this 4 times now with my phone. It doesn't always happen, but it has happened a few times now which is worrying.

The annoying thing is that you obviously don't know when incoming calls stop. You only find out the problem has occured when you attempt to make a call or send a TXT.

I am on tmobile in the UK.

Anyone else seen this or have any suggestions?

mbailey is offline  
Reply With Quote
sponsored links
Old November 25th, 2010, 05:33 PM   #2 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 14
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 2 Times in 1 Post
Default

I had another strange one yesterday, the phone completely lost the network.

I tried going into the menus to select the network manually and automatically, but it wouldn't see the network. It reported the lists of networks it could see, and when I selected Tmobile it said "registered" but the icon at the top of the screen still showed a red cross and zere signal strength.

I tried changing from 3G to GSM, but that didn't make a difference.

In the end I power the phone off and on again, and it worked perfectly again.

What I think is happening is that once it has lost the network it doesn't seem to be able to recover unless the phone is powered off and on again.

Has anyone seen this?
mbailey is offline  
Reply With Quote
Old December 1st, 2010, 12:41 AM   #3 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down

Quote:
Originally Posted by mbailey View Post
I have the latest update 2.1, but I have a very worrying problem.

After a couple of days the phone is unable to make or receive calls, or send or receive txt messages.

If I try and make a call it attempts to start the call, but immediately comes back with unavailable.

Incoming calls go straight to voicemail.

Outgoing txt messages don't work.

What is strange is that if I try and browse the web (over 3G) then that works fine!

I have tried doing a network scan again, and reregistering to Tmobile, but that doesn't make a difference.

If I turn the phone off and on again, then it is fine and all calls/txts are working again.

I have seen this 4 times now with my phone. It doesn't always happen, but it has happened a few times now which is worrying.

The annoying thing is that you obviously don't know when incoming calls stop. You only find out the problem has occured when you attempt to make a call or send a TXT.

I am on tmobile in the UK.

Anyone else seen this or have any suggestions?
I'm getting the exact same issues, I'm thinking it might have something to do with the sleep policies of your wi-fi. If I set it to "never when plugged in" then it happens very often. When it's set to "when screen switches off" then less often.

The only workaround I have thus far, is to switch airplane mode on and off. (Still annoying and unpredictable, but at least it saves time instead of fully restarting).
G4goodservice is offline  
Reply With Quote
Old December 10th, 2010, 07:57 PM   #4 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Men i have the same problem, here in Brazil, and i sow this.. Every Smartphone when you start to make or receive a call they auto turn off 3g, when your call stop they turn on again, and this Xperia doesnd doing this.. so.. if you are in a call and the smarth try to sync or any access to the 3g you miss call and need to restart to work again :S
abarth is offline  
Reply With Quote
Old January 13th, 2011, 06:58 AM   #5 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same anoying thing is appening to me on my ZTE Blade. As anyone found a solution?
davidbaiao is offline  
Reply With Quote
Old May 30th, 2011, 06:13 AM   #6 (permalink)
New Member
 
Join Date: May 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i also have this problem on my samsung galaxy s and nothing so far has fixed it including powering phone off and removing battery. ahhhhhhhhhh. my only temporary fix was taking it to the retailer who took it off me for over a week!
moemccartan is offline  
Reply With Quote
Old August 5th, 2011, 05:07 AM   #7 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same on HTC Incredible

I get the same: calls just go straight to voicemail.
If the backlight is on, then the call goes through and dial. If the phone is on standby, then the call simply doesn't go through.
HELP!
jeminar is offline  
Reply With Quote
Old August 5th, 2011, 05:08 AM   #8 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same on HTC Incredible

I get the same: calls just go straight to voicemail.

If the backlight is on, then the call goes through and rings. If the phone is on standby, then the call simply doesn't go through and gets collected by voicemail.

I'm on giffgaff (UK).
HELP!
jeminar is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:09 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.