Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

test: Reply
 
LinkBack Thread Tools
Old June 13th, 2011, 03:47 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Post X10 USB charging port Broken

Hi, I have had my X10 for under 6months now (on Orange UK via Phones4you) I have always kept my phone in immaculate condition, never been dropped always made sure I let the battery completely run empty on occasions and always clean and dust free. BUT it recently stopped charging. I sent off via phones4you warranty and they sent it back saying that the fault (a broken USB) is not covered and is NOT a manufacturing default. I am aware that some other people have had a similar issue. This is an internal issue and not an external one. Can anyone help me with this as I am due to start a complaint process regarding this issue. Who else has had the problem and how did you go about getting the issue resolved. I thank you in advance for the help.

Advertisements
Limbo1984 is offline  
Reply With Quote
sponsored links
Old June 13th, 2011, 04:35 PM   #2 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by Limbo1984 View Post
Hi, I have had my X10 for under 6months now (on Orange UK via Phones4you) I have always kept my phone in immaculate condition, never been dropped always made sure I let the battery completely run empty on occasions and always clean and dust free. BUT it recently stopped charging. I sent off via phones4you warranty and they sent it back saying that the fault (a broken USB) is not covered and is NOT a manufacturing default. I am aware that some other people have had a similar issue. This is an internal issue and not an external one. Can anyone help me with this as I am due to start a complaint process regarding this issue. Who else has had the problem and how did you go about getting the issue resolved. I thank you in advance for the help.
There was a topic on here about people with wonky USB ports on their phone.

my x10 won't charge!!!!!!

If you can't find a charger that works, try finding the right angle it will charge at. Or you can find a good technician that would solder it for you and fix the problem.

Any other suggestions?
beau420 is offline  
Reply With Quote
The Following User Says Thank You to beau420 For This Useful Post:
Limbo1984 (June 13th, 2011)
Old June 14th, 2011, 02:23 PM   #3 (permalink)
KTP
Senior Member
 
Join Date: Apr 2010
Location: Edinburgh, Scotland
Posts: 508
 
Device(s): Samsung I9100 with Checkrom HD V4 & ICS theme
Carrier: Not Provided

Thanks: 29
Thanked 70 Times in 56 Posts
Default

when i had this issue i took my phone back to o2 and they sent it off to be assessed by their repairer.
after a week i was told it was not viable to repair and they issued me with a new phone, i would have assumed any phone should be guaranteed for a year so i dont know why they cant either fix or replace it.
it may not be listed as a manufacturing flaw but its certainly a common problem.
KTP is offline  
Reply With Quote
Old June 14th, 2011, 06:17 PM   #4 (permalink)
Member
 
Join Date: Jun 2010
Posts: 127
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 19 Times in 13 Posts
Default

dont know the exact situation of your usb port but i got mine done i think around christmas time or after. 1stly on t-mobile! basically my situation at first.. i thought it was the charger but after it didnt charge with the new charger and everything i thought it might be something else. took it to the t-mobile shop and they said most likely it was a usb port problem but i was fine under the guarantee to get it checked and repaired if needed. got it sent off for repair. there was alot of tracking notes but im sure it stated that they ended up replacing the motherboard, usb port area and what not and after trial n testing i got it back in working condition after around 3wks id say! dont know if its much help but i dont see why the manufacturers guarantee wouldnt cover it seen as u aint done anything wrong! think you should complain cuz they shouldnt be able to get away with that!!


Thought id add this link in n al so that maybe you can use it to your advantage to prove your point to them..
http://www.sonyericsson.com/cws/download/1/655/094/1251813505/LegalAndWarranty_1222-9269_2_en_24.pdf

Hope it helps!!
TheManWithAPlan is offline  
Last edited by TheManWithAPlan; June 14th, 2011 at 06:23 PM.
Reply With Quote
Old June 15th, 2011, 08:52 AM   #5 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Thought I would add the original thread I was thinking of that has the pic of where to fix the problem (if the warranty route doesn't work out)

my x10 won't charge!!!!!!

from here -

Sony Ericsson Xperia X10 Not Charging Problem Solution - Hardware ~ Android Solution
beau420 is offline  
Reply With Quote
Old July 11th, 2011, 11:59 PM   #6 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Soooooooo mad with Sony Ericsson right now!

I have to begin by saying that I NEVER sign up and post things on message boards. I'm not even on Facebook, Twitter, etc. However, due to the circumstances surrounding my Xperia X10 I feel compeled to inform my fellow Android community members of my recent problems as follows:

I have been using my X10 for just over a year now. Asside from the lengthy time it took for software upgrades and a few other minor issues I was resonably happy with the phone.

A few days ago I experienced a similar problem with my phone as many of you have lately where my phone suddenly and without warning lost the ability to charge. I tried different cables, taking batteries in and out, and every method of reset I could find. Sadly, none of this worked.

I spoke to a local repair shop where I live and was told the USB port was broken. I called SE's customer service number and was informed that because I was a few days past my one year anniversary any repairs/replacement would not be covered under warranty even though the phone was showing symptoms before it eventually failed. They put me in contact with their repair centre who told me that the phone is UNREPAIRABLE.

As it turns out, unique to the Xperia X10, the design of the USB port is such that once it breaks it is unfixible. Apparently every other phone on the market has the port soldered in place. The X10 was designed where the port is soldered then epoxyed. This epoxy does not allow for USB port removal.

The repair person I spoke with said he has never seen such a "stupid" design. SE told me that even though the phone was off waranty it would not have been fixed anyways because it is "physical damage". Thats right, apparently by using the cable SE gave me, and following the instructions SE gave me for charging, I have damaged the port after just over a year of daily chargings.

It was also suggested to my by the repair person that SE is acutely aware of this design oversight and completly redesigned the charging port on the Xperia ARC however, is unwilling to help anyone out beyond their one year warranty period. What he also noted that was strange is the fact that many other manufacturer (Nokia, Motorolla, RIM etc.) will extend the warranty of their products if it is close to the one year mark as a courtesy to their customers. No such luck with SE.

When explaining the issue to a supervisor at SE's customer support line I asked the question "what am I supposed to do now". The response was something to the effect of "there is nothing we can do". I did not even get an apology. The customer support supervisor even said "have a nice day" and hung up while I was in the middle of a sentance. Talk about customer support!

I am now left with two years on my contract with my provider (Rogers in Canada) with the following options: Pay $500 for a similar replacement or pay $500 to exit my contract. Or continue what I am doing, using my old phone which is, ironically, a SE. That's right, I'm even a long time SE customer.

To conclude, I issue the following warning to current and future SE users: Please beware. I have found out the hard way that SE will not stand by their products and will not value you as a customer. If you notice the slightest problem with your phone while it is under warranty SEND IT IN IMMEDIATLY!

On a last note, to add insult to injury, a good friend of mine has an IPhone 4. A few weeks ago he dropped it in his hot tub. He was completly honest about what happened and Apple replace it for FREE! Understand what you are getting into with SE and set low expectations. And no, I will not be purchasing another Sony product. There are too many other products on the market to go back to dealing with SE.
mad@se is offline  
Reply With Quote
Old July 12th, 2011, 09:29 AM   #7 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Sucks.

I suggest buying a battery and stand alone charger. Then charge the battery in the stand alone charger and stick it in your phone....swap the the other battery and do that every day or every other day.

For transferring files....setup an FTP server on the phone. Then the only thing you can't do is upgrade the phone. Even then....if you have already rooted it and have xrecovery loaded, you could still upgrade....except for the firmware.
beau420 is offline  
Reply With Quote
Old July 12th, 2011, 07:50 PM   #8 (permalink)
Member
 
Join Date: Jul 2010
Location: Toronto
Posts: 256
 
Device(s): Galaxy S Glide (Rogers), Xperia X10 (Rogers)
Carrier: Not Provided

Thanks: 16
Thanked 29 Times in 26 Posts
Default

Mad@Se,

First of all that sucks.

I actually noticed mine this week a few times didn't charge when I plugged it in and worked with I tried a second time. I'll be sure to keep an eye on it.

The only thing for me is that I obtained my x10 via a trade from a BB 8700 that I won. So I'm still hardware eligible from Rogers, but which Android to pick from them right now?

I heard the Play has some reception issues.
I heard the Arc has an issue with the case cracking in the corner but I really like the Camera on it.
I want the Xperia Pro but if it comes to Rogers and now it's delayed till Q4 due to the Tsunami.

What else is good in their lineup?
clockwork58 is offline  
Reply With Quote
Old April 1st, 2012, 02:56 AM   #9 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Upset and angry at Sony and my X10i

I am having the same problem and am totally disappointed, frustrated and angry. My X10i over a period of weeks would not charge properly unless you held the charging lead in a certain position. One night last month I put it on charge when I went to bed the next morning it wont turn on at all, just a flashing red light. I even tried my partners fully charged battery, NOTHING. I phoned Orange Customer service who informed me my phone was covered under the Sony Manufacturers Warranty, send it to the SE Repair Centre and they will diagnose, fix it and send it back. On Friday I was mortified when I received a letter from the repair centre saying that Physical Damage/Broken phone, I could sign an authority to destroy my handset or PAY TEN POUNDS TO GET MY HANDSET SENT BACK TO ME BROKEN???!! I am so upset I know 100% I have not dropped this phone so I phoned the repair centre who state they have a photo showing internal damage to the USB Charging Port, Internal, looks fine from outside. I have read pages and pages and pages of this being a common fault. The repair centre basically said as its part of the main board its not worth fixing?? Yet on other sites I have read other conflicting information. I am so upset. I have sent a complaint to Sony, it seems like anything to get out of repairing or replacing it. My contract is not due for renewal till November and quite frankly after this I will be waving goodbye to Orange as my provider of 15 years and steering clear of Sony phones.
Twiglet73 is offline  
Reply With Quote
Old May 6th, 2013, 05:19 PM   #10 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs down SONY never again

I am having the similar problems with Live with walkman (WT19i) and Xperia Arc S (LT18i). I think it's due to that sony INTENTIONALLY made a charging port rectangular, so the customers would brake it sooner, by not connecting the charging cable correctly (THIS IS ESPECIALLY HARD IN THE DARK) and thus damaging the connector slab located inside the port!!
See this pic
And i am surprised that even Xperia Z, the 2013 flagship of sony still has the rectangular shape of the micro USB port!!!!!!!!!!!!!!! For a 700 $ phone it's nice and thrilling that it can put under water, but eventually the USB port will break, and because it's soldered to the motherboard it's beyond economically feasible repair...way to go sony, way to go!
smrdljiva Xperia Z

ALL other phone manufacturers, as far as i know, have trapezoid-like shape of the USB charning port, so there is no way to connect the charging cable in any other way.
Samsung HTC LG ...

Nuf said, SONY never again
t00dy is offline  
Reply With Quote
sponsored links
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More

Tags
broken usb port, manufacturing default, not charging, orange, phones4you, warranty, x10, xperia x10a


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:23 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.